Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Flavio_Cimetta

I-Frame - Problemas/Dicas

Recommended Posts

Pessoal, boa noite.

Bom, estou com um problema sérião.

Do começo:

- Tenho que resolver um problema da empresa, que trabalha com e-commerce. O sistema atualmente passa por uns problemas no carrinho de compras, ja que a forma de redirecionamento do link tá com pau.

Pensei em fazer um redirecionamento via frame, ou seja, para nao aparecer o subdominio do cara na barra de navegacao quando ele digita o endereco da loja, eu mascarei com esse script:

<?

$redireciona="http://www.iwigo.com.br/loja/home.aspx?loja=342";

$titulo="Vila Fauna";

echo '<html>';

echo '<head>';

echo '<title>' .$titulo. '</title>';

echo '</head>';

echo '';

echo '<frameset rows=/”*/” noborder border=0 frameborder=0>';

echo '';

echo '<frame name=/”conteudo/” scrolling=/”yes/” noresize src='.$redireciona.' marginwidth=0 marginheight=0>';

echo '';

echo '<noframes>';

echo '<body>';

echo '<h1>Seu Navegador não suporta frame:</h1>';

echo '<h1>Favor acessar <a href='.$redireciona.'>'.$redireciona.'</a>';

echo '</body>';

echo '</noframes>';

echo '';

echo '</frameset>';

echo '</html>';

?>

Link da loja do cliente: www.vilafauna.com.br

- Bom, até aí ok, deixei a entrada no DNS como CNAME, ja que o sistema nao está no mesmo server que ele, e coloquei esse script como index.php na raíz da home do cliente.

O que ele faz é redirecionar para o sub-dominio da loja do cara, e navega normalmente.

- Realizei testes de compra com o Firefox, e deu tudo certo, consegui fazer tudo normalmente na page.

- Porém, quando usei o I.E., tentei clicar em Comprar, depois de clicar em algum produto qualquer da loja, e o link me redirecionada para a HOME da loja.

Verifiquei que o I.E. trata o link de uma forma diferente do firefox, que o frame que eu coloquei la nao consegue interpretar a requisicao. Quando eu passo o mouse no botao Comprar, ele me mostra somente o caminho final, sem o http://dominio.com.br/ ou seja, se o caminho inteiro é http://dominio.com.br/teste/comprar.aspx ele me aponta somente o comprar.aspx por exemplo

O que eu posso fazer neste caso?

Existe alguma coisa a mais que eu possa adicionar nesse codigo para que ele passe a reconhecer o link quando eu clico em comprar... No IE?

Nao entendo nada de PHP muito menos de frame, esse script eu peguei pronto de um outro cara que trabalhava na empresa quando ele fez um redirecionamento via frame, só.

estou desesperado, nao só esse cliente, mas outros, estão putos da vida, pois o pessoal da fabrica nao agiliza o conserto do software...

Preciso de uma solucao temporaria...

Agradeço desde ja!

Editado por Flavio_Cimetta

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu não entendi muito bem, mas no meu FF o endereço muda só de entrar na página, não permanece o domínio...

De qualquer forma, verifique nesses links se não estão com target="_blank" ou se no princípio do arquivo não tem alguma base target tb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

echo '<iframe name=/”conteudo/” scrolling=/”yes/” noresize src='.$redireciona.' marginwidth=0 marginheight=0>';

Acho que deve ser isso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×