Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
egs.edmar

Ajuda com o Eagle, 1º circuito!

Recommended Posts

Olá galera!

Sei que já foi tratado deste assunto aqui no fórum, mas como persiste a dúvida resolvi postar.

O problema está na hora de gerar a pcb..., algumas trilhas simplesmente não aparecem, só fica aquela linha amarela..., se eu mudar vai ficar sobreposto as ilhas!...

Ah!, como é minha primeira placa, depois disso eu tenho que usar o comando mirror para imprimir né?(quero usar a técnica térmica...), como faço para deixar a linha preta e o fundo branco?

segue o circuito,Obrigado!

Editado por Bcpetronzio
Corrigir falha na digitação do título

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não há circuito nenhum aqui.

Ah, não entendi direito sua dúvida. Veja se é algo parecido com isso: você está usando o autoroute e ele não gerou todas as trilhas ? Se for, mande pra gente o circuito e o que o autoroute conseguiu fazer pra ver se há algo errado.

Quanto à inversão, nunca precisei (também uso um método de transferência térmica), e para inverter as cores eu uso o famoso ultra mega master paint ! Heheh...

Compartilhar este post


Link para o post
Compartilhar em outros sites
 
Olá galera!

Sei que já foi tratado deste assunto aqui no fórum, mas como persiste a dúvida resolvi postar.

O problema está na hora de gerar a pcb..., algumas trilhas simplesmente não aparecem, só fica aquela linha amarela..., se eu mudar vai ficar sobreposto as ilhas!...

Ah!, como é minha primeira placa, depois disso eu tenho que usar o comando mirror para imprimir né?(quero usar a técnica térmica...), como faço para deixar a linha preta e o fundo branco?

segue o circuito,Obrigado!

Ops!:huh: Faltou o link para o circuito, eis aí(este é da pcb):

circuito2f.th.png

Este é o do circuito, com a diferença que não inclui a bateria, nem os bornes para o relê:

circuito2f.th.png

circuitohj9.th.png

Bom é isso aí, não vejo a hora de acabar com isso...aguardo respostas Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aproveitando o Tópico, Alguem sabe como fazer referencia no EAgle, tipo uma flecha com uma identificação, e no componente uma outr flecha entrando com a mesma identificação, porém isso precisa aparecer no layout também... e se possivel essa referencia deve valer para todas as pg´s do projeto.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Olá galera!

Sei que já foi tratado deste assunto aqui no fórum, mas como persiste a dúvida resolvi postar.

O problema está na hora de gerar a pcb..., algumas trilhas simplesmente não aparecem, só fica aquela linha amarela..., se eu mudar vai ficar sobreposto as ilhas!...

Ah!, como é minha primeira placa, depois disso eu tenho que usar o comando mirror para imprimir né?(quero usar a técnica térmica...), como faço para deixar a linha preta e o fundo branco?

segue o circuito,Obrigado!

Suas trilhas estão muito grossas.

Desta forma fica mais difícil para o programa encontrar rotas.

Para imprimir a placa, eu faço o seguinte:

No menu "View", clico em "Display/hide layers".

Deixo ativo somente as "layers" referentes aos "pads", trilhas, furações e dimensão da placa, ou seja, o que eu quero que seja imprimido. Isto para cada face.

Depois, no menu "File", clico em "Export" e em "Image".

Seleciono "Monochrome" e resolução de 600dpi. Tipo de arquivo .bmp (para imprimir em tamanho real).

Depois, abro a figura no Paint e mando inverter as cores.

Uma opção para não precisar inverter cores depois no Paint é, no menu "Options", clicar em "User interface..." e em "Layout">"Background", selecionar "White".

Editado por Mulder_Fox

Compartilhar este post


Link para o post
Compartilhar em outros sites

É isto mesmo que o colega Mulder_Fox disse: as trilhas estão muito grossas. Além disso, você deve "brincar" um pouco com a disposição e espaçamento dos componentes, para otimizar tanto o tamanho da placa quanto as trilhas geradas.

Mais uma coisa: é comum que o autoroute, mesmo em casos otimizados não consiga rotear tudo com uma única camada. Aí você põe alguns jumpers manualmente pra completar (eu normalmente uso a layer TOP pra isso).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal, assim como o amigo egs. edmar, gostaria de aprender com vocês sobre o assunto do Eagle também, já que o utilizo para criar minhas PCBs, mas honestamente acho que eu poderia explorar mais o software já que não tenho muito e total conhecimento sobre o mesmo.

Vocês, amigo Lokasso, amigo Mulder, poderiam dizer por exemplo os procedimentos tipo básicos para iniciar uma PCB do zero, ou seja, sem o esquematico feito em nenhum outro software. QUero dizer, criar mesmo do zero, tipo on=lhando pra uma revista e inicar a criar!

Nao consegui ver a foto do circuito do amigo egs.edmar! So esta aparecendo a foto do esquema da PCB.

Desculpem entrar assim de repente na conversa, mas é que esse assunto me interessa também e gostaria de aprender mais com a ajuda de vocês se possível!

Grande Abraço a todos e obrigado desde já.

R.Costa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

digam, é possível criar a PCB no Eagle sem ter feito o esquema do circuito no próprio Eagle, mas, é mais fácil fazer o esquema e depois, no menu "File", clicar em "Switch to board".

A partir daí é só posicionar os componentes o melhor possível e mandar rotear.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo Mulder_Fox,

meu caro, muito obrigado mesmo pela dica!

Eu vou te ser bem sincero: SEMPRE criei layouts no Eagle, enfim, varias versões, iniciando na 3.0, e vou te dizer que tenho sido BEM IGNORANTE no uso deste software!:(

Isso porque sei que o Eagle é MUITO BOM, não é a toa que uso ele...mas vou te falar que eu não uso nem mesmo 30% do potencial do software!!!:eek:

Como disse, sempre criei layout, inclusive para venda, projetos que já tenho comercialmente conhecido, como automação para algumas empreas, e sinceramente não utilizo o Eagle digamos de um modo "automático", vou tudo no MANUAL mesmo...sei que dá certo, mas honestamente, se posso fazer melhor, por que não né mesmo?!^_^

Eu vou então, desenhar um esquemátivo usando o Eagle, mas me diz, o que faço assim que o esquemático estiver pronto? Clico em o que exatamente? Poderia me passar uma *Lista dos comandos as serem seguidos ou já é pedir demais meu amigo Mulder?!:huh:

Desculpe por qualquer coisa e te digo que apenas a disposição em postar algo na tentativa de dar um Help! já é uma grande coisa! :D

Abração,

R.Costa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

A partir do esquema pronto no Eagle, no menu "File", você clica em "Switch to board".

O programa vai informar que não existe placa e se deseja criar a partir do esquema.

Então, aparece já a placa no tamanho padrão que você redimensiona e os componentes ao lado já com as linhas que representam as ligações entre eles.

Daí, você posiciona cada componente, procurando deixar próximos os componentes que estão interligados.

De vez em quando, no menu "Tools" clique em "Ratsnest". Isto faz com que o programa refaça as ligações, encontrando caminhos melhores (isto ainda não é o autorouter).

Depois que achar que as peças estão na melhor posição, no menu "Tools" clique em "DRC" para escolher as larguras das trilhas, espaçamento mínimo, etc...

A seguir, no menu "Tools", clique em "Auto...", onde você poderá escolher o número de camadas, o "Routing grid" (quanto menor o número, mais demora para rotear, mas, pode fazer com que chegue a 100%, quando não conseguido) e outras opções.

Eu não sei o que significa aqueles números das abas "Optimise". Deixo no padrão.

Finalmente, você clica em OK para rotear.

Quando não chegar a 100%, você pode, no menu "Edit", clicar em "Ripup" e em seguida clicar no botão com o desenho do semáforo para desfazer as rotas para tentar posicionar melhor os componentes.

Isto é o básico, tem muito mais, que você vai descobrindo fuçando.

Por exemplo, mesmo depois de roteado, você pode clicar com o botão direito numa trilha para aumentar sua largura, desfazer a rota para rotear manualmente, etc...

Editado por Mulder_Fox

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro amigo Mulder_Fox,

Só tenho a lhe dar meu Muito Obrigado pelo paciência em tentar ensinar!;)

Vou te dizer que vou tentar o ensinado por ti a partir de já, e se no processo der alguma "zebra", eu aviso!

Muito obrigado mesmo.

R.Costa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

digam, se lhe ajudar seguem dois tutoriais:

http://www.mediafire.com/file/ym2y4mvjh1m/Apostila_Eagle.pdf

http://www.mediafire.com/file/o3wwmfy4jtw/Eagle.ppt

Eu particularmente não gosto muito do autoroute não. Não sei se é por eu não dominá-lo 100% ou por outro motivo, mas sempre sai melhor quando faço o layout manualmente.

Agora fazer o layout sem o esquemático no Eagle, dá muito mais trabalho mesmo. Recomendo fortemente que você faça o esquemático no Eagle, facilita muito depois.

Ah, aqui segue um link de um tutorial (em inglês) para o Eagle 3D:

http://www.mediafire.com/?wmogyv0zm0d

Ele serve pra fazer isso:

pd31ksxtskde9yed8eui.jpg

Editado por Lokasso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro amigo Lokasse,

putz, nada melhor do que um manual para poder acompanhar os ensinamentos daqui do amigo Mulder e seu!:D Já vou downloadear já! (P.S.: Tentei agora, mas infelizmente o link não inicia o download pelo mediafire. :(;)

Agora, você diz que não utiliza o auto-roteamento, prefere fazer as trilhas (a ligação dos componentes do circuito manualmente), mas eu gostaria de saber: Você então monta o circuito (esquematico) pelo Schematic do proprio Eagle e depois como também o amigo Mulder disse acima, EXPORTA esse esquema para o BOARD (layout da PCI) do Eagle? E depois disso faz a conexao (trilhas) dos componentes manualmente invéz de auto-route?

Caso positivo, você poderia então me dizer qual a vantagem real de se fazer o esquematico e depois exportar nao utilizando o auto-route?

Desculpe, só estou a questionar, para saber maiores detalhes, isso porque eu tb me vejo fazendo o mesmo processo que você faz...porque nao sei se o auto-route ira trabalhar 100% sempre, dessa forma eu aprendo o outro lado da moeda, que neste caso eu penso ser o metodo que você usa (de nem tudo automatico).

Obrigado mesmo meus amigos,

A ajuda é muito bem recebida!

Grande abraço,

R.Costa.

Editado por Digão AMD

Compartilhar este post


Link para o post
Compartilhar em outros sites
Você então monta o circuito (esquematico) pelo Schematic do proprio Eagle e depois como também o amigo Mulder disse acima, EXPORTA esse esquema para o BOARD (layout da PCI) do Eagle? E depois disso faz a conexao (trilhas) dos componentes manualmente invéz de auto-route?

Exatamente !

Caso positivo, você poderia então me dizer qual a vantagem real de se fazer o esquematico e depois exportar nao utilizando o auto-route?

O Eagle indica com linhas amarelas quais componentes devem ser ligados com quais, facilitando muito o posicionamento deles. Veja esta figura: http://www.electronics-lab.com/blog/wp-content/uploads/2008/02/bff-ratsnest.png

O que você pode fazer pra ficar mais rápido é iniciar com o autoroute, e só o que não ficar bom você desfaz e refaz manualmente.

Quanto ao donwload no mediafire, eu tentei aqui agora pouco, e bastou aguardar alguns segundos e clicar em "click here to start download".

Qualquer dúvida é só perguntar =)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Lokasso!

Obrigado pela imagem! Consegui ver legal! Agora eu te pergunto:

- Essa imagem eu suponho ter sido feita com o esquematico após EXPORTADO para o Board do Eagle. Correto?

- Caso positivo, eu te pergunto: Essa linhas (conexoes) amarelas SEMPRE VEM no BOARD do Eagle quando EXPORTADO o esquematico do Schematic do proprio Eagle ou de vez em quando "falta" alguma ligação? Os componentes vem todos Aglomerados e você os distribui como deseja ou ele já vem nessa posição "bonitinha" como a da sua imagem? E pra finalizar (desculpa tantas questoes!): Você então "roteia" (desenha as trilhas) baseado nessas linhas amarelas e depois so faz remove-las para finalizar o layout?

Só uma observação baseado nessa imagem do circuito que voce postou: Se eu me basear pelas linhas amarelas para desenhar as trilhas conectando cada componente com outros, por esse layout exemplo que você postou, eu teria que ter vários Jumpers não? E quando você conecta uma trilha com a outra, ele não mostra uma junçãozinha não nesse esquema das linhas amarelas?:confused:

Desculpe tantas perguntas, mas acho que quanto mais se aprende mais se quer saber né!:D Muito obrigado pela paciência tambéM!

P.S.: Quanto ao link do manual que você passou, talvez seja problema da minha NET aqui...pois agora tentei novamente e depois de muito tentar conectar com o endereço de download, meu browser (Firefox) me da a mensagem:

"- O servidor download143.mediafire.com demorou muito para responder."

Grande Abraço,

Rodrigo Costa.

Editado por Digão AMD

Compartilhar este post


Link para o post
Compartilhar em outros sites

- Essa imagem eu suponho ter sido feita com o esquematico após EXPORTADO para o Board do Eagle. Correto?

Não é possível eu te dizer pois achei ela no google (rsrs), mas acredito que sim. É possível criar os "signals" (esta linha amarela) tanto no esquemático como na board, mas o último caso é muito mais trabalhoso, e só é possível se não existir um esquemático.

- Caso positivo, eu te pergunto: Essa linhas (conexoes) amarelas SEMPRE VEM no BOARD do Eagle quando EXPORTADO o esquematico do Schematic do proprio Eagle ou de vez em quando "falta" alguma ligação?

Elas sempre aparecem. O que pode ocorrer é que no esquemático às vezes parece que você ligou um componente, mas se você arrata ele a "net" (linha verde) não vem junto, então ele não está ligado e isso não aparecerá na board. Outra coisa possível é que a camada ("layer") dessas linhas amarelas (o nome da camada é "unrouted") não está selecionada pra aparecer, aí basta clicar no segundo botão do lado esquerdo da barra de ferramentas vertical que fica na esquerda da tela. O ícone são três quadrados sobrepostos, um verde, um vermelho e um azul. Aí basta selecionar a layer amarela "unrouted" pra aparecer.

Os componentes vem todos Aglomerados e você os distribui como deseja ou ele já vem nessa posição "bonitinha" como a da sua imagem?

Eles aparecem de um jeito aleatório, você deve organizá-los de acordo com seu conheciomento do circuito, deixando os plugues, pot's, etc, nas bordas, colocando os buracos pra parafusos, organizando a seu gosto mesmo, mas de modo a fazer a menor quantidade de linhas amarelas se cruzarem. E enfatizando o que o colega Mulder disse, de vez em quando (ao mudar os componentes de posição ou rodá-los) clique em "Ratsnest" (é um X verde, no fim da barra de ferramentas), que ele dá uma otimizada nas linhas amarelas, facilitando o trabalho.

E pra finalizar (desculpa tantas questoes!): Você então "roteia" (desenha as trilhas) baseado nessas linhas amarelas e depois so faz remove-las para finalizar o layout?

Se você usa o botão "Route" elas desaparecem sozinhas. Se você usa o "Wire" precisa clicar em "Ratsnest" pra elas sumirem (só as que já estão com trilhas somem).

Só uma observação baseado nessa imagem do circuito que voce postou: Se eu me basear pelas linhas amarelas para desenhar as trilhas conectando cada componente com outros, por esse layout exemplo que você postou, eu teria que ter vários Jumpers não?

Do jeito que os componentes estão lá sim, mas dá pra reposicionar alguns deles e melhorar aquele layout.

E quando você conecta uma trilha com a outra, ele não mostra uma junçãozinha não nesse esquema das linhas amarelas?:confused:

Não entendi sua pergunta.

Desculpe tantas perguntas, mas acho que quanto mais se aprende mais se quer saber né!:D Muito obrigado pela paciência tambéM!

A galera está aqui pra ajudar mesmo ! Recomendo que você treine um pouco agora pra assimilar essas suas dúvidas. Se não tiver nenhum circuito aí pra você fazer pegue um qualquer da net, monte o esquemático, passe pra board e brinque um pouco. Assim você já assimila (e volta aqui com mais dúvidas, rsrs).

P.S.: Quanto ao link do manual que você passou, talvez seja problema da minha NET aqui...pois agora tentei novamente e depois de muito tentar conectar com o endereço de download, meu browser (Firefox) me da a mensagem:

"- O servidor download143.mediafire.com demorou muito para responder."

Tente esses links:

Tutorial do Eagle (pdf) -> http://www.plunder.com/-download-4ae5f38422.htm

outro tutorial do Eagle (ppt) -> http://www.plunder.com/-download-8377334387.htm

Tutorial Eagel3D (doc) -> http://www.plunder.com/-download-df22360121.htm

Compartilhar este post


Link para o post
Compartilhar em outros sites

Até hoje não vi nenhuma placa boa feita com o autoroute, ficam todas esquisitas, o melhor é você posicionar os componentes e ir fazendo as trilhas, dá trabalho mas a placa final fica bem melhor em todos os aspectos...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Agora valeu mesmo amigo Lokasso!:D

Pode deixar que já estou pronto a partir pra prática! Tenho um projeto aqui que fiz no Eagle do meu modo "primata" de utilizar o software, dessa forma, vou faze-lo novamente, mas agora partindo do SCHEMATIC do Eagle e exportando pro BOARD, etc...vou realizar as respostas que você assou gentilmente para as minhas dúvidas assim como o amigo Mulder...Caso exista dúvida no meio do processo, eu pergunto novamente sim, sem problemas!

Agora, quanto a:

Citação:

Postado Originalmente por digam AMD viewpost.gif

E quando você conecta uma trilha com a outra, ele não mostra uma junçãozinha não nesse esquema das linhas amarelas?confused.gif

Não entendi sua pergunta.

Vou tentar explicar melhor: O que quis dizer é por exemplo quando se "liga/conecta" um wire(trilha) em outra e não propriamente a "perna/pino" daquele componente ao qual a trilha faz ligação. Aparecerá essa Junção pelo esquema das linhas amarelas?

Caso você continue sem entender, não tem problema! Eu explico melhor com certeza! É que é uma coisa tão simples que eu não devo estar passando a informação corretamente....liga não....só avisa! ;)

P.S.1:

O ícone são três quadrados sobrepostos, um verde, um vermelho e um azul. Aí basta selecionar a layer amarela "unrouted" pra aparecer.

- Seria essa layer que você faz referência? Segue imagem:

eagleRCosta.gif *Meu Eagle é versão 5.3.0.

P.S.: Quanto ao link do manual do Eagle...AGORA FOI! :D Consegui realizar o download pelo primeiro link da lista desses 3 que você mandou no seu último Post. Obrigado!

Mais uma vez obrigado pela paciência meu amigo.

Grande Abraço,

Rodrigo Costa.

Editado por Digão AMD
Inclusão de imagem!

Compartilhar este post


Link para o post
Compartilhar em outros sites

ola galera

aprveitando o tópico eu gostaria de saber o que siguinifica os segintes erros que aparece quando eu clico nos icones (erc,errors)

Overlap 16

Drill Size 20

Clearance.

a e como eu faço para exportar o arquivo como imagem

Editado por guma.torres
Corrigir falha na digitação do texto

Compartilhar este post


Link para o post
Compartilhar em outros sites
O que quis dizer é por exemplo quando se "liga/conecta" um wire(trilha) em outra e não propriamente a "perna/pino" daquele componente ao qual a trilha faz ligação. Aparecerá essa Junção pelo esquema das linhas amarelas?

ACHO que eu entendi agora, rsrs... se estiver errado me corrija: você perguntou se ao ligar dois fios ("nets") no esquemático eles vão aparecer ligados na board, é isso ? Se esses fios não estiverem ligados a componente nenhum, eles nem aparecerão na board. Caso contrário, aparece a linha amarela ligando os componentes a que estes fios estão conectados.

- Seria essa layer que você faz referência?

Acho que sim, as outras com certeza não são (só não garanto a info, pois aqui não tem essa camada). Aqui eu uso o Eagle 4.16, por isso estava com nome diferente. Achei estranho ter só 8 camadas aí no seu eagle. Aqui tem fácil fácil umas 50.

Acho que agora você vai deixar seus trabalhos menos primatas né, rsrs ! Abraço.

ola galera

aprveitando o tópico eu gostaria de saber o que siguinifica os segintes erros que aparece quando eu clico nos icones (erc,errors)

Overlap 16

Guma, eu já tive alguns desses erros, mas não consigo me lembrar quais são exatamente. Se você puder enviar os seus arquivos .sch e .brd eu daria uma olhada.

como eu faço para exportar o arquivo como imagem

Para exportar basta seguir:

File -> Export -> Image, aí você clica em "Browse" pra escolher o nome e o lugar a salvar. Se for pra já fazer a placa, coloque uma resolução alta (eu uso 600~800dpi, mas porque eu sou meio exagerado. 400dpi já está bom) e marque a caixa "Monochrome".

Editado por Lokasso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo Lokasso

Obrigado!

Você entendeu bem! rss...é exatamente isso que estava comentando!:D

Eu só tenho a te agradecer e ao Mulder.

Estou no passo agora da colocação de tudo em prática! ;)

P.S.: Putz, você disse que o Eagle 4 tem umas 50 layers?!:confused: é, no meu so tem aquele pouquinho mesmo...hehehe...vamos ver se funciona legal.

Grande Abraço!

R.Costa.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Guma, eu já tive alguns desses erros, mas não consigo me lembrar quais são exatamente. Se você puder enviar os seus arquivos .sch e .brd eu daria uma olhada.

Para exportar basta seguir:

File -> Export -> Image, aí você clica em "Browse" pra escolher o nome e o lugar a salvar. Se for pra já fazer a placa, coloque uma resolução alta (eu uso 600~800dpi, mas porque eu sou meio exagerado. 400dpi já está bom) e marque a caixa "Monochrome".

Ola lokasso é o seguinte eu já exportei a imagem porém não sei como colocala no fórum será que você puder me ajudar com isso também.

Editado por guma.torres

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pow Guma, era só seguir o tuto do link q eu passei.

Quanto ao circuito, só pela imagem não dá pra resolver todos os problemas, mas parece possível identificar um deles: parece que tem uma trilha passando em cima do pino 20 do CI SMD que não deveria estar la (não sei se deveria ou não, só vendo o esquema). Dê uma conferida, é uma trilha que sai de um dos pinos do conector (que parece ser um USB).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×