Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
bjodogordo

Dúvida - Algoritmo - Visualg2.0 - HELP !!!

Recommended Posts

essa semana meu professor passou um desafio que eu até agora, não consegui resolver, segue:

Escreva um algoritmo que o usúario ao entrar com um número, este por sua vez será correspondente a o número de camadas de uma árvore de natal, que aparecerá na tela;

Por exemplo, se for digitado 10, aparecerá na tela a seguinte imagem:

......................./*\

...................../***\

.................../*****\

................../******\

................./*******\

................/********\

.............../*********\

............../**********\

............./***********\

............/************\

obs: usei essas linhas de pontos apenas para alinhar a arvore no centro, mais no algoritmo não deve haver esses pontinhos, e sim espaços em branco.

essa minha arvore ficou meia torta mas a ideia é essa,

esse foi o mais perto q eu consegui chegar:

##########################################

algoritmo "semnome"

// Função :

// Autor :

// Data : 08/05/2009

// Seção de Declarações

var

quant,z: inteiro

i,cnb,bar,x,ast,esp: caractere

inicio

escreva ("Digite a quantidade de camadas da árvore: ")

leia (quant)

se quant > 0 então

repita

z <- z+1

esp <- (" ")

escreva (esp)

bar <- ("/")

ast <- ast+("*")

cnb <- ("\")

escreval (bar,ast,cnb)

ate quant = z

fimrepita

senao

escreva ("arvore inexistente")

fimse

// Seção de Comandos

fimalgoritmo

##########################################

Então se alguém tiver disposto a me ajudar, desde já obg,

post-519182-13884951500007_thumb.jpg

Editado por bjodogordo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×