Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
0dail

Wireless no ubuntu 9.10

Recommended Posts

Instalei o ubuntu 9.10 no meu PC e ele reconheceu tudo de cara, até me surpreendi. Mas depois que reiniciei o PC, apesar de continuar a enxergar a rede, a internet não funciona mais.

Depois disso, baixei o drive no site do fabricante no site:

http://www.oiwtech.com.br/produtos/equipamentos/oiw_2402usg/

e segui o procedimento abaixo:

==================

Build Instructions

==================

1. Unpack the driver sources and go to the Module directory:

$ tar -xvzf rt73-cvs-daily.tar.gz

$ cd ./rt73-cvs-YYYYMMDDHH/Module

2. Compile the driver sources:

$ make

3. Install the driver (as root):

# make install

Mas quando dou o comando make, dá um erro e não consigo continuar a instalação.

Já procurei em vários lugares com drive semelhante e o pessoal diz para dar um sudo apt-get install build-essential, mas não funcionou. Depois tentei sudo apt-get update, ficou um bom tempo carregando vários arquivos mas mesmo assim o comando make continua não funcionando.

O modelo do receptor wireless é OIW-2402USG. Toda vez que reinstalo o ubuntu acontece a mesma coisa, a primeira vez ele deixa usar a internet mas quando reinicia ela simplesmente para de funcionar. Até pensei que era conflito porque tinha instalado a placa de vídeo, mas instalei uma vez sem usar a internet antes e depois que reiniciei a internet estava funcionado, mas por ter usado, ela parou de funcionar da outra vez que reiniciei :confused:

Compartilhar este post


Link para o post
Compartilhar em outros sites

1. Unpack the driver sources and go to the Module directory:

Isso é Descompactar as fontes do condutor e vá para o diretório do módulo: que significa que você deve extrair o pacote que você baixou, para isso basta clicar com o botão direito do mouse em cima dele e selecionar extrair aqui. Para facilitar um pouco baixe ou deixe esse diretório na pasta downloads (os dois arquivos, tanto o que baixou como o que você extraiu).

"Já procurei em vários lugares com drive semelhante e o pessoal diz para dar um sudo apt-get install build-essential"

Bom esse pacote você pode baixa-lo de outra maneira também, vá em Sistema > Administração > gerenciador de pacotes Synaptic e lá em pesquisa escreva: build-essential agora clique com o direito em cima dele e selecione Marcar para instalação, depois clique em Aplicar. Caso isso não apareça na sua lista faça o seguinte: Vá em Sistema > Administração > Canais de Software, na janelinha que se abre clique na primeira aba "Programas do ubuntu" e deixe marcados todas as opções (são 5) e na opção "Baixar de: mude de servidor do Brasil para servidor principal. Agora clique na aba "Outro Software" e marque todas as opções e na aba Atualizações marque as 3 primeiras. Pronto agora clique em fechar, ele lhe dirá que precisa carregar a lista, diga sim ou OK ou Carregar. Após isso Veja se tem atualizações para fazer, se tiver faça. reinicie o sistema e veja se resolveu se não resolveu vamos prosseguir. Antes veja se no Gerenciador de pacotes Synaptic se já está instalado o build-essential senão instale, agora que sua lista está atualizada se ele não apareceu na lista a primeira vez, agora aparecerá. Ainda no Synaptic em pesquisa escreva : rt73 possivelmente ele lhe dará dois pacotes de drivers para wireless, instale os dois reinicie o sistema e veja se já está funcionando. Partindo do ponto que ainda não funcionou e precisamos instalar o pacote que você baixou, faça o seguinte: Vá em Aplicativos > Acessórios > terminal e digite: cd e dê um espaço depois abra a pasta downloads e procure o arquivo extraído (que está como rt73-cvs......) clique nesse arquivo segure apertado o botão e arraste ele para dentro da janela do terminal e solte-o nela. agora dê um enter, depois no final dê um make e depois sudo make install para instalar. Acredito que não precisará chegar até aqui, quando você instalar o pacote rt73 pelo Synaptic já deve resolver. Caso ainda não deu poste os resultados.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Reinstalei o Umbuntu para seguir os procedimentos acima, mas desta vez a internet não funcionou nem da primeira vez. :(

Como tenho o drive no meu pen-drive, abri o terminal e digitei: cd espaço, e joguei a pasta Module que fica dentro da pasta rt73-cvs-2008040418 (deste jeito é muito mais fácil, valeu pela dica;)) e dei o make. O erro que dá é esse:

make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.31-14-generic'

Building modules, stage 2.

MODPOST 0 modules

make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.31-14-generic'

rt73.ko failed to build!

make: ** [module] Erro 1

Como não tinha feito as atualizações, já esperava que ia continuar o erro. O problema é que agora vou ter que atualizar pelo pen-drive, dá pra fazer isso? :huh:

Obs: O receptor wireless tá funcionando porque tô neste momento usando ele no Windows 7 e tá beleza :rolleyes:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você instalou o build-essential? conexão com a Internet você só tem com wireless? se você tem com cabo (spedy ou velox) abra o terminal e digite sudo pppoeconf de enter ele talvez peça a sua senha, coloque e dê OK na primeira tela, depois OK novamente, depois coloque seu email de acesso a Internet, depois a senha, depois de oK até o fim. pronto você estará conectado, faça as atualizações e veja se refaça o procedimento acima com a Internet conectada.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não instalei o build-essential porque não tenho mais acesso nenhum a internet com o ubuntu, só com o windows. Minha ideia é pegar tudo o que tiver que instalar com o windows, salvar num pendrive e depois instalar no ubuntu, isso é possível? Como faz?

Compartilhar este post


Link para o post
Compartilhar em outros sites

É possível sim, mas é um pouco mais complicado. Mas o seu computador é dual boot? você tem qual provedor? spededy, velox?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Meu PC tá com o Windows e instalei o ubuntu através do wubi. Por isso é muito prático pra mim reinstalar ele quantas vezes quiser, não leva nem 10 minutos.

Meu irmão tem speed e divide comigo através de um roteador wireless da gts telecom, o sinal chega forte no meu PC, pois não tenho problema nenhum com a internet usando o windows.

Creio que conseguindo instalar o drive também vou poder usar a internet no ubuntu porque a rede ele já reconhece.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vamos por partes, o ubuntu reconheceu a placa wireless? se sim então o problema pode ser configuração. Se não, pode ser os drivers, você já foi em Sistema > Administração > Drivers de hardware e viu se sua placa está ativada lá? outra coisa vá ao terminal e dê o comando lspci e poste o modelo da sua placa

Identificando o Chipset

Para identificar o chipset da sua placa de rede sem fios, execute o comando:

Se ela for PCI:

lspci -v | grep Wireless ou

lspci -v | grep WiFi Se ela for USB:

lsusb -v | grep Wireless ou

lsusb -v | grep WiFi

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fui em Sistema > Administração > Drivers de hardware e não apareceu nada, quando a internet funcionava aparecia pelo menos os drive da placa de vídeo.

Digitei lspci no terminal e apareceu:

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)

00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)

00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)

00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)

00:01.3 Co-processor: nVidia Corporation MCP61 SMU (rev a2)

00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)

00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)

00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)

00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)

00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)

00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)

00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)

00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)

00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)

00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)

00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)

00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration

00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map

00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller

00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control

00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control

02:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)

Digitei o comando lsusb -v | grep Wireless e apareceu:

can't get device qualifier: Operation not permitted

can't get debug descriptor: Operation not permitted

cannot read device status, Operation not permitted (1)

can't get device qualifier: Operation not permitted

can't get debug descriptor: Operation not permitted

cannot read device status, Operation not permitted (1)

can't get hub descriptor: Operation not permitted

can't get device qualifier: Operation not permitted

can't get debug descriptor: Operation not permitted

cannot read device status, Operation not permitted (1)

can't get hub descriptor: Operation not permitted

cannot read device status, Operation not permitted (1)

Bus 001 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter

idProduct 0x2573 RT2501USB Wireless Adapter

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ok, se seu irmão tem o speedy e você tem um notebook a melhor opção é você levar o notebook até seu irmão e conectar o cabo amarelo que sai do modem e conecta-lo diretamente ao seu notebook, após estar conectado ligue o notebook, se o modem do speedy for roteado, assim que o ubuntu iniciar ele irá reconhecer e conectar a Internet, se não for roteado faça o seguinte: Vá em aplicativos > Acessórios > terminal e digite sudo pppoeconf, aguarde ele reconhecer o modem na primeira opção clique em sim depois continue até que chegue na opção de colocar o email de acesso e depois a senha (provavelmente seu irmão), dê ok em tudo até ele conectar, faça todas as atualizações inclusive a do driver rt73 que está no gerenciador de pacotes synaptic, depois reinicie e confira se tudo está ok. A principio essa é a melhor opção tendo em vista que seu irmão provavelmente mora próximo e você tem um notebook. outra coisa esse wireless é usb?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×