Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
marcosgl

Maior e Menor

Recommended Posts

Olá pessoal, Estou tentando fazer um programa onde o usuario digite "n" números e no final dizer qual o menor e o maior?

Eu ainda não vi matriz. e o que eu consigo fazer é determinando a quantidade de números.

Alguem pode me ajudar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Hmmmmm então

você não necessáriamente precisa de matriz/vetor para esse exercício...

Já viu loops certo?

voce terá que fazer um loop que leia os números (independente se o usuário digita 2 números ou 100 números)....

e a cada número que ele digitar.. você verifica se ele é maior ou menor...

pra isso você pode utilizar 2 variáveis

Menor

Maior

e Fazer uma condição (dentro do loop ) pra ele vericiar a cada número digitado....

não sei se deu pra entender direito .. mas eu tentei explicar na melhor forma possível sem dar o código pronto....

como montar ta escrito ai em cima.. agora só precisa arrumas as sintaxes =P

boa sorte.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Faça o seguinte...declare quatro variáveis:

n = variável para o usuário digitar os n numeros

maior = para pescar o maior número

menor = para pesar o menor número

contador = para contar quantas vezes o loop irá ser executado

suponhamos que fará o loop 10 vezes. dai faz o seguinte

maior=1

menor=1

leia (n)

enquanto (n < 11) faça

se (n > maior)

então maior = n

senão se (n < menor)

então menor = n

fim se

fim enquanto

caso dê algum pau nas variáveis maior e menor, ou no loop, só consertar, mas a lógica é essa aí. boa sorte.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Faça o seguinte...declare quatro variáveis:

n = variável para o usuário digitar os n numeros

maior = para pescar o maior número

menor = para pesar o menor número

contador = para contar quantas vezes o loop irá ser executado

suponhamos que fará o loop 10 vezes. dai faz o seguinte

maior=1

menor=1

leia (n)

enquanto (n < 11) faça

se (n > maior)

então maior = n

senão se (n < menor)

então menor = n

fim se

fim enquanto

Bruno ai está um erro que eu já cometi em uma prova....Eu esperava o marcosgl responder pra ver no que dava mas acho que voce tambem caiu na mesma pegadinha..

Para este caso voce precisa ver se é o primeiro registro....

Se for a primeira idade digitada você armazena em ambas as variáveis, tanto maior quanto menor.

Outra coisa é que o nosso amigo precisa de um número indefinido de registros..

eu alterei um pouco o código , espero que não se importe... ficou assim:

n = variável para o usuário digitar Quantos numeros serão digitados

idade = Variavel que o usuário irá digitar a idade

maior = para pescar o maior número

menor = para pesar o menor número

contador = para contar quantas vezes o loop irá ser executado

contador=0

leia (n) //usuario informa quantas idades ele irá digitar

enquanto (contador <= n) faça //loop que ira rodar até o numero que o usuario digitou

leia(idade)

se (contador == 0) //verifica se é o primeiro registro.

então maior = menor = idade //seta ambas as variáveis se for a primeira idade digitada

senão

se (idade > maior) então maior = idade //verifica se a idade é maior e se for joga pra variavel maior

fimse

se (idade < menor) então menor = idade //Verifica se a idade é menor e se for joga pra variavel menor

fimse

fimse

contador++

fimenquanto

Editado por duda3005

Compartilhar este post


Link para o post
Compartilhar em outros sites


#include <stdio.h>
int main(void)
{
int i;
float a,b,maior,menor;
for (i=0;;i++)
{
printf("Digite um numero: ");
if (i=0) scanf("%f",&a);
else scanf("%f",&;
if (b>a) maior=b;
if (b<a) menor=b;
}
}

Tá faltando muito, mas já dá pra pensar um pouco. Deve ter alguns erros, fiz com pressa, mas vocês podem completar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

#include <stdio.h>
int main(void)
{
int i;
float a,b,maior,menor;
for (i=0;;i++)
{
printf("Digite um numero: ");
if (i=0) scanf("%f",&a);
else scanf("%f",&;
if (b>a) maior=b;
if (b<a) menor=b;
}
}

Tá faltando muito, mas já dá pra pensar um pouco. Deve ter alguns erros, fiz com pressa, mas vocês podem completar.

Bom este código só compara A com B, ou seja ele só ira comparar o maior/menor no primeiro dígito.. logo ele nao irá comparar os outros números digitados...

falta um break já que o loop é infinito...

ACHO que ficaria mais ou menos assim:

#include <stdio.h>

int main(void)

{

int i;

float a,maior,menor;

char sn; //Variavel utilizada pra verificar se o usuário deseja continuar

for (i=0;;i++)

{

printf("Digite um numero: ");

scanf("%f",&a); //Scanf eu tirei do if pois ele precisa pegar todos os valores sempre.

if (i=0) {// se for o primeiro número ele atribui a variavel maior e menor

maior = menor = a;

} else {

if (menor < a) menor = a; //Se nao for o primeiro digito ele verifica o menor

if (maior > a) maior = a; //Se nao for o primeiro digito ele verifica o maior

}

printf("Deseja continuar? S/N"); //Pede pro usuário digitar se deseja ou não continuar

sn = getchar();

if (sn != 's') break; //Se não ele sai do loop

}

printf("Maior = %f\n",maior);

printf("Menor = %f\n",menor);

}

Compartilhar este post


Link para o post
Compartilhar em outros sites

#include <iostream.h>

int main()

{

int vetor[5];

int x, y, z;

cout<<"digite 5 numeros\n";

for (y = 0; y < 5; y++) /*Este laco faz o scan de cada elemento do vetor*/

{

cin>>vetor[y];

}

z = 1;

y = 0;

x = vetor[0];

while (y < 4)

{

if (vetor[y] < vetor[z])

{

if (vetor[z] > x)

{

x = vetor[z];

}

}

y++;

z++;

}

cout<<"\n O maior numero que voce digitou foi : "<<x;

system("pause");

return 0;

}

e mais ou menos assim que fica em c++...agora tente "conveter" para c e seja feliz

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×