Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
bely

VisualG Programa que verifica o signo

Recommended Posts

Gente, alguém poderia a me ajudar porque não tá rodando esse programa q fala o horóscopo alguém sabe um outro modo de faze-lo? fico grata pela ajuda :)

algoritmo "Horoscopo"
// Função :
// Autor :
// Data : 3/6/2010
// Seção de Declarações
var
   dia,mes: inteiro
   nome:caracter
inicio
   // Seção de Comandos
   escreval("Entre com seu nome")
   leia(nome)
   escreval("Entre com o dia de seu nascimento")
   leia(dia)
   escreval("Entre com o mês de seu nascimento")
   leia(mes)
   se(dia>=20 e dia<=31 e mes=3 dia>=1 dia<=20 e mes=4)então
      escreva(nome,"è do signo de Áries ")
   fimse
   se(dia>=21 e dia<=30 e mes=4 e dia>=1 e dia<=20 e mes=5)então
      escreval(nome,"é do signo de Touro")
   fimse
   se(dia>=21 e dia<=31 e mes==5 e dia>=1 e dia<=20 e mes=6)então
      escreval(nome,"é do signo de Gêmeos")
   fimse
   se(dia>=21 e dia<=30 e mes==6 e dia>=1 e dia<=21 e mes=7)então
      escreval(nome,"é do signo de Cancer")
   fimse
   se(dia>=22 e dia<=31 e mes==7 e dia>=1 e dia<=22 e mes=8)então
      escreval(nome,"é do signo de Leão")
   fimse
   se(dia>=22 e dia<=31 e mes=8 e dia>=1 e dia<=22 e mes=9)então
      escreval(nome,"é do signo de Virgem")
   fimse
   se(dia>=22 e dia<=30 e mes=9 e dia>=1 e dia<=22 e mes=10)então
      escreval(nome,"é do signo de Libra")
   fimse
   se(dia>=23 e dia <=31 e mes==10 e dia>=1 e dia<=21 e mes=11)então
      escreval(nome,"é do signo de Escorpião")
   fimse
   se(dia>=22 e dia<=30 e mes==11 e dia>=1 e dia<=21 e mes=12)então
      escreval(nome,"é do signo de Sagitário")
   fimse
   se(dia>=22 e dia<=31 e mes=12 e dia>=1 e dia<=20 e mes=1)então
      escreval(nome,"é do signo de Capricórnio")
   fimse
   se(dia>=21 e dia<=31 e mes=1 e dia>=1 e dia<=18 e mes=2)então
      escreval(nome,"é do signo de Aquário")
   fimse
   se(dia>=19 e dia<=29 e mes=2 e dia>=1 e dia<=19 e mes=3)então
      escreval(nome,"é do signo de Peixes")
   senao
      escreval("dia ou mês invalido")
   fimse
fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Alguem sabe porque não roda me ajuedem, por favor....

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, essa resposta com certeza não ira te ajudar mais, mas pode ser que ajude a outros.

Var

   dia, mes :inteiro

Inicio

   escreva ("digite o dia do seu nescimento: ")
   leia (dia)
   escreva ("digite o mes do seu nescimento: ")
   leia (mes)
   se ((dia >=21) e (mes=3) ou (dia <=19) e (mes=4)) então
      escreva ("aries")
   senao
      se ((dia >=20) e (mes=4) ou (dia <=20) e (mes=5)) então
         escreva ("touro")
      senao
         se ((dia >=21) e (mes=5) ou (dia <=21) e (mes=6)) então
            escreva ("gemeos")
         senao
            se ((dia >=22) e (mes=6) ou (dia <=22) e (mes=7)) então
               escreva ("cancer")
            senao
               se ((dia >=23) e (mes=7) ou (dia <=22) e (mes=8)) então
                  escreva ("leao")
               senao
                  se ((dia >=23) e (mes=8) ou (dia <=22) e (mes=9)) então
                     escreva ("virgem")
                  senao
                     se ((dia >=23) e (mes=9) ou (dia <=22) e (mes=10)) então
                        escreva ("libra")
                     senao
                        se ((dia >=23) e (mes=10) ou (dia <=21) e (mes=11)) então
                           escreva ("escorpião")
                        senao
                           se ((dia >=22) e (mes=11) ou (dia <=21) e (mes=12)) então
                              escreva ("sagitario")
                           senao
                              se ((dia >=22) e (mes=12) ou (dia <=19) e (mes=1)) então
                                 escreva ("capricornio")
                              senao
                                 se ((dia >=20) e (mes=1) ou (dia <=18) e (mes=2)) então
                                    escreva ("aquario")
                                 senao
                                    se ((dia >=19) e (mes=2) ou (dia <=20) e (mes=3)) então
                                       escreva ("peixes")

                                    fimse
                                 fimse
                              fimse
                           fimse
                        fimse
                     fimse
                  fimse
               fimse
            fimse
         fimse
      fimse
   fimse

Fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×