Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Wendell Menezes

[Resolvido] Fórmula ? Código VBA ?

Recommended Posts

Boa noite pessoal,

Preciso de ajuda com a planilha abaixo:

http://www.megaupload.com/?d=CUK3A5JV

Desejo criar uma planilha máscara, para que quando eu gerar relatórios do SAP, seja necessário apenas colar os valores na planilha para que as fórmulas façam o resto.

O problema é:

Os valores da coluna A se repetem as vezes, assim utilizo a fórmua:

=SE(A2=A1;"-";A2)

Posteriormente eu preciso filtrar tudo que seja "-" e deletar.

Porém quando eu faço isso, algumas células ficam com erro, isso porque as mesmas eram utilizadas na fórmula mas foram excluídas.

Minha última tentativa foi a fórmula:

=SE(ÉERROS(SE(A2=A1;"-";A2);A2;SE(A2=A1;"-";A2)))

Mas também foi um fracasso :\

Obrigado:confused:

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

a partir da linha 4 (inserir nela)( utilize essa fórmula:

=SE(CONT.SE($A$2:$A3;A4)>=1;"""";A4)

copia e cola da linha 5 até a última linha.

depois eu utilizei o auto filtro e deletei todas com "

aqui funcionou

Se você nao quiser deletar, tb é possivel você criar uma planilha "pesquisa" na outra aba.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Wendell

Se você quer apenas filtrar a coluna A para que apareçam só os números que não sejam repetidos é muito fácil fazer isso com Filtro Avançado.

Depois você pode gravar a ação e colocar a macro num botão e fazer isso automaticamente.

Para usar o filtro avançado e muito fácil.

Qual a versão do teu Excel, o meu é o 2007 tem já opção para valores exclusivos.

Veja como fica: Reduziu para 312 linhas depois de filtradas.

http://www.4shared.com/document/0aeCIo4G/KPI_1__wendell_10_03_11.html

Se não souber como fazer eu posso te passar os detalhes. Mas é bem mais fácil, sem fórmula.

Dê retorno.

Um abraço

Compartilhar este post


Link para o post
Compartilhar em outros sites
a partir da linha 4 (inserir nela)( utilize essa fórmula:

=SE(CONT.SE($A$2:$A3;A4)>=1;"""";A4)

copia e cola da linha 5 até a última linha.

depois eu utilizei o auto filtro e deletei todas com "

aqui funcionou

Se você nao quiser deletar, tb é possivel você criar uma planilha "pesquisa" na outra aba.

Funcionou perfeitamente !

Muito obrigado.

Patropi, eu não conhecia essa do filtro avançado, sempre que eu queria apenas separar os dados repitidos eu fazia por Tabela Dinânica. Agradeço à você também pelo conhecimento compartilhado :)

Abraços

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

De nada.

Considere tb a opção pela pesquisa avançada que o patropi falou, pois é mais rápido e fácil, você poderá até utilizar a macro, além de nao precisar mexer com fórmulas toda vez que criar a planilha.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×