Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
Wendell Menezes

[Resolvido] Fórmula ? Código VBA ?

Recommended Posts

Boa noite pessoal,

Preciso de ajuda com a planilha abaixo:

http://www.megaupload.com/?d=CUK3A5JV

Desejo criar uma planilha máscara, para que quando eu gerar relatórios do SAP, seja necessário apenas colar os valores na planilha para que as fórmulas façam o resto.

O problema é:

Os valores da coluna A se repetem as vezes, assim utilizo a fórmua:

=SE(A2=A1;"-";A2)

Posteriormente eu preciso filtrar tudo que seja "-" e deletar.

Porém quando eu faço isso, algumas células ficam com erro, isso porque as mesmas eram utilizadas na fórmula mas foram excluídas.

Minha última tentativa foi a fórmula:

=SE(ÉERROS(SE(A2=A1;"-";A2);A2;SE(A2=A1;"-";A2)))

Mas também foi um fracasso :\

Obrigado:confused:

Compartilhar este post


Link para o post
Compartilhar em outros sites

a partir da linha 4 (inserir nela)( utilize essa fórmula:

=SE(CONT.SE($A$2:$A3;A4)>=1;"""";A4)

copia e cola da linha 5 até a última linha.

depois eu utilizei o auto filtro e deletei todas com "

aqui funcionou

Se você nao quiser deletar, tb é possivel você criar uma planilha "pesquisa" na outra aba.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Wendell

Se você quer apenas filtrar a coluna A para que apareçam só os números que não sejam repetidos é muito fácil fazer isso com Filtro Avançado.

Depois você pode gravar a ação e colocar a macro num botão e fazer isso automaticamente.

Para usar o filtro avançado e muito fácil.

Qual a versão do teu Excel, o meu é o 2007 tem já opção para valores exclusivos.

Veja como fica: Reduziu para 312 linhas depois de filtradas.

http://www.4shared.com/document/0aeCIo4G/KPI_1__wendell_10_03_11.html

Se não souber como fazer eu posso te passar os detalhes. Mas é bem mais fácil, sem fórmula.

Dê retorno.

Um abraço

Editado por Patropi
Colocar link

Compartilhar este post


Link para o post
Compartilhar em outros sites
a partir da linha 4 (inserir nela)( utilize essa fórmula:

=SE(CONT.SE($A$2:$A3;A4)>=1;"""";A4)

copia e cola da linha 5 até a última linha.

depois eu utilizei o auto filtro e deletei todas com "

aqui funcionou

Se você nao quiser deletar, tb é possivel você criar uma planilha "pesquisa" na outra aba.

Funcionou perfeitamente !

Muito obrigado.

Patropi, eu não conhecia essa do filtro avançado, sempre que eu queria apenas separar os dados repitidos eu fazia por Tabela Dinânica. Agradeço à você também pelo conhecimento compartilhado :)

Abraços

Compartilhar este post


Link para o post
Compartilhar em outros sites

De nada.

Considere tb a opção pela pesquisa avançada que o patropi falou, pois é mais rápido e fácil, você poderá até utilizar a macro, além de nao precisar mexer com fórmulas toda vez que criar a planilha.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×