Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
ReneGustavo

[Resolvido] Algoritmo que calcule MDC - Portugol

Posts recomendados

Fala galera, beleza? Meu nome é René Gustavo, estou no 1° Ano do ensino médio no CEFET-MG, no curso de Informática, onde tenho a aula de Linguagem de Programação (LP), e no momento estou aprendendo "Portugol". Bom, estou aqui hoje pois estou com problemas, tenho 1 trabalho para entregar segunda-feira, e não consigo fazer uma questão, que é a seguinte:

- Faça um Algoritmo em Portugol, que leia 2 números digitados pelo usuário e dê o MDC deles.

por favor, seria MUITO grato se alguém me ajudasse. Desde já agradeço, abraço a todos !

Compartilhar este post


Link para o post
Compartilhar em outros sites

E qual é a sua dúvida?

Já fez alguma coisa?

Poste o código que você já fez.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não fiz nada ainda Roberto, não tenho a mínima ideia de como fazer essa lógica, peço que pelo menos me dêem uma pista. Seria muito grato. Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ei galera, tentei, tentei, tentei, e acabei conseguindo, a tempo de entregar o meu trabalho, então vô por aii pra vocês, se alguém, um dia, tiver a mesma dúvida que eu. Bom, o algoritmo (em portugol), eu vô deixar pronto, mas eu recomendo que você não copie, apenas tire umas idéias de como fazer o seu, que fica mais fácil ! valeu

ALGORITMO :

Algoritmo "MDC"

var

x, y, i, mdc : inteiro //x-primeiro número, y-segundo número

inicio

Leia (x)

Leia (y)

para i de 1 ate x faca

se (x%i=0) e (y%i=0) então

mdc<-i

fimse

fimpara

escreva(mdc)

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!