Ir ao conteúdo
  • Cadastre-se
Antonio C N Santos

Duvida Excel

Recommended Posts

Preciso que na função SE, dependendo da resposta uma outra celula tenha um valor atribuído.

Exemplo:

Se a célula A1 tem o valor "V", a celula F1 toma o valor de A1, caso contrario a celula F2 toma o valor de A1+B1.

SE (A1="V";F1=A1;F2=A1+B1)

Tento compor a formula acima mas dá erro. O que posso fazer ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Antonio, Bom Dia.

"...Se a célula A1 tem o valor "V", a celula F1 toma o valor de A1, caso contrario a celula F2 toma o valor de A1+B1..."

Tente fazer assim:

F1 --> =SE(A1="V";A1;"")

F2 --> =SE(A1<>"V";A1+B1;"")

Era isto que você queria?

Espero ter ajudado.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Caro Antonio, Bom Dia.

"...Se a célula A1 tem o valor "V", a celula F1 toma o valor de A1, caso contrario a celula F2 toma o valor de A1+B1..."

Tente fazer assim:

F1 --> =SE(A1="V";A1;"")

F2 --> =SE(A1<>"V";A1+B1;"")

Era isto que você queria?

Espero ter ajudado.

Eu preciso que a a partir da celula que contem V ou não, eu atribua valores a outra celula.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Antonio,

As fórmulas citadas fazem exatamente o que você pediu.

Agora, se você não quer fórmulas para trabalhar no Excel, a única saída é Programação VBA.

Tenho certeza que aparecerá um outro colega especialista em VBA para ajudá-lo.

Tenha um bom domingo de Páscoa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você não vai conseguir somar. Veja bem o que você pediu:

Se a célula A1 tem o valor "V", a celula F1 toma o valor de A1, caso contrario a celula F2 toma o valor de A1+B1.

Se A1= "V" então F1 vai ser V.

Se A1 for diferente de "V", F2 vai ser A1+B1 (Não está dando erro porque o valor de A1 pode ser letras? Como somar letras?)

As fórmulas do amigo Mazzaropi estão corretas!

Seria interessante postar a planilha para podermos analisar. Poste em www.sendspace.com e disponibilize o link.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Flávio, Bom Dia.

Eu entendí que o conteúdo da célula A1 vai alternar entre Texto = V e entre valores numéricos.

É uma quebra de integridade de dados, utilizar o mesmo campo para conteúdo de formato totalmente diferentes.

Mas como o usuário não colocou a planilha exemplo aquí e nem disse a real utilização, então a única saída foi transformar em fórmula a versão EXATA do que ele pediu.

Mas como ele já se manisfestou, ele precisa/quer VBA.

Um Bom domingo de Páscoa para Você e sua Família !

Compartilhar este post


Link para o post
Compartilhar em outros sites

O problema é que mesmo com VBA pode continuar dando erro se não houver um tratamento de letras/números.

Para o problema relatado, uma fórmula simples resolve, só temos que entender como será utilizado a planilha, que dados serão lançados na mesma, etc.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Antonio,

O Excel é um aplicativo de células ativas que trabalha por referência geográfica.

Logo, nas células, o conteúdo pode ser uma Constante, ex.: 25, V, R$ 12,50, ou uma Variável, que adveem do resultado da utilização das funções existentes no aplicativo que compôem as tão faladas fórmulas; ex.: =SE(A1>5;"VALEU";18) Etc.

As células "Buscam" as referências e os valores de outros lugares.

NÃO é possível ter fórmula e valor sendo digitado ao mesmo tempo na mesma célula.

Como você quer "Enviar" dados de uma célula para outra célula sem que a outra célula tenha alguma fórmula, a única possibilidade é através da Programação em VBA Excel.

Para uma ajuda mais precisa, salve a sua planilha em algum site gratuito, ex.: www.4shared.com e coloque o link aquí.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×