Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
thiagophn

VisualG Idade, Sexo e Menor Salário

Recommended Posts

Estou algumas dúvidas sobre alguns aspectos deste programa.

como visualizar a idade e o sexo da pessoa que possui o menor salário.

pois tento e não consigo fazer funcionar.

Foi feita uma pesquisa entre os habitantes de uma região. Foram coletados os dados de idade, sexo (M/F)

e salário. Faça um programa que calcule e mostre:

• a média dos salários do grupo;

• a maior e a menor idade do grupo;

• a quantidade de mulheres com salário até R$ 200,00;

• a idade e o sexo da pessoa que possui o menor salário.

Finalize a entrada de dados ao ser digitada uma idade negativa

var
idade, i,contg, contf200, maxid, meid,id: inteiro
sex, genero:caracter
sal, salario, maxsal,msal: real
inicio
// Seção de Comandos
contg<- 0
contf200<- 0
maxid<- 0
meid<- 200
salario<- 0
maxsal<-0
msal<-99999999999999999
escreval ("Qual é sua idade?: ")
leia (idade)
enquanto idade <> 0 faca
escreval ("Qual é seu salário?: ")
leia (sal)
escreval ("Qual é seu sexo M ou F?: ")
leia (sex)
se (sex <> "F" e "M") então
escreval ("Digite uma letra válida F ou M: ")
leia (sex)
fimse
se (sal > 0) então
salario <- salario + sal
contg<- contg +1
fimse
se (idade > maxid) então
maxid <- idade
fimse
se (idade < meid) então
meid <- idade
fimse
se (sal <= 200) e (sex = "f") então
contf200 <- contf200 + 1
fimse
se (sal > maxsal) então
maxsal<- sal
fimse
se (sal < maxsal) então
msal<- sal
fimse
se (msal < msal1) então
msal <- sal
fimse
escreval ("**************************************************************")
escreval ("Digite a idade do proximo entrevistado ou ZERO para encerrar:")
leia (idade)
fimenquanto
escreval("Media dos salarios do grupo: R$",salario/contg)
escreval("Menor idade: ",meid," anos")
escreval("Maior idade: ",maxid," anos")
escreval("A quantidade de mulheres com salário até R$ 200,00 foi de: ",contf200)
escreval ("A idade: ", id, " e o sexo: ", genero, " da pessoa que possui o menor salário")
fimalgoritmo

 

Editado por Simon Viegas
Olá! Favor ler tópico e seguir orientações sobre POSTAGEM DE CÓDIGOS: http://www.clubedohardware.com.br/announcement/27-poste-seus-c%C3%B3digos-corretamente/
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@thiagophn    dois erros .  hum nessa linha   :

se (sex <> "F" e "M") então    //  essa linha aqui 

escreval ("Digite uma letra válida F ou M: ")

precisa colocar dentro de dois  parenteses assim :

se (sex <> "F") e (sex <> "M") ENTÃO

escreval ("Digite uma letra válida F ou M: ")

e essa variável não foi declarada no inicio :

se (msal < msal1) então    //  msal1 não foi declarada

msal <- sal

fimse

 

Editado por Simon Viegas
Remover trecho referente à postagem removida

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×