Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
gigi915

[Resolvido] Filtrar dados entre planilhas

Recommended Posts

Bom dia pessoal,

Uso duas guias de um arquivo excel 2010

A planilha A1 está mais ou menos assim: ( tem mais de 1000 códigos)

COLUNA A COLUNA B

A1 CÓDIGO DESCRIÇÃO

A2 1004C Tesoura sem ponta

A3 1005C Papel de seda

Eu preciso clicar em qualquer célula da coluna A (Plan2) e ter a opção de filtrar qualquer código da coluna A (Plan1) me retornando a descrição na Coluna B (plan2).

Não sei se consegui explicar direito.

Se alguém entendeu e puder me dar uma dica, fico grata.

Compartilhar este post


Link para o post
Compartilhar em outros sites

O que você precisa é de validação de dados na Plan2.

Passo a passo (Office 2007):

1) Dê um nome a sua coluna de códigos na Plan1. Supondo que podem ser retirados ou adicionados mais códigos, e que o cabeçalho está em A1, vá no Menu Fórmulas > Gerenciador de Nomes > Novo. Escolha um nome (p.ex. COD) e em 'Refere-se a:' cole o código abaixo.

=DESLOC(Plan1!$A$2;0;0;CONT.VALORES(Plan1!$A:$A)-1)

2) Vá na Plan2, selecione de A2 até o fim da planilha (ou o intervalo que lhe convier), vá no Menu Dados > Validação de Dados. Em 'Permitir' seleciona 'Lista"; em 'Fonte' digite '=' e o nome de sua lista (p.ex. =COD).

3)Em B2 cole a fórmula abaixo e arraste até onde deseja que a planilha seja preenchida. Isso busca o correspondente ao código em Plan 1.

=SE(A2="";"";PROCV(A2;DESLOC(Plan1!$A$2;0;0;CONT.VALORES(Plan1!$A:$A)-1;2);2;FALSO))

Pronto! Aqui funcionou!

Se alguém tiver outra dica mais fácil ou que possa somar a nosso conhecimento, ficarei muito grato se puder compartilhar.

Aqui está o exemplo que descrevi acima:

http://www.sendspace.com/file/9ztjz3

Editado por jeffsilveira
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigada Jeff, era isso mesmo que eu precisava, deu certo. Eu não sabia que chamava validação de dados. Obrigada mesmo.

Abraços

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×