Ir ao conteúdo
  • Cadastre-se
N4Y4R4_

Estou criando um htacess da forma certa?

Recommended Posts

Estou tentando colocar o .htaccess na raiz do meu site, mas parece que nenhum comando que eu coloco no .htaccess funciona!

O diretório do meu site tem pastas com arquivos HTML dentro, numa dessas pastas da raiz é que tenho a pasta /blog (com instalação Wordpress).

Ou seja, é assim:

/meusite { pasta1/index.html pasta2/index.html pasta3/index.html blog/index.php }

Não sei o que posso estar fazendo de errado, eu crio um arquivo no bloco de notas exatamente assim ".htaccess" (sem aspas)

Coloco o código por exemplo esse para redirecionar URLs com www para sem www:


RewriteEngine On
RewriteCond %{HTTP_HOST} !^meusite.com$ [NC]
RewriteRule ^(.*)$ http://meusite.com/$1 [L,R=301]

E envio o .htaccess por FTP para /meusite (a pasta raiz ou public_html)

E não funciona! O que acontece? Eu quero colocar qualquer comando em .htaccess para ver rodando no site, por exemplo, quero testar redirecionar os sites com WWW para o domínio sem www.

Estou usando esse código dentro do .htaccess mas nada funciona:


RewriteEngine On
RewriteCond %{HTTP_HOST} !^meusite.com$ [NC]
RewriteRule ^(.*)$ http://meusite.com/$1 [L,R=301]

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×