Ir ao conteúdo
  • Cadastre-se

brunord2014

Membros Juniores
  • Total de itens

    4
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. vln //valor a ser digitado pelo usuário vlm //valor maior vlme //valor menor vls //valor da soma qtd //quantidade vlmd //valor médio
  2. Não consigo achar o menor número usando o repita. algoritmo "TP901.alg" // Função : // Autor : // Data : 07/11/2018 // Seção de Declarações var vln: inteiro vlm: inteiro vls: inteiro vlme: inteiro qtd: inteiro vlmd: real inicio vln <- 0 vlm <- 0 vlme <- 0 vls <- 0 qtd <- 0 vlmd <- 0 escreva ("Digite o primeiro número ou 0 para finalizar: ") leia (vln) vlm <- vln vlme <- vlme se (vln = 0) entao escreva ("Algoritmo finalizado sem calculos...") senao repita qtd <- qtd + 1 vls <- (vls + vln) escreva ("Digite o próximo número ou 0 para finalizar: ") leia (vln) se (vln > vlm) entao vlm <- vln fimse se (vln < vlme) entao vlme <- vln fimse ate (vln = 0) fimse escreval ("Seu algoritmo foi finalizado, veja as conclusões: ") vlmd <- vls/qtd escreval ("O maior valor é: ",vlm,"") escreval ("O menor valor é: ",vlme: 2:2,"") escreval ("A soma dos valores foi de: ",vls) escreval ("Quantidade de números digitados: ",qtd) escreval ("O menor valor digitado foi:" ,vlme,) vlmd <- vls/qtd escreval ("A média foi: ",vlmd) fimalgoritmo
  3. @Simon Viegas valeu cara deu muito certo, corrigi o meu e conseguir identificar o erro, muito obrigado.
  4. Galera, boa noite estou com um probleminha , está dando o seguinte erro quando utilizo 0 como finalizador no visualg: algoritmo "semnome" // Função : // Autor : // Data : 09/11/2018 // Seção de Declarações var n, qtn, s, p, qtp, sp: inteiro mde: real inicio n <- 0 qtn <- 0 s <- 0 p <- 0 qtp <- 0 sp <- 0 mde <- 0 // Seção de Comandos escreva ("Por favor digite o primeiro número ou 0 para finalizar:") leia (n) se (n = 0) entao escreval ("Algortmo finalizado sem calculos...") senao repita qtn <- qtn+1 escreva ("Digite o Próximo número ou 0 para finalizar: ") leia (n) se (n = 0) entao escreval ("Algoritmo finalizado, veja: ") s <- s+n se (n > 0) entao qtp <- qtp+1 p <- n sp <- sp+p fimse fimse ate (n = 0) fimse mde <- sp/qtp escreva ("A quantidade de números digitados foi: ") escreva ("A Soma dos números digitados foi: ",s) se (mde < 0 ) entao escreva ("Você não digitou números positivos.") senao escreva ("A média de números positivos digitados foi: ",mde) fimse fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×