Ir ao conteúdo
  • Cadastre-se

Irwing Seiji Ato

Membros Plenos
  • Total de itens

    88
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. O código creio que está certo porém dá erro não sei porque esse erro aqui e também quando executa o próximo comando ele imprime os números como se fosse par porém não é primo, não sei porque preciso de resposta segue o código Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 07/04/2017 Var // Seção de Declarações das variáveis num:vetor [1..3] de real cont:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para cont de 1 ate 3 faca escreval("Digite um número") leia(num[cont]) fimpara para cont de 1 ate 3 faca se(num[cont] mod 2 = 0) entao escreval("O número par",num[cont]) senao se (num[cont] mod 2 <> 0) entao escreval("O número é ímpar",num[cont]) fimse fimse fimpara Fimalgoritmo
  2. Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 16/05/2019 Var // Seção de Declarações das variáveis matris:vetor[1..5,1..5] de real i,j:inteiro numero:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para i de 1 ate 5 faca para j de 1 ate 5 faca escreval("Digite um número na posição [",i,"]","[",j,"]") leia(matris[i,j]) fimpara fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca escreva("[",i,"]","[",j,"] = ",matris[i,j]," ") fimpara escreval("") fimpara escreval("Digite um número para ser pesquisado na matriz:") leia(numero) para i de 1 ate 5 faca para j de 1 ate 5 faca se(numero = matris[i][j]) escreval("O número digitado existe na posição: [",i,"]","[",j,"]") fimse fimpara fimpara Fimalgoritmo Este é o código porém dá erro ao pesquisar se o número existe na matriz dá esse erro
  3. O código é este mas o problema é que eu coloco a senha da loja e não carrega simplesmente sai do programa não estou achando o erro #include <stdio.h> #include <stdlib.h> /* run this program using the console pauser or add your own getch, system("pause") or input loop */ int main() { int opcao,opcao1,opcao2,opcao3,opcao4,i,quant; struct referencia{ char nome0[100],nome1[100],nome2[100],nome3[100],nome4[100]; } CA[600]; CA[600]; CA[600]; CA[600]; CA[600]; CA[600]; CA[600]; char nome5[100]; system("cls"); printf("Nome do atendente: "); fflush(stdin); scanf("%[^\n]s",nome5); printf("Senha da Loja C&A: "); scanf("%d",&opcao3); switch(opcao3){ case 123456: while(opcao !=6){ while(opcao2 !=1){ system("color F4"); system("cls"); printf("--------------------------------------------------"); printf("\t\t\t\tLoja C&A\n"); printf("--------------------------------------------------\n\n"); printf("\t\tSeja Bem Vindo, Atendente %s\n",nome5); printf("__________________________________________________\n "); printf("1-Cadastrar\n "); printf("2-Exibir Dados\n "); printf("3-Alterar\n "); printf("4-Excluir\n "); printf("5-informações do Sistema\n"); printf("6-Sair\n"); printf("---------------------------------------------------\n\n"); printf("\nQual opcao voce deseja acessar? "); scanf("%d",&opcao); switch(opcao){ case 1: system("cls"); printf("\n\n Quantos cadastros voce deseja realizar? "); scanf("%d",&quant); for(i=1;i<=quant;i++){ system("cls"); printf("\n\n\t\t\t INICIANDO CADASTRO %d\n",i); printf("\t\t\t --------------------------\n\n"); printf("\n Nome do comprador: "); flush(stdin); scanf("%[^\n]s",CA [i].nome0); printf("\n Telefone do comprador: "); fflush(stdin); scanf("%[^\n]s",CA [i].nome1); printf("\n Marca do produto: "); fflush(stdin); scanf("%[^\n]s", CA [i].nome2); printf("\n Codigo do produto: "); fflush(stdin); scanf("%[^\n]s", CA [i].nome3); printf("\n Preco do produto: "); fflush(stdin); scanf("%[^\n]s", CA [i].nome4); printf("\n\n\t\t"); system("pause"); system("cls"); } break; case 2: system("cls"); for(i=1;i<=quant; i++){ system("cls"); printf("\n\n\t\t\t EXIBINDO CADASTRO $d\n", i); printf("\t\t\t ----------------------\n\n"); printf(" Nome do comprado : %s\n",CA [i].nome0); printf("\n Telefone do comprador : %s\n",CA [i].nome1); printf("\n Marca do produto : %s\n", CA [i].nome2); printf("\n Codigo do produto : %s\n", CA [i].nome3); printf("\n Preco do produto : %s\n", CA [i].nome4); system("pause"); } break; case 3: system("cls"); for(i=1;i<=quant;i++){ printf("\n\n\t\t\t ALTERAR CADASTRO\n"); printf("\t\t\t ----------------------\n\n"); printf(" 1 - Nome do comprador"); printf("\n 2- Telefone comprador"); printf("\n 3- Marca do produto"); printf("\n 4- Codigo do produto"); printf("\n 5- Preco do produto\n\n"); printf("Qual opcao voce deseja acessar? \n"); scanf("%d",&opcao1); break; switch(opcao1){ case 1: for(i=1;i<=quant;i++){ system("cls"); printf("\n\n CADASTRO %d\n", i); printf("\n Alterar nome do comprador: "); fflush(stdin); scanf("%[^\n]s",&CA [i].nome0); printf("\n Novo nome do comprador: %s\n\n\t\t"); system("pause"); } break; case 2: for(i=1;i<=quant;i++){ system("cls"); printf("\n\n CADASTRO %d\n",i); printf("\n Alterar telefone do comprador: "); fflush(stdin); scanf("%[^\n]s", &CA [i].nome1); printf("\n Novo telefone do comprador: %s\n\n\t\t"); system("pause"); } break; case 3: for(i=1;i<=quant;i++){ system("cls"); printf("\n\n CADASTRO %d\n", i); printf("\n Alterar marca do produto: "); fflush(stdin); scanf("%[^\n]s", &CA [i].nome2); } case 4: for(i=1;i<=quant;i++){ system("cls"); printf("\n\n CADASTRO %d\n",i); printf("\n Alterar codigo do produto: "); fflush(stdin); scanf("%[^\n]s",&CA [i].nome3); printf("\n Novo codigo do produto: %s\n\n\t\t"); system("pause"); } break; case 5: for(i=1;i<=quant;i++){ system("cls"); printf("\n\n CADASTRO %d\n", i); printf("\n Alterar preco do produto: "); fflush(stdin); scanf("%d[^\n]s",&CA [i].nome4); printf("\n Novo preco do produto: %s\n\n"); system("pause"); } break; } } break; case 4: system("cls"); for(i=1;i<=quant;i++){ printf("\n\n\t\t\t EXCLUIR CADASTRO\n"); printf("\t\t\t ---------------------\n\n"); printf(" 1- Nome do comprador"); printf("\n 2- Telefone do comprador"); printf("\n 3- Marca do produto"); printf("\n 4- Codigo do produto"); printf("\n 5- Preco do produto"); printf("\n 6 Excluir todos os dados\n\n"); printf("Qual opcao voce deseja acessar? \n"); scanf("%d",&opcao4); switch(opcao4){ case 1: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome0,0,sizeof(CA [i].nome0)); printf("Nome do comprador excluido!\n\n"); system("pause"); } break; case 2: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome1,0,sizeof(CA [i].nome1)); printf("Telefone do comprador excluido!\n\n"); system("pause"); } break; case 3: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome2,0,sizeof(CA [i].nome2)); printf("Marca do produto excluida!\n\n"); system("pause"); } break; case 4: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome3,0,sizeof(CA [i].nome3)); printf("Codigo do produto excluido!\n\n"); system("pause"); } break; case 5: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome4,0,sizeof(CA [i].nome4)); printf("Preco do produto excluido!\n\n"); system("pause"); } break; case 6: for(i=1;i<=quant;i++){ system("cls"); memset(&CA [i].nome0,0,sizeof(CA [i].nome0)); memset(&CA [i].nome1,0,sizeof(CA [i].nome1)); memset(&CA [i].nome2,0,sizeof(CA [i].nome2)); memset(&CA [i].nome3,0,sizeof(CA [i].nome3)); memset(&CA [i].nome4,0,sizeof(CA [i].nome4)); printf("Todos os dados foram excluidos!\n\n"); system("pause"); } break; } } break; case 5: system("cls"); printf("Componentes: \n\n"); printf("Irwing Seiji Ato \n"); printf("Copyright@2019"); system("pause"); break; case 6: system("cls"); printf("\n voce realmente deseja sair do sistema da loja C&A?\n\n"); printf(" 1- Sim\n 2- Nao"); printf("\n\n "); scanf("%d", &opcao2); break; switch(opcao2){ case 1: system("cls"); printf("\n\n Volte sempre a loja C&A ! \n\n\n\t\t"); system("pause"); return 0; break; } } } break; } } system("pause"); return 0; }
  4. Estou com esse erro aqui é não sei como consertar isso estou fazendo um trabalho no excel e preciso usar o visual basic só para atualizar a tabela dinâmica Private Sub Worksheet_Activate() Worksheets(2).PivotTables("Tabela_Caixa").PivotCache.Refresh Worksheets(2).PivotTables("Tabela_Gastos").PivotCache.Refresh End Sub O código é esse, o código está no activate
  5. Foi instalado normalmente, só que é crackeado ativei pelo CMD, e com os arquivos que possui na HD do Windows 7
  6. Antes de instalar o Windows 10 tinha o Windows 7 e nele o CD/DVD funcionava normalmente, aparecia em dispositivos e unidades CD/DVD coisa que no Windows 10 não aparece CD/DVD
  7. Eu acho que o cabo SATA está bem encaixado, pois quando clico no botão para abrir abre normalmente e as luzes acendem quando abre
  8. Tenho um computador e nele está instalado Windows 10 possui CD e DVD, fiz todas as possíveis soluções da Microsoft que está nesse link https://support.microsoft.com/pt-br/help/314060/your-cd-or-dvd-drive-is-not-recognized-by-windows-or-other-programs e nenhuma delas funcionou, nem no gerenciador de dispositivos aparecia a unidade de CD/DVD, só aparecia quando clicava em Exibir, mostrar dispositivos ocultos, porém desinstalei o software do mesmo e não consegui reinstala-lo obviamente esse não era a solução do problema pois desinstalei e era para ele automaticamente reinstalar o driver, isso não aconteceu, e acho que mesmo com esse driver instalado novamente não iria funcionar, alguém sabe como resolver esse problema?
  9. Uplay da Ubisoft não é pirateado é original é o giveaway da Ubisoft
  10. Baixei está instalado roda mas depois ele sai do jogo sozinho não sei porque
  11. As configurações do meu notebook são Windows 10 Home Language 64 bits Processador :Intel Core i7 8550U CPU 1,80 GHz (8 CPUs), ~ 2.0 GHz Memória RAM: 8192 MB RAM Placa Integrada: Intel UHD Graphics 620 Total Aprox. de memória: 4156 MB Memória de vídeo (VRAM): 128 MB Memória Compartilhada : 4028 MB Placa de vídeo dedicada: AMD Radeon 520 Total Aprox. Memória: 6068 MB Memória de vídeo: 2039 MB O notebook roda o jogo?
  12. adicionado 5 minutos depois Não sei porque dá negativo quando colocar int(exp(base,i-1)) mas o base10 tem que ser real porque senão não aceita dá um erro http://www.apoioinformatica.inf.br/produtos/item/30-as-funcoes-do-visualg-versao-2-0 Exp( base, expoente) - Retorna o valor de base elevado a expoente, sendo ambos expressões do tipo real.
  13. Atualizei o código e ficou assim o se e o senão, porém se colocar no código int(exp(base,i-1) retorna um valor negativo tem que ser exp(base,i-1) somente isso se for int(exp(base,i-1) aparece negativo Var // Seção de Declarações das variáveis sequencia:vetor [1..8] de caractere i, base:inteiro base10 : real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite qual a base") leia(base) para i de 8 ate 1 passo -1 faca escreval("Digite o número",i) leia(sequencia[i]) fimpara para i de 1 ate 8 faca se sequencia[i] = "A" entao base10 <- base10 + 10 * Exp(base, i-1) senao se sequencia[i] = "B" entao base10 <- base10 + 11 * Exp(base, i-1) senao se sequencia[i] = "C" entao base10 <- base10 + 12 * Exp(base, i-1) senao se sequencia[i] = "D" entao base10 <- base10 + 13 * Exp(base, i-1) senao se sequencia[i] = "E" entao base10 <- base10 + 14 * Exp(base, i-1) senao se sequencia[i] = "F" entao base10 <- base10 + 15 * Exp(base, i-1) senao se sequencia[i] = "0" entao base10 <- base10 + 0 * Exp(base, i-1) senao se sequencia[i] = "1" entao base10 <- base10 + 1 * Exp(base, i-1) senao se sequencia[i] = "2" entao base10 <- base10 + 2 * Exp(base, i-1) senao se sequencia[i] = "3" entao base10 <- base10 + 3 * Exp(base, i-1) senao se sequencia[i] = "4" entao base10 <- base10 + 4 * Exp(base, i-1) senao se sequencia[i] = "5" entao base10 <- base10 + 5 * Exp(base, i-1) senao se sequencia[i] = "6" entao base10 <- base10 + 6 * Exp(base, i-1) senao se sequencia[i] = "7" entao base10 <- base10 + 8 * Exp(base, i-1) senao se sequencia[i] = "8" entao base10 <- base10 + 8 * Exp(base, i-1) senao se sequencia[i] = "9" entao base10 <- base10 + 9 * Exp(base, i-1) fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimse fimpara escreval("Número na base 10",base10) O de ler de uma só vez não acho interessante vou deixar assim mesmo lendo 1 por 1
  14. Acho que consegui segue o código Var // Seção de Declarações das variáveis sequencia:vetor [1..8] de caractere i, base, digitotraduzido:inteiro base10: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite qual a base") leia(base) para i de 8 ate 1 passo -1 faca escreval("Digite o número",i) leia(sequencia[i]) fimpara para i de 1 ate 8 faca se sequencia[i] = "A" entao digitotraduzido <- 10 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "B" entao digitotraduzido <- 11 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "C" entao digitotraduzido <- 12 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "D" entao digitotraduzido <- 13 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "E" entao digitotraduzido <- 14 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "F" entao digitotraduzido <- 15 base10 <- base10 + digitotraduzido * exp(base, i-1) fimse se sequencia[i] = "0" entao base10 <- base10 + 0 * exp(base, i-1) fimse se sequencia[i] = "1" entao base10 <- base10 + 1 * exp(base, i-1) fimse se sequencia[i] = "2" entao base10 <- base10 + 2 * exp(base, i-1) fimse se sequencia[i] = "3" entao base10 <- base10 + 3 * exp(base, i-1) fimse se sequencia[i] = "4" entao base10 <- base10 + 4 * exp(base, i-1) fimse se sequencia[i] = "5" entao base10 <- base10 + 5 * exp(base, i-1) fimse se sequencia[i] = "6" entao base10 <- base10 + 6 * exp(base, i-1) fimse se sequencia[i] = "7" entao base10 <- base10 + 8 * exp(base, i-1) fimse se sequencia[i] = "8" entao base10 <- base10 + 8 * exp(base, i-1) fimse se sequencia[i] = "9" entao base10 <- base10 + 9 * exp(base, i-1) fimse fimpara escreval("Número na base 10",base10)
  15. Como ficaria o código então o meu está dando um monte de erros olhe o código como está Var // Seção de Declarações das variáveis sequencia:vetor [1..8] de inteiro i, base, digitotraduzido:inteiro base10: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite qual a base") leia(base) para i de 8 ate 1 passo -1 faca escreval("Digite o número",i) leia(sequencia[i]) fimpara para i de 1 ate 8 faca se sequencia[i] = "A" entao digitotraduzido <- 10 fimse se sequencia[i] = "B" entao digitotraduzido <- 11 fimse se sequencia[i] = "C" entao digitotraduzido <- 12 fimse se sequencia[i] = "D" entao digitotraduzido <- 13 fimse se sequencia[i] = "E" entao digitotraduzido <- 14 fimse se sequencia[i] = "F" entao digitotraduzido <- 15 fimse se sequencia[i] = "0" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "1" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "2" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "3" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "4" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "5" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "6" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "7" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "8" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse se sequencia[i] = "9" entao base10 <- base10 + sequencia[i] * exp(base, i-1) fimse fimpara escreval("Número na base 10",base10)

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!