Ir ao conteúdo
  • Cadastre-se

dimitruf

Membros Plenos
  • Total de itens

    27
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. To fazendo esse programinha, ali na soma, eu queria saber como faço para voltar para o MENU do programa digitando o numero 0, só nao sei com usar o Do e While junto com FOR #include <stdio.h> #include <stdlib.h> #include <conio.h> void soma(); void subtracao(); void multiplicacao(); void divisao(); void menu(); void porcentagem(); int main() { printf(""); menu(); return 0; } void soma() { int num[8], cont, soma=0 ; system("cls"); printf("\nDigite -0 para ir para a Tela Principal ou de ENTER para mais uma operacao!\n"); for(cont=0; cont<8; cont++){ printf("\nDigite um numeros [%d]: ",cont); scanf("%d",&num[cont]); } { for(cont=0; cont<8;cont++){ soma=soma+num[cont];} printf("a soma e %d", soma); } } void subtracao() { float num1,num2 ; float total; do { system("cls"); printf("\nDigite -0 para ir para a Tela Principal ou de ENTER para mais uma operacao!\n"); printf("\nDigite o primeiro numero: \n"); scanf("%f",&num2); if (num1 != 0) { printf("Digite o segundo numero: \n"); scanf("%f", &num2); total = num1-num2; printf("O resultado da subtracao e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void multiplicacao() { float num1,num2 ; float total; do { system("cls"); printf("\nDigite -0 para ir para a Tela Principal ou de ENTER para mais uma operacao!\n"); printf("\nDigite o primeiro numero: \n"); scanf("%f",&num1); if (num1 != -0) { printf("Digite o segundo numero: \n"); scanf("%f", &num2); total = num1*num1; printf("O resultado da multipliacao e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void divisao() { float num1,num2 ; float total; do { system("cls"); printf("\nDigite -0 para ir para a Tela Principal ou de ENTER para mais uma operacao!\n"); printf("\nDigite o primeiro numero: "); scanf("%f",&num1); if (num1 != -0) { printf("\nDigite o segundo numero: "); scanf("%f", &num2); total = num1/num2; printf("\nO resultado da divisao e = "); printf("%.2f\n", total); printf("\nSe deseja fazer mais uma operacao de enter!"); getch(); } else { main(); } } while (num1 != -0); } void porcentagem() { float num1,num2 ; float total; do { system("cls"); printf("\nDigite -0 para ir para a Tela Principal ou de ENTER para mais uma operacao!\n"); printf("\nDigite o primeiro numero: \n"); scanf("%f",&num1); if (num1 != -0) { scanf("%f", &num2); total = num1+num2; printf("A porcentagem e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void menu() { int opcao; system("cls"); printf("**********************************\n"); printf("***DIGITE UM NUMERO E DE ENTER***\n"); printf("**********************************\n"); printf("\n 1-Soma\n"); printf("\n 2-Subtracao\n"); printf("\n 3-Multiplicacao\n"); printf("\n 4-Divisao\n"); printf("\n 5-Porcentagem \n\n"); scanf("%d", &opcao); switch(opcao) { case 1: soma(); break; case 2: subtracao(); break; case 3: multiplicacao(); break; case 4: divisao(); break; default: system("exit"); } }
  2. Boa tarde, eu gostaria de saber como eu poderia adicionar vetores a este código e o que eu poderia incrementar de funcionalidades? Obrigado. #include <stdio.h> #include <stdlib.h> #include <conio.h> void soma(); void subtracao(); void multiplicacao(); void divisao(); void menu(); void porcentagem(); int main() { printf(""); menu(); return 0; } void soma() { float num1,num2 ; float total; do { system("cls"); printf("\nDigite -0 e pressione para fechar o programa\n"); printf("\nDigite o primeiro numero:"); scanf("%f",&num1); if (num1 != -0) { printf("\nDigite o segundo numero:"); scanf("%f",&num2); total = num1+num2; printf("\nO resultado da soma e = "); printf("%.2f", total); getch(); } else { main(); } } while (num1 != -0); } void subtracao() { float num1,num2 ; float total; do { system("cls"); printf("Digite -0 para fechar o programa\n"); printf("Digite o primeiro numero: \n"); scanf("%f",&num2); if (num1 != 0) { printf("Digite o segundo numero: \n"); scanf("%f", &num2); total = num1-num2; printf("O resultado da subtracao e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void multiplicacao() { float num1,num2 ; float total; do { system("cls"); printf("Digite sair para fechar o programa\n"); printf("Digite o primeiro numero: \n"); scanf("%f",&num1); if (num1 != -0) { printf("Digite o segundo numero: \n"); scanf("%f", &num2); total = num1*num1; printf("O resultado da multipliacao e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void divisao() { float num1,num2 ; float total; do { system("cls"); printf("Digite -0 para fechar o programa\n"); printf("Digite o primeiro numero:\n "); scanf("%f",&num1); if (num1 != -0) { printf("\n / "); scanf("%f", &num2); total = num1/num2; printf("O resultado da divisao e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void porcentagem() { float num1,num2 ; float total; do { system("cls"); printf("Digite -0 e pressione para fechar o programa\n"); printf("Digite o primeiro numero: \n"); scanf("%f",&num1); if (num1 != -0) { scanf("%f", &num2); total = num1+num2; printf("A porcentagem e = "); printf("%.2f\n", total); getch(); } else { main(); } } while (num1 != -0); } void menu() { int opcao; system("cls"); printf("**********************************\n"); printf("***DIGITE UM NUMERO E DE ENTER***\n"); printf("**********************************\n"); printf("\n 1-Soma\n"); printf("\n 2-Subtracao\n"); printf("\n 3-Multiplicacao\n"); printf("\n 4-Divisao\n"); printf("\n 5-Porcentagem \n\n"); scanf("%d", &opcao); switch(opcao) { case 1: soma(); break; case 2: subtracao(); break; case 3: multiplicacao(); break; case 4: divisao(); break; default: system("exit"); } }
  3. dimitruf

    C Erro Dev C Main

    Está aparecendo esse para mim, o que pode ser? 45 8 [Error] 'main' was not declared in this scope https://pastebin.com/3stnpzVb
  4. dimitruf

    C Erro codigo DEV C

    @Flávio Pedroza @devair1010 Teriam dicas de como identar código no DEV C++?
  5. dimitruf

    C Erro codigo DEV C

    Obrigado. adicionado 7 minutos depois @devair1010 Testei agora corretamente com o preço das questões e está dando errado. #include <stdio.h> #include <conio.h> main(){ float valorI, valorF; int x; printf("\n Digite o valor do produto: "); scanf("%f",&valorI); printf("\t\tMenu: \n\t\t1 > A vista com dinheiro ou cheque. \n\t\t2 > A vista no cartao.\n\t\t3 > Em duas vezes. \n\t\t4 > Em tres vezes."); printf("\n\nSelecione um menu: "); scanf("%d",&x); if(x==1){ valorF=valorI*0.10; printf("\nGanhou um desconto!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else if(x==2){ valorF=(valorI*0.05); printf("\nGanhou um desconto!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else if(x==3){ printf("\Sem Juros!\n\nTOTAL A PAGAR: R$ %.2f", valorI); }else if(x==4){ valorF=valorI*0.10; printf("\nPagando com juros!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else{ printf("\n\t\tERRO!"); getch(); return 0; } getch(); } Está sempre dando 5
  6. dimitruf

    C Erro codigo DEV C

    Elabore um algoritmo que calcule o que deve ser pago por um produto, considerando o preço normal de etiqueta e a escolha da condição de pagamento. Utilize os códigos da tabela seguinte para ler qual a condição de pagamento escolhida e efetuar o cálculo adequado. Código Condições de pagamento 1 À vista em dinheiro ou cheque, recebe 10% de desconto 2 À vista no cartão de crédito, recebe 5% de desconto 3 Em 2 vezes, preço normal de etiqueta sem juros 4 Em 3 vezes, preço normal de etiqueta mais juros de 10% do total e depois divide em 3 parcelas. CODIGO #include <stdiio.h> #include <conio.h> main(){ float valorI, valorF; int x; printf("\n Digite o valor do produto: "); scanf("%d",&valorI); printf("\t\tMenu: \n\t\t1 > A vista com dinheiro. \n\t\t2 > A vista no cartao.\n\t\t3 > Em duas vezes. \n\t\t4 > Em tres vezes."); printf("\n\nSelecione um menu: "); scanf("%d",&x); if(x==1){ valorF=valorI*0.85; printf("\nGanhou um desconto!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else if(x==2){ valorF=(valorI*0.90); printf("\nGanhou um desconto!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else if(x==3){ printf("\Sem Juros!\n\nTOTAL A PAGAR: R$ %.2f", valorI); }else if(x==4{ valorF=valorI*1.10; printf("\nPagando com juros!\n\nTOTAL A PAGAR: R$ %.2f", valorF); }else{ printf("\n\t\tERRO!"); getch(); return 0; } getch(); } ERRO: 1 O valor em todas alternativas estão zerando
  7. 1)Um hospital precisa de um programa para calcular e imprimir os gastos de um paciente. A tabela de preços do hospital é a seguinte : Quartos : Particular – R$ 160,00 Semi-particular – R$ 110,00 Coletivo – R$ 85,00 Telefone : R$ 3,00 Televisão : R$ 4,00 Escreva um programa que leia : o número de dias gastos no hospital; um caractere representando o tipo do quarto (P, S, C); um caractere indicando se usou ou não o telefone (S, N); outro caractere indicando se usou ou não a televisão (S, N). Então emita o seguinte relatório: Hospital Comunitário Número de dias no hospital : 5 Tipo de quarto : P Diárias :............... R$ 800,00 Telefone :............ R$ 0,00 Televisão :........... R$ 4,00 Total :.................. R$ 804,00 2)Elabore um algoritmo que calcule o que deve ser pago por um produto, considerando o preço normal de etiqueta e a escolha da condição de pagamento. Utilize os códigos da tabela seguinte para ler qual a condição de pagamento escolhida e efetuar o cálculo adequado. Código Condições de pagamento 1 À vista em dinheiro ou cheque, recebe 10% de desconto 2 À vista no cartão de crédito, recebe 5% de desconto 3 Em 2 vezes, preço normal de etiqueta sem juros 4 Em 3 vezes, preço normal de etiqueta mais juros de 10% do total e depois divide em 3 parcelas. 3)Faça um algoritmo que tendo como dados de entrada o código de região de localização do cliente, o nome do cliente, o número de peças vendidas e o nome do vendedor; calcule e informe o valor do frete, a comissão do vendedor e o lucro obtido com a venda. Sabendo-se que: O valor do frete depende da quantidade transportada e da região; Comissão do vendedor = 6,5 % do valor total da venda; Lucro = Valor total venda – custo total – comissão do vendedor; Custo por peça = R$ 7,00; Custo total = custo por peça * número de peças vendidas; Valor total da venda = custo total acrescido em 50%; Valor do Frete por Região: OBS. Para região Sul - Valor do frete acima de 1000 peças terá um desconto de 10% sobre o valor do frete por peça. Paga somente 90% do valor do frete por peça. Cada Região tem um desconto diferenciado para peças acima de 1000 peças. Favor verificar na tabela abaixo.
  8. Ok. Muito obrigado!
  9. Como faço pra encontrar o maior valor adicionado 2 minutos depois include <stdio.h> #include <stdlib.h> int main(){ int num1, num2, maior; printf("Digite um valor inteiro: "); scanf("%i",&num1); printf("Digite outro valor inteiro: "); scanf("%i",&num2); if(num1 > num2){ maior = num1; maior = num2; } else { printf("\nOs numeros sao iguais: %d\n", num1); } printf("O maior valor encontrado e : %d", maior); system("pause"); return 0 } Assim não está correto? [Error] expected ';' before '}' token Aparece isso
  10. #include <stdio.h> #include <stdlib.h> int main() { int num1, num2, maior, igual; printf("Digite um valor inteiro: "); scanf("%i",&num1); printf("Digite outro valor inteiro: "); scanf("%i",&num2); { if(num1 > num2); maior = num1; printf("O maior valor encontrado é : %d", maior); if (num1 = num2); igual = num1; printf("\nOs numeros são iguais: %d\n",igual); } system("pause"); return 0 } Na primeira esta dando erro.
  11. 1) Faça um algoritmo que leia dois números inteiros, em seguida, se eles forem diferentes, escreva na tela o maior deles. Caso contrário escreva a mensagem “números iguais” e o seu valor. 2) Faça um algoritmo que leia um número e verifique se ele é par ou ímpar, Imprima a frase “é par” ou “é ímpar”.
  12. @Simon Viegas var peso, altura, percM, PercF, mediaI, mediaPM, mediaPF, somaPM, somaPF : real idade, qtdM, qtdF, somaIdade, totalP, maior, menor : inteiro sexo, cor_olhos, cor_cabelo, pesquisa : caractere inicio idade <- 0 mediaPF <- 0 mediaPM <- 0 peso <- 0 totalP <- 0 repita limpatela totalP <- totalP + 1 escreval("Digite seu peso: ") leia(peso) escreval("Digite sua altura: ") leia(altura) escreval("Digite sua idade: ") leia(idade) repita escreval("Digite seu sexo M/F: ") leia(sexo) se (sexo <> "M") e (sexo <> "F") entao escreval("Sexo incorreto, regedite") fimse ate (sexo = "M") ou (sexo = "F") repita escreval("Digite a letra da cor do seus olhos: ") leia(cor_olhos) se (cor_olhos <> "A") e (cor_olhos <> "V") e (cor_olhos <> "C") entao escreval("Cor dos olhos incorreta, siglas válidas: A, V ou C") fimSe ate (cor_olhos = "A") ou (cor_olhos = "V") ou (cor_olhos = "C") repita escreval("Digite a letra cor dos seus cabelos: ") leia(cor_cabelo) se (cor_cabelo <> "L") e (cor_cabelo <> "P") e (cor_cabelo <> "C") entao escreval("Cor do cabelo incorreta, siglas válidas: L, P ou C") fimSe ate (cor_cabelo = "L") ou (cor_cabelo = "P") ou (cor_cabelo = "C") somaIdade <- somaIdade + idade se (sexo = "M") entao qtdM <- qtdM + 1 somaPM <- peso + 0 senao se (sexo = "F") entao qtdF <- qtdF + 1 somaPF <- peso + 0 fimSe fimSe se(idade>maior)entao maior <- idade senao se (idade<menor)entao menor <- idade fimse fimse escreval("Deseja fazer mais uma pesquisa? Digite N para não ou S para sim") leia(pesquisa) ate (pesquisa = "N") mediaPM <- somaPM / qtdM mediaPF <- somaPF / qtdF mediaI <- somaIdade / totalP percM <- qtdM/totalP*100 percF <- qtdF/totalP*100 escreval("Total de pessoas pesquisadas : ", totalP) escreval("Total de homens pesquisados : ", qtdM, " (", percM:1, "%)") escreval("Total de mulheres pesquisadas : ", qtdF, " (", percF:1, "%)") escreval("Média de idade dos pesquisados : ", mediaI) escreval("A idade mais velha encontrada : ", maior) escreval("A idade mais nova encontrada : ", menor) escreval("A media dos pesos masculinos : ", mediaPM) escreval("A media dos pesos femininos : ", mediaPF) fimalgoritmo Consegui fazer dos pesos, porém idade menor não entendi muito bem e continua zerando E não consegui fazer está parte aqui
  13. @Simon Viegas var //Dados do pesquisado peso, altura, percM, PercF, mediaI, mediaPM, mediaPF,somaPM, somaPF : real idade, qtdM, qtdF, somaIdade, totalP, maior, menor: inteiro sexo, cor_olhos, cor_cabelo, pesquisa : caractere inicio // Seção de Comandos totalP <- 0 peso <-0 altura<-0 percM<-0 PercF<-0 mediaI<-0 idade<-0 repita limpatela totalP <- totalP + 1 escreval("Digite seu peso: ") leia(peso) escreval("Digite sua altura: ") leia(altura) escreval("Digite sua idade: ") leia(idade) repita escreval("Digite seu sexo M/F: ") leia(sexo) se (sexo <> "M") e (sexo <> "F") entao escreval("Sexo incorreto, regedite") fimse ate (sexo = "M") ou (sexo = "F") repita escreval("Digite a letra da cor do seus olhos: ") leia(cor_olhos) se (cor_olhos <> "A") e (cor_olhos <> "V") e (cor_olhos <> "C") entao escreval("Cor dos olhos incorreta, siglas válidas: A, V ou C") fimSe ate (cor_olhos = "A") ou (cor_olhos = "V") ou (cor_olhos = "C") repita escreval("Digite a letra cor dos seus cabelos: ") leia(cor_cabelo) se (cor_cabelo <> "L") e (cor_cabelo <> "P") e (cor_cabelo <> "C") entao escreval("Cor do cabelo incorreta, siglas válidas: L, P ou C") fimSe ate (cor_cabelo = "L") ou (cor_cabelo = "P") ou (cor_cabelo = "C") somaPM <- somaPM + peso somaPF <- somaPF + peso somaIdade <- somaIdade + idade se (sexo = "M") entao qtdM <- qtdM + 1 somaPM <- somaPM + 1 fimse se (sexo = "F") entao qtdF <- qtdF + 1 somaPF <- somaPF + 1 fimSe se(idade>maior)entao maior <- idade fimse se(idade<menor)entao menor <- idade fimse mediaPM <- somaPM / qtdM mediaPF <- somaPF / qtdF mediaI <- somaIdade / totalP percM <- qtdM/totalP*100 percF <- qtdF/totalP*100 se(totalP=1)entao maior<-idade menor<-idade fimse escreval("Deseja fazer mais uma pesquisa? Digite N para não ou S para sim") leia(pesquisa) ate (pesquisa = "N") limpatela escreval("Total de pessoas pesquisadas : ", totalP) escreval("Total de homens pesquisados : ", qtdM, " (", percM:1, "%)") escreval("Total de mulheres pesquisadas : ", qtdF, " (", percF:1, "%)") escreval("Média de idade dos pesquisados : ", mediaI) escreval("A idade mais velha encontrada : ", maior) escreval("A idade mais nova encontrada : ", menor) escreval("A media dos pesos masculinos : ", mediaPM) escreval("A media dos pesos femeninos : ", mediaPF) adicionado 16 minutos depois @Simon Viegas totalP <- 0 peso <-0 altura<-0 percM<-0 PercF<-0 mediaI<-0 mediaPM<-0 mediaPF<-0 somaPM<-0 somaPF<-0 idade<-0 repita totalP <- totalP + 1 escreval("Digite seu peso: ") leia(peso) escreval("Digite sua altura: ") leia(altura) escreval("Digite sua idade: ") leia(idade) repita escreval("Digite seu sexo M/F: ") leia(sexo) se (sexo <> "M") e (sexo <> "F") entao escreval("Sexo incorreto, regedite") fimse ate (sexo = "M") ou (sexo = "F") repita escreval("Digite a letra da cor do seus olhos: ") leia(cor_olhos) se (cor_olhos <> "A") e (cor_olhos <> "V") e (cor_olhos <> "C") entao escreval("Cor dos olhos incorreta, siglas válidas: A, V ou C") fimSe ate (cor_olhos = "A") ou (cor_olhos = "V") ou (cor_olhos = "C") repita escreval("Digite a letra cor dos seus cabelos: ") leia(cor_cabelo) se (cor_cabelo <> "L") e (cor_cabelo <> "P") e (cor_cabelo <> "C") entao escreval("Cor do cabelo incorreta, siglas válidas: L, P ou C") fimSe ate (cor_cabelo = "L") ou (cor_cabelo = "P") ou (cor_cabelo = "C") somaPM <- somaPM + peso somaPF <- somaPF + peso somaIdade <- somaIdade + idade se (sexo = "M") entao qtdM <- qtdM + 1 somaPM <- somaPM + 1 fimse se (sexo = "F") entao qtdF <- qtdF + 1 somaPF <- somaPF + 1 fimSe se(idade>maior)entao maior <- idade fimse se(idade<menor)entao menor <- idade fimse //mediaPM <- somaPM / qtdM //mediaPF <- somaPF / qtdF mediaI <- somaIdade / totalP percM <- qtdM/totalP*100 percF <- qtdF/totalP*100 se(totalP=1)entao maior<-idade menor<-idade fimse escreval("Deseja fazer mais uma pesquisa? Digite N para não ou S para sim") leia(pesquisa) ate (pesquisa = "N") limpatela escreval("Total de pessoas pesquisadas : ", totalP) escreval("Total de homens pesquisados : ", qtdM, " (", percM:1, "%)") escreval("Total de mulheres pesquisadas : ", qtdF, " (", percF:1, "%)") escreval("Média de idade dos pesquisados : ", mediaI) escreval("A idade mais velha encontrada : ", maior) escreval("A idade mais nova encontrada : ", menor) escreval("A media dos pesos masculinos : ", mediaPM) escreval("A media dos pesos femeninos : ", mediaPF) E nesse aqui os pesos estão zerando.
  14. @Simon Viegas var //Dados do pesquisado peso, altura, percM, PercF, mediaI, mediaPM, mediaPF : real idade, qtdM, qtdF, somaIdade, totalP, maior, menor, somaPM, somaPF : inteiro sexo, cor_olhos, cor_cabelo, pesquisa : caractere inicio // Seção de Comandos totalP <- 0 repita totalP <- totalP + 1 escreval("Digite seu peso: ") leia(peso) escreval("Digite sua altura: ") leia(altura) escreval("Digite sua idade: ") leia(idade) repita escreval("Digite seu sexo M/F: ") leia(sexo) se (sexo <> "M") e (sexo <> "F") entao escreval("Sexo incorreto, regedite") fimse ate (sexo = "M") ou (sexo = "F") repita escreval("Digite a letra da cor do seus olhos: ") leia(cor_olhos) se (cor_olhos <> "A") e (cor_olhos <> "V") e (cor_olhos <> "C") entao escreval("Cor dos olhos incorreta, siglas válidas: A, V ou C") fimSe ate (cor_olhos = "A") ou (cor_olhos = "V") ou (cor_olhos = "C") repita escreval("Digite a letra cor dos seus cabelos: ") leia(cor_cabelo) se (cor_cabelo <> "L") e (cor_cabelo <> "P") e (cor_cabelo <> "C") entao escreval("Cor do cabelo incorreta, siglas válidas: L, P ou C") fimSe ate (cor_cabelo = "L") ou (cor_cabelo = "P") ou (cor_cabelo = "C") somaIdade <- somaIdade + idade se (sexo = "M") entao qtdM <- qtdM + 1 somaPM <- peso + 1 senao se (sexo = "F") entao qtdF <- qtdF + 1 somaPF <- peso + 1 fimSe fimSe se(idade>maior)entao maior <- idade senao menor <- idade fimse escreval("Deseja fazer mais uma pesquisa? Digite N para não ou S para sim") leia(pesquisa) ate (pesquisa = "N") limpatela mediaPM <- somaPM / qtdM mediaPF <- somaPF / qtdF mediaI <- somaIdade / totalP percM <- qtdM/totalP*100 percF <- qtdF/totalP*100 escreval("Total de pessoas pesquisadas : ", totalP) escreval("Total de homens pesquisados : ", qtdM, " (", percM:1, "%)") escreval("Total de mulheres pesquisadas : ", qtdF, " (", percF:1, "%)") escreval("Média de idade dos pesquisados : ", mediaI) escreval("A idade mais velha encontrada : ", maior) escreval("A idade mais nova encontrada : ", menor) escreval("A media dos pesos masculinos : ", mediaPM) escreval("A media dos pesos femeninos : ", mediaPF) FIMALGORITMO Fiz esse, a idade do mais velho está dando certo, porém, na idade do mais novo sempre está dando o número 0 E nesse, diz que as variáveis somaPM e somaPF tem que estar em inteiro, mas ela está em inteiro.
  15. sexo, cor_olhos, cor_cabelo, pesquisa, maior, menor : Caractere peso, altura,idade, percM, percF, mediaI: real totalp, qtdM, qtdF : inteiro Inicio idade <- 0 totalp <- 0 repita escreval("Digite seu peso: ") leia(peso) escreval("Digite sua altura: ") leia(altura) escreval("Digite sua idade: ") leia(idade) repita escreval("Digite seu sexo M/F: ") leia(sexo) se(sexo <> "M")e(sexo <> "F")entao escreval("Sexo incorreta, regedite") fimse ate(sexo = "M")ou(sexo = "F") repita escreval("Digite a letra da cor do seus olhos: ") Leia(cor_olhos) Se(cor_olhos <> "A")e(cor_olhos <> "V")e(cor_olhos <> "C")entao Escreval("Cor dos olhos incorreta, siglas válidas: A, V ou C") Fimse Ate (cor_olhos = "A")ou(cor_olhos = "V")ou(cor_olhos = "C") Repita Escreval("Digite a letra cor dos seus cabelos: ") Leia(cor_cabelo) Se(cor_cabelo <> "L")e(cor_cabelo <> "P")e(cor_cabelo <> "C")entao Escreval("Cor do cabelo incorreta, siglas válidas: L, P ou C") Fimse Ate(cor_cabelo = "L")ou(cor_cabelo = "P")ou(cor_cabelo = "C") escreval("Deseja fazer mais uma pesquisa? Digite N para não ou S para sim") leia(pesquisa) limpatela totalp <- totalp+ 1 se (sexo = "M") entao qtdM <- qtdM + 1 senao se (sexo = "F") entao qtdF <- qtdF + 1 fimSe fimSe ate (pesquisa = "N") percM <- qtdM/totalP*100 percF <- qtdF/totalP*100 escreval("Total de pessoas pesquisadas : ",totalP) escreval("Total de homens pesquisados : ",qtdM," (",percM:1,"%)") escreval("Total de mulheres pesquisadas : ",qtdF," (",percF:1,"%)") idade <- idade mediaI <- (idade+idade)/totalp escreval("A media da idade das pessoas é: ", mediaI)

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!