Ir ao conteúdo
  • Cadastre-se

Janilson Brito

Membros Juniores
  • Total de itens

    11
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Muito obrigado pelo apoio, era exatamente o que eu precisava. Adaptei o código que o OsvaldoMP disponibilizou e funcionou do jeito que eu estava imaginando. Muito obrigado pelo apoio mesmo.
  2. caro Haner, obrigado pelo retorno! Tambem havia pensando nessa posibilidade. porém: para cada linha, tenho um horario diferente, e da forma sugerida por voce, que tambem ja tentei, limito o user_id e data somente na celula F2 e G2 Preciso que quando coloque horario na celula c3 preencha na F3 (executor) e G3 (data) Talvez algo que eu tenha esquecido de comentar e faz muito diferenca, a planilha pode ser utilizada por outros usuarios.
  3. Senhores, bom dia! mais uma vez precisando muito da ajuda de vocês. Tenho uma planilha onde preencho hora inicio / hora final / executor/ data inicio e data termino minha intenção seria: preencher a celula do executor ( pelo login do usuario) preencher a data inicio (data atual formato dd/mmm) sendo que preciso preencer a celula C2 com um horario a C3 com outro horario e assim até o final da planilha pesquisando na internet, consegue ate chegar em algo parecido do que eu preciso, porém fica limitado a uma unica celula e tenho varias celulas na mesma planilha onde faço o preenchimento. em anexo o arquivo até onde cheguei. ao colocar horario na celula C2 ==> preenche a celula K2 com o login do usuario. na celula F2 tem a formula =SEERRO((PROCV(K2;ANALISTAS!$A$2:$B$30;2;0));"") segue abaixo o codigo que consigui até o momento. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Address = "$C$2" Then Call userid_C2 Call data_C2 Exit Sub End If End Sub Private Sub userid_C2() Dim wshNetwork As Object Dim LogonName As Variant Set wshNetwork = CreateObject("WScript.Network") LogonName = "" & wshNetwork.UserName Range("K2").Value = LogonName End Sub Private Sub data_C2() Dim Data As Date Data = Now() Range("G2").Value = Data 'ActiveCell.Select 'ActiveCell.Offset(0, 4).Value = Data End Sub FECHAMENTO_MENSAL.rar
  4. Osvaldo, mais uma vez obrigado pela ajuda, apesar do código estar um tanto complicado, voce consegue me ajudar, consegui adaptar o código que voce mandou no que eu fiz. Como ainda estou aprendendo, estou fazendo da forma completa, então acabo colocando muitas anotações para sabe o que cada código faz, um dia vou conseguir simplificar mais os códigos.
  5. Senhores, bom dia! Mais uma vez eu por aqui, ja tive bastante ajuda do Osvaldo, no qual deixo aqui meu agradecimento. Mais uma duvida que estou tendo. consegui montar o formulário de pesquisa no Excel, onde tenho um combobox, para definir o local da pesquisa. na coluna "a" linha 2 tenho a formula =D2&E2 resultando em 11. quando faço a pesquisa definindo essa coluna como base, a pesquisa é feita pelo conteúdo e não pelo valor do resultado, ou seja se colocar no combobox da pesquisa "11" resulta que não ha dados pesquisado se colocar no combobox da pesquisa "2" vai trazer todas as linhas onde tiverem o numero 2 o arquivo esta em anexo. cadastro (2).rar
  6. Osvaldo, muito, muito obrigado! ficou exatamente como eu precisava. aos poucos vou aprendendo cada dia mais, um dia quem sabe não serei eu também a poder ajudar aos amigos do forum
  7. Osvaldo, boa tarde! Obrigado pela ajuda, acabei de incluir a planilha para sua analise cadastro.zip
  8. Senhores, bom dia! Mais uma vez preciso da ajuda de vocês. Criei uma planilha de cadastro e dentro dela criei dois formulários: Um para incluir dados ==> este consegui fazer tudo sozinho. Um para consultar dados ==> neste não estou conseguindo fazer o que pretendo. Quando faço a inclusão de dados, tenho um Txtbox com o campo telefone: Neste campo formatei o texbox para quando digitar aparecer os campos (##) # ####-#### Na planilha, na célula onde o campo telefone é inserido, formatei a célula para telefone com 10 ou 11 dígitos [>11111111111]"("00") "0 0000"-"0000 ;"("00") "0000"-"0000, também esta funcionando. O que eu gostaria é que quando abrisse o formulário de consulta, mostrar na tela o telefone no formato (xx) x xxxx-xxxx ou (xx) xxxx-xxxx e é isso que não estou conseguindo fazer, conforme imagem abaixo. na primeira imagem tem o dado na planilha onde o campo telefone aparece no formato desejado. na segunda imagem tem o resultado da pesquisa porém o numero do telefone aparece sem a formatação desejada.
  9. Patropi, muito obrigado, era isso mesmo que eu precisava, inclui apenas o final da formula que eu havia feito e agora vai ficar muito mais fácil para eu fazer o trabalho que estou precisando =SOMARPRODUTO((MÊS($A$3:$A$392)=1)*($E$3:$E$392<>"")/CONT.SE($E$3:E392;$E$3:E392&""))
  10. Patropi, desde ja obrigado pela ajuda. estou inserindo a planilha apenas com 02 meses, (janeiro e fevereiro) espero que ajude. conforme pode observar no total de toalhas a soma esta calculando janeiro e fevereiro total de 297 o que eu preciso é que some apenas janeiro = 146 01-renato.xlsx
  11. Senhores, bom dia! Conheço razoavelmente o Excel, porém estou necessitando de uma ajuda em uma formula: ABAIXO SEGUE UM PRINT DA PLANILHA Tenho uma planilha com dados do ano inteiro. Na coluna “A” tenho a data Na coluna “E” tenho a seguinte formula: =CONCATENAR(A3;C3) Na coluna “G” tenho a seguinte formula: =SE(SEERRO(LOCALIZAR("corte";B3);SEERRO(LOCALIZAR("tintura";B3);SEERRO(LOCALIZAR("mechas";B3);SEERRO(LOCALIZAR("luzes";B3);LOCALIZAR("progressiva";B3)))));"capa";"") Na coluna “H” tenho a seguinte formula: =SEERRO(CONCATENAR(E3;G3);"") Na coluna “I” tenho a seguinte formula: =SEERRO(LOCALIZAR(128;B3);"") Para somar a quantidade de toalhas montei a seguinte formula =SOMARPRODUTO(($E$4:E1969<>"")/CONT.SE($E$4:E1969;$E$4:E1969&"")) Para somar a quantidade de capas montei a seguinte formula =SOMARPRODUTO(($H$4:H1969<>"")/CONT.SE($H$4:H1969;$H$4:H1969&"")) Ate então os resultados estão sendo esperado pois estava utilizando a planilha mensalmente, agora preciso fazer um balanço semestral e preciso que: Utilize a função =SOMARPRODUTO(($E$4:E1969<>"")/CONT.SE($E$4:E1969;$E$4:E1969&"")) Apenas para o período de cada mês, ou seja: Gostaria de fazer a soma das toalhas Contando valores únicos dentre valores duplicados porém dentro do período de cada mês: Tipo SE A3>=01/01/2019 E A1969<=31/01/2019 ENTAO =SOMARPRODUTO(($E$4:E1969<>"")/CONT.SE($E$4:E1969;$E$4:E1969&""))

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!