Ir ao conteúdo
  • Cadastre-se

MATEUS GOMES85

Membros Juniores
  • Total de itens

    2
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Muito bom amigo!! Acabei de rodar aqui e deu certo também! Eu tava colocando um Se Entao a mais. Muito obrigado! Me abriu a mente! valeu adicionado 1 minuto depois
  2. Bom dia galerinha do bem! Fiz um programinha com estruturas de repetição no VISUALG, rodando bacana mas quando fecha a estrutura de repetição dá o seguinte erro: "Fim Enquanto sem enquanto correspondente" Alguém pode apontar um possível problema? Programa roda legal até o término do segundo Enquanto, ele deveria voltar para o início do Enquanto mas ele dá a mensagem "FIM Enquanto sem Enquanto correspondente". Não descobri por que. Quem conseguir ver onde está o problema agradeço muito. Obrigado galera! -------------------------------------------------------------------------------------------------------------------------------------------- Algoritmo "vetor 30 ordem crescente" Var // Seção de Declarações das variáveis V: vetor[1..5] de Inteiro Vazio: vetor[1..5] de Inteiro h, i, j, k, m, n, p, aux, opcao, resta: Inteiro partida, final: Inteiro resp, tec: Caractere Inicio // P R O G R A M A P R I N C I P A L // Seção de Comandos, procedimento, funções, operadores, etc... opcao <- 1 Enquanto (opcao <> 0) faca Para n <- 1 ate 5 faca // Inicialização de Vetores e contadores Vazio[n] <- 1 FimPara resta <- 5 Para p <- 1 ate 5 faca V[p] <- 0 FimPara Enquanto (opcao <> 6) ou (opcao <> 0) faca LimpaTela EscrevaL("Você gostaria de inserir quantos números no vetor de 5 posições ?") EscrevaL(" :'''''''''''''': ") EscrevaL("-----------------------: MENU :--------------------------") Escreval(" :,,,,,,,,,,,,,,: ") EscrevaL(" ") Escreval(" Digite 1 - Para inserir 1 número ") Escreval(" Digite 2 - Para inserir 2 números ") EscrevaL(" Digite 3 - Para inserir 3 números ") Escreval(" Digite 4 - Para inserir 4 números ") Escreval(" Digite 5 - Para inserir 5 números ") Escreval(" Digite 0 - Para sair do programa ") Escreval(" Digite 6 - Para reinicializar os vetores ") EscrevaL("-----------------------------------------------------------------") Leia(opcao) Se opcao = 1 entao // 1º Se Se resta <> 0 entao // 2º Se h <- 1 partida <- 0 Enquanto partida = 0 faca Se (Vazio[h] = 1) entao // 3º Se partida <- h FimSe // Fim 3º Se h <- h + 1 FimEnquanto final <- partida Para i <- partida ate final faca EscrevaL(i, "ª. posição: ") Leia(V) Vazio <- 0 FimPara resta <- resta - opcao EscrevaL("Você gostaria de ordenar de forma crescente ? [S/N]") Leia(resp) Se resp = "S" entao // 4º Se Para m <- 1 ate 4 faca j <- 1 Enquanto j < 5 faca k <- j + 1 Se (Vazio[j] = 0) e (Vazio[k] = 0) entao // 5º Se Se V[j] > V[k] entao // 6º Se aux <- V[j] V[j] <- V[k] V[k] <- aux FimSe //Fim do 6º Se FimSe //Fim do 5º Se j <- j + 1 FimEnquanto FimPara FimSe //Fim do 4º Se Para i <- 1 ate 5 faca EscrevaL(V) FimPara Escreval("Para voltar para o MENU dgite qualquer tecla seguida de ENTER") Leia(tec) Senao //Senao do 2º Se Aviso() Escreval("Para retornar ao MENU tecle qualquer tecla seguida de ENTER") Leia(tec) FimSe FimSe // Fim 1º Se FimEnquanto Se (opcao = 6) entao // 25º Se EscrevaL("Reinicializando programa ...Aguarde!") EscrevaL("") EscrevaL("") Escreval("Tecle qulaquer tecla seguida de ENTER para continuar") Leia(tec) FimSe FimSe // Fim 25º Se FimEnquanto Escreval("Obrigado por usar nosso programa!!! Volte sempre!") EscrevaL("-------------------------------------------------") EscrevaL("------------- FIM -------------------") EscrevaL("-------------------------------------------------") Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!