Ir ao conteúdo
  • Cadastre-se

ynp

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D

Tudo que ynp postou

  1. Recebi uma tarefa de um professor para fazer um programa que converta números decimais para binário, octal e hexadecimal, estou tentando usar o VisualG por estar no meu primeiro ano da faculdade e ser a única linguagem que conheço o básico, e estou tendo dificuldades, pois estou com um código que faz as conversões corretamente, porém ele faz sempre as 3 de uma vez, e eu gostaria de poder escolher a conversão que desejo fazer, tentei usar o "caso" mas não está dando certo. Meu código é esse, se alguém puder me ajudar ou me dizer algo que está errado eu agradeceria. Algoritmo "conversãodecimal" Var Num, Valor: inteiro Resultado1, Resultado2, Resultado3, opcao, binario, octal, hexadecimal: Caractere Inicio // primeira parte, onde eu desejo criar a "interface" permitindo o usuário escolher qual conversão deseja fazer escreval("para qual base você deseja converter seu número decimal?") escreval("binário") escreval("octal") escreval("hexadecimal") leia(opcao) escolha opcao // conversão para binário caso(opcao=binario) faca escreval ("Digite um valor Decimal: ") leia (Num) Valor <- (Num) enquanto (Num > 0) faca escolha (Num mod 2) caso 0 Resultado1 <- ("0" + Resultado1) caso 1 Resultado1 <- ("1" + Resultado1) fimescolha Num <- (Num div 2) fimenquanto escreval ("O valor: ", Valor, " em Decimal será de: ", Resultado1, " em Binários!!") // conversão para octal caso (opcao="octal") faca escreval ("Digite um valor Decimal: ") leia (Num) Valor <- (Num) enquanto (Num > 0) faca escolha (Num mod 8) caso 1 Resultado2 <- ("1" + Resultado2) caso 2 Resultado2 <- ("2" + Resultado2) caso 3 Resultado2 <- ("3" + Resultado2) caso 4 Resultado2 <- ("4" + Resultado2) caso 5 Resultado2 <- ("5" + Resultado2) caso 6 Resultado2 <- ("6" + Resultado2) caso 7 Resultado2 <- ("7" + Resultado2) fimescolha Num <- (Num div 8) fimenquanto escreval ("O valor: ", Valor, " em decimal será de: ", Resultado2, " em octal") // conversão para hexadecimal caso (opcao = hexadecimal) faca escreval ("Digite um valor Decimal: ") leia (Num) Valor <- (Num) enquanto (Num > 0) faca escolha (Num mod 16) caso 1 Resultado3 <- ("1" + Resultado3) caso 2 Resultado3 <- ("2" + Resultado3) caso 3 Resultado3 <- ("3" + Resultado3) caso 4 Resultado3 <- ("4" + Resultado3) caso 5 Resultado3 <- ("5" + Resultado3) caso 6 Resultado3 <- ("6" + Resultado3) caso 7 Resultado3 <- ("7" + Resultado3) caso 8 Resultado3 <- ("8" + Resultado3) caso 9 Resultado3 <- ("9" + Resultado3) caso 10 Resultado3 <- ("A" + Resultado3) caso 11 Resultado3 <- ("B" + Resultado3) caso 12 Resultado3 <- ("C" + Resultado3) caso 13 Resultado3 <- ("D" + Resultado3) caso 14 Resultado3 <- ("E" + Resultado3) caso 15 Resultado3 <- ("F" + Resultado3) fimescolha Num <- (Num div 16) fimenquanto escreval ("O valor: ", Valor, " em decimal será de: ", Resultado3, " em hexadecimal.") fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!