Ir ao conteúdo
  • Cadastre-se

Alice Braga

Membros Juniores
  • Total de itens

    5
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Bom dia, boa tarde, boa noite! fiz esse algoritmo, porque acho as regras de acentuação gráfica muito chatas p ficar decorando, e acredito eu q vou economizar bastante tempo fazendo a prova Se vocês puderem testar e ver se está funcionando corretamente, ficarei muito grata. (o código tá um pouco confuso mesmo, mas acho q dá p entender) Var // Seção de Declarações das variáveis palavra,letra14,letra15: inteiro letra,letra2,letra4,letra5,letra6,letra7,letra8,letra9,letra10,letra11,letra12,letra13: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... //oxitonas escreval("------------COMO UTILIZAR O ACENTO GRÁFICO CORRETAMENTE-----------") ESCREVAL("") ESCREVAL("-->PENSE EM UMA PALAVRA! a palavra que você deseja se encaixa em qual classificação abaixo:") escreval("1-ÓXITONA") escreval("2-PAROXITÓNA") escreval("3-PROPAROXITÓNA") escreval("4-MONOSSÍLABO TÔNICO") escreva("") escreval("------------------------------------------------------------------------------------------------------------------------------------------------------------------------") escreval("LEMBRANDO QUE....") ESCREVAL("PALAVRAS OXÍTONAS: A SÍLABA TÔNICA ESTÁ NA ÚLTIMA SÍLABA") ESCREVAL("PALAVRAS PAROXÍTONAS: A SÍLABA TÔNICA ESTÁ NA PENÚLTIMA SÍLABA") ESCREVAL("PALAVRAS PROPAROXÍTONAS: A SÍLABA TÔNICA ESTÁ NA ANTEPENÚLTIMA SÍLABA") ESCREVAL("MONOSSÍLABOS TÔNICOS: SÓ TEM UMA SÍLABA") leia(palavra) se (palavra=1) entao escreval("sua palavra termina em que letra?") escreval("1-a/as") escreval("2-e/es") escreval("3-i/is") escreval("4-o/os") escreval("5-u/us") ESCREVAL("6-outro") leia(letra) fimse se (letra=3) ou (letra=5) entao escreval("sua letra vem precedida de outra vogal?") escreval("1-sim") escreval("2-não") leia(letra15) fimse se (letra15=1) entao escreval("sua palavra é acentuada!") fimse se (letra15=2) entao escreval("sua palavra não é acentuada!") fimse se (letra=1) ou (letra=2) ou (letra=4) entao escreval("sua palavra possui acento! Acompanhada de S ou não!") fimse se (letra=6) entao escreval("sua palavra funciona como diferencial de plural e singular?") escreval("exemplo¹: ele tem dois carros") escreval("exemplo²:eles têm dois carros") escreval("1-sim/2-não") leia(letra2) fimse se (letra2=1) entao escreval("sua palavra possui acento cincunflexo") fimse se (letra2=2) entao escreval("sua palavra termina em R,L,Z,X,I,U,IM,UM,OM?") escreval("1-sim") escreval("2-não") leia(letra11) fimse se (letra11=1) entao escreval("sua palavra é antecedida por outra vogal?") escreval("como por exemplo: açAI, bAU?") escreval("1-sim") escreval("2-não") leia (letra12) fimse se (letra11=2) entao escreval("sua palavra oxitona possui mais de uma sílaba, isto é a sua última sílaba é a mais forte. Porém, as restantes sílabas da palavra são pronunciadas com menor intensidade? ") escreval("Geralmente terminada em EM ou ENS?") escreval("1-sim") escreval("2-não") leia(letra13) fimse se (letra12=1) entao escreval("sua palavra é acentuada graficamente") fimse se (letra12=2) entao escreval("sua palavra não é acentuada graficamente!") fimse se (letra13=1) entao escreval("sua palavra é acentuada") fimse se (letra13=2) entao escreval("sua palavra não é acentuada!") fimse //paroxitonas se (palavra=2) entao escreval("sua palavra possui os ditongos abertos (éi) ou (ói)?") escreval("") escreval("DITONGOS-JUNCAO DE UMA VOGAL E UMA SEMIVOGAL, NUMA MESMA SÍLABA. EX:CÉU") escreval("1- sim") escreval("2-não") leia (letra8) fimse se (letra8=1) entao escreval("sua palavra não é mais acentuada graficamente!") fimse se (letra8=2) entao escreval("sua palavra termina em IS,US,EM,ENS,ON,ÓNS?") escreval("1-sim") escreval("2-não") leia(letra6) fimse se (letra6=1) entao escreval("sua palavra é acentuada!") fimse se (letra6=2)entao escreval("sua palavra termina em R,L,X,N,ÃO,Ã,ÃS,EI,PS,AO,ÃOS?") escreval("1-sim") escreval("2-não") leia(letra14) fimse se (letra14=1) entao escreval("sua palavra é acentuada graficamente!") fimse se (letra14=2) entao escreval("sua palavra possui os ditongos crescentes: IO,IA,UA,ETC?") escreval("1-sim") escreval("2-não") leia (letra9) fimse se (letra9=1) entao escreval("sua palavra é acentuada") fimse se (letra9=2) entao escreval("sua palavra não é acentuada!") fimse //PROPAROXITONAS se (palavra=3) entao ESCREVAL("TODAS AS PALAVRAS PROPAROXÍTONAS SÃO ACENTUADAS.") ESCREVAL("") ESCREVAL("SUA PALAVRA TERMINA EM -ea, -eo, -ia, -ie, -io, -oa, -ua, e -uo.?") escreval("1-sim") escreval("2-não") LEIA (letra4) fimse se (letra4=1) entao escreval("sua palavra é uma proparoxítona aparente!") fimse se (letra4=2) entao escreval("sua palavra é uma proparoxitona, por isso sempre será acentuada") fimse //MONOSSILABOS TONICOS se (palavra=4) entao escreval("seu monossilábo tônico termina em que letra?") escreval("1-a/as") escreval("2-e/es") escreval("3-o/os") escreval("4-s") escreval("5-outro") leia(letra7) fimse se (letra7=1) ou (letra7=2) ou (letra7=3)entao escreval("seu monossílabo tônico é acentuado") fimse se (letra7=5) OU (letra7=4) entao escreval("sua palavra termina com um desses ditongos: ÉI,ÉIS,EU,ÉUS,ÓI,ÓIS") escreval("1-sim") escreval("2-não") leia(letra5) fimse se (letra5=1) entao escreval("sua palavra é acentuada!!") fimse se (letra5=2) entao escreval("sua palavra não pode ser acentuada!") fimse
  2. Eu fiz ao contrario, ao invés de mostrar o menor, eu mostrei o maior. Tentei arrumar, mas não consegui. Então vô mandar assim mesmo Var // Seção de Declarações das variáveis Nome: vetor[1..3] de caractere Altura: vetor[1..3] de real posicao: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para posicao de 1 ate 3 faca escreva("Digite o seu nome: ") leia(Nome[posicao]) escreval("") escreva("Digite a sua altura: ") leia(Altura[posicao]) limpatela fimpara escreval(" REGISTROS ") para posicao de 1 ate 3 faca escreval("nome"," ","altura") ESCREVAl(Nome[posicao]," ", Altura[posicao]) fimpara se (Altura[1]>Altura[2]) e (Altura[1]>Altura[3]) entao escreval("") escreval(Nome[1]," é o maior da lista,com:",Altura[1]," metros de altura") fimse se (Altura[2]> Altura[1]) e (Altura[2]>Altura[3]) entao escreval("") escreval(Nome[2]," é o maior da lista,com:",Altura[2]," metros de altura") fimse se (Altura[3]> Altura[1]) e (Altura[3]>Altura[2]) entao escreval("") escreval(Nome[3]," é o maior da lista,com:", Altura[3]," metros de altura") fimse fimalgoritmo
  3. Tive esse teste ontem, consegui fazer, mas não sei se esta certo. Até porque n sei usar função muito bem ainda. Alguém me diz se ta certo? (A FT DO Q É PRA FAZER TA EM BAIXO) Var // Seção de Declarações das variáveis alcool,alcool1,alcooldes,gasolina,gasolina1,x,media,gasolinades,total,total2: real funcao CalGaso(n1,n2:real):real inicio media<-n1,n2 se (alcool<=20) entao alcooldes<-(alcool*3)/100 total<-alcool1-alcooldes fimse se (alcool>20) entao alcooldes<-(alcool*5)/100) total<-alcool1-alcooldes fimse se (gasolina>20) entao gasolinades<-(gasolina*6)/100 total2<-gasolina1-gasolinades fimse se (gasolina<=20) entao gasolinades<-(gasolina*4)/100 total2<-gasolina1-gasolinades fimse retorne media fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("PROGRAMA PARA CALCULAR A MÉDIA DE COMBUSTIVEL") ESCREVAL("DIGITE 1- ALCOOL") ESCREVAL("DIGITE 2- GASOLINA") ESCREVAL("DIGITE 0 -SAIR") leia(x) se (x=1) entao ESCREVAL("QUANTOS LITROS DE ALCOOL VOCÊ DESEJA?") LEIA (alcool) alcool1<-alcool*2.90 escreval("o preço do alcool é de:", alcool1,"reais") media<-CalGaso(alcool1,gasolina) escreval("o preço do alcool com desconto é de:",total ) escreval("desconto de:",alcooldes) fimse se (x=2) entao escreval("quantos litros de gasolina você deseja?") leia(gasolina) gasolina1<-gasolina*3.30 escreval("o preço da gasolina é de:",gasolina1,"reais") media2<-CalGaso(alcool1,gasolina1) escreval("o preço da gasolina com desconto é:", total2) escreval("com desconto de:",gasolinades) se (x<0) entao escreval("você finalizou o programa!") fimse fimse
  4. Ótima explicação! Estou começando agora nessa área, e confesso que ainda estou perdida com os comandos. Vou refazer este algoritmo e já mando
  5. Var // Seção de Declarações das variáveis n,x,t,i: inteiro funcao FuncaoLeNum(n1,n2:inteiro):inteiro inicio t<- i*n retorne t fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("digite um número para saber a tabuada dele:") leia(n) se (n>10) e (n<1) entao escreval("digite um número válido") fimse para i de 1 ate 10 faca x<-FuncaoLeNum(n,i) escreval("o numero",i," x",n," é igual a:",x) fimpara Var // Seção de Declarações das variáveis n,x,t,i: inteiro funcao FuncaoLeNum(n1,n2:inteiro):inteiro inicio t<- i*n retorne t fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("digite um número para saber a tabuada dele:") leia(n) se (n>10) e (n<1) entao escreval("digite um número válido") fimse para i de 1 ate 10 faca x<-FuncaoLeNum(n,i) escreval("o numero",i," x",n," é igual a:",x) fimpara adicionado 46 minutos depois 2-a) Var // Seção de Declarações das variáveis v1,v2,maior,igual,m: inteiro funcao MAX(x,y:inteiro):inteiro inicio maior<-x,y se v1>v2 entao maior<-v1 senao maior<-v2 se v1=v2 entao maior<-v1,v2 retorne maior fimse fimse fimfuncao Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("--------------PROGRAMA PARA COMPARAR OS NÚMEROS---------------") ESCREVAL("--------------DIGITE UM NÚMERO PARA SABER QUAL É MAIOR------------") escreval("digite um número:") leia(v1) escreval("digite outro número:") leia(v2) m<-MAX(v1,v2) escreval("o maior número é:",maior) se (v1=v2) entao escreval("os numeros são iguais") fimse

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!