×
Ir ao conteúdo
  • Cadastre-se

CriadorDeTravaZap

Membro Júnior
  • Posts

    2
  • Cadastrado em

  • Última visita

Reputação

2
  1. Eu estou estudando algoritmo e estou tendo problema com o Visualg, ele buga, mesmo sendo uma versão mais atualizada, ele da esse erro, eu já terminei, ele esta assim: algoritmo "Seletor de Pessoas" var Sex, Resp: Caractere Old, Hair: Inteiro Cont1, Cont2: Inteiro inicio Repita EscrevaL("======================") Escreval("| SELETOR DE PESSOAS |") EscrevaL("======================") EscrevaL("Qual o sexo? [M/F]") Leia(Sex) EscrevaL("Qual idade? ") Leia(Old) EscrevaL("Qual a cor do cabelo?") EscrevaL("----------------------") EscrevaL("[1] Preto") EscrevaL("[2] Castanho") EscrevaL("[3] Loiro") EscrevaL("[4] Ruivo") Leia(Hair) Escolha Hair Caso 1 Hair <- 1 Caso 2 Hair <- 2 Caso 3 Hair <- 3 Caso 4 Hair <- 4 FimEscolha Se(Sex = "F")e(Old => 25)e(Old <= 30)e(Hair = 3)entao Cont2 <- Cont2 + 1 SeNao Se(Sex = "M")e(Old => 18)e(Hair =2)entao Cont1 <- Cont1 + 1 FimSe FimSe EscrevaL("Você deseja continuar? [S/N]") Leia(Resp) Ate(Resp = "N") EscrevaL("Total de Homemns com mais de 18 e cabelos castanhos", Cont1) Escreva("Total de Mulheres entre 25 e 30 com cabelos loiros", Cont2) fimalgoritmo
  2. Eu estou tendo um problema em não conseguir executar meu arquivo .alg, ele fala que o faça esta faltando em meu algoritmo, mas ele simplesmente está no algoritmo. E mesmo eu reiniciando meu programa, ele continua dando erro, e eu não acho esse tal erro, já tentei mudar tipo de var, mas nada muda. No momento ele está assim: algoritmo "semnome" var R, D, Con, S: REAL inicio D <- 1 S <- 0 Enquanto(D <= 5) faca Escreva("Qual o valor em R$? ") Leia(R) D <- R/5,62 EscrevaL("O Valor convertido e US$", D:5:2) Con <- Con + 1 S <- S + D FimEnquanto fimalgoritmo Lembrando que o algoritmo não está de fato pronto, so executei o para saber se o valor estava sendo colocado na variável certa.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!