Ir ao conteúdo
  • Cadastre-se

r00ki3

Membro Júnior
  • Total de itens

    5
  • Registro em

  • Última visita

  • Qualificações

    0%
  1. procedimento principal(a:inteiro) var dif,maior,posant,pospos:inteiro Inicio para i de 1 ate n-1 faca se vet[i]<vet[i+1] entao dif<-vet[i+1]-vet[i] senao dif<- vet[i]-vet[i+1] fimse se maior < dif entao maior <- dif posant<-vet[i] pospos<-vet[i+1] fimse fimpara Escreva("A maior diferença é: ", maior, " entre ",posant, " e ", pospos) Fimprocedimento var n,i:inteiro vet: vetor[1..10] de inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreva("In
  2. Esqueci-me de colocar, desculpa. O enunciado é: Dado um vector de N elementos determine a maior diferença entre dois elementos consecutivos e em que posição.
  3. Fiz um exercício com vetores e agora queria introduzir uma função ou procedimento nele. Não estou a conseguir. Alguém pode ajudar? O código é este: Var // Seção de Declarações das variáveis n,i,dif,maior,posant,pospos:inteiro vet: vetor[1..10] de inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreva("Indique o comprimento do vetor :") leia (n) para i de 1 ate n faca Escreva("Indique o",i,"º número :") leia(vet[i]) fimpara para i de 1 ate n-1 faca se vet[i]<vet[i+1] entao dif<-vet[i+1]-vet[i

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!