×
Ir ao conteúdo
  • Cadastre-se

BiancaV.

Membro Júnior
  • Posts

    4
  • Cadastrado em

  • Última visita

  • Qualificações

    0%

Reputação

1

Informações gerais

  • Cidade e Estado
    São Paulo/SP
  • Sexo
    Feminino
  1. O enunciado completo: Estou errando ainda a contagem das cidades com menos de 2000 veículos: Algoritmo "IBGE: Acidentes de trânsito no estado do Paraná" // Disciplina : Lógica de Programação Var mun, munMaior, munMenor: Caractere codmun, veic, acid, acid2000, contador, maior, menor, cidadesMenos2000Veic: Inteiro soma, somaAcid2000, mediaVeic, mediaAcid: Real Inicio contador <- 0 soma <- 0 menor <- 9999999 enquanto (contador <= 1) faca escreval ("Insira o nome do município: ") leia (mun) escreval ("Insira o código do município: ") leia (codmun) escreval ("Insira o número de veículos de passeio de ", mun, ":") leia (veic) escreval ("Insira o número de acidentes de trânsito com vítimas de ", mun, ":") leia (acid) se (acid > maior) entao maior <- acid munMaior <- mun fimse se (acid < menor) entao menor <- acid munMenor <- mun fimse soma <- soma + veic contador <- contador + 1 mediaVeic <- soma/contador fimenquanto escreval ("O maior número de acidentes de trânsito com vítimas é: ", maior,", referente à cidade de ", munMaior, ".") escreval ("O menor número de acidentes de trânsito com vítimas é: ", menor,", referente à cidade de ", munMenor, ".") escreval ("A média de veículos de passeio de todas as cidades juntas é: ", mediaVeic, ".") se (cidadesMenos2000Veic = 0) entao escreval ("Não há cidades com menos de 2000 veículos.") senao se (cidadesMenos2000Veic > 0) entao acid2000 <- acid soma <- soma + acid2000 mediaAcid <- soma/cidadesMenos2000Veic escreval ("A média de acidentes de trânsito nas cidades com menos de 2000 veículos de passeio é :", mediaAcid, ".") fimse fimse Fimalgoritmo
  2. O enunciado diz: E minha solução: Inicio contador <- 0 soma <- 0 enquanto (contador <= 1) faca escreval ("Insira o nome do município: ") leia (mun) escreval ("Insira o código do município: ") leia (codmun) escreval ("Insira o número de veículos de passeio de ", mun, ":") leia (veic) escreval ("Insira o número de acidentes de trânsito com vítimas de ", mun, ":") leia (acid) se (acid > maior) entao maior <- acid munMaior <- mun fimSe se (acid < menor) entao menor <- acid munMenor <- mun fimSe soma <- soma + veic contador <- contador + 1 mediaVeic <- soma/contador fimenquanto veicMenor <- 2000 somaAcid <- soma + acid somaAcidMenor <- somaAcid - somaAcidMaior contadorMenor <- contador - contadorMaior se (veic < veicMenor) entao contadorMenor <- contador somaAcidMenor <- somaAcid mediaAcid <- somaAcidMenor/contadorMenor fimse escreval ("O maior número de acidentes de trânsito com vítimas é: ", maior,", referente à cidade de ", munMaior, ".") escreval ("O menor número de acidentes de trânsito com vítimas é: ", menor,", referente à cidade de ", munMenor, ".") escreval ("A média de veículos de passeio de todas as cidades juntas é: ", mediaVeic, ".") se (veic > veicMenor) entao escreval ("Não há cidades com menos de 2000 veículos.") senao se (veic < veicMenor) entao escreval ("A média de acidentes de trânsito nas cidades com menos de 2000 veículos de passeio é :", mediaAcid, ".") fimse fimse Fimalgoritmo Mas sigo errando: o menor número de acidentes acusa sempre como 0 e com a média de acidentes para cidades com menos de 2000 veículos estou com problemas em "isolar" o contador.
  3. Maravilha! Consegui entender bem a lógica com a explicação, muito obrigada! Fiz alguns testes e agora o problema parece ter sido solucionado: Inicio contador <- 0 soma <- 0 menosVeiculos <- 2000 enquanto (contador <= 2) faca escreval ("Insira o nome do município: ") leia (mun) escreval ("Insira o código do município: ") leia (codmun) escreval ("Insira o número de veículos de passeio de ", mun, ":") leia (veic) escreval ("Insira o número de acidentes de trânsito com vítimas de ", mun, ":") leia (acid) se (acid > maior) entao maior <- acid munMaior <- mun senao (acid < menor) entao menor <- acid munMenor <- mun fimse soma <- soma + veic contador <- contador + 1 media <- soma/contador fimenquanto mediaAcid <- acid/contador menosVeiculos <- 2000 se (veic < menosVeiculos) entao menormediaAcid <- mediaAcid fimse escreval ("O maior número de acidentes de trânsito com vítimas é: ", maior,", referente à cidade de ", munMaior, ".") escreval ("O menor número de acidentes de trânsito com vítimas é: ", menor,", referente à cidade de ", munMenor, ".") escreval ("A média de veículos de passeio de todas as cidades juntas é: ", media, ".") se (veic < menosVeiculos) entao escreval ("Não há cidades com menos de 2000 veículos.") senao escreval ("A média de acidentes de trânsito nas cidades com menos de 2000 veículos de passeio é :", menormediaAcid, ".") fimse Fimalgoritmo Ainda, estou com um problema no último bloco: algumas vezes, o senao é acusado como estando errado, e outras roda normal. De resto, tudo como esperado.
  4. Olá! Sou mega iniciante e gostaria de saber como posso relacionar um dado de entrada a outro numa espécie de lista. Por exemplo: ao executar esse algoritmo, o município que se relaciona ao maior número aparece como sendo o mesmo do menor número. Como soluciono? Criando outra variável? Segue: Algoritmo "IBGE: Acidentes de trânsito no estado do Paraná" Var mun: Caractere codmun, veic, acid, contador, maior, menor: Inteiro soma, media: Real Inicio contador <- 0 soma <- 0 enquanto (contador <= 1) faca escrevaL ("Insira o nome do município: ") leia (mun) escrevaL ("Insira o código do município: ") leia (codmun) escrevaL ("Insira o número de veículos de passeio de ", mun, ":") leia (veic) escrevaL ("Insira o número de acidentes de trânsito com vítimas de ", mun, ":") leia (acid) se (acid > maior) entao maior <- acid senao (acid < menor) entao menor <- acid fimse soma <- soma + veic contador <- contador + 1 media <- soma/contador fimenquanto escrevaL ("O maior número de acidentes de trânsito com vítimas é: ", maior,", referente à cidade de ", mun, ".") escrevaL ("O menor número de acidentes de trânsito com vítimas é: ", menor,", referente à cidade de ", mun, ".") escrevaL ("A média de veículos de passeio de todas as cidades juntas é: ", media) Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!