×
Ir ao conteúdo
  • Cadastre-se

Artur Elias Coelho

Membro Júnior
  • Posts

    3
  • Cadastrado em

  • Última visita

  • Qualificações

    0%
  1. Estou desenvolvendo um jogo da velha pra uma atividade em VisualG, mas eu não sei porque quando estou criando o "X" sendo o vencedor ele não manda a mensagem "o jogador x ganhou". Não sei o porquê. Algoritmo "jogo da velha" Var matriz:vetor [1..3,1..3] de caractere x,y,z:inteiro Inicio matriz[1,1] := "1" matriz[1,2] := "2" matriz[1,3] := "3" matriz[2,1] := "4" matriz[2,2] := "5" matriz[2,3] := "6" matriz[3,1] := "7" matriz[3,2] := "8" matriz[3,3] := "9" //1-------------------------------1------------------------------------------ para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara escreval("Digite um Número para X") leia(z) se z = 1 entao matriz[1,1] := ("X") fimse se z = 2 entao matriz[1,2] := ("X") senao fimse se z = 3 entao matriz[1,3] := ("X") senao fimse se z = 4 entao matriz[2,1] := ("X") senao fimse se z = 5 entao matriz[2,2] := ("X") senao fimse se z = 6 entao matriz[2,3] := ("X") senao fimse se z = 7 entao matriz[3,1] := ("X") senao fimse se z = 8 entao matriz[3,2] := ("X") senao fimse se z = 9 entao matriz[3,3] := ("X") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //2--------------------------------2--------------------------// escreval("Digite um Número para O") leia(z) se z = 1 entao matriz[1,1] := ("O") fimse se z = 2 entao matriz[1,2] := ("O") senao fimse se z = 3 entao matriz[1,3] := ("O") senao fimse se z = 4 entao matriz[2,1] := ("O") senao fimse se z = 5 entao matriz[2,2] := ("O") senao fimse se z = 6 entao matriz[2,3] := ("O") senao fimse se z = 7 entao matriz[3,1] := ("O") senao fimse se z = 8 entao matriz[3,2] := ("O") senao fimse se z = 9 entao matriz[3,3] := ("O") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //----------------------------------------3----------------------------------- escreval("Digite um Número para X") leia(z) se z = 1 entao matriz[1,1] := ("X") fimse se z = 2 entao matriz[1,2] := ("X") senao fimse se z = 3 entao matriz[1,3] := ("X") senao fimse se z = 4 entao matriz[2,1] := ("X") senao fimse se z = 5 entao matriz[2,2] := ("X") senao fimse se z = 6 entao matriz[2,3] := ("X") senao fimse se z = 7 entao matriz[3,1] := ("X") senao fimse se z = 8 entao matriz[3,2] := ("X") senao fimse se z = 9 entao matriz[3,3] := ("X") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara se (matriz[1,1] = "X") e (matriz[1,2] = "X") e (matriz[1,3] = "X") entao escreval("Jogador X Ganhou!!!!") fimse //--------------------------------------------4---------------------------- escreval("Digite um Número para O") leia(z) se z = 1 entao matriz[1,1] := ("O") fimse se z = 2 entao matriz[1,2] := ("O") senao fimse se z = 3 entao matriz[1,3] := ("O") senao fimse se z = 4 entao matriz[2,1] := ("O") senao fimse se z = 5 entao matriz[2,2] := ("O") senao fimse se z = 6 entao matriz[2,3] := ("O") senao fimse se z = 7 entao matriz[3,1] := ("O") senao fimse se z = 8 entao matriz[3,2] := ("O") senao fimse se z = 9 entao matriz[3,3] := ("O") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //----------------------------------5-------------------------------- escreval("Digite um Número para X") leia(z) se z = 1 entao matriz[1,1] := ("X") fimse se z = 2 entao matriz[1,2] := ("X") senao fimse se z = 3 entao matriz[1,3] := ("X") senao fimse se z = 4 entao matriz[2,1] := ("X") senao fimse se z = 5 entao matriz[2,2] := ("X") senao fimse se z = 6 entao matriz[2,3] := ("X") senao fimse se z = 7 entao matriz[3,1] := ("X") senao fimse se z = 8 entao matriz[3,2] := ("X") senao fimse se z = 9 entao matriz[3,3] := ("X") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //------------------------------6--------------------------- escreval("Digite um Número para O") leia(z) se z = 1 entao matriz[1,1] := ("O") fimse se z = 2 entao matriz[1,2] := ("O") senao fimse se z = 3 entao matriz[1,3] := ("O") senao fimse se z = 4 entao matriz[2,1] := ("O") senao fimse se z = 5 entao matriz[2,2] := ("O") senao fimse se z = 6 entao matriz[2,3] := ("O") senao fimse se z = 7 entao matriz[3,1] := ("O") senao fimse se z = 8 entao matriz[3,2] := ("O") senao fimse se z = 9 entao matriz[3,3] := ("O") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //----------------------------------7-------------------------------- escreval("Digite um Número para X") leia(z) se z = 1 entao matriz[1,1] := ("X") fimse se z = 2 entao matriz[1,2] := ("X") senao fimse se z = 3 entao matriz[1,3] := ("X") senao fimse se z = 4 entao matriz[2,1] := ("X") senao fimse se z = 5 entao matriz[2,2] := ("X") senao fimse se z = 6 entao matriz[2,3] := ("X") senao fimse se z = 7 entao matriz[3,1] := ("X") senao fimse se z = 8 entao matriz[3,2] := ("X") senao fimse se z = 9 entao matriz[3,3] := ("X") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //------------------------------8--------------------------- escreval("Digite um Número para O") leia(z) se z = 1 entao matriz[1,1] := ("O") fimse se z = 2 entao matriz[1,2] := ("O") senao fimse se z = 3 entao matriz[1,3] := ("O") senao fimse se z = 4 entao matriz[2,1] := ("O") senao fimse se z = 5 entao matriz[2,2] := ("O") senao fimse se z = 6 entao matriz[2,3] := ("O") senao fimse se z = 7 entao matriz[3,1] := ("O") senao fimse se z = 8 entao matriz[3,2] := ("O") senao fimse se z = 9 entao matriz[3,3] := ("O") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //----------------------------------9-------------------------------- escreval("Digite um Número para X") leia(z) se z = 1 entao matriz[1,1] := ("X") fimse se z = 2 entao matriz[1,2] := ("X") senao fimse se z = 3 entao matriz[1,3] := ("X") senao fimse se z = 4 entao matriz[2,1] := ("X") senao fimse se z = 5 entao matriz[2,2] := ("X") senao fimse se z = 6 entao matriz[2,3] := ("X") senao fimse se z = 7 entao matriz[3,1] := ("X") senao fimse se z = 8 entao matriz[3,2] := ("X") senao fimse se z = 9 entao matriz[3,3] := ("X") senao fimse para x de 1 ate 3 faca para y de 1 ate 3 faca escreva(matriz[x,y]," ") fimpara escreval() fimpara //--------------X vencedor-------------------------------- se (matriz[1,1]="X") e (matriz[1,2]) e (matriz[1,3] = "X") entao escreval("Joador X Ganhou!!!!!") fimse fimalgoritmo
  2. Eu sei como fazer o algoritmo ler os valor do vetor, mas como faço pra identificar se a posição do vetor é impar ou par? "Ler 3 números reais em vetor e depois exibir os números localizados nas posições impares"

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Curso de Hacker Ético

LANÇAMENTO!

CLIQUE AQUI E CONFIRA!

* Este curso não é ministrado pela equipe do Clube do Hardware.