×
Ir ao conteúdo
  • Cadastre-se

Marlon Gramacho

Membro Júnior
  • Posts

    8
  • Cadastrado em

  • Última visita

Reputação

5

Informações gerais

  • Cidade e Estado
    Salvador/BA
  • Sexo
    Masculino
  1. @kgin Mande o print da tela toda ai porque aqui ta dando que não reconhece o const MAXIMO_PRODUTOS = 10
  2. @Simon Viegas esse código não esta rodando no visualg nem no 2.5 e nem no 3.0
  3. @kgin Esse constante é o que e coloca onde?? const MAXIMO_PRODUTOS = 10 tipo tproduto=registro nome:caractere codigo:inteiro valor:real fimRegistro
  4. Bom galera, é o seguinte Fiz este código a qual esta funcionando perfeitamente, mas gostaria que apresentasse um tipo de nota fiscal no final do valor informando os itens selecionados o valor de cada item e o valor final bem parecido como em uma nota fiscal. Tem como fazer isso, se sim, como? Pois não faço a menor ideia. Var valorTotal: real codigo, quantidade: inteiro deveContinuarPerguntando, digitouRespostaInvalida: logico clienteConsumiuMais : caractere Inicio funcao retornarValorPeloCode(code: inteiro): real inicio escolha code caso 100 // R$ 5,20 Pao de Queijo retorne 5.20 caso 101 //Bauru simples 101 R$ 7,30 retorne 7.30 caso 102 //Quibe 102 R$ 6,50 retorne 6.50 caso 103 //Coxinha de frango 103 R$ 6,70 retorne 6.70 caso 104 //Torta de Frango (fatia) 104 R$ 11,10 retorne 11.10 caso 105 //Empada de bacalhau 105 R$ 9,50 retorne 9.50 caso 106 //Pão delícia 106 R$ 5,80 retorne 5.80 caso 107 //Esfirra 107 R$ 8,40 retorne 8.40 caso 108 //Rissole de queijo 108 R$ 10,60 retorne 10.60 caso 109 //Croquete 109 R$ 9,10 retorne 9.10 caso 110 //Canapés 110 R$ 13,40 retorne 13.40 fimescolha fimfuncao deveContinuarPerguntando := verdadeiro valorTotal := 0 enquanto deveContinuarPerguntando faca Escreval ("___________________________________________________________________________________________________") Escreval (" Delicatessen Veneza ") Escreval ("___________________________________________________________________________________________________") Escreval ("") Escreval(" Olá, seja Bem Vindo a Delicatessen Veneza ") Escreval(" O que vamos consumir hoje? ") Escreval ("") escreva("Digite o codigo de um salgado que o cliente consumiu: ") leia(codigo) escreva("Digite a quantidade desse salgado que o cliente consumiu: ") leia(quantidade) valorTotal <- (retornarValorPeloCode(codigo) * quantidade) escreva("O cliente consumiu mais algum salgado? Digite S(SIM) OU N(NÃO)") repita leia(clienteConsumiuMais) se clienteConsumiuMais = "S" entao deveContinuarPerguntando := verdadeiro interrompa fimse se clienteConsumiuMais = "N" entao deveContinuarPerguntando := falso interrompa fimse fimrepita fimenquanto Escreval ("") ESCREVAL("O cliente deve pagar: R$", valorTotal:6:2) Escreval ("") Escreval(" Obrigado volte sempre! ") Fimalgoritmo
  5. A questão é a seguinte: o cliente tem que escolher a metodologia de pagamento sendo:  Condição de pagamento 1 - Em dinheiro, recebe 12% de desconto.  Condição de pagamento 2 - Cartão de crédito, recebe 5% de desconto.  Condição de pagamento 3 - Parcelado no cartão de crédito em duas vezes, preço normal, sem juros.  Condição de pagamento 4 - Parcelado no cartão de crédito em três vezes, com juros 5%. A primeira parte roda com sucesso. Só estou com dificuldade para colocar a opção do cliente escolher a metodologia e assim ocorrer o calculo e seu devido desconto. Obs: a parte que esta espaçado funciona perfeitamente porém não consigo aplicar o desconto var Codigo : Real Nome : caractere Valor: Real Media : Real I: inteiro Total: Real Qnt : real desc : real total_desc : real pagamento : caractere Inicio Para I de 1 Ate 10 Faca Escreva ("Nome do Produto: ") Leia (Nome) Escreva ("Código do Produto: ") Leia (Codigo) Escreva ("Valor Unitario do produto: R$") Leia (Valor) Escreva ("Quantidade do Produto: ") Leia (Qnt) total <-(Valor * Qnt) Escreval( "O Valor total deste produto é: R$", total) media <- (total+media) escreval ("Total da compra é: R$", media) repita escreval ("Escolha a metodologia de pagamento: ") Leia (pagamento) escolha pagamento fimrepita enquanto op<>"4" faca Escreval ("(1) Dinheiro") Escreval ("(2) Cartão de Credito") Escreval ("(3) Cartão de credito (2x)") Escreval ("(4) Cartão de credito (3x)+ 5% de juros") Se op="1" então limpatela Dinheiro() fimse Se op="2" então limpatela Cartão de Credito() fimse Se op="3" então limpatela Cartão de credito (2x)() fimse Se op="4" então limpatela Cartão de credito (3x)+ 5% de juros() fimse fimenquanto fimprocedimento fimescolha procedimento cadastra_item para 1 faca Escreval ("Medologia: Dinheiro") Escreval ("Valor: R$ ", valor*12/100)
  6. Copiei esse código e continua apresentando o mesmo erro
  7. Cara teria outra forma de fazer isso acontecer? O meu tá dando erro na Variável Var poluicao : real Inicio Escreval ("____________________________________________________________") Escreval (" Secretaria Municipal de Meio Ambiente ") Escreval (" SMMA ") Escreval ("____________________________________________________________") Escreval ("Software Controlador de Emissão de Gases Poluentes") Escreval (" CEGP - Vitoria da Conquista ") Escreval (" ") repita escreval ("Informe o nível de poluição: ") leia (poluicao) escolha (poluicao) caso 0 ate 0,69 escreval ("Todas as empresas podem funcionar normalmente") caso 0,7 escreval ("1º grupo de empresas com suas atividades suspensas") caso 0,8 escreval ("1º e 2º grupo de empresas com suas atividades suspensas") caso 0,9 escreval ("1º, 2º e 3º grupo de empresas com suas atividades suspensas") Escreva ("Voltar para o menu (S/N)?") Leia (op) ate op = "n" fimescolha fimprocedimento Fimalgoritmo
  8. Galera é o seguinte fiz o código porém quero que apareça p/ o usuário logo após digitar o valor a opção de voltar ao menu mas é claro que ficando ao critério do usuário, ou seja, usuário digitando a opção "S" volta pra tela perguntando "Informe o nível do mar:" EXEMPLO ABAIXO: Escreva ("Voltar para o menu (S/N)?") Leia (op) Se op="S" entao var mar: real inicio ... escreval("Informe o nível do mar: ") leia(mar) escolha mar caso 0 ate 0,69 escreval("bom") caso 0,7 escreval ("atenção II") caso 0,8 escreval("atenção III") caso 0,9 escreval("ALERTA MAXIMO") fimEscolha fimEnquanto fimProcedimento fimAlgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como ganhar dinheiro montando computadores!

MINICURSO GRÁTIS!

Como ganhar dinheiro montando computadores!

CLIQUE AQUI E INSCREVA-SE AGORA MESMO!