Ir ao conteúdo
  • Cadastre-se

camelo

Membros Plenos
  • Total de itens

    50
  • Registro em

  • Última visita

  • Qualificações

    0%
  1. Salve galera. Direto ao assunto. Seguinte: comprei uma Asus P5ND2-SLI e uma Ati Radeon x 1600 256mb PCI-E e quando tentei liga-la ficou bipando, como se tivesse com defeito a placa de video. Então coloquei no segundo slot da placa mãe e funcionou Olhei o manual de cima pra baixo, de traz pra frente e não vi nada restringindo. Será que é bronca na placa mãe ou as ATI´s não pegam nessa placa mãe corretamente? Se funcionou no slot 2, tem alguma perda de desempenho por ser o segundo slot? Antes de postar procurei sobre o assunto mas não tinha nada sobre o problema alvo. Obrigado...
  2. E aí.. Voltando aqui no forum, faz muito tempo que não entrava... cara, e quando volto uma duvida do velho pascal hehe... Vou tentar ajudar, vamos la. Essa função recebe primeiro um vetor, o n° do loop e o elemento que esta querendo procurar respectivamente, certo? mas aqui voce esta invertendo os valores, passando o vetor, elemento, n1. Faz muito tempo que não programo em pascal e não tenho o compilador aqui, mas acho que deveria ser assim a passagem de parametros: if (num_vetor = 1) then begin if (pertence(vetor1, n1,elemento) = true) then writeln('O elemento pertence no conjunto 1.') else writeln('O elemento não pertece contido no conjunto 1.'); end else if (num_vetor = 2) then begin if (pertence(vetor2, n2,elemento) = true) then writeln('O elemento pertence ao conjunto 2.') else writeln('O elemento não pertence ao conjunto 2.'); end else Acho que é isso.... tenta rodar o programa com break point, só não lembro como usar no pascal Uma dica... para ficar mais profissional, comece a fazer os if´s sem comparar como TRUE e FALSE, pois o if já retorna TRUE caso a condição seja verdadeira, pois é o mesmo que escrever: "se o cavalo branco de napoleão for igual a 'branco' então..." if (pertence(vetor1, n1,elemento)) then .......... <se for verdadeiro> else .......... <se for falso> if not (pertence(vetor1, n1,elemento)) then .......... <se for falso> else .......... <se for verdadeiro> Espero ter ajudado... falou.
  3. Olá para todos! Mesmo não sendo tecnico em hardware, vistante e participante desde fórum, estou sempre participando do fórum "Programação e Desenvolvimento", pois é com que trabalho, mas de vez em quando dou uma olhada no site Clube do Hardware, que na minha opnião, mesmo não sendo especialista, é bem desenvolvido pelo seus administradores e contem um excelente conteúdo. Bem, respondendo ao tópico: Como sempre os americanos se achando melhor e superior que todos! Sua arrogancia me irrita profundamente, e não suporto ver um americano, principalmente aqueles que vem ganhar dinheiro a nossas custas comprando mão de obra barata ou como religiões mascaradas . Não só com Brasil, mas menospreza os países da America Latina entre outros em crescente desenvolvimento. Vi o editorial no site, vi os coments e não pude deixar de opinar. Está de parabens pela coragem Gabriel Torres! Parabens pelo editorial e opnião sobre a Intel. E que isso sirva de MAIS um exemplo de como os americanos se relacionam com o Brasil!!! Sem mais comentarios........
  4. Não acredito que seja o 'ready only' que esta 'true'. Tente apagar o componente e inserir outro. A minha dica é que voce use codigos SQL, pois é mais confiavel. Sempre uso e nunca da problema. Ex: query.sql.close; query.sql.add('INSERT INTO TABELA(CODIGO,NOME,TELEFONE) VALUES (:COD, :NOME, :TEL)'); query.parambyname('COD').AsInteger := strtoint(edtcodigo.text); query.parambyname('NOME').AsString := edtnome.text; query.parambyname('TEL').AsString := edttel.text; database.commit;
  5. aê! Dá uma olhada nisto Sistemas de arquivos É uma pequena explicação, mas já deve servir pra esclarecimento.
  6. Exatamente, eu nunca formato assim por uma besteira, pois é um saco instalar tudo novamente , fora as configurações, servidores, atualizações etc. E não tenho spywares O MvRegclean eu já tenho. Não passei ainda, mas pelo que eu saiba ele limpa as entradas de registro que não são mais usadas, não é isso ? Será que resolve. Bem, se for entrada de registro, mas se fosse assim toda vez que uma entrada de registro inválida desse erro, estariamos fritos hehe . Mas vou testar. O outro não conhecia. Muito obrigado, valeu ! Se não resolver ainda volto aqui para postar novamente Feliz ano novo à todos do fórum. Primeiramente saúde, o resto agente conquista
  7. aê galera, sempre to navegando no forum de programação, nunca postei por aqui, acho que estou precisando de uma ajudinha de vocês que são mais manjados nas entranhas do Windows Bem, eu manjo das configurações avançadas, mas não sei muita coisa. Já uso o XP há uns 6 anos mas não me deparei ainda com esse problema e não achei uma solução. O seguinte: esses spywares são um pé no saco, estão sempre rodando a rede e voce não tem como se safar deles, a não ser sempre usar os programinhas anti-spywares com freqüência. Vou tentar resumir. O problema que peguei um spyware que estava bloqueando o Ctlr+alt+del mas JÁ o removi. Antes me firewall já tinha bloqueado uma tentativa de um programa de alto risco foi ai que desconfiei que era o mesmo programinha que estava fazendo tal bloqueio. Tentei apaga-lo mas nem podia pois não podia acessar o gerenciador de tarefas, sorte que o anti-spyware detectou e removeu. Junto com o arquivo estava uma entrada de regitro, essa sim é que tinha o valor de entrada para bloquear o gerenciador. Mas O PRO. é : que quando o windows inicia está executando esse arquivo que já não existe mais, pois o deletei (acho que ele proprio criou uma auto execução). Ai fica dando uma mensagem de erro, como se o usuario fosse em Executar e digitasse o nome do programa, ele não existe e da uma mensagem de erro e tal (logico) Quero saber onde acho tal arquivo ou entrada do registro , onde eu possa remover essa excução automática, pois não achei no Msconfig nenhuma referencia da execução. (Está causando um lentidão na incialização e o erro é primeira coisa que ocorre, bem antes de inicar todos o programas de StarUp do sistema. Quando logo no sistema, so ouço o som de erro do windows, depois de algum tempo, ele abre o desktop e tal e a mensagem de erro está lá ). Antecipadamente, Obrigado
  8. Que tal dar uma olhada no TOPICOS IMPORTANTES no topo do fórum!!!!!!
  9. Com certeza há um erro ai, mas não sei se este codigo é em Delphi ou VB, alguns codigos sao parecidos para os dois. Bem, se for Delphi é o seguinte: Não precisa copiar a string, basta so converter para data. A função StrToDate já converte para uma data valida, o que voce tem que fazer é tratar o erro que vai mostrar! Faça assim: Try StrInicio := StrToDate(MkDataInicial.Text); Except Showmessage('Data inicial '+MkDataInicial.Text +' inválida!'); exit; end; try StrFim := StrToDate(MkDataFinal.Text); Except Showmessage('Data final '+MkDataFinal.Text +' inválida!'); exit; end; Pronto, sua data esta validada, depois é so passar os parametros normamente.
  10. Pricilla, sem desespero, é simples! voce vai jogar os labels la no relatorio e simplesmente vai pegar por exemplo: a hora do windows (que é o que o sysdata faz) e jogar la. Pra somar os valores voce pode fazer um "while query.eof do" na sua query somando os valores numa variavel e depois jogando no label. Espero ter ajudado, abraço.
  11. aê! não pude deixar de postar quando vi. Eu uso o timer, e nunca aconteceu esse problema. O programa que já fiz, roda em hardwares diferente e nem por isso acontece tal coisa. O codigo que uso é o seguinte: if (time.Interval = 1) then time.Interval := 60000;
  12. E aê voce tem que criar um banco com driver interbase (.GDB) e assim conectar seu banco. Tem varias forma de fazer: DbExpress(recomendo, pois se posteriormente quiser mudar o banco é fácil), DataBase ou uma paleta que tem so pra interbase. Da uma olhada e depois posta ai
  13. camelo

    Erro no DELPHI

    rapaz, esse erro é quando você tenta colocar um valor que não cabe aquela propriedade, por exemplo: Em um componente qualquer, na propriedade "Name", se você tentar colocar o nome com espaço ou caracteres do tipo acentuado, dá esse erro ai. então, acho que você está digitando algo no campo da propriedade Enabled, e não selecionando o value = false.
  14. se não é impressora fiscal fica mais fácil. Mas não entendi a forma de comunicao que você quer. Se for pra simular uma impressora que não seja essas jato de tinta, que não precisa de simulação, voce pode procurar na net uns simuladores de impressora. Geralmente tem muitos desses simuladore quando se trata de impressora fiscal. Se não for nada disso, faz um relatorio e exibi os dados nele normalmente, e manda imprimir pra ve se sai la!
  15. Exato Gabriel. Depende do componente de acesso do banco de dados que ele está usando. Se seu banco tiver senha, voce pode setar o login e senha nesse componente e desabilitar o login prompt. Da uma olhada nas propriedades do teu componente de acesso ao banco de dados beleza.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!