Ir ao conteúdo
  • Cadastre-se

osvaldomp

Membros VIP
  • Total de itens

    3.132
  • Registro em

  • Qualificações

    0%

Reputação

1.661

Sobre osvaldomp

Informações gerais

  • Cidade e Estado
    São Paulo - SP
  • Sexo
    Masculino
  1. Coloquei na busca do Google ~~~> excel converter horas em decimais retornou 105.000 resultados, entre eles o link abaixo https://pt.linkedin.com/pulse/mágica-do-24-converter-horas-em-decimal-e-vice-versa-couto-fernandes
  2. Segue uma forma de pintar as células via Formatação Condicional. 1. selecione B5:Y5 2. menu Página Inicial / Formatação Condicional / Gerenciar Regras / Nova Regra / Usar uma fórmula ... 3. na caixa de fórmula cole uma cópia desta fórmula ~~~> =E(B$3>=$I$15;B$3<=$I$16;$I$17="FALTA PROGRAMAÇÃO") 4. formate o preenchimento na cor vermelha 5. repita para as outras duas condições mudando apenas o texto na fórmula obs. 1. a FC acima vale somente para o intervalo citado, para os demais dias você precisa replicar o quadro B15:I17 e adequar os endereços na fórmula 2. em I15:I16 coloque a hora representada por um número inteiro somente, exemplo coloque 14 e não 14:00, isso para ficar compatível com as "horas" que você colocou na linha 3
  3. Experimente: Sub testeV2() Dim I As Integer I = 2 Do While Cells(I, 1) <> "" If (Cells(I, 1) = "Em trânsito" Or Cells(I, 1) = "Programada") And Cells(I, 2) = "" Then MsgBox "Verdadeira na linha " & I End If I = I + 1 Loop End Sub
  4. Se você tiver interesse que eu continue tentando ajudar então disponibilize a sua planilha COM TODAS AS FÓRMULAS contidas no intervalo D4:I3301, independente de seu tamanho. E tenha fé, apesar do tamanho, a sua fórmula vai conseguir passar pelos cabos da internet e chegar aqui no fórum. Ainda, outra solução: coloque as suas fórmulas fora do intervalo D4:I3301
  5. Na planilha que você disponibilizou não há fórmulas, por isso eu sugeri limpar tudo.
  6. Não entendi porque você dividiu a instrução em trocentos intervalos para limpar as células ? Limpe todo o intervalo numa tacada só. Range("D4:I3301") = ""
  7. No passado eu consegui resolver problema semelhante via atualização do DLL, conforme comentado no primeiro link.
  8. =cont.se(c:c;"adm*") =soma(cont.se(c:c;{"adm a";"adm b";"adm c";"adm d"}))
  9. Coloquei na busca do sábio Google ~~~> vba erro: o componente activex não pode criar objeto e ele retornou 34.900 resultados, entre eles os dois abaixo. Veja se ajuda. https://docs.microsoft.com/pt-br/office/vba/language/reference/user-interface-help/activex-component-can-t-create-object-or-return-reference-to-this-object-error-4 https://blog.agenciadatecnologia.com.br/erro-429-componente-do-activex-nao-pode-criar-objeto-resolvido/
  10. Os registros localizados abaixo de A152 não aparecem na ListView porque o seu código para de carregar a ListView ao encontrar uma célula vazia na coluna A (A153), então abaixo dela os registros não são carregados. Ou você elimina as linhas vazias da tabela ou altera o seu código conforme abaixo. substitua estas linhas ' Do Until Sheets("Base").Cells(lin, 1) = "" ' Set li = ListView1.ListItems.Add(Text:=Sheets("Base").Cells(lin, 1).Value) ' li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 2).Value ' li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 3).Value ' li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 4).Value ' li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 5).Value 'Canal ' lin = lin + 1 ' Loop por estas Do Until lin = Sheets("Base").Cells(Rows.Count, 1).End(3).Row + 1 If Sheets("Base").Cells(lin, 1) <> "" Then Set li = ListView1.ListItems.Add(Text:=Sheets("Base").Cells(lin, 1).Value) li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 2).Value li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 3).Value li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 4).Value li.ListSubItems.Add Text:=Sheets("Base").Cells(lin, 5).Value 'Canal End If lin = lin + 1 Loop
  11. Experimente a fórmula matricial abaixo. Faça os ajustes nos intervalos. =SE(LIN(A1)>CONT.SE(C$2:C$9;"#N/D");"";ÍNDICE(B$2:B$9;MENOR(SE(ÉERROS(C$2:C$9);LIN(B$1:B$8));LINS(A$1:A1)))) obs. por tratar-se de fórmula matricial, se a versão do Excel não for a 365, então após colar uma cópia da fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter, em seguida arraste pela coluna
  12. Segue uma alternativa. Na planilha do post #1 substitua a fórmula que está em D2, conforme abaixo, e estenda pela coluna. atual ~~~> =CONCATENAR(TEXTO(C2;"dd/mm/aaaa");"-";TEXTO(E2;"hh:mm")) substitua por esta ~~~> =C2+E2 ~~~> deverá ficar no formato Personalizado dd/mm/aaaa hh:mm Depois cole uma cópia da fórmula abaixo em M3 e arraste para baixo. =SOMASES($H:$H;$B:$B;J3;$D:$D;">="&K3+11/24;$D:$D;"<="&L3+11/24) resultados: 16.089,66 10.117,47 655,01 2.213,55 dica - data e data & hora o Excel entende como sendo números; o conteúdo de K14 ~~~> 27/07/2020-11:00 ~~~> se parece com data & hora, mas para o Excel é texto; para testar coloque em qualquer célula vazia ~~~> =ÉNÚM(K14) ~~~> irá retornar FALSO, em seguida substitua o hífen por espaço em K14, o resultado muda para VERDADEIRO
  13. Disponibilize o seu arquivo Excel.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!