Ir ao conteúdo
  • Cadastre-se

nickosoft

Membros Plenos
  • Total de itens

    22
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

6

Sobre nickosoft

  • Data de Nascimento 24/08/1981 (38 anos)

Informações gerais

  • Cidade e Estado
    ABC - SP
  1. nao tinha visto mesmo.....
  2. penso que no momento do preenchimento, usando . para separar os decimais em vez de colocar 34,99 usar 34.99
  3. jovem, como nao sei exatamente qual seu código, o q vejo errado.... iniciando pela query ja existe erro nela..... update tabela set campo = valor where parametro falta definir o campo e qual valor, e no parâmetro, where código o q? parâmetros podem ser feitos de duas formas sempre antes Dim command As New SqlCommand(commandText, connection) aqui sua query e sua conexao command.Parameters.Add("@codigo", SqlDbType.Int) command.Parameters("@codigo").Value = txtCodigo.text ou assim command.Parameters.AddWithValue("@codigo", txtCodigo.text)
  4. algumas observações, o separador decimal em programação é o ponto e nao virgula, isso segue o padrão inglês para limitar as casas decimais na exibição use %.2f penso q isso ja o ajude
  5. fundacao lemann tem parte de programacao bem basica, pra trabalhar a logica, sem linguagem alguma como foco.... sim, a fundacao lemann do khan academy, por ser de matematica deve conhecer....
  6. vá pensando instrucao a instrucao.... primeiro de tudo em tam você guarda o tamanho do nome isso ja é usado no primeiro for, q vai de 0 até tam, vale 0 agora o segundo for usa o valor do primeiro, de 0 até o valor menor ou igual ao índice do primeiro for q agora é 0 faz os prints, e volta ao segundo for agora ja é maior, vamos ao primeiro entao o primeiro for vale 1 agora q ainda é menor q o tamanho do nome vamos ao segundo for q agora vai de 0 a 1=(tam), valendo 0 agora voltamos ao segundo for q agora esta valendo 1 ao voltar ao segundo for, ja vale mais q (tam), entao volta ao primeiro for imagino q o print nao tenha segredo.....mas a cada laço do segundo for é o proximo caracter.... ou simplificando, o primeiro for é o q dita a linha da impressao, o segundo for dita até qual caracter imprimi....
  7. Algoritmo "vetor 30 ordem crescente" Var // Seção de Declarações das variáveis V: vetor[1..5] de Inteiro Vazio: vetor[1..5] de Inteiro h, i, j, k, m, n, p, aux, opcao, resta: Inteiro partida, final: Inteiro resp, tec: Caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... opcao <- 1 Enquanto (opcao <> 0) faca Para n <- 1 ate 5 faca // Inicialização de Vetores e contadores Vazio[n] <- 1 FimPara resta <- 5 Para p <- 1 ate 5 faca V[p] <- 0 FimPara Enquanto (opcao <> 6) ou (opcao <> 0) faca LimpaTela EscrevaL("Você gostaria de inserir quantos números no vetor de 5 posições ?") EscrevaL(" :'''''''''''''': ") EscrevaL("-----------------------: MENU :--------------------------") Escreval(" :,,,,,,,,,,,,,,: ") EscrevaL(" ") Escreval(" Digite 1 - Para inserir 1 número ") Escreval(" Digite 2 - Para inserir 2 números ") EscrevaL(" Digite 3 - Para inserir 3 números ") Escreval(" Digite 4 - Para inserir 4 números ") Escreval(" Digite 5 - Para inserir 5 números ") Escreval(" Digite 0 - Para sair do programa ") Escreval(" Digite 6 - Para reinicializar os vetores ") EscrevaL("-----------------------------------------------------------------") Leia(opcao) Se opcao = 1 entao // 1º Se Se resta <> 0 entao // 2º Se h <- 1 partida <- 0 Enquanto partida = 0 faca Se (Vazio[h] = 1) entao // 3º Se partida <- h FimSe // Fim 3º Se h <- h + 1 FimEnquanto final <- partida Para i <- partida ate final faca EscrevaL(i, "ª. posição: ") Leia(V[i]) Vazio[i] <- 0 FimPara resta <- resta - opcao EscrevaL("Você gostaria de ordenar de forma crescente ? [S/N]") Leia(resp) Se resp = "S" entao // 4º Se Para m <- 1 ate 4 faca j <- 1 Enquanto j < 5 faca k <- j + 1 Se (Vazio[j] = 0) e (Vazio[k] = 0) entao // 5º Se Se V[j] > V[k] entao // 6º Se aux <- V[j] V[j] <- V[k] V[k] <- aux FimSe //Fim do 6º Se FimSe //Fim do 5º Se j <- j + 1 FimEnquanto FimPara FimSe //Fim do 4º Se Para i <- 1 ate 5 faca EscrevaL(V[i]) FimPara Escreval("Para voltar para o MENU dgite qualquer tecla seguida de ENTER") Leia(tec) Senao //Senao do 2º Se Aviso() Escreval("Para retornar ao MENU tecle qualquer tecla seguida de ENTER") Leia(tec) FimSe FimSe // Fim 1º Se Se (opcao = 6) entao // 25º Se EscrevaL("Reinicializando programa ...Aguarde!") EscrevaL("") EscrevaL("") Escreval("Tecle qulaquer tecla seguida de ENTER para continuar") Leia(tec) FimSe se (opcao=0) entao Escreval("Obrigado por usar nosso programa!!! Volte sempre!") EscrevaL("-------------------------------------------------") EscrevaL("------------- FIM -------------------") EscrevaL("-------------------------------------------------") leia(tec) interrompa fimse FimEnquanto FimEnquanto Fimalgoritmo desse jeito rodou direitinho, nao tive o erro q informa hora nenhuma na verdade, tive outros qnt ao preenchimento do vetor, usei o visualg 3.0.6.5
  8. a resposta é qq uma, o grande X, o ponto principal q o pessoal inventa de querer estudar desenvolvimento é querer saber qual a linguagem pika das galaxias, e a resposta é nenhuma, a sua logica q faz a diferença...isso ai nenhum curso, nenhuma certificação, nenhum mestrado, doutorado, pos doutorado vai te falar...... < Ler um qr code do comprovante de pagamento para identificar se precisa pagar valor excedente > disparar o leitor, fazer a interpretação dos dados, avaliar data e hora atual, com o valor pago, determinando o vencimento da estadia, se ainda estiver na validade ok, do contrario é necessário pagar extra agora com a linguagem q optar você detalha essa linha de raciocínio....você tendo boa logica, boa visão de todo contexto, você faz c qq linguagem, a diferença entre uma e outra é sintaxe apenas.....tem if/else em todas, tem select case/switch em todas, muda a forma da sintaxe apenas.....umas dao um pouco mais de trabalho em algum tipo de codigo, outras em outro lugar, mas sua capacidade de pensar q vão fazer a diferença e nao a linguagem...
  9. depende o q cursa, tem q ver as vagas disponíveis o q estão pedindo no momento.... uma tendencia q vejo é tudo voltado a web, veja a questão asp.net core agora, não sei se é pedido pelas vagas, mas vejo ser uma tendencia de mercado. vá atras de outras linguagens, primeiro domine a logica da programação, e ai estude a sintaxe de outras linguagens....qq questão de desempate por uma vaga vão optar por alguém q conheça varias linguagens..... de uma olhada nos sites de freelance q tem pela net, da pra ter uma noção do q estão querendo atualmente, e conforme for o seu nível de conhecimento, você pode conseguir fazer um dinheirinho...
  10. das citadas o sharp e mono são as q mais se aproximam do VS, e são as mais amigáveis ganhar tempo em compilação não vai mudar tanto pela IDE usada, é um processo q esta muito próximo pra não dizer idêntico, independente da IDE usada.... avalie seu hardware, veja se não tem um espaço pra melhoria em algo q esta interferindo diretamente na compilação uso uma maquina abaixo do minimo recomendado para o VS no dia a dia, um netbook pela facilidade de locomoção, sofro um pouco na compilação, executáveis q compilam e passam de 10Mb, são um pesadelo....mas mesmo assim, fico no VS mesmo.
  11. então siga a dica, porque se você for atras de literaturas e exercícios, vai ver q no fundo o C# não é 100% OO, e vai se enrolar quando encontrar conceitos q não se aplicam.......ta certo q são coisas bem profundas, mas pro nosso dia a dia de desenvolvedor o C# atende muito bem e até com sobra o conceito de OO
  12. entendeu? vá desenvolvendo algo seu, pequeno mesmo, apenas pra aplicar o q vai aprendendo.....
  13. crie uma variável, a inicie com 0 se for o caso cada click do botão você converter o conteúdo do textbox para inteiro, decimal, conforme a variável declarada, e acrescenta na variável
  14. resolveu c a dica?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!