Ir ao conteúdo
  • Cadastre-se

nickosoft

Membros Juniores
  • Total de itens

    18
  • Registro em

  • Última visita

  • Qualificações

    0%

Tudo que nickosoft postou

  1. fundacao lemann tem parte de programacao bem basica, pra trabalhar a logica, sem linguagem alguma como foco.... sim, a fundacao lemann do khan academy, por ser de matematica deve conhecer....
  2. vá pensando instrucao a instrucao.... primeiro de tudo em tam você guarda o tamanho do nome isso ja é usado no primeiro for, q vai de 0 até tam, vale 0 agora o segundo for usa o valor do primeiro, de 0 até o valor menor ou igual ao índice do primeiro for q agora é 0 faz os prints, e volta ao segundo for agora ja é maior, vamos ao primeiro entao o primeiro for vale 1 agora q ainda é menor q o tamanho do nome vamos ao segundo for q agora vai de 0 a 1=(tam), valendo 0 agora voltamos ao segundo for q agora esta valendo 1 ao voltar ao segundo for, ja vale mais q (tam), entao volta ao primeiro for imagino q o print nao tenha segredo.....mas a cada laço do segundo for é o proximo caracter.... ou simplificando, o primeiro for é o q dita a linha da impressao, o segundo for dita até qual caracter imprimi....
  3. Algoritmo "vetor 30 ordem crescente" Var // Seção de Declarações das variáveis V: vetor[1..5] de Inteiro Vazio: vetor[1..5] de Inteiro h, i, j, k, m, n, p, aux, opcao, resta: Inteiro partida, final: Inteiro resp, tec: Caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... opcao <- 1 Enquanto (opcao <> 0) faca Para n <- 1 ate 5 faca // Inicialização de Vetores e contadores Vazio[n] <- 1 FimPara resta <- 5 Para p <- 1 ate 5 faca V[p] <- 0 FimPara Enquanto (opcao <> 6) ou (opcao <> 0) faca LimpaTela EscrevaL("Você gostaria de inserir quantos números no vetor de 5 posições ?") EscrevaL(" :'''''''''''''': ") EscrevaL("-----------------------: MENU :--------------------------") Escreval(" :,,,,,,,,,,,,,,: ") EscrevaL(" ") Escreval(" Digite 1 - Para inserir 1 número ") Escreval(" Digite 2 - Para inserir 2 números ") EscrevaL(" Digite 3 - Para inserir 3 números ") Escreval(" Digite 4 - Para inserir 4 números ") Escreval(" Digite 5 - Para inserir 5 números ") Escreval(" Digite 0 - Para sair do programa ") Escreval(" Digite 6 - Para reinicializar os vetores ") EscrevaL("-----------------------------------------------------------------") Leia(opcao) Se opcao = 1 entao // 1º Se Se resta <> 0 entao // 2º Se h <- 1 partida <- 0 Enquanto partida = 0 faca Se (Vazio[h] = 1) entao // 3º Se partida <- h FimSe // Fim 3º Se h <- h + 1 FimEnquanto final <- partida Para i <- partida ate final faca EscrevaL(i, "ª. posição: ") Leia(V[i]) Vazio[i] <- 0 FimPara resta <- resta - opcao EscrevaL("Você gostaria de ordenar de forma crescente ? [S/N]") Leia(resp) Se resp = "S" entao // 4º Se Para m <- 1 ate 4 faca j <- 1 Enquanto j < 5 faca k <- j + 1 Se (Vazio[j] = 0) e (Vazio[k] = 0) entao // 5º Se Se V[j] > V[k] entao // 6º Se aux <- V[j] V[j] <- V[k] V[k] <- aux FimSe //Fim do 6º Se FimSe //Fim do 5º Se j <- j + 1 FimEnquanto FimPara FimSe //Fim do 4º Se Para i <- 1 ate 5 faca EscrevaL(V[i]) FimPara Escreval("Para voltar para o MENU dgite qualquer tecla seguida de ENTER") Leia(tec) Senao //Senao do 2º Se Aviso() Escreval("Para retornar ao MENU tecle qualquer tecla seguida de ENTER") Leia(tec) FimSe FimSe // Fim 1º Se Se (opcao = 6) entao // 25º Se EscrevaL("Reinicializando programa ...Aguarde!") EscrevaL("") EscrevaL("") Escreval("Tecle qulaquer tecla seguida de ENTER para continuar") Leia(tec) FimSe se (opcao=0) entao Escreval("Obrigado por usar nosso programa!!! Volte sempre!") EscrevaL("-------------------------------------------------") EscrevaL("------------- FIM -------------------") EscrevaL("-------------------------------------------------") leia(tec) interrompa fimse FimEnquanto FimEnquanto Fimalgoritmo desse jeito rodou direitinho, nao tive o erro q informa hora nenhuma na verdade, tive outros qnt ao preenchimento do vetor, usei o visualg 3.0.6.5
  4. a resposta é qq uma, o grande X, o ponto principal q o pessoal inventa de querer estudar desenvolvimento é querer saber qual a linguagem pika das galaxias, e a resposta é nenhuma, a sua logica q faz a diferença...isso ai nenhum curso, nenhuma certificação, nenhum mestrado, doutorado, pos doutorado vai te falar...... < Ler um qr code do comprovante de pagamento para identificar se precisa pagar valor excedente > disparar o leitor, fazer a interpretação dos dados, avaliar data e hora atual, com o valor pago, determinando o vencimento da estadia, se ainda estiver na validade ok, do contrario é necessário pagar extra agora com a linguagem q optar você detalha essa linha de raciocínio....você tendo boa logica, boa visão de todo contexto, você faz c qq linguagem, a diferença entre uma e outra é sintaxe apenas.....tem if/else em todas, tem select case/switch em todas, muda a forma da sintaxe apenas.....umas dao um pouco mais de trabalho em algum tipo de codigo, outras em outro lugar, mas sua capacidade de pensar q vão fazer a diferença e nao a linguagem...
  5. depende o q cursa, tem q ver as vagas disponíveis o q estão pedindo no momento.... uma tendencia q vejo é tudo voltado a web, veja a questão asp.net core agora, não sei se é pedido pelas vagas, mas vejo ser uma tendencia de mercado. vá atras de outras linguagens, primeiro domine a logica da programação, e ai estude a sintaxe de outras linguagens....qq questão de desempate por uma vaga vão optar por alguém q conheça varias linguagens..... de uma olhada nos sites de freelance q tem pela net, da pra ter uma noção do q estão querendo atualmente, e conforme for o seu nível de conhecimento, você pode conseguir fazer um dinheirinho...
  6. das citadas o sharp e mono são as q mais se aproximam do VS, e são as mais amigáveis ganhar tempo em compilação não vai mudar tanto pela IDE usada, é um processo q esta muito próximo pra não dizer idêntico, independente da IDE usada.... avalie seu hardware, veja se não tem um espaço pra melhoria em algo q esta interferindo diretamente na compilação uso uma maquina abaixo do minimo recomendado para o VS no dia a dia, um netbook pela facilidade de locomoção, sofro um pouco na compilação, executáveis q compilam e passam de 10Mb, são um pesadelo....mas mesmo assim, fico no VS mesmo.
  7. então siga a dica, porque se você for atras de literaturas e exercícios, vai ver q no fundo o C# não é 100% OO, e vai se enrolar quando encontrar conceitos q não se aplicam.......ta certo q são coisas bem profundas, mas pro nosso dia a dia de desenvolvedor o C# atende muito bem e até com sobra o conceito de OO
  8. entendeu? vá desenvolvendo algo seu, pequeno mesmo, apenas pra aplicar o q vai aprendendo.....
  9. crie uma variável, a inicie com 0 se for o caso cada click do botão você converter o conteúdo do textbox para inteiro, decimal, conforme a variável declarada, e acrescenta na variável
  10. resolveu c a dica?
  11. pares serão o numero modulo 2=0, e os impares se esse modulo de 2 for diferente de 0, sendo q modulo é representado por % então numero % 2 == 0 esse numero é par, se <>0 esse numero é impar if (n % 2 == 0) { //par } else { //impar }
  12. depende como é o acesso ao BD deve estar faltando os runtimes
  13. existe o relacionamento, uma pessoa pode ter vários pedidos..... mas um pedido só pode ter uma pessoa....... seria um relacionamento 1 para muitos entre pessoas e pedidos, precisa haver a chave estrangeira em pedidos, relacionada ao id_pessoa.... algo parecido com o q ensaiou com id_produto, em pedido
  14. no model do cliente esse campo tipo cliente tem q receber um list, e você vai enviar o conteúdo como bag pra essa view você pode excluir por completo esse campo data da view, verifique o codigo dela, e exclua por completo o div q cria esse campo
  15. uma boa alma pode me dizer se um T5800 vai ser suportado apenas por GL40 + ICH9M ou somente o GL40 suporta esse T5800? to na dependencia disso pra resolver q modelo pego e transplanto meu processador com memoria e tudo eu ainda nao entendi o q ser o ICH9M ali, e se poderia ser possivel atualizar bios de note como faz com placa-mãe de desktop to querendo pegar um microboard U342 q antes vinha com T6400, nao devo ter problemas em por o T5800, hj em dia nao vem mais com o T6400
  16. so pra constar 2 modelos q estou de olho e interessado depende da possibilidade de colocar meu processador e minhas memorias q sao 800 pra ajudar e nao serem o gargalo, e de preferência 6 pra mais celulas na bateria meu uso é desenvolvimento de sistemas em visual studio com windows 7 ultimate 64bits microboard http://notebook.extra.com.br/Microboard-Ultimate-Black-U342-Notebook-c-Intel-Core-2-Duo-1-66-GHz-4GB-320GB-141-Wireless-Bluetooth-HDMI-e-Linux-43880.html?Filtro=C56_C57_V1540#detalhes intelbras http://notebook.extra.com.br/Notebook-Intelbras-i541-c-Intel-Pentium-Dual-Core-T4300-4GB-HD-500GB-LCD-14-Wireless-e-Linux-70253.html?Filtro=C56_C57_M257#detalhes
  17. pessoal, tenho um note amazon, processador T5800 com 4Gb, até ai joia, o infeliz apareceu um osmarcontato laskado q se movimenta a tela trava, agora move a tela desliga o lance é... encontrei aqui mesmo falando sobre esse chipset e nao sei o q ser esse ICH9M ai, tudo bem, vi o pessoal comentando q nao suportava C2D, acho q sao topicos do lancamento do chipset pois achei um microboard aqui mesmo com Intel GL40 + ICH9M e T6400 minha duvida é o GL40 sozinho sem o ICH9M suportaria meu T5800, ou apenas uma placa Intel GL40 + ICH9M suportaria o T5800, qnt ao microboard nao achei mais pra vender esse modelo com o T6400.... quero comprar um note de baixo custo q suporte meu processador e minha memoria, e de preferência q tenha driver 64bits coisa q o amazon com 672 no video nao dava suporte

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!