Ir ao conteúdo
  • Cadastre-se

othman

Membros Plenos
  • Total de itens

    108
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

0

Sobre othman

  • Data de Nascimento 09-09-1990 (28 anos)

Informações gerais

  • Cidade e Estado
    Viamão
  1. Olá, há mais ou menos um mês eu montei minha máquina e ela dá algumas telas azuis de vez em quando,olhei as temperaturas e estão normais.As telas azuis não são tão frequentes e não há um período de tempo específico entre uma e outra tela azul. Mensagem : BCCode:1000007e BCP1: FFFFFFFFC0000005 BCP2: FFFFF80002D754AE BCP3: FFFFF88002FF5968 BCP4: FFFFF88002FF51C0 OS Version: 6_1_7600 Service Pack: 0_0 Product: 256_1 Minha configuração : CPU: AMD Athlon II x2 240 2.8GHz Memória :2 x 2GB Kingston 1333Mhz Kingston HD : 500 GB S-ATA 2 Seagate (Não me recordo do modelo) Placa de vídeo : 9800GT 1GB DDR3 256 Bits EVGA Fonte : C3-Tech DSA500VE 500W S.O : Windows 7 Ultimate 64 Bits. Usei o MemTest para testar a memória e ele me retornou alguns erros,um deles foi : "Memory Error, Copying Between 238cd05 and 238cccb did not resulte in a acurate copy." Agradeço à ajuda.
  2. Já consegui resolver o problema,acabei descobrindo que estava usando uma lógica errada A solução está aqui,caso alguém precise: Validar_cadastro.php <?php class validar_cadastro{ public function verificanome($nome) { $verifica_nome = ctype_digit($nome); return $verifica_nome; } public function verificarg ($rg) { $verifica_rg = ctype_digit ($rg); return $verifica_rg; } public function verificatelefone ($telefone){ $verifica_telefone = ctype_digit ($telefone); return $verifica_telefone; } public function verificaemail ($email){ if(filter_var($email,FILTER_VALIDATE_EMAIL)){ print "<br><br>E-mail : "; print $email; }else{ return false; } } } ?> classe_upload.php <?php class classe_upload { function upload ($nomearquivo,$arquivotmp,$nome,$rg){ $uploaddir = '/'; $upload_max_filesize = 1024 * 1024 * 2; $uploadfile = $uploaddir . $nomearquivo; $extensoes_permitidas = array ('doc' , 'docx' ); $pegar_extensao = strtolower (end(explode ('.' , $nomearquivo) ) ); if (array_search ($pegar_extensao , $extensoes_permitidas ) === false ){ print "<br><br>Extensão de arquivo inválida!"; $prossiga = false; }else{ print "<br><bR>Arquivo : "; print $nomearquivo; $prossiga = true; } if ($prossiga = true ){ $pegar_extensao = '.'.$pegar_extensao; if(move_uploaded_file ($arquivotmp , $uploaddir . $nome . $rg . $pegar_extensao)){ print "<br><br>Cadastro efetuado com sucesso!"; }else{ print "<br><br>Impossível realizar upload!"; } } } } upload_a_objeto.php <title> Cadastro e envio de currículo</title> <?php require 'validar_cadastro.php'; $objeto_cadastro = new validar_cadastro (); $tudo_ok = 4; if ($objeto_cadastro -> verificanome ($_REQUEST ['nome'] ) === false){ print "<br><br>"; print "Nome : "; print $_REQUEST['nome']; } else { print "Nome inválido!"; $tudo_ok = $tudo_ok - 1; } if ($objeto_cadastro -> verificarg ($_REQUEST['rg']) === false){ print "<br>"; print "RG inválido!"; $tudo_ok = $tudo_ok - 1; } else{ print "<br><br>"; echo "RG : "; print $_REQUEST['rg']; } if ($objeto_cadastro -> verificatelefone ($_REQUEST['telefone']) === false){ print "<br><br>"; print "Telefone inválido"; $tudo_ok = $tudo_ok - 1; } else{ print "<br><br>"; print "Telefone : "; print $_REQUEST['telefone']; } if($objeto_cadastro -> verificaemail ($_REQUEST['email'])=== false){ print "<br><br>E-mail inválido!"; $tudo_ok = $tudo_ok - 1; } else {} require 'classe_upload.php'; $objeto_upload = new classe_upload; if($tudo_ok == 4){ $objeto_upload -> upload ($_FILES['arquivo']['name'],$_FILES['arquivo']['tmp_name'],$_REQUEST['nome'],$_REQUEST['rg']); } else{ print "<br><br> Preencha novamente o formulário!"; } Pode fechar o tópico moderador,obrigado.
  3. Olá,estou resolvendo um exercício em php orientado à objetos,mas não estou conseguindo utilizar os valores da função return de um método.Vou mostrar o código para que fique mais claro: Classe_upload.php: <?php class classe_upload{ public function verificanome($nome) { $verifica_nome = ctype_digit($nome); return $verifica_nome; } public function verificarg ($rg) { $verifica_rg = ctype_digit ($rg); return $verifica_rg; } public function verificatelefone ($telefone){ $verifica_telefone = ctype_digit ($telefone); return $verifica_telefone; } public function verificaemail ($email,$invalido,$valido,$validador_email_retorno){ $validador_email = '.com'; $encontra_com = strtolower (end(explode('@',$email))); if(array_search($validador_email , $encontra_com) === false){ $invalido = "E-mail inválido!"; $validador_email_retorno = false; return $validador_email_retorno; } else{ $valido = "E-mail Válido."; $validador_email_retorno = true; return $validador_email_retorno; } } preciso pegar os valores do return $validador_email_retorno , mas não sei qual função usar,li o manual php e pensei que fosse includ,mas não funcionou. outro código : <?php require 'classe_upload.php'; $objeto_upload = new classe_upload (); $tudo_ok = 5; if ($objeto_upload -> verificanome ($_REQUEST ['nome'] ) === false){ print "<br><br>"; print "Nome : "; print $_REQUEST['nome']; } else { print "Nome inválido!"; $tudo_ok = $tudo_ok - 1; } if ($objeto_upload -> verificarg ($_REQUEST['rg']) === false){ print "<br>"; print "RG inválido!"; $tudo_ok = $tudo_ok - 1; goto a; } else{ print "<br><br>"; echo "RG : "; print $_REQUEST['rg']; } if ($objeto_upload -> verificatelefone ($_REQUEST['telefone']) === false){ print "<br><br>"; print "Telefone inválido"; $tudo_ok = $tudo_ok - 1; } else{ print "<br><br>"; print "Telefone : "; print $_REQUEST['telefone']; } /* Nesta última parte do código para poder validar o e-mail é necessário o valor da variável $validador_email_retorno mas não sei qual função "importa" ela para que ela se torne utilizável no segundo código */ if($validador_email_retorno === true){ print "<br>"; print "E-mail válido"; } else{ print "<br>"; print "E-mail inválido!"; } } Por eu ser iniciante em PHP e em programação meu código e minha lógica são meio toscos mas o meu objetivo é tentar verificar os dados que o usuário digitou no formulário,se o telefone é somente números,se o nome é somente letras,se o e-mail digitado está completo,etc. Agradeço desde já .
  4. Já consegui solucioar o problema,pra quem tiver com um problema parecido aí vai o código: Encontrei navegando na internet,os créditos são do autor do código : Thiago Belem. Limitar o tamanho do arquivo para upload para 2 mb: $upload_max_filesize = 1024 * 1024 *2; Limitar extensões: $upload_extensoes = array ['doc' , 'docx']; $extensao = strtolower(end(explode ('.' , $_FILES['arquivo']['name']))); if (array_search($extensao , $upload_extensoes) === false){ print "Extensão inválida!"; } else { } Pode fechar o tópico moderador. Agradeço à atenção.
  5. Olá,estou aprendendo PHP e estou com esse exercício que não estou conseguindo fazer,o objetivo é criar uma página de php que receba um currículo com no máximo 2mb na extensão doc e docx,o nome do arquivo deve ser o nome do candidato e seu RG. o que eu já consegui: <?php $uploaddir = '/'; $uploadfile = uploaddir . $_FILES['arquivo'] , ['name']; $upload_max_filesize integer = 2097152; $_UP ['extensoes'] = array ('doc' , 'docx'); if(move_uploaded_files($_FILES ['arquivo'] ['tmp_name'], $uploaddir . $_FILES['arquivo] ['name'])){ print "Arquivo carregado com sucesso. info:\n"; print $_FILES; } else{ print "O arquivo não foi carregado com sucesso. info:\n"; print $_FILES; } print "</pre>"; ?> Estou tendo problemas com essa história do nome do candidato e RG,não tenho a mínima ideia de como fazer isso.Esse código foi feito com a ajuda do professor então ele lançou o desafio para os alunos terminarem em casa,eu estou pesquisando e estou tentando fazer por mim mesmo,o que eu ja consegui fazer sozinho foi ajustar o tamanho do arquivo e as extensões Outro detalhe que eu achei estranho foi que os avisos das Error levels não foram definidos,se isso for realmente necessário. Agradeço a ajuda desde já.
  6. Olá,estou terminando de montar a minha configuração e preciso saber quanto ta custando em média essas VGAs (que são as que eu pretendo comprar),eu estou pesquisando a um bom tempo na internet e a média de preço que encontro é de R$380,00.A mais barata foi uma GTS450 com memória DDR3 por R$322,00 no site kabum!. Gostaria de algumas sugestões de lojas online ou aqui na região metropolitana de Porto Alegre e de outros modelos de placas de vídeo que sejam boas. Penso em gastar no máximo R$390,00 em uma placa de vídeo,minha configuração é a da assinatura. Agradeço desde já.
  7. Bom pessoal,como meu objetivo era apenas navegar na internet eu comprei o athlon II x2 240 a memória e a placa mãe citados na primeira mensagem,mas agora descobri que o Athlon não é tão fraco,portanto, resolvi colocar uma placa de vídeo,pelo custo x benefício e pela minha situação financeira atual resolvi escolher a HD 5770(a menos que haja uma sugestão melhor) mas descobri que minha fonte genérica não aguenta ela,queria saber qual a potência da fonte necessária pra aguentar meu sistema junto com a placa de vídeo. Ainda me restam R$315,00(destinados pra GPU e pra fonte),mas estou juntando mais grana pra poder comprar um equipamento de qualidade.Moro em POA e se alguém souber de uma loja que tenha por aqui(ou pela internet,que seja confiável) e possa me indicar eu agradeceria. Agradeço à atenção.
  8. Olá,estou terminando uma configuração nova e preciso de uma ajuda.Atualmente a configuração está assim: AMD Athlon II x2 240 2.8GHz 2GB DDR3 1066Mhz Kingston 500GB Sata2 Seagate placa-mãe Gigabyte M68MT-S2P Fonte Mymax 420Watts Reais Vídeo Onboard GeForce 7500 256Mb Ainda Preciso comprar uma fonte "de Verdade" e uma placa de vídeo. Estou atrás de uma AMD Radeon HD5770 E a fonte ainda estou pesquisando uma,pensei nessa aqui: http://www.atera.com.br/dispprod.asp?COD=W0379RU Alguém pode me ajudar a escolher essas duas ultimas peças? Atualmente tenho apenas R$315,00 guardado então vou juntar mais uma grana. Desde já agradeço.
  9. Olá,boa tarde, estou com um problema estranho,um certo dia o video do pc se apagou durante a utilização(estava usando a placa de vídeo off board),então eu reiniciei com a placa ainda conectada,o pc iniciou normalmente(ou quase) deu apenas um bip como de rotina mas não apareceu nada no vídeo.Desconectei a placa de vídeo offboard e liguei o monitor na onboard,funcionou normalmente.Hoje eu conectei a placa de vídeo offboard no slot e o pc ligou normal mas nao deu video,então eu liguei o monitor na entrada de vídeo onboard(com a placa ainda conectada) e o pc ligou normalmente,que eu saiba quando a placa de video é conectada no slot o video onboard é desativado. Obs: o audio também parou de funcionar. Teria solução esse problema? Desde já agradeço.
  10. Boa tarde,estou com um problema aqui e não consegui resolver,o negócio é o seguinte,meu pc costumava reiniciar sozinho e eu não conseguia resolver o problema até que um dia ele desligou e não ligou mais.Há um led na própria placa-mãe para indicar que ela está ligada(ou pelo menos está recebendo energia),esse led acende e quando eu aperto o botão pra ligar não acontece nada o cooler não gira nem a fonte liga.Já testei outra fonte e nao funcionou,já testei a fonte que tava ligada nesse pc em outros pcs e funcionou direitinho,tentei dar a partida na placa-mãe manualmente(pressionando com uma chave de fenda os pinos d painel frontal) várias vezes e também não adiantou.Pode ser a placa-mãe?Tenho também aqui um processador extra para testar,só ainda nao tive tempo de fazer isso,queria saber o que é primeiro antes de mexer no pc de novo. Obs: a última vez que o pc ligou foi hj de manha,então ele desligou sozinho(como ele já vinha fazendo há um bom tempo) e nao ligou mais. Já tentei ligar o pc só com a placa-mãe,processador,memória e fonte e também não resolveu. Desde já agradeço.
  11. Olá,meu PC ta reiniciando sozinho,as vezes ele só desliga e não liga mais,só depois de um tempo,sei que isso pode ser a temperatura do processador mas ele tá a 54º com um ventilador ligado em cima do pc.Outro detalhe é que se eu der uma batidinha na fonte ele liga,fica um tempo e desliga de novo,o período de tempo nunca é o mesmo ás vezes ele desliga antes do boot,antes de iniciar o sistema,durante a utilização do pc. Detalhe: A fonte é nova comprada a duas semanas. Alguém sabe o que pode ser esse problema? Coloquei um cabo de força novo achando que esse poderia ser o problema,então agora ele reinicia com menos frequência. Agradeço desde já.
  12. othman

    A lógica está certa?

    O exercício pede para fazer um programa que peça o nome de duas pessoas o peso e a altura,diga qual é a mais pesada e a mais alta. Sou iniciante em java estou aprendendo vetores arrecem,então não sei muitos recursos,minha principal dúvida é na hora de obter os dados para o vetor nome,ou seja,eu fiz assim "nome = String.parseString..."mas sei que não é assim,gostaria de saber como eu faço do jeito certo. import java.util.*; import java.text.*; import javax.swing.JOptionPane; public class peso_altura_nome{ public static void main (String args []){ float peso[] = new float [2],altura[] = new float [2] ; String nome[] = new String [2]; for(int i = 0 ; i<2 ; i++){ nome[i] = String.parseString(JOptionPane.showInputDialog(null,"Digite o nome da "+(i+1)+"ª pessoa:")); peso[i] = Float.parseFloat(JOptionPane.showInputDialog(null,"Digite o peso da "+(i+1)+"ª pessoa:")); altura[i] = Float.parseFloat(JOptionPane.showInputDialog(null,"Digite a altura da "+(i+1)+"ª pessoa:")); if(peso[0] > peso[1]){ JOptionPane.showMessageDialog(nome[0]+" é mais pesado(a)."); } if(peso[1] > peso[0]){ JOptionPane.showMessageDialog(nome[1]+" é mais pesado(a)."); } else{ JOptionPane.showMessageDialog("Ambos possuem o mesmo peso."); } if(altura[0]>altura[1]){ JOptionPane.showMessageDialog(nome[0]+" é mais alto(a)."); } if (altura[1]>altura[0]){ JOptionPane.showMessageDialog(nome[1]+" é mais alto(a)."); } else{ JOptionPane.showMessageDialog("Ambos possuem a mesma altura."); } } } } Desde já agradeço a ajuda. Obs. Estou usando o DR.Java.
  13. Boa noite,tenho aqui internet a rádio e queria instalar um roteador wireless pra usar o notebook em qualquer parte da casa.O roteador já estava sendo usado anteriormente em outra rede então eu resetei ele para os padrões de fábrica.O roteador é um Intelbras WRG240E e queria saber como configurá-lo para usar com uma net à rádio,não sei se escolho PPoE ou IP estático,ou IP dinâmico,nenhum está dando certo. Desde já agradeço a ajuda.
  14. othman

    Hotmail não abre!

    É verdade,eu ja tive muitos problemas com a data,e esse foi mais um,a data da cmos estava em 21 de fevereiro ,mas a hora estava certa e eu não percebi,muito obrigado pela ajuda.
  15. othman

    Hotmail não abre!

    Bom dia,estou com um problema extremamente irritante,tentei instalar o MSN 2009 e quando fui entrar ele disse que não era possível entrar,dizendo que meu roteador poderia estar bloqueando as portas,ou o firewall.Chequei no e estava tudo ok(acredito que o msn utilize a porta 80).Instalei o aMsn e funcionou perfeitamente,mas pelo aMSN eu não conseguia acessar minha caixa de entrada,tentei entrar pelo navegador,indo no site do msn,mas quando clico em hotmail acontece um problema,quando abro com o firefox 4.0 a aba fica com o nome Entrar e a página fica em branco,no explorer 8 ele já dá o aviso de "A página não pode ser exibida".Alguém sabe qual pode ser o problema?Estou escaneando com o antivirus(Avast free) já usei Ccleaner e Mv Regclean e não adiantou. Meu S.O é o Windows XP Professional 32 bits SP3. Desde já agradeço.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×