Ir ao conteúdo
  • Cadastre-se

rafaeddd

Membros Juniores
  • Total de itens

    19
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

13

Sobre rafaeddd

  • Data de Nascimento 07-08-1992 (26 anos)

Informações gerais

  • Cidade e Estado
    Dourados

Outros

  • Biografia
    Aprendiz
  • Ocupação
    Designer All
  • Interesses
    PC, PS3 , FUT , TERRES ,
  1. Nao entendi como usar vetores // EXERCICIO NUMERO 7 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "7" var Q: vetor[1..10] de inteiro i,posicao: inteiro inicio para i de 1 ate 10 faca escreval("Digite o", i, "º numero:") leia(Q[i]) posicao <- i escreval("Na posição:", posicao) escreval enquanto (Q[i] < 0) faca escreval("Digite um valor positivo") leia(Q[i]) fimenquanto fimpara para i de 1 ate 10 faca posicao <- i fimpara fimalgoritmo nao sei se o que eu fiz ta certo !
  2. @Simon Viegas entendi ... vou tentar melhorar este código ... obrigado
  3. @Kauan Maia da Silva MUITO OBRIGADO ! deu tudo certo agora ! // EXERCICIO NUMERO 2 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "Desconto para comercio" Var // Seção de Declarações das variáveis descricaoproduto:caractere precounitario,quantidade:real valordesconto,valorpagar:real valorpagardesconto:real precototal:real // Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Descrição Do Produto..............: ") leia(descricaoproduto) escreva("Preço Unitario..................R$: ") leia(precounitario) escreva("Quantidade........................: ") leia(quantidade) precototal<-quantidade*precounitario //preço por unidade //OS DESCONTOS Se (precototal >= 0) e (precototal < 150) entao valordesconto<-(precototal*15/100) //15% senao Se (precototal >= 150) e (precototal < 499.99) entao valordesconto<-(precototal*18/100) //18% senao Se (precototal >= 500) e (precototal < 799.99) entao valordesconto<-(precototal*23/100) //23% senao Se (precototal >= 800) e (precototal < 1000) entao valordesconto<-(precototal*27/100) //27% senao Se (precototal >= 1000) entao valordesconto<-(precototal*30/100) //30% FimSe FimSe FimSe FimSe FimSe valorpagar<-precototal-valordesconto escreval("Preço Total do Produto..........R$: ",precototal) escreval("Valor do Desconto...............R$: ",valordesconto) escreval("Valor a Pagar...................R$: ",valorpagar) escreval("********FIM DO ALGORITMO*******") fimalgoritmo adicionado 0 minutos depois obrigado
  4. @Kauan Maia da Silva é possivel fazer este codigo de outra maneira para nao bugar ?
  5. @Kauan Maia da Silva sabe como faço para corrigir isto ?
  6. @Kauan Maia da Silva consegue ver para min se este novo código faz a função que pede no exercício ?
  7. acho que consegui Algoritmo "Desconto para comercio" Var // Seção de Declarações das variáveis descricaoproduto:caractere precounitario,quantidade:real valordesconto,valorpagar:real valorpagardesconto:real precototal:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Descrição Do Produto..............: ") leia(descricaoproduto) escreva("Preço Unitario..................R$: ") leia(precounitario) escreva("Quantidade........................: ") leia(quantidade) precototal<-quantidade*precounitario //preço por unidade //OS DESCONTOS //15% menor R$150 caso precototal 0 ate 149 valordesconto<-(precototal*15/100) caso precototal 150 ate 499 entao valordesconto<-(precototal*18/100) caso precototal 500 ate 799 entao valordesconto<-(precototal*23/100) caso precototal 800 ate 1000 entao valordesconto<-(precototal*27/100) caso precototal > 1000 entao valordesconto<-(precototal*30/100) fimescolha valorpagar<-precototal-valordesconto escreval("Preço Total do Produto..........R$: ",precototal) escreval("Valor do Desconto...............R$: ",valordesconto) escreval("Valor a Pagar...................R$: ",valorpagar) escreval("********FIM DO ALGORITMO*******") fimalgoritmo esta correto com o exercício ? adicionado 1 minuto depois @giu_d sim, agora eu entendi como usar o senao retirei todos e mudei de se para caso ...
  8. @Kauan Maia da Silva eu nao sei o que é estruturas condicionais aninhadas ... estou em programação 1 , e não consigo fazer este exercício.
  9. o que eu conseguir foi dar o desconto porém so consigo para 10% os outros eu nao consigo fazer ... preciso de ajuda // EXERCICIO NUMERO 2 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "Desconto para comercio" Var // Seção de Declarações das variáveis descricaoproduto:caractere precounitario,quantidade:real precototal,valordesconto,valorpagar:real valorpagardesconto:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Descrição Do Produto..............: ") leia(descricaoproduto) escreva("Preço Unitario..................R$: ") leia(precounitario) escreva("Quantidade........................: ") leia(quantidade) precototal<-quantidade*precounitario //preço por unidade //OS DESCONTOS //15% menor R$150 se precototal<150 entao valordesconto<-(precototal*15/100) senao valorpagar<-precototal fimse //18% de R$150 a R$499 se precototal>150 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal<499 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal>500 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal<799 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal>800 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal<=1000 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal>1001 entao valordesconto<-(precototal*30/100) senao valorpagar<-precototal-valordesconto fimse escreval("Preço Total do Produto..........R$: ",precototal) escreval("Valor do Desconto...............R$: ",valordesconto) escreval("Valor a Pagar...................R$: ",valorpagar) escreval("********FIM DO ALGORITMO*******") fimalgoritmo
  10. Muito obrigado estou tentando absorver estar explicações sobre "Enquanto" ... Agora entendi como usar ... pode me ajuda neste casso aqui . Faça um algoritmo que leia 5 números inteiros e, para cada um deles, exiba o antecessor, o sucessor, o dobro e o triplo. esta certo ? Algoritmo "leia 5 números inteiros e, para cada um deles, exiba o antecessor, o sucessor, o dobro e o triplo" //Exercicio 1 Var // Seção de Declarações das variáveis anumero:inteiro bnumero:inteiro cnumero:inteiro dnumero:inteiro enumero:inteiro dobro:inteiro triplo:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite o A numero: ") leia(anumero) //1 dobro <- (2*anumero) triplo <- (3*anumero) anumero := anumero-1 escreval("Anterior",anumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o B numero: ") leia(bnumero) //2 dobro <- (2*bnumero) triplo <- (3*bnumero) bnumero := bnumero-1 escreval("Anterior",bnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o C numero: ") leia(cnumero) //3 dobro <- (2*cnumero) triplo <- (3*cnumero) cnumero := cnumero-1 escreval("Anterior",cnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o D numero: ") leia(dnumero) //4 dobro <- (2*dnumero) triplo <- (3*dnumero) dnumero := dnumero-1 escreval("Anterior",dnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o E numero: ") leia(enumero)//5 dobro <- (2*enumero) triplo <- (3*enumero) enumero := enumero-1 escreval("Anterior",enumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval Fimalgoritmo Update acho que consegui
  11. sim e entre 20 e 30 vou tentar usa r <= >= obrigado
  12. Algoritmo "semnome" Var // Seção de Declarações das variáveis numero: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Digite o numero:") leia(numero) enquanto (numero < 20) ou (numero > 30) faca escreval("Erro! O numero deve ser entre 20 e 30") escreva("Digite novamente: ") leia(numero) fimenquanto escreval("Numero aprovado!") fimalgoritmo nao sei se esta certo intende ...
  13. Estou tentando mais não consigo alguém pode ma ajudar ?
  14. Ola Gente preciso da uma ajuda ... meu computador tem 3 HD onde 1 e do Windows e 2 de Jogos e Dados Ontem peguei um " virus " fiz o backup dos dados no HD de 1 tb e formatei o do Windows e o de dados. Ai houve o problema quando terminei o HD do windows estava OK e o de dados formatando mais tarde ficou OK JAAA o de 1 tb reconhecia na bios mais no windows aparecia como DISK DYNAMIC ... procurei no google " Como converter diskdynamic em basico sem perder dados " E encontrei o programa "Aomei Dynamic Disk Manager Pro Edition" onde nele com uma video aula consegui voltar para basico ! o problema foi que quando o processo terminou o pc reiniciou e o HD de 1 tb voltou como Na foto sem nem 1 arquivo ! Perdi tudo os meu dados ah uma maneira de Reverter o processo ou recuperar os dados perdidos ? OBRIGADO Windows 7 x64
  15. sim eu edito a ima original ... depois salvo em bmd igual a original e adiciono no arquivo.exe com o resHacker mais fica com os contorno verde !

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×