Ir ao conteúdo
  • Cadastre-se

Wicos

Membros Juniores
  • Total de itens

    15
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

6

Sobre Wicos

  • Data de Nascimento 25/04/1966 (54 anos)

Informações gerais

  • Cidade e Estado
    São Gonçalo-RJ
  1. Passado para informar que estou tentado viabilizar dessa maneira. Obrigado pelas dicas e correções.
  2. Caro Simom Viegas, realmente falta ainda muita, mais muita prática e codificar um enunciado para mim. adicionado 33 minutos depois Exponho aqui o enunciado da questão: Levando em conta a sua recomendação,baixei a versão indicada e estou utilizando. Aqui o algoritmo que desenvolvi, com o que aprendi até o momento, reduzi para apenas 3 idades, com o intuito de testá-lo facilmente. algoritmo "vetorContSomaMedia1Impressao" // Ler 3 idades e armazena nos vetores correspondente // conta quantas idades foi inseridas em cada vetores // faz as medias das faixa etárias e a geral // imprime as idades por faixa etária var idade: vetor[1..3] de inteiro menor: vetor[1..3] de inteiro adulto: vetor[1..3] de inteiro idoso: vetor[1..3] de inteiro i: inteiro ci, cm, ca, cid: real si, sm, sa, sid: real mi, mm, ma, mid: real inicio escreval("Digite 3 idades:") para i de 1 ate 3 faca leia(idade[i]) ci := ci + 1 si := si + idade[i] mi <- si / ci se (idade[i] >= 0) e (idade[i] <= 18) entao menor[i] <- idade[i] cm := cm + 1 // contador sm := sm + idade[i] // soma das idades mm <- sm / cm // média das idades fimse se (idade[i] >= 19) e (idade[i] <=60) entao adulto[i] <- idade[i] ca := ca + 1 sa := sa + idade[i] ma <- sa / ca fimse se idade[i] > 61 entao idoso[i] <- idade[i] cid := cid + 1 sid := sid + idade[i] mid <- sid / cid fimse fimpara limpatela // Impressão das idades por faixas etárias escreval("Lista da idades de pessoas por faixa etária dos Menores: ", menor[i]) escreval("Lista da idades de pessoas por faixa etária dos Adultos: ", adulto[i]) escreval("Lista da idades de pessoas por faixa etária dos Idosos : ", idoso[i]) escreval("-------------------------------------------------------------------") // Impressão de quantidades de pessoas por faixa etária e geral escreval("Quantidade de pessoas da faixa etária dos Menores: ", cm) escreval("Quantidade de pessoas da faixa etária dos Adultos: ", ca) escreval("Quantidade de pessoas da faixa etária dos Idosos : ", cid) escreval("-------------------------------------------------------------------") // Média das idades por faixas etárias e geral escreval("Média da faixa etária dos Menores: ", mm) escreval("Média da faixa etária dos Adultos: ", ma) escreval("Média da faixa etária dos Idosos : ", mid) escreval("-------------------------------------------------------------------") // Média geral de todas as idades escreva("Média geral de todas idades: ", mi) fimalgoritmo A parte que estou encontrando dificuldade é na impressão das quantidades de pessoas por faixa-etária, ao digitar as três idades 10, 40 e 70 respectivamente, e observar no VisualAG, Na aba "Áreas das variáveis de memórias (Globais e Locais), os vetores estão com suas idades adquiridas (preenchidas) pelas condições, mas pelo que observei é só impresso a ultima idade digitada, ou seja o 70. Uma outra dúvida nessa mesma aba é que os índices dos vetores, não são preenchidos na sequencia, ele pula, se digitar o 10 primeiro, ele vai alocar no vetor menor no índice 0, mais se digitar 40 primeiro e em seguida digitar o 10, ele o 10 aloca no índice 1 do vetor menor e não no 0.
  3. Agradeço devair1010 de coração pela presteza em responder. Realmente está "bugado", baixei novamente e instalei no "C:", como recomenda o autor. Funcionando perfeitamente. Quanto ao segundo algoritmo, ele está errado.
  4. Há alguma possibilidade de informar por que no VisualAG está dando erro de falta de "entao", neste algoritmo abaixo. Esse algoritmo lê a entrada de 3 idades e armazena as idades em cada faixa etária. algoritmo "vetor" var idade: vetor[1..3] de inteiro menor: vetor[1..3] de inteiro adulto: vetor[1..3] de inteiro idoso: vetor[1..3] de inteiro i: inteiro inicio escreval("Digite 3 idades:") para i de 1 ate 3 faca leia(idade[i]) se (idade[i] >= 0) e (idade[i] <= 18) entao <===== erro aqui, diz que falta o então e não passa menor[i] <- idade[i] fimse se (idade[i] >= 19) e (idade[i] <=60) entao adulto[i] <- idade[i] fimse se idade[i] > 61 entao idoso[i] <- idade[i] fimse fimpara fimalgoritmo Fiz de um outro jeito,mais ocorre o mesmo erro : algoritmo "vetor" var idade: vetor[1..3] de inteiro menor: vetor[1..3] de inteiro adulto: vetor[1..3] de inteiro idoso: vetor[1..3] de inteiro i, a: inteiro inicio escreval("Digite 3 idades:") para i de 1 ate 3 faca leia(a) idade[i] <- a se a < 19 entao menor[i] <- a fimse se a > 19 e a <= 60 entao <==== o erro aqui adulto[i] <- a fimse se a > 61 entao idoso[i] <- a fimse fimpara fimalgoritmo
  5. Obrigado por responder. Fui em busca das informações, me gerou mais dúvidas. Tenho a seguinte configuração de hardware: 1-Motheboard GA-78LMT-USB3 (rev. 6.0), que tem placa de vídeo integrada ATI Radeon HD 3000. 2-CPU AMD FX(tm)-8350 Eight-Core Processor; 3-GPU - GeForce GTX 750 Ti, 2G; e 4-Memória 16GiB. Habitei normalmente a virtualização na BIOS da motheboard. Estou em dúvida é se esses hardware suporta passthrough, saberia informar? Um outra indagação é se habilitar IOMMU e a mesma coisa que habilitar a virtualização, nesta placa, ou é em um outro local da configuração da BIOS?
  6. Tenho uma dúvida com relação a virtualização. Teria como virtualizar direcionando a GPU onbord para a guest e a GPU offboard para o host, na mesma CPU?
  7. Obrigado por responder, verdade até agora os preços são altos.
  8. Saudações a todos, Recentemente consegui um xeon e3-1225 v5. e quero montar um "setup" para games e renderizar para o youtube A questão é, qual placa-mãe devo adquirir, que não seja um preço exorbitante, teriam algumas sugestões?
  9. Entendi o seu procedimento, mas neste caso qualquer um que tenha cesso remoto ao PC, poderia acessar o HD do Linux, enquanto eu utilizava o Windows10 e vice-versa. Como expliquei acima, eu queria um tipo de dispositivo que pudesse alternar de HDs antes de ligar o PC, (desligado da fonte). Pois o HD desligado da fonte, ninguém poderia acessá-lo entendeu?
  10. Por favor, poste o resultado desses teste. Um adendo: Tive o mesmo problema com a Nvidia GTS 250, 1024M, 256bits, depois de algum tempo utilizando dessa maneira a tela começou a ficar tipo de cor verde listrada, as vezes tipo matrix, ficou desse jeito tanto no linux(Archlinux-XFCE4 como no windows10. Tive que comprar outra placa de vídeo.
  11. Um bom dia a todos. Bom, tenho 2 HDs SATA interno com SOs diferente um com o Linux e o outro com o Windows. Não quero utilizar dual boot por questão de segurança. Quando quero entrar em um SO que não está ativo no momento, utilizo de um dos dois "modus operandi": 1- modo: Reinício a máquina, entro no SETUP, ativo o HD em questão e desarmo o outro. 2- modo: Com o PC desligado abro a tampa lateral e conecto o cabo de energia do HD no que irei utilizar, deixando o cabo de energia do outro desligado Pergunto: Teria algum tipo de "dispositivo" que possa alternar de HDs?
  12. Problema parcialmente resolvido, retirei todos os relacionamento e ao fazer a sincronização não foi reportado nenhum erro. Aprendendo RELACIONAMENTO.
  13. Boa noite a todos Sou iniciante em construção de banco de dados. Sou militar e estou desenvolvendo um banco de dado de cadastro de produto (termo geral)para seção em que trabalho. Dados das ferramentas que estou utilizando: mysql-5.5.11-win32; mysql-workbench-gpl-5.2.33b-win32 link da imagem do diagrama do banco de dados: http://i274.photobucket.com/albums/jj246/wicosi/Banco%20de%20dados/Diagramadobanco.png Realizei os relacionamentos do banco e ao sincronizar dá esse erro, abaixo: Executing SQL script in server ERROR: Error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') REFERENCES `bh-12-v10`.`correcoes_cartas` () ON DELETE NO ACTION ON UPDA' at line 3 ALTER TABLE `bh-12-v10`.`cartas` CHANGE COLUMN `idcartas` `idcartas` INT(11) NOT NULL AUTO_INCREMENT , ADD CONSTRAINT `idcorrecoes_cartas` FOREIGN KEY () REFERENCES `bh-12-v10`.`correcoes_cartas` () ON DELETE NO ACTION ON UPDATE NO ACTION , ADD INDEX `idcorrecoes_cartas` () SQL script execution finished: statements: 4 succeeded, 1 failed Com os dados acima, alguém teria uma solução?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!