×
Ir ao conteúdo
  • Cadastre-se

DJunqueira

Membro Pleno
  • Posts

    976
  • Cadastrado em

  • Última visita

  • Qualificações

    0%

Tudo que DJunqueira postou

  1. Essa fórmula funciona sem chaves: =SOMARPRODUTO(SEERRO((1/(C4:C18<>0))*(C4:C18);""))/CONT.SE(C4:C18;"<>0") fórum 7.xlsx
  2. excel 365: =MÉDIA(FILTRO(C4:C18;C4:C18<>0)) fórum 7.xlsx
  3. Gráficos bem legais p/ seu filho! Gráficos de desempenho escolar 2021.xlsx
  4. É só usar o conceito de tabela nomeada q suas fórmulas serão acrescentadas em toda nova linha. Vídeo introdutório: Formula acrescimo de linha.xlsx
  5. Experimente colocar: =SEERRO(fórmula;" ")
  6. Ficar nomeando colunas inteiras dá muito trabalho e piora o desempenho das fórmulas q tem de procurar dados por mais de 1 milhão de linhas, o ideal é trabalhar com tabelas nomeadas e suas colunas já identificadas. Procure manter duas ou três colunas entre as tabelas nomeadas se possível. Veja se o resultado está como desejado e dê retorno. estudo apostilas colorida.xlsx
  7. Na aba AT_Base Completa (1+2) eu deixei alguma fórmulas (contas) relacionadas ao q eu compreendi até agora do q você quer com sua planilha, veja se faz algum sentido p/ você tb p/ podermos ir avançando nos cálculos. Análise.xlsx
  8. Confesso q não compreendi a lógica da sua tabela.
  9. Tá ótimo, parabéns, essa mensagem é p/ acompanharmos o seu desenvolvimento com a planilha? Já se for p/ obter ajuda informe sua versão do Excel e anexe sua planilha.
  10. A pergunta q fica é, você foi bem no exame afinal?
  11. É, se você pensar nos espaços em branco q um arquivo texto pode ter e daí ser comprimido... Outro detalhe é q .csv e .txt é a mesma coisa praticamente, então teria algo errado escolher um deles como resposta única.
  12. No arquivo anexo há 3 formas populares de se filtrar uma tabela q está em uma aba em outra aba. Veja o arquivo e deixe sua breve opinião s/ qual é a melhor opção. MACRO x PQ x FILTER.zip
  13. Formas de estabelecer Data/Hora não volátil. https://chandoo.org/wp/timestamps-excel-formula-help/
  14. ActiveSheet.ListObjects("Table1").ListRows.Add AlwaysInsert:= True
  15. Mariana, se você quiser ajuda com sua macro você deve anexar uma planilha explicando com exemplo o objetivo q você quer atingir.
  16. P/ tirar espaços vazios uma boa ferramenta do Excel é o Power Query e p/ manipular dados xml o Exce tem a função FILTRARXML().
  17. Tá ótimo, mas se você coloca um problema muito específico a resposta vem de acordo. As vezes é interessante elaborar um pouco mais.
  18. Humberto, cuidado com o princípio do "garbage in, garbage out", uma mesma nota fiscal com datas diferentes??
  19. Uma forma muito rápida de resolver essa questão é remover duplicadas com o Power Query (ferramenta nativa no Excel desde a versão 2016, no 2010 e 2013 tem de adicionar) e depois habilitar a totalização na tabela nomeada. A outra seria utilizando a fórmula abaixo se você tiver o Excel 365. =SOMARPRODUTO(ÚNICO(Tabela1)*{0\0\1}) Mas talvez você pudesse evitar esse problema de importação com a função FILTROXML() ou pelo Power Query. Clube do Hardware.xlsx
  20. Me parece q você não está descrevendo bem o seu problema geral, seria o caso de você ter uma "tabela" banco de dados q você gostaria de segmentar por pessoa em abas particulares com os respectivos nomes? O Power Query (ferramenta do Excel pré instalado a partir do 2016, no 2010 e 2013 tem de instalar) pode fazer isso p/ você com relativa facilidade. Não ficou claro se você vai ficar separando e adicionado novos dados com frequência nas abas respectivas. Eventualmente você pode postar a estrutura real da sua base de dados sem as informações sensíveis p/ q eu possa oferecer uma proposta. No nome, por exemplo, você pode deixar só as 3 primeiras letras e assim por diante.
  21. Se você compactar com .zip, nativo no Windows, mais pessoas poderão te ajudar. Veja como.
  22. Transfere dados e acrescenta em outra tabela em outra aba como você quer sem usar VBA, tudo isso usando Power Query. P/ você q é iniciante no Excel o Power Query é uma ferramenta interessante p/ pesquisar. Se for insistir em macro procure utilizar Range("B3:D3").Copy, melhor q Array. Livro1.xlsx
  23. Fiz algumas correções na sua planilha, especialmente na consolidação das médias mensais. Fórum (1).xlsx
  24. Hehe, não tem VBA!
  25. Na planilha anexa há 4 formas de você consolidar os dados. Criando uma tabela nomeada e filtrando com Segmentação de Dados; Utilizando fórmulas de matriz do novo Excel 365 q se ajustam a nova entrada de dados de forma q você não precisa mais ajustar a quantidade de linhas q a fórmula tem de estar p/ consolidar os dados; Utilizando o Power Query (PwQ), ferramenta nativa do Excel a partir da versão 2016, na 2010 e 2013 tem de instalar, nesta solução é preciso clicar no botão Atualizar p/ refletir a entrada de novos dados; Utilizando Tabela Dinâmica, tb precisa clicar no botão de Atualizar, mas é bem fácil de montar. 4 formas de consolidar dados.xlsx

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Curso de Hacker Ético

LANÇAMENTO!

CLIQUE AQUI E CONFIRA!

* Este curso não é ministrado pela equipe do Clube do Hardware.