Ir ao conteúdo
  • Cadastre-se

Vengefull

Membros Plenos
  • Total de itens

    29
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

26

Informações gerais

  • Cidade e Estado
    Curitiba/PR
  • Sexo
    Masculino
  1. eu queria os dois manualmente e aleatório para ver como se comporta obrigado pela resposta
  2. Boa noite, estou querendo criar um desdobramento aqueles com experiência no assunto poderia me ajudar ou melhorar esse código eu quero inserir 36 números de 1 a 60 depois escolher dos 36 9 e ele fazer o desdobramento de 9 com as 36 números como faria isso e com um contador de máximo que pode chegar de combinação. obrigado desde já Código:
  3. Boa tarde, muito obrigado pela ajuda e resposta eu tentei fazer algo como me disse porém ele só funciona com apenas o vetores_6[1,j] agora se tentar colocar os outros vetores que no caso seria 2,3,4,5 não funciona da erro de logica eu tentei fazer o mesmo para imprimir e nada to fazendo tudo errado olha as duas versões que fiz a que funciona e a que não funciona. estou confuso me ajude por favor o que funcionou ao testar seu código com seu exemplo algoritmo "Algoritmo exercicio Mega Sena " var vetor_60 :vetor [1..60] de inteiro vetor_6 :vetor [1..6] de inteiro vetores_6:vetor [1..10,1..6] de inteiro p,num,contador,k :inteiro //auxiliar para posicionar o vetor i,j,x,aux :inteiro //auxiliar para percorrer o vetor OK :logico //flag para verificar se a etapa foi realizada com sucesso excluir :inteiro //número a ser excluído do vetor aguardar:caracter //variável criada apenas para aguardar um ENTER na interação com o usuário Inicio MudaCor("Preto","Frente") --> caracter Azul MudaCor("Branco","Fundos") --> fundo branco //gera os 60 números do vetor inicial escreval("GERANDO OS 60 NÚMEROS INICIAIS...") para p de 1 ate 60 faca vetor_60[p]:=p fimpara escreval("Tecle Enter") leia(aguardar) escreval("NÚMEROS GERADOS COM SUCESSO!") //exibe os 60 números gerados escreval() escreval("Aqui estão os 60 números iniciais") p:=1 para i de 1 ate 10 faca //cada linha para j de 1 ate 6 faca //cada coluna escreva(vetor_60[p]:2," - ") p:=p+1 fimpara escreval//para pular para a linha de baixo fimpara escreval //sortear 6 aleatórios escreval("Vamos Escolher Aleatoriamente Os Primeiros 6 Números Dos 60") para i de 1 ate 6 faca //serão 6 números repita //repite se precisar ok:=VERDADEIRO p:=Randi(60)+1 //gera um número aleatorio se vetor_60[p]=0 ENTAO //se numero foi deletado ok:=FALSO fimSe para j de 1 ate 6 faca se ok=VERDADEIRO ENTÃO //se o número não houver sido deletado se vetores_6[1,j] = vetor_60[p] ENTÃO//se no vetor já haver o numero gerado ok := falso//b recebe o valor 2 para repetir e escolher outro numero interrompa fimSe fimSe fimPara se ok = verdadeiro ENTÃO vetores_6[1,i]:=vetor_60[p] //armazena o numero gerado fimSe ate ok fimPara escreval("Os Primeiros 6 Números Foram Gerados Com Sucesso") escreval //escrevando os primeiros números gerados aleatórios escreval("Aqui Estão Os primeiros 6 Números Gerados Aleatórios") p:=1 para i de 1 ate 1 faca para j de 1 ate 6 faca escreva(vetores_6[1,p]," - ") p := p+1 fimpara escreval//para pular para a linha de baixo fimpara fimalgoritmo e esse outro código foi tentando colocar para os 10 vetores que da erro algoritmo "Algoritmo exercicio Mega Sena " var vetor_60 :vetor [1..60] de inteiro vetor_6 :vetor [1..6] de inteiro vetores_6:vetor [1..10,1..6] de inteiro p,num,contador,k :inteiro //auxiliar para posicionar o vetor i,j,x,aux :inteiro //auxiliar para percorrer o vetor OK :logico //flag para verificar se a etapa foi realizada com sucesso excluir :inteiro //número a ser excluído do vetor aguardar:caracter //variável criada apenas para aguardar um ENTER na interação com o usuário Inicio MudaCor("Preto","Frente") --> caracter Azul MudaCor("Branco","Fundos") --> fundo branco //gera os 60 números do vetor inicial escreval("GERANDO OS 60 NÚMEROS INICIAIS...") para p de 1 ate 60 faca vetor_60[p]:=p fimpara escreval("Tecle Enter") leia(aguardar) escreval("NÚMEROS GERADOS COM SUCESSO!") //exibe os 60 números gerados escreval() escreval("Aqui estão os 60 números iniciais") p:=1 para i de 1 ate 10 faca //cada linha para j de 1 ate 6 faca //cada coluna escreva(vetor_60[p]:2," - ") p:=p+1 fimpara escreval//para pular para a linha de baixo fimpara //sortear 6 aleatórios escreval("Vamos Escolher Aleatoriamente Os Primeiros 6 Números Dos 60") para i de 1 ate 6 faca //serão 6 números repita //repite se precisar ok:=VERDADEIRO p:=Randi(60)+1 //gera um número aleatorio se vetor_60[p]=0 ENTAO //se numero foi deletado ok:=FALSO fimSe para j de 1 ate 6 faca se ok=VERDADEIRO ENTÃO //se o número não houver sido deletado se vetores_6[1,2,3,4,5,6,7,8,9,10,j] = vetor_60[p] ENTÃO//se no vetor já haver o numero gerado ok := falso//b recebe o valor 2 para repetir e escolher outro numero interrompa fimSe fimSe fimPara se ok = verdadeiro ENTÃO vetores_6[1,2,3,4,5,6,7,8,9,10,i]:=vetor_60[p] //armazena o numero gerado fimSe ate ok fimPara escreval("Os Primeiros 6 Números Foram Gerados Com Sucesso") //escrevando os primeiros números gerados aleatórios escreval("Aqui Estão Os primeiros 6 Números Gerados Aleatórios") p:=1 para i de 1 ate 1 faca para j de 1 ate 6 faca escreva(vetores_6[1,2,3,4,5,6,7,8,9,10,p]," - ") p := p+1 fimpara escreval//para pular para a linha de baixo fimpara para i de 1 ate 6 faca //pegando 6 numeros repita ok:=falso escreva("Digite o",i,"º numero ") leia(num) // pega um número para j de 1 ate 6 faca se vetores_6[1,2,3,4,5,6,7,8,9,10,j] = num ENTÃO ok:=verdadeiro escreval("Você Já Inseriu Esse Número") interrompa fimse fimpara ate ok = falso vetores_6[1,2,3,4,5,6,7,8,9,10,i] := num fimpara //verificação de acertos entre os vetores contador:=0 para j de 1 ate 6 faca para k de 1 ate 6 faca se vetores_6[1,2,3,4,5,6,7,8,9,10,j] = vetor_6[k] ENTÃO contador := contador + 1 interrompa fimse fimpara fimpara escreval("Caro usuário Você Acertou ",contador," Números . . . !")// mostra quantos acertos fimalgoritmo
  4. Boa tarde tentei fazer não consegui e me perdi totalmente na lógica por que mudou totalmente o código olha como ficou da erro de fimalgoritmo sendo que no final esta colocado coloquei as variáveis e nada Código:
  5. Boa noite, obrigado pela ajuda e resposta teria alguns exemplos desses dois para um dentro do outro em VisualG e C++ ? realmente o que eu tava buscando era isso que você disse limpa bastante o código mais a duvida e como fazer, voltei as aulas hoje, e quero começar o C/C++ mais trabalhando nessa mesma ideia depois partir para coisa mais grandes como sockets,servidor cliente, entre outras linguagem como Java e C# e minha concentração e no que disse aprender a organizar o código para que fique mais limpo e legível aprender esses macete me ajude com exemplos desse dois para dentro um do outro em visualG e em C++ e se possível exemplos de como guardar em modo texto realmente não tenho cabeça ainda para criar isso sou iniciante apenas adaptei algumas funçoes desse codigo para fazer da forma que queria. obrigado pela ajuda.
  6. Boa tarde, estou querendo converter todo esse código escrito em Visualg para o C++. Alguém experiente poderia me ajudar? quero deixar da forma que está . Meu motivo para migrar para o C++ é para apenas estudos e também para aprendizado da linguagem, porém acho que só da para fazer no C++. Eu quero salvar toda operação quando o programa terminar a execução em modo texto, depois que salvar os números gerado em modo texto ter uma opção para abrir novamente o arquivo txt e ter a opção de fazer o analise de acertos novamente e salvar em txt de novo. Não sei como fazer isso nem ideia salvar texto, abrir texto, fazer analise dos acertos. Código:
  7. Boa tarde, aquele que já tem experiencia como faço para liberar mais user no meu banco de dados resumindo liberar conexão sei que se não me engano o máximo é 65535 e pra aproveita o post para não flood como faço para deixa o sqlserver para fazer backup automatico a cada 15 dias e salvar em um hd direcionada a cada 15 dias?
  8. Boa noite, obrigado pelas reposta, vou ter que comprar esse roteador então mais como irei fazer isso tem algum manual para estudo ou algo parecido ? agradeço desde já obrigado.
  9. Boa noite aqueles mais experiente no assunto eu preciso de ajuda, como faço para dividir minha internet para o meu servidor local quero deixar 50 megas pro servidor e 10 mega para meu computador que uso para estudos é possível fazer isso ? eu me lembro que ouvi dizer que isso existe mais não sei como se é possível agradeço desde já obrigado.
  10. Obrigado pela reposta, mais consegui identificar como foi feito , foi escrito em c++ com win32 api , onde posso conseguir todos códigos do win32 api para montagem de tela as instrução e sua funcionalidade sobre o servidor sim quero apenas para estudos sera escrito todo em c++ e o db em mssql server e por fim quando terminar todo esse estudos vou iniciar meus estudos em java,c#,c,html,xml,php,mysql,assembly e por fim engenharia reversa e reengenharia quero poder futuramente ajuda grande e pequenas empresas que não tem suporte para sistema etc , não isso é violência é apenas interesse em aprender e buscar conhecimentos !
  11. Boa tarde, estou aqui para pedir algumas informações de como construir uma tela parecidas com essas pois estou querendo montar um servidor apenas para estudos e aperfeiçoamento em sockets pois sou iniciante e estou querendo aprender o c++ atualmente estudo o visualg e vou partir agora pro c++ alguém poderia me ajudar nesse estudo não tenho conhecimento suficiente mais quero partir pra coisas mais complexas e uma duvida nessa imagem que linguagem e escrita dentro da tela ? linguagem script ou de maquina? olha a imagem https://imgur.com/iop2rWf
  12. Boa noite,Entendi muito obrigado @Simon Viegas apenas um descuido ao ler os exemplos obrigado @devair1010 uma boa noite.
  13. Boa noite, obrigado pela resposta e ajuda mais ainda não entendi e nem sai do lugar vou parar por aqui mesmo.
  14. Boa noite, obrigado pela resposta Sr @devair1010, mais não é desta forma, eu tentei imaginar, arrumar uma maneira não conseguir pensar mais eu acho que eu errei na explicação ao tentar expressar a maneira que eu queria então , fiz uma representação simples com imagem observe que aqui foi adicionado mais 2 vetores de 20 posições resumindo repetiu 2 vez ao invés dele imprimir um embaixo do outro, imprimir um do lado do outro Imagem original Imagem modificada de como eu queria não consegui pensar uma maneira sei que é possível Duvida: Visualg da para salvar arquivos em texto e abrir arquivos texto ? Obrigado desde já pela ajuda um grande abraço.
  15. Obrigado pelo exemplo @devair1010 voltei aos estudos e vou pegar um bom tempo firme testei seu exemplo e funcionou, só que ao repetir por exemplo o processo de imprimir 5 vezes em vez de ele imprimir um embaixo do outro imprimir um do lado do outro 5 para não perder digamos a massa ta tela. uma outra duvida é possível aumentar os números ou letras controlar os tamanhos ? Obrigado desde de já pela sua ajuda um grande abraço.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×