Ir ao conteúdo
  • Cadastre-se

Otonashi Oliveira

Membros Plenos
  • Total de itens

    20
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Obrigado Ciro-Mota, esses comandos realmente resolveram o meu problema, apesar de eu ter encontrado outra solução tb (Aviso, a mensagem abaixo eu ja tinha escrevido antes do Ciro-mota ter apresentado sua solução e que eu quis esperar um pouco mais pra dar essa resposta, mas vou deixar da forma original para que outras pessoas possam ter uma segunda opção de solução) "CONSEGUI RESOLVER! pena que eu nao sabia fazer isso antes, pois acabei perdendo muitos arquivos quando tive o mesmo problema antes! Inicialmente quando eu compactei os arquivos o pendrive nao suportava o dobro dos mesmos arquivos (pois o pendrive nao aguenta muito espaço). Por isso fiz da seguinte forma: Copiei o icone do pendrive que nem na imagem abaixo e colei na area de trabalho (nao pode pegar o arquivo do pendrive e jogar na area de trabalho, senao nao da certo). Vendo que os arquivos nao estavam na pasta que eu joguei na area de trabalho, eu compactei os arquivos e tudo na pasta, (que parecia nao ter nada) foi processado, até virar um arquivo .rar. Eu extrai o arquivo e mesmo assim nao apareceu nada. Entao eu abri o arquivo .rar e todos os arquivos sumidos estavam lá! Sabendo que extrair os arquivos nao apareciam nada, eu tive que manualmente pegar os arquivos dentro da pasta .rar e jogar na area de trabalho, "somente assim deu certo!" Isso serve de conhecimento para que outras pessoas nao passem o mesmo problema que o meu e formatem o pendrive que nem ja fiz antes num caso muito parecido com esse perdendo-se assim os arquivos Enfim, Muito obrigado, gostei mais do metodo do Ciro Mota, pois é mais rápido adicionado 1 minuto depois Ciro Mota, você saberia explicar porque isso aconteceu? Se foi realmente o anti virus ou algum outro problema? preciso saber sobre isso para evitar esse tipo de problema novamente
  2. Eu tinha ido ontem na lan house para imprimir uma folha e pelo que parece peguei um virus no pendrive. Ao utilizar o pendrive em meu computador, o kaspersky parece que removeu todos os arquivos do pendrive, porém, ao colocar o pendrive na televisão todos os arquivos parecem estar dentro do pendrive e funcionando normalmente, somente no computador que ela nao aparece. Eu desabilitei o anti virus e mesmo assim os arquivos não aparecem quando eu retiro e coloco novamente o pendrive. Eu estou usando agora um método que nao sei se vai dar certo, mas que mesmo assim vou deixar aqui para que nao repitam o mesmo metodo nos comentarios abaixo que é do print que estarei deixando aqui. Eu apenas estarei compactando os arquivos para ver se eles aparecem compactados e assim eu poderei fazer o backup. Inicialmente os arquivos pareciam nao querer ser compactados, e por isso desabilitar o anti virus foi essencial para que os arquivos começassem a ser compactados. Até agora enquanto estou digitando eles estão sendo compactados e vai demorar um pouco para terminar. Mesmo que eu consiga da forma que estou tentando eu gostaria que vcs compartilhassem outros metodos que podem tentar recuperar esses arquivos "ocultos" (eu já habilitei a opção "mostrar arquivos ocultos" e mesmo assim nao aparece nada) para que caso eu nao consiga resolver com o metodo acima descrito, eu ja parta para outro metodo. (Caso eu consiga resolver com o método de compactação, estarei deixando avisado para que outras pessoas tb possam saber o que fazer nesse tipo de problema)
  3. Agradeço por todos os detalhes que ofereceu Concordo com você kkkkkkk, faz sentido.... perai, nao nao faz sentido kkkk
  4. Agradeço muito a ajuda prestada, vou anota-las e estuda-las. Só fiquei com uma duvida: Estaria certo tb se eu colocasse "inteira"?
  5. Devo começar dizendo que a forma que você explica as coisas de forma completa acaba abrindo a mente das pessoas, realmente agradeço por me motivar dessa forma Eu dei uma pesquisada sobre as coisas que você citou abaixo, e isso realmente ajudou-me a entender melhor o comando enquanto, apesar de eu achar que eu preciso estudar mais ainda para ficar uma coisa mais concreta Enfim, voltando ao exercicio Algoritmo "Exercicio" // Disciplina : [Linguagem e Lógica de Programação] // Professor : (curso online) e (clubedohardware) // Descrição : Desenvolva um algoritmo que peça ao usuário valores entre 100 e // 200, caso o usuário digite um valor fora deste limite, o sistema deve fechar //e exibir a mensagem (“valor fora do alcance”) // Autor(a) : Marcus // Data atual : 17/09/2018 Var valor :inteiro Inicio escreval ("digite um valor entre 100 e 200") leia (valor) enquanto (valor >= 100) e (valor <= 200) faca leia (valor) escreval ("valor fora do alcance") fimenquanto Fimalgoritmo Deu certo essa resolução, mas se eu por exemplo, digito 180 na primeira, e na segunda vez eu digito 180 novamente, ele acaba dizendo ("valor fora do alcance") sendo que eu acho que essa mensagem nao deveria aparecer nesse momento. Eu nao sei se isso esta certo, mas eu queria saber se tem como eu ficar digitando varias vezes por exemplo o 180 ou outro numero entre 100 e 200 sem que a mensagem ("valor fora do alcance") apareça. tipo assim, após apertar F9: 180 180 150 80 valor fora do alcance Apesar de nao ter ficado como eu queria, se eu digitar normalmente como o enunciado pede, parece ficar certinho, mas eu quero saber se tem como ficar do jeito acima citado
  6. Eu nao estou encontrando <> na barra de ferramentas da janela postar, você poderia tirar um print por favor? Pois eu usei <> que é aqui do teclado, mas fica dando erro do tipo "esperava um argumento do tipo logico", e nao estou conseguindo resolver esse problema
  7. Exercício: Desenvolva um algoritmo que peça ao usuário valores entre 100 e 200, caso o usuário digite um valor fora deste limite, o sistema deve fechar e exibir a mensagem ("valor fora do alcance"). var valor: inteiro inicio escreval ("digite um valor entre 100 e 200: ") leia(valor) enquanto valor < > 100 e 200 faca leia(valor) fimenquanto escreval("valor fora do alcance: " Estou tendo problema pra resolver a partir do comando Enquanto, que eu tento de várias formas chegar a solução, mas não encontro.
  8. Muito boa a pergunta Eu estou também iniciando na área da programação, ainda esta fazendo uma semana, e parece, pelos comentários, que eu estou indo pelo caminho certo
  9. Eu pesquisei o que era vetores e tentei corrigir do meu jeito. Eu acredito que a parte do comando Para até Fimpara esteja correto, só nao estou conseguindo corrigir a partir do comando Se até Fimse var v: vetor [1..5] de inteiro indice:inteiro inicio para indice de 1 ate 5 faca escreva ("digite um valor ", indice, " :") leia(v[indice]) fimpara se indice > 0 entao escreva ("valor positivo ") senao escreva ("valor negativo ") fimse
  10. Entao, o enunciado diz somente aquilo que pede na questão, eu nao sei exatamente se o que eu disse acima esta certo ou nao, principalmente por se tratar de um curso basico onde estou estudando o comando ''Para''. Eu vou estudar esses vetores que você disse, mas levando em questão que eu estou estudando o comando ''Para'', alem de ser somente um curso basico, você diria que essa resolução abaixo esta correta, baseando-se somente na questão? Pois acredito que essa questão seja bem simples, sem fugir muito do comando Para, pois se trata disso que eu estou estudando. Caso a resolução abaixo esteja no caminho certo, eu preciso entender como eu chego na resposta certa var valor, x :inteiro inicio escreval ("digite um valor positivo") leia(valor) se (valor > 0) entao escreval ("valor positivo") senao escreval ("valor negativo") fimse
  11. Entao, eu fiz assim: var valor, x :inteiro inicio escreval ("digite um valor positivo") leia(valor) se (valor > 0) entao escreval ("valor positivo") senao escreval ("valor negativo") fimse Mas eu percebi que não é assim que a questão quer que você faça. Ele esta pedindo para que o programa receba 5 numeros, ou seja, quando eu apertar f9 eu tenho que informar cinco numeros e nao só um que nem ficou esse algoritmo acima. Por isso eu tentei desse jeito aqui var valor1: inteiro valor2: inteiro valor3: inteiro valor4: inteiro valor5: inteiro inicio escreval ("digite primeiro valor") leia(valor1) escreval ("digite segundo valor") leia(valor2) escreval ("digite terceiro valor") leia(valor3) escreval ("digite quarto valor") leia(valor4) escreval ("digite quinto valor") leia(valor5) se (valor 1 ate 5 > 0) entao escreval ("valor positivo") senao escreval ("valor negativo") fimse Mas alguma coisa nao esta dando certo
  12. Ainda nao. O curso que estou fazendo é bem basico mesmo adicionado 14 minutos depois Eu fiz aqui só nao estou conseguindo fazer o que você disse ''E somente imprimir se a condição for válida''. Qual é o comando que faz isso que você disse para eu tentar aqui?
  13. Eu estou fazendo um curso gratis na internet e nao tenho ninguem para tirar minhas duvidas, por isso estou contando com você leitor para me ajudar a corrigir e chegar na resposta certa das questões que estou fazendo Questão: Elabore um programa que receba 5 números e imprima somente os positivos. Eu consegui fazer isso abaixo e pelo que parece, depois de eu apertar f9, surgiu algum resultado, mas nao sei se esta correto a forma que eu fiz. Por isso me diga se eu fiz certo ou nao var valor, x :inteiro inicio escreval ("digite um valor positivo") leia(valor) para x de 0 ate 5 faca escreva (valor + x) fimpara Eu gostaria de saber tambem como seria caso ao invés de ele falar, ''imprima somente os positivos'' ele falasse ''imprima os negativos". Eu teria que mudar somente o sinal (+) para (-)? Enfim, obrigado pela atenção e paciencia
  14. Oi Agradeço a atenção dada a um iniciante nesse curso que estou fazendo. Entao, eu estou fazendo esse e mais dois exercicios para eu ir pro proximo estudo que é o comando Enquanto, sendo que só esse que você citou, o Repita, acho que nao tem no curso gratis que estou fazendo Mas vou deixar essas duas questões que você citou acima anotadas no caderno aqui pra mais pra frente eu tentar resolve-las depois de estudar o assunto agradeço a ajuda

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...