Ir ao conteúdo
  • Cadastre-se

Sylvano DA Silva

Membros Juniores
  • Total de itens

    2
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. // Data atual : 30/10/2017 Var // Seção de Declarações das variáveis nomes : vetor [1..3] de caracter notas : vetor [1..2] de inteiro i,a1,a2,a3,c1,c2,c3: inteiro s1,s2,s3 : real Inicio //recebe o nome dos alunos para i<-1 ate 3 faca escreval("Digite o nome do aluno",i) leia(nomes[i]) fimpara //for para pegar o aluno 1 e setar as notas para a1<-1 ate 2 faca escreval("Digite a nota ",a1," do aluno ",nomes[1]) //armazena a nota no vetor leia(notas[a1]) //calcula a media aluno 1 c1<-c1+notas[a1] s1 <-c1/2 fimpara //imprime escreval("Média:",s1) //for para pegar o aluno 2 e setar as notas para a2<-1 ate 2 faca escreval("Digite a nota ",a2," do aluno ",nomes[2]) leia(notas[a2]) //calcula a media aluno 2 c2<-c2+notas[a2] s2 <-c2/2 fimpara //imprime escreval("Média:",s2) //for para pegar o aluno 3 e setar as notas para a3<-1 ate 2 faca escreval("Digite a nota ",a3," do aluno ",nomes[3]) leia(notas[a3]) //calcula a media aluno 3 c3<-c1+notas[a3] s3 <-c3/2 fimpara //imprime escreval("Média:",s3) Fimalgoritmo Fiz com 2 notas é só alterar o tamanho do vetor e o calculo da media
  2. Resolvi o meu dessa forma: Var // Seção de Declarações das variáveis nome : caracter nota : vetor [1..3] de real i,y : real media,mf :real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite o nome do aluno:") leia(nome) //repetiçao pegando as notas e colocando no vetor para i <- 1 ate 3 faca escreval("Digite a nota",i) leia(nota[i]) fimpara //calcula as notas do vetor para y <- 1 ate 3 faca media <- media+nota[y] fimpara //calcula a média mf <- media/3 //faz a condiçao se mf >= 60 então //imprime escreva("Aluno ",nome," ficou com média ",mf," foi Aprovado!") //faz segunda condição senao se mf < 60 então //imprime escreva("Aluno ",nome," ficou com média ",mf," foi Reprovado!") fimse Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!