Ir ao conteúdo
  • Cadastre-se

Hiago_h3

Membros Juniores
  • Total de itens

    8
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Var // Seção de Declarações das variáveis idade, i: inteiro peso, acm1, acm2, mediapeso,mediaidade: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para i de 1 ate 127 faca escreval ("Insira sua idade:") leia (idade) enquanto (idade<=0) faca escreval ("Idade Invalida.") escreval ("Insira sua idade:") leia (idade) fimenquanto escreval ("Insira seu peso:") leia (peso) enquanto (peso<=0) faca escreval("Peso invalido.") escreval ("Insira seu peso:") leia (peso) fimenquanto se (peso>=50) e (peso<=70) entao acm1<- (acm1+peso) senao se (idade>=10) e (idade<=14) e (peso>70) entao acm2<-(acm2+1) fimse fimse fimpara mediapeso<- (acm1/127) mediaidade<- (acm2/127)*100 escreval ("A média da idade das pessoas que estão com peso entre 50kg e 70kg é:", mediapeso) escreval ("Porcentagem de pessoas com idade entre 10 e 14 anos que estão com peso acima de de 70kg é:", mediaidade, "%") Fimalgoritmo @Simon Viegas @Ricardov Depois de muito pesquisar e quebrar a cabeça consegui fazer esse código. O que acham?
  2. @Simon Viegas algoritmo "FCdH" var idade :inteiro i: inteiro mediaIdade :real inicio para i de 1 ate 5 faca escreval ("Insira sua idade:") leia (idade) fimPara Escreval ("A media de idades é:", idade/5) fimAlgoritmo Só não sei se fiz 100% correto, pois não achei onde usar a variavél "mediaIdade" que você colocou aí.
  3. @Ricardov Var // Seção de Declarações das variáveis idade, i: inteiro peso: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para i<-1 ate 127 faca escreval ("Insira sua idade:") leia (idade) escreval ("Insira seu peso:") leia (peso) fimpara Fimalgoritmo
  4. @Simon Viegas @Ricardov eu estou perdido de como farei para o código fazer a media de pessoas entre tal peso e idade.
  5. Faça um algoritmo que receba informações de 127 pessoas que serão informadas pelo usuário, que são: idade e o peso. Estas informações devem ser validadas para não aceitar valores inválidos. Após isso, o algoritmo deverá calcular e exibir: a) A media da idade das pessoas que estão com peso entre 50 e 70kg; b) O percentual de pessoas cuja idade está entre 10 e 14 anos e cujo peso está acima de 70kg. Me ajudem, por favor. Não estou conseguindo fazer o codigo para a questão A e nem a B. Também não sei como validar. Desde já obrigado!
  6. @BillyMao as peças são essas: Memoria ram: Memória Kingston 8gb 1866mhz Hyperx Fury Ddr3 placa-mãe: placa-mãe Lga 1156 Foxconn H55 adicionado 2 minutos depois @Math.Pi Memoria ram: Memória Kingston 8gb 1866mhz Hyperx Fury Ddr3 placa-mãe: placa-mãe Lga 1156 Foxconn H55 Processador: Intel core i5 1°geração adicionado 3 minutos depois @Sidiyo também é ddr3
  7. @Math.Pi O modelo da memoria é ddr3, inclusive ela aparece na na bios.
  8. Bom dia. Alguns dias atrás estava montando um PC, comprei todas as peças e montei o pc. Ao ligar para formatar ele dava uma tela preta com um traço piscando, achei que fosse problema com a placa-mãe. Testei todas as peças em um pc de um amigo e todas funcionaram de boa. Depois desse erro persistir, resolvi levar em um técnico antes de devolver qualquer peça, para ter certeza em qual peça era o problema. Ele constatou que o problema era que a placa-mãe não suportava a memoria ram, ele colocou uma memoria de GB menor e a maquina funcionou. Eis a minha duvida, a placa-mãe que comprei o máximo suportado por ela são 8gb e a memoria que comprei é de 8gb também. Por que não funcionou? Será que pode ser por causa da velocidade da memoria que é de 1866mhz e o suportado pela placa-mãe é de 1600mhz? Entrei em contato com o vendedor da placa-mãe e ele disse que ela só funciona sendo 2x4gb, e isso é possível? Uma placa-mãe tendo sua capacidade maxima de 8gb, não teria que funcionar independe de ser 1x8gb ou 2x4gb?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...