Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Lucas Da Silva Aleixo

Membros Plenos
  • Total de itens

    33
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Qual seria a diferença entre o SQL e o SQL Server? O SQL seria a linguagem e o SQL Server a "IDE"?
  2. Gostaria de saber se é possível salvar a saída de um algoritmo em um arquivo (.txt)? EXEMPLO: - ALGORITMO algoritmo "semnome" var x :inteiro inicio escreva("Digite um valor: ") leia(x) escreval(x) fimalgoritmo - SAÍDA Digite um valor: 1 1 Teria como salvar a saída em um arquivo (.txt)?
  3. Preciso de um algoritmo que escreva o vetor em ordem crescente e caso possível impedir que sejam gerados vetores iguais. Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 11/07/2018 // Seção de Declarações var n :vetor [1..6] de inteiro x :inteiro inicio para x de 1 ate 10 faca n[1] := randi(60) n[2] := randi(60) n[3] := randi(60) n[4] := randi(60) n[5] := randi(60) n[6] := randi(60) enquanto (n[1] = 0) ou (n[2] = 0) ou (n[3] = 0) ou (n[4] = 0) ou (n[5] = 0) ou (n[6] = 0) ou (n[1] = n[2]) ou (n[1] = n[3]) ou (n[1] = n[4]) ou (n[1] = n[5]) ou (n[1] = n[6]) ou (n[2] = n[1]) ou (n[2] = n[3]) ou (n[2] = n[4]) ou (n[2] = n[5]) ou (n[2] = n[6]) ou (n[3] = n[1]) ou (n[3] = n[2]) ou (n[3] = n[4]) ou (n[3] = n[5]) ou (n[3] = n[6]) ou (n[4] = n[1]) ou (n[4] = n[2]) ou (n[4] = n[3]) ou (n[4] = n[5]) ou (n[4] = n[6]) ou (n[5] = n[1]) ou (n[5] = n[2]) ou (n[5] = n[3]) ou (n[5] = n[4]) ou (n[5] = n[6]) ou (n[6] = n[1]) ou (n[6] = n[2]) ou (n[6] = n[3]) ou (n[6] = n[4]) ou (n[6] = n[5]) faca n[1] := randi(60) n[2] := randi(60) n[3] := randi(60) n[4] := randi(60) n[5] := randi(60) n[6] := randi(60) fimenquanto escreval(x, ".", n[1], " - ", n[2], " - ", n[3], " - ", n[4], " - ",n[5], " - ", n[6]) escreval("") fimpara fimalgoritmo O QUE JÁ CONSEGUI FAZER: - Impedir que o número gerado seja 0. - Impedir que os números no mesmo vetor se repitam. O QUE GOSTARIA DE FAZER: - Escrever o vetor gerado em ordem crescente. - Caso possível: Impedir que sejam gerados vetores iguais. Exemplificando: - Vetor Gerado: n[1] = 34 n[2] = 23 n[3] = 2 n[4] = 54 n[5] = 53 n[6] = 25 Saída: 1. 34 - 23 - 2 - 54 - 53 - 25 Como gostaria: 1. 2 - 23 - 25 - 34 - 53 - 54 E caso possível fazer com que os vetores gerados não se repitam. Se puderem ajudar agradeço.
  4. Funcionou, apenas fiz algumas alterações na fórmula: Exercício 5: salario_bruto <- (valor * horas) salario <- ((filhos * 0.03 * salario_bruto) + salario_bruto) Exercício 6: salario_total <- ((percentual * total_vendas * salario_fixo) + salario_fixo) Fiz a conta antes e deu o mesmo valor. Obrigado.
  5. A parte que eu não tenho certeza se está correto são as partes da fórmula: Veja: Exercício 5: salario_bruto <- (valor * horas) salario <- ((3 * filhos / 100) + salario_bruto) Exercício 6: salario <- ((percentual * total_vendas / 100) + salario_fixo) Queria saber se estas duas fórmulas estão corretas ou incorretas.
  6. 5- Escrever um algoritmo que lê o nome de um funcionário, o número de horas trabalhadas, o valor que recebe por hora e o número de filhos. Com estas informações, calcular o salário deste funcionário, sabendo que para cada filho, o funcionário recebe 3% a mais, calculado sobre o salário bruto. algoritmo "Exercício 5" // Função : Calcular o salário de um funcionário que recebe 3% a mais por filho calculado sobre o salário bruto. // Autor : // Data : 08/07/2018 // Seção de Declarações var nome :caractere horas, filhos :inteiro valor, salario_bruto, salario :real inicio escreva("Digite seu nome: ") leia(nome) escreval("") escreva("Digite o número de horas trabalhadas: ") leia(horas) escreval("") escreva("Digite o valor que recebe por hora: ") leia(valor) escreval("") escreva("Digite quantos filhos você tem: ") leia(filhos) escreval("") salario_bruto <- (valor * horas) salario <- ((3 * filhos / 100) + salario_bruto) escreva("Sálario do ", nome, ": R$", salario) fimalgoritmo 6- Escrever um algoritmo que lê o nome de um vendedor, o seu salário fixo, o total de vendas por ele efetuadas e o percentual que ganha sobre o total de vendas. Calcular o salário total do vendedor. Escrever o número do vendedor e seu salário total. algoritmo "Exercício 6" // Função : Calcular o salário de um vendedor. // Autor : // Data : 08/07/2018 // Seção de Declarações var nome :caractere total_vendas :inteiro salario_fixo, percentual, salario :real inicio escreva("Digite seu nome: ") leia(nome) escreval("") escreva("Digite seu salário fixo: ") leia(salario_fixo) escreval("") escreva("Digite o total de vendas efetuadas: ") leia(total_vendas) escreval("") escreva("Digite o percentual sobre o total de vendas: ") leia(percentual) escreval("") salario <- ((percentual * total_vendas / 100) + salario_fixo) escreval("Salário do vendedor ", nome, ": R$", salario) fimalgoritmo Desde já agradeço.
  7. Qual Script em Bat para apagar pasta e seus arquivos? EX: Eu quero apagar essa pasta "C:\Users\User\Desktop\Pasta", quero apagar a pasta em negrito e todo seu conteúdo. Como faço isso?
  8. Preciso de um script em bat que verifique se uma pasta está vazia. Obrigado desde já!
  9. É não deu certo, mas obrigado, vou continuar procurando.
  10. É, fiz isso mas não resolveu. Nem com o solucionador de compatibilidade do Windows resolveu. Alguma outra ideia?
  11. Estava reparando agora que quando eu coloco no gerenciador de tarefas e clico em processos, o Java não aparece mais, será por isso?
  12. Overkill Xbr Não mexi em nenhuma configuração do Java, e a quantidade de RAM que ele está consumindo está normal.
  13. Comprei o Minecraft Original, instalei tudo certo mas ao entrar dá esse erro: Configurações do meu PC: Processador: Intel(R) Core(TM) 2 CPU 6600 @2.40 GHz 2.39z Memória Instalada (RAM): 4,00 GB (utilizável: 3,25 GB) Tipo De Sistema: Sistema Operacional de 32 Bits Sistema Operacional (SO): Windows 7 Home Premium Coisas que já tentei para resolver o problema: . Atualizar o Java . Reinstalar o Minecraft . Reinstalar o Java . Reparar o Minecraft . Executar como administrador . Executar em modo de compatibilidade Windows 7 . Desativar temas visuais . Verificar se algum driver estava desatualizado . Verificar se algum programa que eu tinha era incompatível . Verificar se meu PC tinha as configurações mínimas . Testar se com o launcher antigo funcionava Mas nada disso deu certo, se puderem me ajudar agradeço. OBS: Não tenho Mods nem nada instalado, acabei de comprar e instalar.
  14. Enunciado: 9- Dados um capital, uma taxa de juros (em porcentagem) mensal e um período em meses, informe o montante ao final de cada mês. O programa deve funcionar como a seguir: Juros: 10% Capital: 100.00 Período: 3 1o mês R$ 110,00 2o mês R$ 121,00 3o mês R$ 133,10 Minha Resposta: algoritmo "Exercício 9 - Para" // Função : Este programa pede para o usuário informar a taxa de juros, o capital, o período e ao final é exibido o montante ao final de cada mês. // Autor : // Data : 01/04/2018 // Seção de Declarações var m, p, i :real x, n :inteiro inicio escreva("Informe a taxa de juros(%): ") leia(i) escreva("Informe o capital: ") leia(p) escreva("Informe o período: ") leia(n) escreval() i := (i / 100) para x de 1 ate n faca n := (n + 1) m := (p * (1 + i) ^ n) escreval(x, "° Mês: R$", m) fimpara fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×