Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

kadafimatatu

Membros Juniores
  • Total de itens

    12
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Olá pessoal, estou com dificuldades para resolver uma questão de C, se alguém pudesse dar uma sugestão ficaria muito grato. Segue a pergunta: (Integração com Retângulos) Faça um programa em C, para integrar a função F(X) = 2X^2 - 5e^2x - 12, onde e^2x é uma função exponencial Pela regra dos retângulos. Adote os seguintes limites de integração A = 1.45 e B=1.75. E considere a divisão deste intervalo [A, B] em N = 6 subintervalos de igual comprimento. Procure ver como se codifica a função exponencial em C. Procure ver como codificar X^2 em C. Construa um programa principal e um subprograma para calcular a função F(x).
  2. TAREFA T6 - Algoritmo para multiplicação de matrizes - Programar em C @cyer
  3. @cyer @AnsiC , vcs tem razão, eu acabei me confundindo, peço desculpas. O topico ja foi editado, realmente é linguagem C.
  4. Olá pessoal, estou com dificuldade para resolver uma questão de c, com matriz, e gostaria de saber se teria como algum me ajudar. Eu cheguei a montar um algoritmo, mas dá erro quando tento executar, segue a pergunta e o que eu consegui fazer: '' programa multiplica_matrizes; matriz mat1, mat2, mat3; inteiro linha, coluna, i, acumula; "leia mat1"; "leia mat2"; "verifique se mat1 é compativel com mat2"; para linha de 1 até "numero de linhas de mat1" faça para coluna de 1 até "numero de colunas de mat2" faça acumula=0; para i de 1 até "numero de colunas de mat1" faça acumula=acumula+mat1[linha]*mat2[coluna]; fimpara; mat3[linha][coluna]=acumula; fimpara; fimpara; imprima mat3; fim programa;'' #include <stdio.h> #include <stdlib.h> int main(){ int M[3][3]; int V[3]; int i,j; for(i=1; i<=3; i++) { for(j=1; j<=3; j++){ scanf("%d\n", M[i][j]); }; }; for(j=1; j<=3; j++) { V[j]=0; for(i=1; i<=3; i++) V[j] = V[j] + M[i][j]; }; for(j=1; j<=3; j++) printf("%d", V[j]); system("pause"); return 0; }
  5. Bem, é verdade eu acabei me confundindo, mas agradeço por apontar isso@Simon Viegas. Obrigado realmente por me ajudar, aprendi muito com suas sugestões e dicas. Acho que vou me tornar mais assíduo no fórum, vejo que a comunidade aqui é bem educada e disposta a ajudar. Qualquer coisa volto a publicar aqui nesse tópico, mas pode ter certeza que voltarei a criar outros hahaha.
  6. @Simon Viegas olá, com base no primeiro programa que fiz para uma turma com N aluno, eu escrevi um para M turmas, se pudesse gostaria que você desse uma olhada. Segue o algoritmo: Algoritmo "semnome" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro T: Inteiro contador: Inteiro soma: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF, NR: Real somaTurma, medTurma, medTurmas,somaTurmas: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... soma <- 0 Escreval("Informa o número de turmas: ") leia(T) enquanto (soma < T) faca soma <- soma + 1 contador <- 0 Escreval("Informe o número de alunos:") Leia(N) enquanto (contador < N) faca contador <- contador + 1 Escreval("Matrícula do aluno: ") leia(M) Escreval("Notas do aluno ", contador,":") ALEATORIO 2,8 Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) se (MF >= 9.0) e (MF <= 10.0) então Escreval("Aluno aprovado ") fimse se (MF >= 7.5) e (MF < 9.0) então Escreval("Aluno aprovado ") fimse se (MF >= 6.0) e (MF < 7.0) então Escreval("Aluno aprovado ") fimse se (MF >= 3.0) e (MF <= 6.0) então Escreval("Aluno em recupeção ") Escreval("Nota da recuperação: ") leia(NR) MF <- ((MP + NR) / 2) Escreval("Média final: ", MF) se (MF >= 0.0) e (MF < 6.0) então Escreval("Aluno reprovado") fimse fimse se (MF >= 0.0) e (MF <= 3.0) então Escreval("Aluno reprovado") fimse ALEATORIO OFF somaTurma <- (MF + somaTurma) medTurma <- (somaTurma / contador) fimenquanto escreval("A média da Turma ", soma," é: ", medTurma) somaTurmas <- (medTurma + somaTurmas) medTurmas <- (somaTurmas / soma) fimenquanto escreval("A média das Turmas é: ", medTurmas) Fimalgoritmo
  7. Peço desculpas, realmente não conseguir esclarecer as coisas. Na verdade são duas tarefas, no qual, a primeira consiste no que perguntei no tópico, e a outra diz respeito a uma evolução disso. Vou publicar aqui as duas tarefas na íntegra. Segue as tarefas: TAREFA PRÁTICA 1 (Variáveis Simples, Estrutras Lógicas de seleção e repetição) Considere a sua turma da disciplina de Introdução à Ciência da Computação que você faz parte. Use para os dados de entrada, para cada aluno: a sua matricula M (inteiro) e as notas das provas P1 (real) e P2 (real). Suponha que existam 5 tarefas práticas TP1, ...., TP5. Entre com as notas das tarefas práticas TP1, ... TP5. Para confirmar o que digitou, escreva as mensagens e as notas de entrada. Faça algoritmo que: a) Leia o número N de alunos da turma. N deve ser fornecido via teclado. Suponha um valor de N inteiro. O algoritmo deve verificar se o aluno foi aprovado ou reprovado. b) Considere a média aritmética ponderada das provas de cada aluno: MP = ( P1 + P2 )/2. Considere que a média das tarefas práticas é MT = (0.20*TP1 + ... + 0.20*TP5), supondo 5 tarefas práticas. A média final MF = (0.4*MP + 0.6*MT)/2.0. Se 9.0 <= MF <= 10.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 7.5 <= MF < 9.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 6.0 <= MF < 7.5, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escrva MF. Se 3.0 <= MF < 6.0 então o algoritmo deve escrever uma mensagem "ALUNO EM RECUPERAÇÂO". O aluno deverá fazer outra prova para recuperação, Obtendo uma nota NR. Entre com esta nota NR, e a nota final será calculada como MF = (MP + NR)/2. Se 0.0 <= MF < 6.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". Se 0.0 <= MF < 3.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". c) O algoritmo deve fornecer ao final, a média aritmética MEDFINAL das notas MF dos alunos da turma. Deve escrever a mensagem identificando a média da turma, "A MEDIA DA TURMA É = " . TAREFA PRÁTICA 2 (Variáveis Simples, Estrutras Lógicas de seleção e repetição) Continuação da TAREFA 1. (a) Inserir a programação dos conceitos e da média das notas MF da turma. (b) Considerar e programar para 3 turmas existentes, usando FLAG para turma e um FLAG para alunos processados. O último algoritmo que publiquei aqui, diz respeito à tarefa prática 2. Vou trabalhar com o que consegui até agora, e então vou publicar aqui, mas se tiveres uma sugestão em relação a isso, ficaria muito agradecido. Obrigado por tudo.
  8. obrigado de verdade pela sugestão, mas infelizmente eu ainda não cheguei nesse conteúdo e acredito que mesmo que eu faça com matriz meu professor deseja que essa tarefa seja feita com sistemas de repetição. Se tiver qualquer sugestão a mais ficaria agradecido.
  9. olá, agradeço de verdade por me ajudar. Na verdade eu acabei não esclarecendo, mas calcular esse processo para 3 turmas e posteriormente calcular a média total com a média dessas 3 turmas faz parte de uma continuação da primeira tarefa: Continuação da TAREFA 1. (a) Inserir a programação dos conceitos e da média das notas MF da turma. (b) Considerar e programar para 3 turmas existentes, usando FLAG para turma e um FLAG para alunos processados. Por isso fiz o questionamento sobre as 3 turmas. Peço desculpas por não ter dito antes, mas se fosse possivel, gostaria de uma ajuda, pois mais uma vez to batendo cabeça com isso rsrsrs. Sobre o que foi sugerido anteriormente: na verdade ja está inserido, pois há uma distinção entre os alunos que estão na faixa de 0.0<=MF<3.0 e os alunos que estão nessa faixa de 3.0<=MF<6.0. Sobre a continuação da TAREFA 1: Eu consegui escrever essas linhas, usando o comando repita, mas eu acabo caindo em uma especie de loop e ele nao reproduz a média de cada turma. Segue o que escrevi: Algoritmo "semnome" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro contador: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF, NR: Real somaTurma, medTurma: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... contador <- 0 Escreval("Informe o número de alunos:") Leia(N) enquanto (contador < N) faca Escreval("Matrícula do aluno: ") leia(M) Escreval("Notas do aluno ", M,":") Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) se (MF >= 9.0) e (MF <= 10.0) então Escreval("Aluno aprovado ") fimse se (MF >= 7.5) e (MF < 9.0) então Escreval("Aluno aprovado ") fimse se (MF >= 6.0) e (MF < 7.0) então Escreval("Aluno aprovado ") fimse se (MF >= 3.0) e (MF <= 6.0) então Escreval("Aluno em recupeção ") Escreval("Nota da recuperação: ") leia(NR) MF <- ((MP + NR) / 2) Escreval("Média final: ", MF) se (MF >= 0.0) e (MF < 6.0) então Escreval("Aluno reprovado") fimse fimse se (MF >= 0.0) e (MF <= 3.0) então Escreval("Aluno reprovado") fimse contador <- contador + 1 somaTurma <- (MF + somaTurma) medTurma <- (somaTurma / contador) fimenquanto escreval("A média da Turma é: ", medTurma) Fimalgoritmo Algoritmo "semnome" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro contador, soma: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF, NR: Real somaTurma, medTurma, medTurmas, numTurma, somaTurmas: Real resp: caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... contador <- 0 soma <- 0 Repita Escreval("Informa o número da turma:") leia(numTurma) Escreval("Informe o número de alunos:") Leia(N) enquanto (contador < N) faca Escreval("Matrícula do aluno: ") leia(M) Escreval("Notas do aluno ", M, ":") Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) se (MF >= 9.0) e (MF <= 10.0) então Escreval("Aluno aprovado ") fimse se (MF >= 7.5) e (MF < 9.0) então Escreval("Aluno aprovado ") fimse se (MF >= 6.0) e (MF < 7.0) então Escreval("Aluno aprovado ") fimse se (MF >= 3.0) e (MF <= 6.0) então Escreval("Aluno em recupeção ") Escreval("Nota da recuperação: ") leia(NR) MF <- ((MP + NR) / 2) Escreval("Média final: ", MF) se (MF >= 0.0) e (MF < 6.0) então Escreval("Aluno reprovado") fimse fimse se (MF >= 0.0) e (MF <= 3.0) então Escreval("Aluno reprovado") fimse contador <- contador + 1 somaTurma <- (MF + somaTurma) medTurma <- (somaTurma / contador) fimenquanto escreval("A média da Turma", numTurma, " é: ", medTurma) Escreva("Você deseja continuar? [S/N]: ") leia(resp) ate (resp = "N") soma <- soma + 1 somaTurmas <- (medTurma + somaTurmas) medTurmas <- (somaTumas / soma) Escreval("A média das Tumas é: ", medTurmas) Fimalgoritmo Aguardo sua resposta, e agradeço desde já.
  10. olá, agradeço muito pela sua ajuda de verdade, pude evoluir muito com suas dias e seu esboço e acredito que o programa está terminado. Gostaria que você avaliasse e desse alguma sugestão de algo a melhorar se necessário. Tenho apenas uma última pergunta, como eu faria isso para 3 Turmas distintas e usando o Flag? Segue o programa realizado: Algoritmo "Média de uma turma" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro contador: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF, NR: Real somaTurma, medTurma: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... contador <- 0 Escreval("Informe o número de alunos:") Leia(N) enquanto (contador <= N) faca Escreval("Matrícula do aluno: ") leia(M) ALEATORIO 3,10 Escreval("Notas do aluno: ", M) Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) ALEATORIO OFF MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) se (MF >= 9.0) e (MF <= 10.0) então Escreval("Aluno aprovado ") fimse se (MF >= 7.5) e (MF < 9.0) então Escreval("Aluno aprovado ") fimse se (MF >= 6.0) e (MF < 7.0) então Escreval("Aluno aprovado ") fimse se (MF >= 3.0) e (MF <= 6.0) então Escreval("Aluno em recupeção ") Escreval("Nota da recuperação: ") leia(NR) MF <- ((MP + NR) / 2) Escreval("Média final: ", MF) se (MF >= 0.0) e (MF < 6.0) então Escreval("Aluno reprovado") fimse fimse se (MF >= 0.0) e (MF <= 3.0) então Escreval("Aluno reprovado") fimse contador <- contador + 1 somaTurma <- (MF + somaTurma) medTurma <- (somaTurma / contador) fimenquanto escreval("A média da Turma é: ", medTurma) Fimalgoritmo Aguardo a resposta.
  11. nossa obrigado de verdade por me responder, e realmente foi de ajuda. Como dito, segue abaixo o que escrevi para as médias do aluno: Algoritmo "semnome" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreval("Informe o número de alunos:") Leia(N) ALEATORIO 4,10 Escreval("Notas do aluno 1: ") Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) ALEATORIO OFF MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) Fimalgoritmo bem, funcionou bem, se tiveres outra sugestão ficaria muito agradecido se compartilhasse . Agora vou escrever a parte dos "aluno provado ou reprovado". Aguardo sua resposta. adicionado 42 minutos depois Olá, eu consegui calcular as aprovações e reprovações do aluno, assim como, sua recuperação e com que tudo isso fosse escrito no CMD. Acredito que so falta fazer com que o programa faça isso pra uma turma de N aluno e que no final calcule a média da turma com N alunos e escreva essa nota no CMD. Bem a parte de fazer com uma turma inteiro com sistema de repetições é que me assusta mais, se pudesse me dar uma sugestão ficaria agradecito. Segue o que escrevi até agora: Algoritmo "semnome" Var // Seção de Declarações das variáveis N: Inteiro M: Inteiro P1, P2: Real TP1, TP2, TP3, TP4, TP5: Real MP, MT, MF, NR: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreval("Informe o número de alunos:") Leia(N) ALEATORIO 0,10 Escreval("Notas do aluno 1: ") Escreva("Prova 1: ") leia(P1) escreva("Prova 2: ") leia(P2) escreva("Tarefa prática 1: ") leia(TP1) escreva("Tarefa prática 2: ") leia(TP2) escreva("Tarefa prática 3: ") leia(TP3) escreva("Tarefa prática 4: ") leia(TP4) escreva("Tarefa prática 5: ") leia(TP5) ALEATORIO OFF MP <- ((P1 + P2) / 2) escreval("Média aritmética: ", MP) MT <- ((TP1 * 0.20) + (TP2 * 0.20) + (TP3 * 0.20) + (TP4 * 0.20) + (TP5 * 0.20)) escreval("Média das tarefas praticas: ", MT) MF <- ((MP * 0.40) + (MT * 0.60)) escreval("Média final: ", MF) se (MF >= 9.0) e (MF <= 10.0) então Escreval("Aluno aprovado ") fimse se (MF >= 7.5) e (MF < 9.0) então Escreval("Aluno aprovado ") fimse se (MF >= 6.0) e (MF < 7.0) então Escreval("Aluno aprovado ") fimse se (MF >= 3.0) e (MF <= 6.0) então Escreval("Aluno em recupeção ") Escreval("Nota da recuperação: ") leia(NR) MF <- ((MP + NR) / 2) se (MF >= 0.0) e (MF < 6.0) então Escreval("Aluno reprovado") fimse fimse se (MF >= 0.0) e (MF <= 3.0) então Escreval("Aluno reprovado") fimse Fimalgoritmo
  12. Olá pessoal, estou com bastante dificuldade em resolver uma questão, e gostaria de saber se alguém poderia me ajudar com isso. Consegui escrever algumas linhas de codigo, mas realmente nao sei como proceder com esse programa. Segue a pergunta: TAREFA PRÁTICA 2 (Variáveis Simples, Estrutras Lógicas de seleção e repetição) Considere a sua turma da disciplina de Introdução à Ciência da Computação que você faz parte. Use para os dados de entrada, para cada aluno: a sua matricula M (inteiro) e as notas das provas P1 (real) e P2 (real). Suponha que existam 5 tarefas práticas TP1, ...., TP5. Entre com as notas das tarefas práticas TP1, ... TP5. Para confirmar o que digitou, escreva as mensagens e as notas de entrada. Faça algoritmo que: a) Leia o número N de alunos da turma. N deve ser fornecido via teclado. Suponha um valor de N inteiro. O algoritmo deve verificar se o aluno foi aprovado ou reprovado. b) Considere a média aritmética ponderada das provas de cada aluno: MP = ( P1 + P2 )/2. Considere que a média das tarefas práticas é MT = (0.20*TP1 + ... + 0.20*TP5), supondo 5 tarefas práticas. A média final MF = (0.4*MP + 0.6*MT)/2.0. Se 9.0 <= MF <= 10.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 7.5 <= MF < 9.0, então, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escreva MF. Se 6.0 <= MF < 7.5, o algoritmo deve escrever uma mensagem "ALUNO APROVADO". Escrva MF. Se 3.0 <= MF < 6.0 então o algoritmo deve escrever uma mensagem "ALUNO EM RECUPERAÇÂO". O aluno deverá fazer outra prova para recuperação, Obtendo uma nota NR. Entre com esta nota NR, e a nota final será calculada como MF = (MP + NR)/2. Se 0.0 <= MF < 6.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". Se 0.0 <= MF < 3.0, então, o algoritmo deve escrever uma mensagem "ALUNO REPROVADO". c) O algoritmo deve fornecer ao final, a média aritmética MEDFINAL das notas MF dos alunos da turma. Deve escrever a mensagem identificando a média da turma, "A MEDIA DA TURMA É = " . Segue o que eu consegui escrever até agora: Var // Seção de Declarações das variáveis N: Inteiro p1, p2, TP1, TP2, TP3, MP, MT, MF, SomaMF: Real Flag: Real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... leia(N) leia(p1, p2, TP1, TP2, TP3) MP <- ((p1 + p2)/2) MT <- ((0.20 * TP1) + (0.20 * TP2) + (0.20 * TP3)) MF <- (((0.4 * MP) + (0.6 * MT)) / 2) Se (9 <= MF) escreval("Aluno conceito A ") fimse Se então escreval("Aluno conceito B ") fimse Fimalgoritmo Aguardo a resposta de alguém e agradeço desde já.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×