Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Niê

Membros Plenos
  • Total de itens

    126
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

54

Sobre Niê

  • Data de Nascimento 06-05-1998 (20 anos)

Informações gerais

  • Cidade e Estado
    Rio de Janeiro
  • Sexo
    Masculino

Outros

  • Ocupação
    Cursa Sistemas de Informação
  1. @Simon Viegas Consegui resolver, mas estou com outro problema, pode me ajudar? adicionado 20 minutos depois Esquece, consegui resolver hauahua!
  2. Mudo só o de quantidades, ou do restante também?
  3. @Simon Viegas Estou com um problema na parte de vender, fiz o código mas tentei diversas vezes acrescentar a opção de dar erro caso não tenha a quantidade de produtos o suficiente no estoque... Segue o código ENORME no primeiro spoiler. No segundo apenas a parte que estou com esse problema.
  4. @Simon Viegas Ah, mas quando eu for vender, já vai remover automaticamente. adicionado 6 minutos depois Eu posso deixar o estoque para Admins, adicionar um login e senha. Então, as vendas seriam para os vendedores e o estoque para os Administradores. Porém isso posso ver mais pra frente, já que agora quero criar apenas a parte de venda.
  5. Então, meu professor confirmou comigo que do jeito que está, ele gostou e achou até melhor. Foi ele quem fez o enunciado para mim mesmo. Deixarei assim. Isso também está encaminhado, sou vou mexer no que você disse, por na mesma linha. Já já mando aqui.
  6. Olá! Sempre usei Windows 7 pois gosto de jogar e me identifico mais com o mesmo. Há meses estou cursando Sistemas de Informação, e isso me faz ter muito contato com programação, continuo usando Windows, mas estou afim de me aprofundar e utilizar linux para aprender mais sobre, e também conciliar com a programação. Pergunta: Qual é o melhor SO para programação e que seja bem aberto para eu modificar e fazer o que quiser?
  7. @MyNameIsMech Me recomenda qual Linux para programação?
  8. @Simon Viegas Entendi o que você explicou agora. Sanou metade da minha dúvida. Explicando a minha dúvida: Isso me confundiu na hora de criar o código, porque na minha cabeça o coditem funcionava para ficar ao lado da variavel do vetor, para acompanhar o valor do coditem com a variável. Entendeu? Entendi o que é o certo, e que eu pensei errado kkkk. coditem serve como controlador! Na minha cabeça servia para apenas guardar as posições e comparar com a variável do vetor. adicionado 4 minutos depois Agora vejo que não faz sentido. Quanto a isso: O que acha melhor? No código né, afinal vou utilizar os produtos que irei cadastrar no estoque...
  9. Entendi que icod é igual a posição do vetor, mas não entendi porque usar entre colchetes ao invés do codItem (que estava dando erro).
  10. algoritmo "ESTOQUE" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Estoque // Cadastro de item no estoque // Descrição / Quantidade / Preço de custo / Preço de venda // Cadastro de combo promocional // Descrição / Quantidade / Preço de custo / Preço de venda // Retirar item do estoque // Retira quantidade do item selecionado // Relatório de itens no estoque. // Todos os itens var //dados do produto (cada vetor é um atributo) descricoes :vetor [1..4] de caractere quantidades :vetor [1..4] de inteiro precosCustos:vetor [1..4] de real precosVendas:vetor [1..4] de real //Vetores do estoque codItem :inteiro //código do produto (gerado em sequência) opc,opc2 :caractere //usado para selecionar opções fimcad :real //usado para acompanhar a exibição do ultimo cadastro icod :inteiro //usado para ler o código do menu editar remov :inteiro //usado para recadastrar a quantidade de itens j :inteiro //usado como pombo correio, para passar a quantidade para outra variável login,senha:caracter //removi do var local para usar em outro proced. procedimento login () //procedimento cadastro e login Var //variaveis locais para o uso no procedimento loginv,senhav: vetor [1..1] de caracter l,s: inteiro Inicio repita //repita usado para repetir em caso de erro da senha para l de 1 ate 1 faca escreval ("Crie um LOGIN para você utilizar.") escreva("Usuário: ") leia(loginv[l]) fimpara limpatela para s de 1 ate 1 faca escreval ("Crie uma SENHA para você utilizar.") escreva("Senha: ") leia(senhav[s]) fimpara limpatela escreval("Por favor digite o seu LOGIN e SENHA cadastrados anteriormente.") escreva("Usuário: ") leia(login) escreva("Senha: ") leia(senha) se (login= loginv[l]) e (senha= senhav[s]) então //comparação para permitir escreval("aceito") //que o usuário entre no sistema menu_estoque() senao escreval() escreval("Seu Login ou Senha não está de acordo com os que foi cadastrado") escreval("em nosso sistema.") escreval() escreval ("Tecle ENTER para tentar novamente") leia (opc) limpatela fimse ate (login=loginv[l]) e (senha=senhav[s]) fimprocedimento procedimento cadastro_item //Procedimento para cadastrar produtos no estoque inicio codItem := codItem+1 //constante que dará o código ao produto escreval("** Cadastro de produto **") escreva ("Descrição :") leia(descricoes[codItem]) escreva ("Quantidade :") leia(quantidades[codItem]) escreva ("Preço de CUSTO :") leia (precosCustos[codItem]) escreva ("Preço de VENDA :") leia (precosVendas[codItem]) limpatela //Abaixo irá mostrar o último produto cadastrado e informará o código escreval() escreval() escreval ("Você cadastrou ",descricoes[coditem]) escreval ("Código do produto:",coditem) escreval ("Quantidade :",quantidades[coditem]) escreval ("Custo :",precosCustos[coditem]) escreval ("Preço R$:",precosVendas[coditem]) escreval() escreval ("Para visualizar o código novamente, imprima o relatório") escreval ("de produtos.") escreval() escreval("Pressione ENTER para voltar ao menu") leia(opc) fimProcedimento procedimento imprimir_produtos()//Prodedimento para imprimir os produtos cadastrados var i :inteiro inicio escreval("Você possui no estoque os seguintes itens: ") para i de 1 ate codItem faca //do primeiro até a quantidade já cadastrada escreval() escreval("Código :",i) escreval("Descrição : ",descricoes[i]) escreval("Quantidade :",quantidades[i]) escreval("Preço de CUSTO :",precosCustos[i]) escreval("Preço de VENDA : R$:",precosVendas[i]) escreval("------------------------------------------") escreval() fimpara escreva ("Pressione ENTER para voltar ao menu") leia(opc) //apenas para aguardar até que pressioner ENTER. Imprimir um de cada vez fimProcedimento procedimento editar() var novaQtd :inteiro inicio escreval("Digite o código do item que deseja pesquisar (ex: 57): ") escreval("Lembre-se, todos os números devem ser por ...") leia(icod) se (icod >=1) E (icod <= codItem) então //se é um código válido escreval("Código :",icod) //o código é a posição no vetor!!! escreval("Descrição :",descricoes[icod]) escreval("Quantidade :",quantidades[icod]) escreval("Custo :",precosCustos[icod]) escreval("Preço de venda :",precosVendas[icod]) escreval() escreval("Digite a quantidade correta que possui no estoque, ou") escreval("caso não queira modificar, digite a quantidade atual.") leia(novaQtd) quantidades[icod]:=novaQtd //atualiza a quantidade escreval("O produto ",descricoes[icod]," agora possui ",quantidades[icod]," unidades") escreval() escreval("Pressione ENTER para continuar") leia (opc) fimse fimprocedimento procedimento menu_estoque() inicio repita limpaTela escreval("--------ESTOQUE - PDV--------") escreval() escreval(" 1-Cadastro de Item ") escreval(" 2-Pesquisar/Editar ") escreval(" 3-EM CONSTRUÇÃO ") escreval(" 5-Sair ") escreval() escreval(" 0-*Imprimir produtos ") escreval() escreval(" Possuem atualmente",codItem," produtos") escreval(" cadastrados no estoque!") escreval() escreva ("Comando: ") leia(opc) escolha (opc) caso "1" limpatela cadastro_item() //qdn esse método é invocado, ao finalizar, o programa vai continuar daqui... caso "2" limpatela editar() caso "0" limpatela imprimir_produtos() caso "5" fimEscolha ate opc="5" fimProcedimento INICIO codItem <- 0 //inicializa o controlador de código login() FIMALGORITMO Isto é o que tenho no código até agora! Eu utilizei o código para alterar o valor. Funcionou perfeitamente. Agora vou criar a parte de vender os produtos que estão no estoque, crio separadamente e depois coloco no código, ou crio já junto? Qual é a melhor opção? @Simon Viegas Se puder me explicar novamente o que você me mandou referente ao trecho de editar a quantidade, não entendi muito bem.
  11. @Simon Viegas No caso de chegar mais quantidades do mesmo produto, o jeito seria ao invés de cadastrar com a mesma descrição, ir na opção de Pesquisar/Editar Quantidade. Não sei se foi isso que você quis dizer. Eu ainda não consegui ajeitar a parte do contador do código. O jeito vai ser fazer um modo em que a pessoa crie o próprio código? Do jeito que tá o codItem recebe +1 em cada cadastro, no segundo cadastro codItem já se transforma no número 2, ou seja, o item do código 1 parou de existir no momento em que criei um cadastro novo. CODITEM := CODITEM + 1 (em cada registro recebe 1) fiz um registro chamado SUCO, o código dele é 1 porque CODITEM recebeu 1. fiz outro registro chamado MAÇÃ, o código dele é 2 porque CODITEM recebeu mais 1, logo o item anterior não existe mais porque CODITEM virou 2 e deixou de ser 1. Entendeu? To confuso quanto a isso. Não sei se faço um modo do usuário cadastrar o próprio código, ou se isso tem uma solução mais simples. Fora isso está funcionando perfeitamente o modo de edição de quantidade, aqui cadastrei um produto com 50 unidades, agora vou pesquisar o mesmo pelo código e modificar. Aqui pesquisei e mudei de 50 para 30 Abri relatório de estoque e realmente mudou a quantidade. Isso com um item cadastrado, vou cadastrar mais um. Cadastrei: Agora tento achar o item 1 e não tenho sucesso porque CODITEM agora não é mais 1, e sim 2... Espero ter esclarecido tudo, esse problema está me deixando careca, tentei o dia todo e não queria fazer o usuário cadastrar o próprio código...
  12. Respondendo aqui; codItem quando o se é executado depende da quantidade de itens cadastrados, eu acho, afinal ele soma +1 após cadastrar cada item. Se eu cadastrar 3 por exemplo, antes do se o codItem valerá 3. Ou pelo menos foi isso que eu entendi. Sobre o código; Para ele saber o código, basta listar os cadastros no 0 (no menu), lá aparece o código. Mas dá para por pra imprimir após cadastrar.
  13. Vou deixar o (Ex: 150). O professor vive dizendo "Você está programando para o usuário, e as vezes ele é burro". icod = variável que será comparada com a posição do vetor (itemcod), ou seja, se icod for igual a algum valor da posição, por exemplo 1 = 1(posição), ele irá selecionar para modificar a quantidade do vetor na posição 1. Porém se for diferente, vai exibir a mensagem e ao teclar enter voltará para o menu. Digitei 1, logo, a posição 1 no vetor que se refere ao código, é exibida para editar a quantidade. Aqui digitei 3, mas o vetor ainda não tem a posição (código) 3, ou seja, aparece a mensagem e pede para voltar ao menu. Resumindo, eu só comparo um com o outro por conta da posição, já que a pesquisa funciona através disso e não pelo nome do produto. Entendeu? adicionado 23 minutos depois Simon, editando aqui: Percebi que depois de cadastrar 2 ou mais produtos, o anterior não fica mais disponíveis para eu encontrar através do código. Entendi o porque, mas não sei como ajeitar isso. codItem <- codItem+1 o codItem está sempre recebendo 1, ou seja, o produto que era cod 1 agora sumiu porque o 2 tomou o lugar dele. Como ajeita? Estava muito tranquilo pra ser verdade.
  14. algoritmo "ESTOQUE" // Estoque // Cadastro de item no estoque // Descrição / Quantidade / Preço de custo / Preço de venda // Cadastro de combo promocional // Descrição / Quantidade / Preço de custo / Preço de venda // Retirar item do estoque // Retira quantidade do item selecionado // Relatório de itens no estoque. // Todos os itens var //dados do produto (cada vetor é um atributo) descricoes :vetor [1..1000] de caractere quantidades :vetor [1..1000] de inteiro precosCustos:vetor [1..1000] de real precosVendas:vetor [1..1000] de real //Vetores do estoque codItem :inteiro //código do produto (gerado em sequência) opc,opc2 :caractere //usado para selecionar opções fimcad :real //usado para acompanhar a exibição do ultimo cadastro icod :inteiro //usado para ler o código do menu excluir acresc :inteiro //usado para recadastrar a quantidade de itens j :inteiro //usado como pombo correio, para passar a quantidade para outra variável procedimento cadastro_item //Procedimento para cadastrar produtos no estoque inicio codItem <- codItem+1 escreval("** Cadastro de produto **") escreva ("Descrição :") leia(descricoes[codItem]) escreval() escreval("*Todas as opções abaixo devem ser digitadas em forma de números*") escreval("Ex: 150") escreval() escreva ("Quantidade :") leia(quantidades[codItem]) escreva ("Preço de CUSTO R$:") escreva("") leia (precosCustos[codItem]) escreva ("Preço de VENDA R$:") leia (precosVendas[codItem]) //Abaixo irá mostrar o último produto cadastrado escreval() escreval() escreval("Você cadastrou ",descricoes[coditem]) escreval ("Quantidade :",quantidades[coditem]) escreval ("Custo :",precosCustos[coditem]) escreval ("Preço R$:",precosVendas[coditem]) escreval ("Tecle enter para retornar ao menu.") leia(opc) fimProcedimento procedimento imprimir_produtos()//Prodedimento para imprimir os produtos cadastrados var i :inteiro inicio escreval("Você possui no estoque os seguintes itens: ") para i de 1 ate codItem faca //do primeiro até a quantidade já cadastrada escreval() escreval("Código :",i) escreval("Descrição : ",descricoes[i]) escreval("Quantidade :",quantidades[i]) escreval("Preço de CUSTO :",precosCustos[i]) escreval("Preço de VENDA : R$:",precosVendas[i]) escreval("------------------------------------------") escreval() fimpara escreva ("Pressione ENTER para voltar ao menu") leia(opc) //apenas para aguardar até que pressioner ENTER. Imprimir um de cada vez fimProcedimento procedimento editar() var i:inteiro inicio escreval ("Digite o código do item que deseja pesquisar (ex: 57): ") escreval ("Lembre-se, todos os números devem ser por e") leia (icod) se (icod = coditem) então escreval("Código :",coditem[i]) escreval("Descrição :",descricoes[coditem]) escreval("Quantidade :",quantidades[coditem]) escreval ("Digite a quantidade correta que possui no estoque, ou") escreval ("caso não queira modificar, digite a quantidade atual.") leia (acresc) j:= acresc escreval ("O produto ",coditem[i]," possui ",j," unidades") leia(opc) senao se (icod <> coditem) então escreval ("Este código ainda não foi cadastrado") escreval("Pressione ENTER para voltar ao menu") leia (opc) fimse fimse quantidades[coditem]:= j //FUNÇÃO ESSENCIAL, salva a quantidade!!! fimprocedimento procedimento menu() inicio repita limpaTela escreval("--------ESTOQUE - PDV--------") escreval() escreval(" 1-Cadastro de Item ") escreval(" 2-Pesquisar/Editar Quantidade ") escreval(" 3-EM CONSTRUÇÃO ") escreval(" 5-Sair ") escreval() escreval(" 0-*Imprimir produtos ") escreval() escreval("Possuem atualmente",codItem," produtos") escreval(" cadastrados no estoque!") escreval("-------------------------------") leia(opc) escolha (opc) caso "1" limpaTela cadastro_item() //qdn esse método é invocado, ao finalizar, o programa vai continuar daqui... caso "2" limpaTela editar() caso "0" limpaTela imprimir_produtos() fimEscolha ate opc="5" fimProcedimento INICIO codItem <- 0 //inicializa o controlador de código menu() FIMALGORITMO Então, como modifiquei o excluir pra editar a quantidade, não é mais excluir. auhauhah Mas sim! Está funcionando. Testa aí. Mas testa no visualg 3.0, no 2,0 está bugando para imprimir o código do produto.
  15. @Simon Viegas Conversei com o professor, ele permitiu. Do mesmo, você achou que ficou bom?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×