Ir ao conteúdo
  • Cadastre-se

DiogoR00

Membros Juniores
  • Total de itens

    2
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Acabou por responder a outra dúvida que tinha, como coloco mais de um tipo primitivo em um procedimento! Não sabia que se podia utilizar o ponto e virgula para colocar mais de um parâmetro de outro tipo! Agora vou poder continuar os meus estudos em paz. Agradeço imenso Simon, abraço.
  2. Olá, recentemente aprendi procedimentos, até que não é difícil, mas tenho as minhas dúvidas. Eu gostaria de saber qual a diferença do primeiro algoritmo do segundo. Eu não percebo para que serve os parâmetros visto que sem eles funciona na mesma, como podem ver em negrito. É que o algoritmo 2 é bem mais simples que o primeiro, pois imaginemos que estou a usar variáveis de tipo inteiro e caractere, teria que criar 2 procedimentos? ou teria que mudar essa variavel do tipo caractere para inteiro? 1 algoritmo "FazSomaProcedimento" var X, Y: Inteiro Procedimento Soma(A, B: Inteiro) inicio EscrevaL("Recebi o valor ",A) Escreval("Recebi o valor ",B) Escreval("A soma entre os dois e ", A + B ) FimProcedimento inicio X <- 5 Y <- 3 Soma(X, Y) fimalgoritmo ____________________________________ 2 algoritmo "FazSomaProcedimento" var X, Y: Inteiro Procedimento Soma() inicio EscrevaL("Recebi o valor ",X) Escreval("Recebi o valor ",Y) Escreval("A soma entre os dois e ", X + Y ) FimProcedimento inicio X <- 5 Y <- 3 Soma() fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×