Ir ao conteúdo
  • Cadastre-se

Giovanni C Batista

Membros Juniores
  • Total de itens

    3
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Muito obrigado pela ajuda. Eu consegui com um amigo resolver a questão... Obrigado mesmo pela atenção.
  2. Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs... O trabalho é este: Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo: Tabela IRPF Tabela INSS Salário até R$1500,00 será 0% de imposto; Salário até R$3000,00 será 15% de imposto; Salário acima de R$3000,00 será 27,5% de imposto. Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor) Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido. Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo: Salário Bruto Salário Líquido R$ 5000,00 R$ 3225,00 R$ 3500,00 R$ 2152,50 Retorno de resultado R$ 1800,00 R$ 1332,00 R$ 1400,00 R$ 1246,00 Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor): var salarioB, irpf, inss: real inicio //IRRF: //Até 1.500 | - //De 1.500 até 3.000 | 15,0 //Acima de 3.000 | 27,5 //INSS: //Fixo | 11,0 | Limite de desconto 400 escreva("Digite o salário:") leia (salarioB) se (salarioB<1500.00)ou(salarioB=1500.00) entao inss<- salarioB*11/100 escreval("Seu SalarioB Liquido é", salarioB - inss) senao se (salarioB>1500.01)e(salarioB<=3000.00) entao irpf<- salarioB*15/100 inss<- salarioB*11/100 escreval ("IRPF a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) senao se (salarioB>3000.00)ou(salarioB= 3000.00) entao irpf<- salarioB*27.5/100 inss<- salarioB*11/100 escreval ("IRPJ a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) fimse fimse fimse fimalgoritmo
  3. Prezados, boa tarde. Precisa de uma macro que inserisse na coluna A o seguinte formato aos números: =(“1231231223”) hoje os números estão assim 1231231223, porém preciso que eles fiquem todos na formatação acima. Não posso usar função como exemplo concatenar, pois precisa parecer que foi inserido normalmente, então só uma macro pra ajudar. atenciosamente, Giovanni Batista

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×