Ir ao conteúdo
  • Cadastre-se

Rafael Mariano Domingos

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. n consigo achar o erro no programa queria fazer um laço de repetição condicional no qual uso enquanto para definir os turnos dos jogadores mas esta dando erro alguem pode me ajuda ? Algoritmo "Classes" procedimento vezArqueiro() var//variaveis procedimento inicio Escreval(" ") Escreval("---------------------------------------------------") Escreval(" ") Escreval(" A R Q U E I R O ") Escreval(" ") Escreval(" [A] Causa 3 de dano ") Escreval(" Causa 1.5 de dano ") Escreval(" [C] Causa 7 de dano ") Escreval(" ") Escreval("---------------------------------------------------") Escreval(" ") fimprocedimento//final procedimento vezAnao() var inicio Escreval(" ") Escreval("---------------------------------------------------") Escreval(" ") Escreval(" A N A O ") Escreval(" ") Escreval(" [A] Causa 4 de dano ") Escreval(" Causa 5 de dano ") Escreval(" [C] Causa 7 de dano ") Escreval(" ") Escreval("---------------------------------------------------") Escreval(" ") fimprocedimento Tipo // registro Classes = registro arq_Hp: real arq_S1: real arq_S2: real arq_U : real ana_Hp: real ana_S1: real ana_S2: real ana_U : real fimregistro //final var //variaveis do programa skill: caractere resultado: real Dano: real arq: Classes ana: Classes i: inteiro inicio //programa arq.arq_Hp <- 15 arq.arq_S1 <- 3 arq.arq_S2 <- 1.5 arq.arq_U <- 7 ana.ana_Hp <- 20 ana.ana_S1 <- 4 ana.ana_S2 <- 5 ana.ana_U <- 7 enquanto (arq.arq_Hp = 0) ou (ana.ana_Hp = 0)faca vezArqueiro()//VEZ ARQUEIRO leia (skill) Escolha skill caso "a" resultado <- arq.arq_S1 ana.ana_Hp <- ana.ana_Hp - resultado escreval(" Arqueiro causou ", arq.arq_S1, " de dano e deixou anão com ", ana.ana_Hp, " de HP.") caso "b" resultado <- arq.arq_S2 ana.ana_Hp <- ana.ana_Hp - resultado escreval(" Arqueiro causou ", arq.arq_S2, " de dano e deixou anão com ", ana.ana_Hp, " de HP.") caso "c" resultado <- arq.arq_U ana.ana_Hp <- ana.ana_Hp - resultado escreval(" Arqueiro causou ", arq.arq_U, " de dano e deixou anão com ", ana.ana_Hp, " de HP.") outrocaso Limpatela Escreval("Opção invalida!") fimescolha vezAnao()//VEZ ANAO Leia(skill) Escolha skill caso "a" resultado <- ana.ana_S1 arq.arq_Hp <- arq.arq_Hp - resultado escreval(" Anão causou ", ana.ana_S1, " de dano e deixou arqueiro com ", arq.arq_Hp, " de HP.") caso "b" resultado <- ana.ana_S2 arq.arq_Hp <- arq.arq_Hp - resultado escreval(" Anão causou ", ana.ana_S2, " de dano e deixou arqueiro com ", arq.arq_Hp, " de HP.") caso "c" resultado <- ana.ana_U arq.arq_Hp <- arq.arq_Hp - resultado escreval(" Anão causou ", ana.ana_U, " de dano e deixou arqueiro com ", arq.arq_Hp, " de HP.") outrocaso Limpatela Escreval("Opção invalida!") fimescolha Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×