Ir ao conteúdo
  • Cadastre-se

Erick Corrêa

Membros Plenos
  • Total de itens

    25
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. @Silent Rain sim, estou cursando na Unicesumar, você também? Eu dei umas ajustadas a mais no código, questão de fórmulas e afins, porém não mexi mais, estou envolvido no de linguagem C agora!
  2. Ajustei de acordo com o indicado, realmente deixa tudo bem explícito ao que deve ser feito, o que o programa realmente deve seguir, sem falhas ou brechas para as mesmas!! Obrigado galera!! Até o próximo código!! Abraço!
  3. Segue, já ajustado: Algoritmo "Entrevista" //Aluno: Erick Corrêa da silva //R.A.: 175.864-45 Var nome : caractere idade : inteiro sexo : caractere filhos,j, homem, mulher, rena_acime_500: inteiro nasc_2000 : inteiro rendaf: real contador, contadorf:real ph,pm,pfilho:real Inicio Para j de 1 ate 2 faca escreval ("DIGITE OS DADOS DO ENTREVISTADO") escreval ("Tecle ENTER para sair!") escreva ("Nome :") leia(nome) se compr(nome)=0 então interrompa fimse escreva ("Idade :") leia(idade) se idade < 19 então nasc_2000:=nasc_2000+1 fimse escreva ("Sexo [M ou F] :") leia(sexo) se sexo="M" então homem:=homem+1 senao se sexo="F" então mulher:=mulher+1 fimse fimse escreva ("Filhos :") leia(filhos) se filhos > 0 então contadorf:=contadorf+1 fimse escreva ("Renda Familiar:R$") leia(rendaf) se rendaf >= 500.00 então rena_acime_500:=rena_acime_500+1 fimse limpatela contador:=contador+1 fimpara pfilho:=100*contadorf/contador ph:=100*homem/contador pm:=100*mulher/contador escreval("A porcentagem de homens e mulheres é respectivamente:",ph,"% e",pm,"%.") escreval("Pessoas com renda familiar acima de R$500,00:",rena_acime_500," pessoas.") escreval("Porcentagem de pessoas que tenham ao menos um filho:",pfilho,"%.") escreval("Pessoas que nasceram a partir do ano 2000:",nasc_2000,".") Fimalgoritmo
  4. No caso serve pra otimizar o programa, é menos processamento, correto?
  5. Não entendi essa parte, tem algum cálculo que está "inútil" no código? @Simon Viegas adicionado 39 minutos depois Rodando 100%, testado e aprovado, dados testados na mão batendo 100% com os dados fornecidos pelo programa! Obrigado a todos envolvidos, agora vou partir para o projeto em linguagem C e irei criar um post e espero a ajuda de vocês, que além de esclarecedora e limpa, é muito útil, a paciência e disposição de vocês para ensinar e o método que utilizam, é incrível, estimulando o iniciante a entender. Mais uma vez obrigado!!!
  6. Meu código ficou assim, acabei de testar com as 20 pessoas, 3 parâmetros funcionaram, o único que deu errado foi das pessoas que nasceram a partir/ em diante do ano 2000, ficou com o valor de 1. Algoritmo "Entrevista" //Aluno: Erick Corrêa da silva //R.A.: 175.864-45 Var nome : caractere idade : caractere sexo : caractere filhos,j, homem, mulher, rena_acime_500: inteiro nasc_2000 : inteiro rendaf: real contador, contadorf:real ph,pm,pfilho:real Inicio Para j de 1 ate 20 faca escreval ("DIGITE OS DADOS DO ENTREVISTADO") escreval ("Tecle ENTER para sair!") escreva ("Nome :") leia(nome) se compr(nome)=0 então interrompa fimse escreva ("Idade :") leia(idade) se idade < 19 então nasc_2000:=nasc_2000+1 fimse escreva ("Sexo [M ou F] :") leia(sexo) se sexo="M" então homem:=homem+1 senao se sexo="F" então mulher:=mulher+1 fimse fimse escreva ("Filhos :") leia(filhos) se filhos > 0 então contadorf:=contadorf+1 fimse escreva ("Renda Familiar:R$") leia(rendaf) se rendaf >= 500.00 então rena_acime_500:=rena_acime_500+1 fimse limpatela contador:=contador+1 pfilho:=100*contadorf/contador ph:=100*homem/contador pm:=100*mulher/contador fimpara escreval("A porcentagem de homens e mulheres é respectivamente:",ph,"% e",pm,"%.") escreval("Pessoas com renda familiar acima de R$500,00:",rena_acime_500, "pessoas.") escreval("Pessoas que tenham ao menos 1(um) filho:",pfilho,"%.") escreval("Pessoas que nasceram a partir do ano 2000:",nasc_2000,".") Fimalgoritmo
  7. Sim, eu pensei dessa forma também, mas para esse tipo de informação teria que ser algo bem mais complexo e elaborado, o que eu acho que não seria o caso, se não seria pedido também a data de nascimento, assim eu poderia calcular utilizando o mês e determinar quem ja completou 19 anos ou não, assim dizendo que é dos anos 2000! @Simon Viegas Logo eu posto, estou fazendo os últimos ajustes aqui e vou testar o código inteiro com as 20 pessoas, estava fazendo com o laço de 1 a 4 no máximo, para ser rápido...
  8. Valeu cara, amanha posto o resultado do teste final...
  9. Po, eu pensei dessa forma, mas achei que seria mt óbvio, ai eu fui tentando pela operação... isso parece mágica, ta loco bicho! ---- Mas se eu colocar dessa forma, mesmo que eu coloque 45 ele vai contabilizar, porque está dizendo que "se idade for maior que 17 então adicione +1 a pessoas que nasceram após o ano 2000"... não faz sentido! Não seria "se idade for <= a 18 então adicione +1 a nasc_2000" ?? ---- Tentei agora com o <=18 e ele da um conflito, sempre conta 1 a mais, e nunca deixa ficar zerado, caso não tenha ninguém que nasceu nos anos 2000 ou após nos cadastros...
  10. última dúvida, eu estou tentando colocar o cálculo das pessoas que nasceram após o ano de 2000, estou colocando assim e da erro de sintaxe (sintaxe incorreta): escreva ("Idade :") leia(idade) nasc_2000=2018-idade Ja deixei certo essa parte e tentei colocar a operação junto com as de porcentagem, e ainda da o mesmo erro de sintaxe incorreta! leia(idade) se nasc_2000 >= 2000 então nasc_2000:=nasc_2000+1 fimse
  11. @devair1010 cara que erro fútil, kkkkkkkkk agora foi, vou prestar mais atenção nisso, e quando me falaram que "o código nunca roda 100% de prima" eu não quis acreditar!!! adicionado 9 minutos depois Agora meu problema é nos filhos, ta sempre contando ou todos, ou ele zera... nesse caso aqui está zerando: se filhos <0 então pessoas_com_filho:=pessoas_com_filho+1 fimse
  12. Ela está declarada, mas está dando erro na hora que vai imprimir... escreval("A porcentagem de homens e mulheres é respectivamente:",ph"% e" ,pm"%") tirei os underlines achando que pudesse ser isso, mas as variáveis estão declaradas, tanto do contador como ph e pm, como "real" e depois que eu finalizo e ele contabiliza, da o erro na hora de imprimir ai...
  13. Certo, agora o erro é de que a variável não foi encontrada, mesmo eu colocando a fórmula ali, como procedo? ja tentei colocar após o "fimpara" e antes disso também, não sei onde posicionar ou o que está errado...
  14. Sim, tanto a contador como as variáveis p_h e p_m estão como INTEIRO!
  15. contador:=contador+1 fimpara p_h:=100*homem/contador p_m:=100*mulher/contador Coloquei dessa forma, e no fim ele da o seguinte erro: Erro na atribuição de valores à variável P_H: REAL para INTEIRO. O que estou fazendo errado?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×