Ir ao conteúdo
  • Cadastre-se

Kakahh

Membros Juniores
  • Total de itens

    10
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Olá, preciso fazer uma matriz em java que reconheça um padrão, por exemplo 1|1 1|0 O objetivo é que a matriz seja preenchida com números aleatórios e depois de preenchida faça uma reconhecimento desse padrão acima e me devolva quantos padrões foram encontrados, segue abaixo o código que fiz até agora, porém está dando erro se alguém poder me dar um auxilio eu agradeço. package Códigos; import java.util.Random; public class Matriz { public static void main(String[] args) { // O programa deve ser possível ler no mínimo uma matriz 10x10 e encontrar ou não o padrão. //A matriz pode ser preenchida de forma automática de forma aleatória. int tam=10; int matriz [][]= new int[tam][tam]; int l,c; int padrão=0; int cont=0; l=0; c=0; for ( l=0;l<tam;l++){ for (c=0;c<tam;c++){ Random rand= new Random(); matriz[l][c]=rand.nextInt(2); } } for (l=0;l<tam;l++) { for (c=0;c<tam;c++) { if (matriz[l][c] == 1 && matriz[l][c + 1] == 1 && matriz[l+1][c]==0) { cont++; padrão+= cont; } } } System.out.println(padrão); } }
  2. @Simon Viegas Através das suas dicas eu arrumei e ficou dessa forma, eu acho que agora esta certo, eu testei e funcionou. algoritmo "ex15" var numero,x : inteiro maior_idade, idade, idade_maior_nota:inteiro nota,maior_nota,nota_maior_idade:real inicio escreva("Informe o número de alunos:") leia(numero) para x de 1 ate numero passo 1 faca escreva("Informe a idade do aluno:") leia(idade) escreva("Informe a nota do aluno:") leia (nota) escreval("----------------") se (nota > maior_nota) então maior_nota<-nota idade_maior_nota<-idade fimse se (idade > maior_idade) então maior_idade <- idade nota_maior_idade<-nota fimse fimpara escreval("O aluno que obteve a maior nota tem: " ,idade_maior_nota, " anos ") escreva("O aluno mais velho obteve a nota:" ,nota_maior_idade) fimalgoritmo
  3. Preciso de ajuda com esse exercício Ler um número (informado pelo usuário) de pares de valores. Cada par representa a idade de um aluno e a sua respectiva nota. Calcular e escrever: - A idade do aluno que obteve a maior nota. - A nota do aluno mais velho.algoritmo var numero,x,mais_velho : inteiro nota,maior_nota,idade:real inicio escreva("Informe um numero:") leia(numero) para x de 1 ate numero passo 1 faca escreva("Informe a idade do aluno:") leia(idade) escreva("Informe a nota do aluno:") leia (nota) escreval("----------------") se (nota > maior_nota) então maior_nota<-nota idade<-maior_nota fimse se (idade > mais_velho) então nota<-mais_velho fimse fimpara escreval("O aluno que obteve a maior nota tem:" ,idade,"anos") escreva("O aluno mais velho obteve a nota:" ,nota,) fimalgoritmo Eu não tenho certeza se interpretei corretamente a questão mas fiz dessa forme e não funcionou, a idade aparece sempre a ultima que eu informei ao invés de aparecer a do aluno que obteve a maior nota e o "escreva ("O aluno mais velho que obteve a nota:" ,nota,)" nem aparece na tela.
  4. Uma loja de Calçados deseja fazer uma estimativa para saber quais calçados vendem mais entre femininos e masculinos. Considerando 50 vendas, leia o valor do calçado vendido e se é feminino (F) ou masculino (M). Após as vendas mostre qual o gênero de calçado mais vendido e o valor total de vendas dos calçados masculinos e femininos. var f,m,genero,mais_vend:caracter total_fem,total_masc, x,valor:inteiro inicio escreval("Veja qual o gênero do calçado mais vendido e o valor total das vendas de ambos") acm<-0 para x de 1 ate 5 passo 1 faca escreva("Informe o valor do calçado:") leia(valor) escreval("Informe o gênero do calçado:") escreval("Digite F para feminino") escreval("Digite M para masculino") escreva("->") leia(genero) se (f > m) então mais_vend<- f fimse se(m > f ) então mais_vend<- m fimse fimpara escreva("O genero mais vendido é:" ,mais_vend) fimalgoritmo Estou tendo dificuldade em conseguir mostrar qual o gênero mais vendido, fiz dessa forma mas não funcionou. O valor total das vendas de cada gênero também não sei como colocar, se alguém pode me mostrar o caminho, o que estou errado eu agradeço.
  5. Por conta da sintaxe do Visualg com o " = " não funcionou, mas coloquei da seguinte forme menor_venda<-valor_venda e funcionou perfeitamente, muito obrigada !!!!!
  6. O menor valor sempre apresenta 0 independente do numero que eu informe, preciso de ajuda pra descobrir o que tem errado var valor_venda, maior_venda ,menor_venda:real x:inteiro inicio escreval("Veja qual a maior venda e a menor venda do dia") para x de 1 ate 5 faca escreva("Informe o valor da venda:") leia(valor_venda) escreval("---------------") se (valor_venda > maior_venda )então maior_venda <- valor_venda fimse se (valor_venda < menor_venda) então menor_venda<- valor_venda fimse fimpara escreval("O valor da maior venda é:",maior_venda) escreva("O valor da menor venda é:",menor_venda) fimalgoritmo
  7. Eu fiz e funcionou certinho, a explicação ajudou bastante, obrigada!!!
  8. Ler o código e a altura de cada aluno de uma turma de 10 alunos. Escrever o código e a altura do aluno mais alto.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×