Ir ao conteúdo
  • Cadastre-se

cafcatos

Membros Juniores
  • Total de itens

    3
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Muito obrigada. Agora vou quebrar a cabeça mais um pouco para entender. Meu problema é saber o quê tenho de colocar e quais a ordem. valeu!
  2. Seria bom se fosse na linguagem. Pois estou aprendendo agora e é por isso que não consigo entender o que e como fazer. adicionado 2 minutos depois @Matheus Ribeiro_765701 seria bom se fosse nessa linguagem pois, estou aprendendo agora e é por isso que não consigo entender o quê e como fazer. Porém, se tem como explicar em outra linguagem também é bem vindo.
  3. Tem esse problema que já fiz de tudo mas não consigo nem entender o que estou fazendo. Começo e no meio fico toda atrapalhada. Sou mega iniciante e super frustrada. o tal problema é o seguinte: Foi realizada uma pesquisa entre os habitantes de uma cidade. Através dessa pesquisa foram coletados os dados de salário, idade, sexo, e número de filhos de cada habitante. Faça um algoritmo que calcule e mostre: a) A média de salário das mulheres. b) A maior e a menor idade da população. c) A média do número de filhos de cada habitante. d) O maior salário da população. e) O percentual de pessoas com salário maior que R$ 954,00. Obs.: O programa encerra quando o salário digitado for igual a zero. meu algoritmo todo errado é o seguinte: Var idade,sexo,mulheres,somaFilho,quantFilho,habitante,menoridade,maioridade:inteiro TotalSalario,percentualSalario,totalFilho,maiorSalario,salario,salarioMulher,mediaSalMulher:real inicio salario:= 1 enquanto (salario <> 0) faca escreval("Digite o seu salario") leia (salario) se(salario <> 0) então escreval("Digite seu sexo:") escreval("1 - Masculino") escreval("2 - Feminino") leia(sexo) escreval("Digite a sua idade") leia(idade) escreval("qual o numero de filhos:") leia(quantFilho) se(salario > maiorSalario) então maiorSalario <- salario fimse se(salario > 954) então salarioMaior 954<= salarioMaior 954 + 1 enquanto(salario > 0) faca totalSalario<-totalSalario + salario totalFilho<- quantFilho + quantFilho habitante <- habitante + 1 fimenquanto repita escreval("Sua idade") leia(idade) se(idade>= 18) então escreval("maioridade") senao("menoridade") fimse escreval("Sua idade") leia(idade) se(idade>= 18) então escreval("maioridade") senao("menoridade") ate(idade=0) fimse fimse ate(sexo = 1) ou (sexo = 2) mediaSalMulher := totalSalMulher/habitante escreval("Digite Nº Filhos") leia(filhos) totalFilhos := totalFilhos + filhos mediaFilhos := totalFilhos/habitante fimse fimse escreval("____________________________________________________") fimenquanto mediaSalMulher := salarioMulher / mulheres mediaFilho := somaFilho / habitante percentualSalMaior954 := (salarioMaior954 * 100) / habitante escreval("RELATORIO") escreval("a) Media Salario das mulheres: ", meidaSalMulher) escreval("b) Maior idade da poulcao:", maioridade) escreval("Menor idade da populacao:", menoridade) escreval("c) A média do numero de filhos de cada habitante:", mediaFilho) escreval("d) O maior salario da população:", maiorSalario) escreval("e) O percentual de pessoas com salario maior que R$ 954,00:", percentualSalario) fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×