Ir ao conteúdo
  • Cadastre-se

Gabriel Sassaki

Membros Juniores
  • Total de itens

    15
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Bom dia a todos, Consegui resolver esse problema somente acrescentando o "offset 1" também ao select do FolhasOld, e trocando = po := nas outras variáveis, ficando assim: FolhasOld := (SELECT OLDSHEET FROM TRANSICAO WHERE ID_IMPRESSORA_TONER = 7 ORDER by IDTRANSICAO DESC LIMIT 1 OFFSET 1); Muito Obrigado.
  2. Bom dia a todos, Já consegui resolver fazendo uma trigger no banco de dados para fazer o calculo "after insert on" e funcionou. Muito Obrigado.
  3. Boa tarde a todos, estou com um probleminha e ainda não consegui resolver. tenho um função criada em uma tabela no postgres e um trigger para acionar essa função mas, algo não está funcionando, testei as partes isoladas da função e funcionam bem mas, como um todo não, poderiam me ajudar por favor? Segue o código: Function: create function calculo() returns trigger as $calculo$ declare FolhasOld int; IdFolhasOld int; FolhasNew int; calculo int; begin FolhasOld = (SELECT OLDSHEET FROM TRANSICAO WHERE ID_IMPRESSORA_TONER = 7 ORDER by IDTRANSICAO DESC LIMIT 1); IdFolhasOld = (SELECT IDTRANSICAO FROM TRANSICAO WHERE ID_IMPRESSORA_TONER = 7 ORDER by IDTRANSICAO DESC LIMIT 1 OFFSET 1); FolhasNew = (SELECT FOLHAS FROM TRANSICAO WHERE ID_IMPRESSORA_TONER = 7 ORDER by IDTRANSICAO DESC LIMIT 1); calculo = FolhasNew - FolhasOld; update transicao set folhasnew = calculo where IDTRANSICAO = IdFolhasOld; return null; end; $calculo$ language plpgsql; Trigger: create trigger calculo after insert on transicao for each row execute procedure calculo(); Não sei se de repente eu perdi ou esqueci de alguma coisa. Desde já agradeço imenso.
  4. Bom dia a todos, Consegui resolver o problema de abas no evento ONSHOW do form principal. Agradeço imenso.
  5. Bom dia a todos, Estou com uma dificuldade, aliás, eu procurei em muitos lugares e não tenho ideia de como exatamente proceder. Tenho uma tabela que recebe dados de troca de toner, desses dados, eu preciso calcular quantas folhas foram impressas entre uma troca e outra. Até aqui a lógica não está difícil, seleciono o número do folhas da troca recente e calculo com base no numero de folhas da última troca desse toner. Para isso vou fazer um select *, e um order by para alinhar os dados que preciso, a questão é. Como posso fazer para que este calculo seja feito sempre automaticamente na tabela? Lembrando que são vários tipos de toners e varias trocas serão inseridas ao lonogo do tempo. Esta aplicação está sendo desenvolvida em Delphi Tokyo. Desde já agradeço qualquer ajuda. Cordialmente.
  6. Pessoal, desculpem demorar para responder, tem sido meio corrido por aqui... De qualquer forma, eu resolvi o problema indo até "Programas e Recursos", depois cliquei com o botão direito do Mouse no Office e depois em "Alterar", depois disso em "Reparar"... Foi demorado pra burro pois ele baixou o Office todo de novo e a internet por aqui não é assim tão boa... De qualquer forma, após isso o próprio Office fez todos os reparos e tudo voltou a normalidade.... Obrigado a todos pelas respostas, ajudou muito. Grande Abraço.
  7. Hoje Fiz a recriação da indexação e adivinhem só, agora não retorna nada... O que será que pode ter sido?
  8. Já sim mas ainda assim a situação continua a mesma... Verifiquei em uma penca de configurações do próprio Outlook mas não encontrei algo que pudesse me ajudar...
  9. Bom Dia a todos, Estou com um problema que é o seguinte, tenho o Outlook 2016 instalado em um Win10Pro32, ele funciona normalmente, envia e recebe todos os e-mails, o problema é quando preciso pesquisar alguma coisa em qualquer caixa, me retorna todos os resultados até um mês atrás, depois disso mais nada. Exemplo: "Se eu pesquiso Clube... hoje 08/08 ele me retorna todos os e-mails até 08/07, depois disso nada". Mesmo se eu clicar para procurar mais no servidor não adianta. O windows e o Office estão atualizados. Rodei um ScanPST, sem problemas. Alguém sabe o que pode ser e/ou como resolver? Agradeço imenso de antemão. Cordialmente.
  10. Boa tarde a todos, Como já havia dito em um post anterior, sou novato em desenvolvimento e mais ainda em Pascal/Delphi, no programa que estou escrevendo, me deparei com um problema que de repente é até simples mas não estou conseguindo resolver. Tenho uma unit, dentro desta unit tenho um PageControl com seis abas e dentro da primeira aba tenho outro PageControl com mais duas abas (por enquanto). Pois bem, dentro das abas deste último PageControl, tenho dois DBGrids, com SQLDataSet, DataSetProvider e ClientDataSet. Inseri e programei alguns botões para Inserir, Editar, Excluir, Cancelar, Salvar e Sair, todos configurados e funcionando, tudo no PageControl(último citado). Ainda no mesmo PageControl, coloquei um ComboBox e um botão de "OK", para selecionar as abas, funcionando quase da forma que preciso. Ainda no mesmo PageControl, coloquei um campo TEdit para digitar e um potão de pesquisa, também funcionando, para as duas abas. Ainda no mesmo PageControl, e agora vem a questão mesmo, inseri um botão de voltar, programei a parte em que ele apaga os dados escritos no campo de pesquisa porém, ele não retorna a tabela ao seu estado original, a tabela fica com o resultado da busca indefinidamente. 1º Como posso fazer para que quando eu trocar de abas em qualquer um dos PageControl's a outra aba desapareça? 2º Como posso fazer para que quando eu clique no botão voltar o grid retorne ao seu estado original? Se houver mais alguma dica ou algo que eu possa melhorar em meu código(o que eu acho muito provável), eu agradeço imensamente. Segue o código do botão voltar até agora: procedure TfrmCompras.sbtnVoltarClick(Sender: TObject); Var i : Integer; begin for i := 0 to ComponentCount -1 do if Components is TEdit then begin TEdit(Components).Text := ''; end; if pcFormCompras.ActivePage = tbsInsumos then begin tbsInsumos.TabVisible := false; TClientDataSet(dsInsumos.DataSet).Close; TClientDataSet(dsInsumos.DataSet).Open; tbsInsumos.TabVisible := true; end; end; Código do botão "OK" para troca de abas do segundo PageControl, o do primeiro é basicamente a mesma coisa: procedure TfrmCompras.sbtnComprasFormClick(Sender: TObject); begin case cbxComprasForm.ItemIndex of 0 : tbsInsumos.TabVisible := true; 1 : tbsProcedimentos.TabVisible := true; end; edtFormCompras.SetFocus; end; Utilizo Win10Pro64, Delphi Tokyo, MySQL(HeidiSQL) Desde já agradeço imensamente.
  11. Bom dia a todos, Já consegui fazer a migração, usei o HeidiSQL, converti o arquivo do Excel em CSV e fiz o import para dentro do HeidSQL, tive de alterar alguma poucas configurações e alguns dados mas deu tudo certo. Agradeço imensamente. Cordialmente.
  12. Boa tarde a todos, Iniciei muito recentemente na área de desenvolvimento e, como etapa inicial, estou tentando desenvolver um programa simples para ajudar no dia-a-dia de um dos setores da empresa em que trabalho. Este setor tem uma pasta em rede cheia de planilhas em excel, arquivos em .doc e pdf, minha intenção é criar uma aplicação que possa substituir o uso desse monte de documentos, ou a maior parte deles ao menos. Comecei a aplicação mas me deparei com uma coisa que ainda não sei como resolver, os documentos que já existem, precisarei migrá-los para dentro da aplicação, só não tenho ideia de como fazer. Encontrei algumas dicas na internet mas nada que eu tenha compreendido direito. Eu estou usando o Delphi Tokyo, MySQL com HeidSQL, em um Win10Pro64. A princípio, preciso descobrir como migrar ao menos uma planilha em .xlsx para o delphi e posteriormente salvar no banco de dados ou migrar direto para o banco de dados se for o caso. A criação da aplicação em si, até o momento não tem sido um problema. Qualquer ajuda é sempre bem-vinda. Agradeço imenso.
  13. Boa tarde a todos, @tchagas fiz o que sugeriu a aparentemente até agora está OK, não houve recorrência. Agradeço muito a ajuda de todos e me desculpem a demora em responder. Abraços.
  14. Boa tarde a todos, sou novo por aqui e após ler as regras não entendi direito se é ou não uma infração eu trazer este tópico novamente a ativa mas meu problema é basicamente o mesmo que deu origem a esse tópico. Se é uma infração peço que me desculpem. Vejam meu cenário, trabalho em uma empresa que tem vários computadores e vária impressoras em rede, em uma determinada área tem um pc com win10pro32 com uma impressora instalada e compartilhada, todos os pcs desta área imprimem normalmente, sendo esses com sistemas win7pro32, win7ultimate32, win10 pro32 e win10pro64. Desses pcs, todos imprimem normalmente mas, tem dois desses que tenho autenticar quase todos os dias, sem esta autenticação a impressão é impossível, pesquisei muito e não consegui achar uma solução, o vídeo da ultima postagem deste tópico infelizmente não me ajudou por isso a ressurreição do tópico. Os pcs dessa rede tem todos ips fixos, usuário e senha, sendo que estes são padrão para todos os pcs da rede. Como posso resolver esse problema? Por que só dois entre tantos não conseguem "segurar a autenticação"? A sim, os dois pcs que preciso autenticar quase todos os dias são win7pro32 Desde já agradeço imenso.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×