Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''Portugol''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 43 registros

  1. Enfim, eu estou criando um jogo no Portugol Studio (Show do Milhão), é um jogo de perguntas e respostas... Porém, meu trabalho tem que ter o modo de 2 jogadores (Multiplayer) E eu não tenho ideia de como fazer esse Loop na mesma pergunta para que os 2 jogadores respondam, e só assim ir pra próxima pergunta Vou deixar parte do código aqui pra entenderem melhor se (jogadores==2) //2 JOGADORES { escreva("Digite nome/apelido do primeiro jogador: ") leia(nome_jogador1) escreva("Digite nome/apelido do segundo jogador: ") leia(nome_jogador2) limpa() escreva("Qual o nível de dificuldade que desejam jogar?\n") escreva("\n") escreva("1 - Fácil\n") escreva("2 - Médio\n") escreva("3 - Difícil\n") escreva("Digite o número da dificuldade aqui: ") leia(dificuldade) limpa() para (inteiro i = 1; i <= sorteios; i++) //Sortear qual jogador irá começar { valor_sorteado = u.sorteia(valor_inicial, valor_final) se (valor_sorteado==1) //Se o valor for 1, logo o jogador número 1 irá começar { escreva("O jogador ", nome_jogador1) escreva(" que irá começar a responder\n\n") } se (valor_sorteado==2) //Se o valor for 2, logo o jogador número 2 irá começar { escreva("O jogador ", nome_jogador2) escreva(" que irá começar a responder\n\n") } } se (dificuldade==1) { escreva("Nível de dificuldade: Fácil\n\n") escreva("Pergunta nº1\n\n") escreva("Qual desses componentes, é um componente de armazenamento?\n") escreva("1 - HD\n") escreva("2 - Processador\n") escreva("3 - Memória Ram\n") escreva("4 - placa-mãe\n") escreva("5 - Fonte\n") escreva("Digite sua resposta aqui: ") leia(resposta1) se (resposta1==1) { escreva("\n") escreva("Você acertou!\n") escreva("----------------------------\n\n") acertos = acertos+1 } senao { escreva("\n") escreva("Você errou, que pena.\n") escreva("----------------------------\n\n") erros = erros+1 } escreva("Pergunta nº2\n\n") escreva("Qual o maior espaço de um disco abaixo?\n") escreva("1 - 500GB\n") escreva("2 - 250GB\n") escreva("3 - 1TB\n") escreva("4 - 40GB\n") escreva("5 - 80GB\n") escreva("Digite sua resposta aqui: ") leia(resposta2) Se puderem me ajudar com isso, irei ficar muito grato. Obs: Como eu posso identificar qual jogador foi sorteado na primeira pergunta? E ordenar para que os 2 jogadores respondam a mesma questão (só assim pra ir pra próxima)!? Obs²: São 5 perguntas no modo fácil, 5 no modo médio e 5 no modo difícil... Cada pergunta com 5 alternativas (Já feito). copa.rar
  2. Olha eu de novo novamente, boa noite, juro q tentei resolver o problema mas não consegui, quando eu escolho os casos de 1 a 4, o "Desenho" aparece e apaga mt rápido, como posso resolver isso? algoritmo "semnome" var M:Vetor[1..4, 1..4] de inteiro R,L,C:Inteiro Procedimento Matriz() inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva(M[L,C]:4) Fimpara Escreval() Fimpara Fimprocedimento Procedimento Diagonal() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L=C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento Procedimento Superior() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L<C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento Procedimento Inferior() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L>C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva("Digite o valor da posição [",L,",",C,"]") Leia(M[L,C]) Fimpara Fimpara Limpatela Repita Limpatela Escreval("=====================") Escreval(" Menu De Opções ") Escreval("=====================") Escreval("[1]Mostrar a Matriz ") Escreval("[2]Diagonal Principal") Escreval("[3]Triangulo Superior") Escreval("[4]Triangulo Inferior") Escreval("[5]Sair") Escreva("Escolha: ") Leia(R) Escolha R Caso 1 Matriz() Caso 2 Diagonal() Caso 3 Superior() Caso 4 Inferior() Limpatela FimEscolha Ate (R = 5) fimalgoritmo
  3. Boa noite, olha eu aqui dnv... Bom, estava fazendo um algoritmo para reservar poltronas no cinema, ocorreu tudo certinho, maaaas ocorreu algo inusitado, quando eu reservo uma cadeira, a linha --Escreva("Cadeira B",[N]," Reservada") --não aparece na tela, alguem pode me dizer porque acontece isso? conflito de comandos ou sla.... algoritmo "semnome" var Cadeira:Vetor[1..10] de Caractere C, N:Inteiro R :Caractere inicio Para C <- 1 ate 10 faca Cadeira[C] <- "OK" Fimpara Repita Para C <- 1 ate 10 faca Se Cadeira[C]="OK" então Escreva("[B",C,"]") Senao Escreva("[--]") Fimse Fimpara Escreval("") Escreva("Reservar Cadeira: B") Leia(N) Se (Cadeira[N]="OK") então Cadeira[N] <- "X" Escreva("Cadeira B",[N]," Reservada") Senao Escreval("ERROR Cadeira já reservada, Tente novamente") Fimse Escreva("Deseja Reservar outra cadeira?[S/N] ") Leia(R) Limpatela ate(R="N") fimalgoritmo
  4. Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código. Alguém pode me ajudar? ele tem como finalidade, comparar as questões dos alunos, contar a quantidade de acertos e dar as notas. Algoritmo "Gabarito" Var Gab : Vetor[1..5] de Caractere Nome: Vetor[1..3] de Caractere GabA: Vetor[1..5] de Caractere Nota: Vetor[1..3] de Real C : Inteiro Inicio Escreval("-----------------------------") Escreval("Passo 1- Cadastro de gabarito") Escreval("-----------------------------") Para C <- 1 ate 5 Faca Escreva("Questão ",C,": ") Leia(Gab[C]) Fimpara Limpatela Para C <- 1 ate 3 faca Escreval("-----------------------------") Escreval(" Aluno C ") Escreval("-----------------------------") Escreva("Nome: ") Leia(Nome[C]) Para C <- 1 ate 5 faca Escreva("Questao ",C,":") Leia(GabA[C]) Se (GabA[C]= Gab[C]) então Nota[c] <- Nota[c] + 2 Fimse Fimpara Limpatela Fimpara Escreval("============") Escreval("Notas Finais") Escreval("============") Para C <- 1 Ate 3 faca Escreval(Nome[C],Nota[C]) Fimpara Fimalgoritmo
  5. Qual linguagem de programação mais básica? Que programa eu uso para digitar os códigos? Quero aprender a programar, mas não sei por onde começar e nem como. Me falaram para usar o Code:blocks, mas não sei como uso!
  6. Estou tentando resolver um problema que é: Dados os 3 valores escolhidos por Alice, Beto e Clara, cada valor zero ou um, um programa que determina se ha um ganhador, e nesse caso determina quem é o ganhador, tendo como saída somente um caractere, a inicial do nome de quem ganhou. Se nenhum deles ganhar, no caso de todos colocarem 1 ou todos colocarem 0 , que apareça um " * ". Estou aprendendo Logica e estou tentando pegar , mas é bem difícil, estou no começo. Algoritmo Ganhador Var A , B , C : Inteiro inicio
  7. Escreva um procedimento que receba um número inteiro e o imprima na forma extensa. Por exemplo, para 1 a saída desejada é “Um”. A função deve ser capaz de gerar o extenso dos números de 0 até 15, inclusive. Caso um número não compatível seja recebido o procedimento deve mostrar uma mensagem de erro. Crie também um algoritmo que leia um valor inteiro e chame o procedimento criado acima para a impressão do número extenso. Eu fiz assim, alguém pode me ajudar, achei na internet totalmente diferente, então não seio se estar errado, estar dando erro no [ escreval(extenso(n)) ] var n: inteiro procedimento extenso(n: inteiro) var ext: caracter inicio escolha (n) caso 1 ext < "Um" caso 2 ext <- "Dois" caso 3 ext <- Três" caso 4 ext <- "Quatro" caso 5 ext <- "Cinco" caso 6 ext <- "Seis" caso 7 ext <- "Sete" caso 8 ext <- "Oito" caso 9 ext <- "Nove" caso 10 ext <- "Dez" outrocaso ext <- "Erro. Número inválido" fimescolha escreval(ext) fimprocedimento inicio escreva("Informe um número: ") leia(n) escreval(extenso(n)) fimalgoritmo OBS. no visualG (portugol)
  8. Boa noite. Gostaria de apoio na resolução deste problema. Estou no início do curso e necessito de ajuda. Muito obrigado. Para esta atividade MAPA queremos que você exercite o conteúdo que está sendo apresentado na disciplina. Sendo assim: Escreva um algoritmo que faça a entrevista de 20 pessoas. Seu algoritmo em Portugol deve conter os seguintes requisitos: I. Realizar a leitura dos seguintes dados, para cada uma das 20 pessoas: - Nome. - Idade. - Sexo. - Quantidade de filhos. - Renda mensal familiar. Obs.: Sair do laço de repetição se um nome não for preenchido, mesmo se não atingir 20 pessoas. II. Com base nos dados coletados, apresente na tela as seguintes informações: - Percentual de mulheres e homens. - Número de pessoas com renda familiar de 500.00 (quinhentos reais) ou acima. - Percentual de pessoas que tem ao menos 1 filho. - Número de pessoas que nasceram a partir do ano 2000.
  9. Estou tentando montar esse algoritmo, porém, está dando erro quando coloro "Coroa" na escolha do jogador. Se alguém achar outro erro, pode me ajudar a consertar? inicio texto cara , coroa , escolha inteiro moeda escrever "Digite Cara ou Coroa" , "\n" ler escolha moeda <- aleatorio ( ) * 2 se moeda = 0 então escrever "\nCara" fimse se moeda = 1 então escrever "\nCoroa" fimse se escolha = "cara" então escrever "\nVocê ganhou" senao se escolha = "coroa" então escrever "\nA máquina ganhou" fimse fimse fim
  10. Fala galera eu preciso fazer o seguinte exercicio em pseudocódigo: Dado um conjunto de N frases, faça um algoritmo para imprimir cada frase juntamente com o número de vezes que aparece a palavra DE na frase. Gostaria de saber se o que eu fiz está correto? // algoritmo FRASES /* - - - - - - - -- - - - - - - - - - - - -- */ VARIAVEIS string frase[200]; inteiro i,frase,n; INICIO leian frase para(i=0; i<frase; i++) se (frase[i]=='d' e frase[i+1]== 'e' e frase[i+2]== ' ') qtde++ fimse fimpara escrevaln "Encontrados vezes",qtde; fimalgoritmo
  11. Bom dia! Primeiramente gostaria de me apresentar. Meu nome é Everton e recentemente iniciei um curso técnico de análise e desenvolvimento de sistemas... Estamos no segundo mês de curso. Estou gostando bastante. Apesar de parecer muito simples. Estou tendo dificuldades nos comandos SE, SENAO e SENAO SE. Não consegui resolver um exercício que me foi passado... e sinceramente fico bastante frustrado... kkkk. Se alguém conseguir me dar uma dica, ficaria agradecido. A questão é o seguinte. Só pode ser feita com comandos de controle. Questão: Preciso criar um algoritmo que tenha 3 senhas no sistema (Constantes) e um email também. O usuário precisa primeiro inserir o E-mail. Se o e-mail estiver no sistema... ele irá pedir a senha do usuário em seguida se não... O programa finaliza nessa parte, nem chega a pedir os outros dados. (Meu problema é nessa parte). Se a senha do usuário não for nenhuma das 3 do sistema ele informará, que senha é inválida e o programa finaliza. Caso for aparecerá mensagem, "Sistema Ativado". Abaixo o código que fiz... Se alguém conseguir me dar uma luz, ficaria agradecido. Estamos usando o Portugol Studio. Estou tendo problema na parte que pede o E-mail e o usuário insere o mesmo incorreto. Era pro problema finalizar e mesmo assim pede a senha... Programa: { funcao inicio() { const cadeia SENHA1 = "300390" const cadeia SENHA2 = "300490" const cadeia SENHA3 = "300590" const cadeia EMAIL = "teste_everton@hotmail.com" cadeia password cadeia email_usuario escreva ("Informe o seu email: ","\n") leia (email_usuario) se (email_usuario != EMAIL) { escreva ("E-mail inválido!") } se (email_usuario == EMAIL) { escreva ("Informe a sua senha: ") } leia (password) se ((password == SENHA1) ou (password == SENHA2) ou (password == SENHA3)) { escreva ("Sistema ativado!","\n") } senao { escreva ("Senha incorreta!") } } } Muito obrigado galera!
  12. Como faço para limitar um valor de salário para aumentar em porcentagem ? Ex: Preciso informar o nome e o salário. Funcionários que ganham entre 5 e 7mil o aumento vai ser de 14%, e o resultado precisa ser o salario mais a porcentagem. E que condição eu uso, se então ?
  13. Fazer um algoritmo que: • Leia um número indeterminado de linhas contendo cada uma a idade de um indivíduo. • A última linha que não entrará nos cálculos, contém o valor da idade igual a zero. • Calcule e escreva a idade média deste grupo de indivíduos. • Escreva também a maior idade e a menor Conseguir fazer ele, o problema é quando vai escrever a idade menor sempre da 1: algoritmo "Média_de_idades" // Função : Calcular a média de idades de qualquer número de pessoas // Autor : Anatanael Fonseca Barbosa // Data : 13/04/2018 // Seção de Declarações var cont,soma,idade,maior,menor:inteiro media:real inicio cont<-0 soma<-0 idade<-1 menor<-idade maior<-idade enquanto (idade>0) faca escreva("Digite a idade:") leia(idade) escolha idade caso 0 outrocaso se (idade < menor) então menor <- idade senao se idade > maior então maior <- idade fimse fimse fimescolha cont<-cont+1 soma<-soma+idade fimenquanto media<-soma/(cont-1) escreval("A média de idades é:",media) escreval ("MAIOR:",maior) escreval ("MENOR:",menor) fimalgoritmo
  14. Eu comecei a programar a muito pouco tempo, alguém poderia me ajudar numa pergunta? "Some os números de 1 a 100 e imprima o valor" (portugol)
  15. Faça um algoritmo que leia o salário bruto de um cidadão e depois exiba o salário líquido, valor da contribuição a previdência social e valor descontado de imposto de renda. Considere a seguinte situação: desconta-se inicialmente 11% do salário bruto do trabalhador, como contribuição à previdência social. Após esse primeiro desconto, poderá existir outro desconto do salário bruto, referente ao imposto de renda, com base nas seguintes situações. * Salário bruto inferior a R$ 1.500, não há desconto; * Salário bruto de R$ 1.500 até R$ 1.999, desconto de 5%; * Salário bruto de R$ 2.000 até R$ 3.499, desconto de 7%; * Salário bruto igual ou superior a R$ 3.500, desconto de 9,5%. ---- Gente, só está lendo os 5%, me ajudem inicio ---- real salbruto , salliqui , previd , renda , renda2 , renda3 , salliqui2 , salliqui3 escrever "Qual seu salário bruto?: " ler salbruto se salbruto < 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd senao se salbruto >= 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd fimse fimse escrever "\nDesconto da previdência " , salbruto se salbruto < 1500 então escrever "\nNão há desconto de Imposto de Renda" senao se salbruto >= 1500 ou salbruto <= 1999 então renda <- salbruto * 5 / 100 salliqui <- salbruto - renda escrever "\nSeu salário líquido é: " , salliqui senao se salbruto >= 2000 ou salbruto <= 3499 então renda2 <- salbruto * 7 / 100 salliqui2 <- salbruto - renda2 escrever "\nSeu salário líquido é: " , salliqui2 senao se salbruto >= 3500 então renda3 <- salbruto * 9.5 / 100 salliqui3 <- salbruto - renda3 escrever "\nSeu salário líquido é: " , salliqui3 fimse fimse fimse fimse fim
  16. Bem, foi me dado esse algoritmo para fazer mas tenho muitas duvidas de como ficaria Escreva um algoritmo para conversão de moedas onde o usuário deverá informar a quantidade a ser convertida e o nome do país. O algoritmo deverá relacionar o nome do país com um código, e por meio desse código realizar a conversão da quantia solicitada. Como saída o algoritmo deverá fornecer a quantidade na moeda desejada com o símbolo da moeda. A taxa de conversão deverá ser definida no algoritmo (taxa fictícia) e informada na saída juntamente com o resultado da conversão. Considere Código Símbolo País 790 BRL Brasil 996 FUA Costa do Marfim 470 JPY Japão 220 USD Estados Unidos Se puderem me ajudar agradeço.
  17. Alguém poderia transformar esse pseudo código de C para a linguagem Portugol? registro produto codigo: numérico nome: textual preco: numérico fim_registro quantidade_de_produtos = 5 declara produtos: produto[quantidade_de_produtos] para i=0 até quantidade_de_produtos faça leia produtos.codigo leia produtos.nome leia produtos.preco fim_para para i=0 até quantidade_de_produtos faça escreva produtos.codigo escreva produtos.nome fim_para declara codigo_digitado: numérico leia codigo_digitado para i=0 até quantidade_de_produtos faça se produtos.codigo == codigo_digitado então escreva produtos.preco fim_para Codigo em C se facilitar #include <stdio.h> typedef struct { long codigo; char nome[100]; float preco; } Produto; #define QUANTIDADE_DE_PRODUTOS 5 int main(){ Produto produtos[QUANTIDADE_DE_PRODUTOS]; printf("Campos: codigo-do-produto nome preco\n"); for(int i=0; (i < QUANTIDADE_DE_PRODUTOS); i++){ printf("\nInforme os dados do produto(%i): ",i+1); scanf("%ld %s %f",&produtos.codigo,produtos.nome, &produtos.preco); } for(int i=0; (i < QUANTIDADE_DE_PRODUTOS); i++){ printf("\n%ld\t%s R$ %1.2f", produtos.codigo, produtos.nome,produtos.preco); } long codigo_digitado; printf("\nInforme o codigo do produto: "); scanf("%ld", &codigo_digitado); for(int i=1; (i < QUANTIDADE_DE_PRODUTOS); i++){ if (produtos.codigo == codigo_digitado) { printf("\nPreço: R$ %1.2f\n", produtos.preco); } } getchar(); return 0; }
  18. Construa um algoritmo para gerenciar a venda de ingressos das poltronas numeradas de um teatro, que tem 100 lugares. Para cada nova reserva deve ser verificado se o assento se encontra disponível. questão pede para ser feita em matriz.~!
  19. » Criar um algoritmo que leia as informações de 4 produtos distintos (ex Tabela abaixo) e seja capaz de buscar um determinado produto informado pelo usuário e imprima na tela todas as informações sobre esse produto. » A estrutura possui o identificador “Produtos” e conta com os campos: Tipo, Preço e Quantidade em Estoque.
  20. Olá amigos do fórum,boa tarde! Iniciei a faculdade de Ads faz menos de 2 meses e não consigo aprender "Lógica de programação",alguém poderia me dá dicas? Uma ajuda nesse exercício aqui : Um cinema possui capacidade de 30 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário (sendo assim 30 pessoas responderam o questionário), no qual constava sua idade e sua opinião em relação ao filme, segundo as seguintes notas: 5 – ótimo, 4 –bom, 3 – Regular, 2 – Ruim, 1 – Péssimo. Elabore um algoritmo que leia estes dados, calcule e imprima: a quantidade de respostas de cada tipo; a média de idade das pessoas que responderam ruim; a percentagem de respostas péssimo e a maior idade que utilizou esta opção; média de idade das pessoas que responderam ótimo ou bom. Fazer o exercício sem usar vetores, caso o aluno saiba como utilizar vetores.
  21. Bom dia, gostaria que alguém me ajudasse a identificar o erro de um algoritmo para o seguinte exercício: Um cinema possui capacidade de 30 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário (sendo assim 30 pessoas responderam o questionário), no qual constava sua idade e sua opinião em relação ao filme, segundo as seguintes notas: 5 – ótimo, 4 –bom, 3 – Regular, 2 – Ruim, 1 – Péssimo. Elabore um algoritmo que leia estes dados, calcule e imprima: a quantidade de respostas de cada tipo; a média de idade das pessoas que responderam ruim; a percentagem de respostas péssimo e a maior idade que utilizou esta opção; média de idade das pessoas que responderam ótimo ou bom. Fazer o exercício sem usar vetores, caso o aluno saiba como utilizar vetores. //cinema inicio Nota, cont, contNT1, contNT2, contNT3, contNT4, contNT5 inteiro; maioridd, idade, idade1, idade2, idade4, idade5 inteiro; mediabo, mediar real; percentagem real; contNT1=0; contNT2=0; contNT3=0; contNT4=0; contNT5=0; Nota=0; idade1=0; idade2=0; idade4=0; idade5=0; idade=0; mediabo=0; mediar=0; Para cont de 1 até 30 passo 1 faça Escreva ("Digite a sua idade: "); Leia (idade); Escreva ("Digite uma nota, 5 -ótimo, 4 -bom, 3 -regular, 2 -ruim, 1 -péssimo: "); Leia (Nota); se Nota == 1 faça contNT1 = contNT1+1; maioridd=idade; idade>maioridd; maioridd=idade; senaose Nota==2 faça contNT2 = contNT2+1; idade2 = idade2+idade senaose Nota==3 faça contNT3 = contNT3+1; senaose Nota==4 faça contNT4 = contNT4+1; idade4 = idade4+idade senaose Nota==5 faça contNT5 = contNT5+1; idade5 = idade5+idade fimse fimse fimse fimse fimse fimpara mediabo= idade5+idade4/(contNT5+contNT4); mediar= idade2/contNT2; percentagem=(contNT1*100)/30; Escreval ("A quantidade de pessoas que responderam Ótimo foi: ", contNT5); Escreval ("A quantidade de pessoas que responderam Bom foi: ", contNT4); Escreval ("A quantidade de pessoas que responderam Regular foi: ", contNT3); Escreval ("A quantidade de pessoas que responderam Ruim foi: ", contNT2); Escreval ("A quantidade de pessoas que responderam Péssimo foi: ", contNT1); Escreval ("A percentagem de pessoas que responderam Péssimo foi de: ", percentagem); Escreval ("A idade da pessoa mais velha que respondeu Péssimo é: ". maioridd); Escreval ("A média de idade das pessoas que responderam ruin foi: ", mediar); Escreval ("A média de idade das pessoas que responderam bom ou ótimo foi: ", mediabo); fim
  22. Olá preciso que vocês me ajudem pois sou iniciante e não sei se isso é para ser feito em Portugol ou Visualg, mas alguem pode resolver para mim em portugol? Por favor me ajudem. 3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos números maiores que 30 foram digitados.
  23. Aonde está o erro? Não estou conseguindo fazer. Função : f(x)=2x+4 Desenvolver um programa para calcular a área definida entre o gráfico de uma função e o eixo x dentro de um valor inicial x=a até um valor final x=b sugestão: construir uma função que receba um valor de x e retorne o valor de f(x) para uma função matemática qualquer (adotar). Com isso podemos calcular facilmente para qualquer função (é só trocar)
  24. Não estou conseguindo fazer a questão que meu professor passou: Fazer um programa que receba 3 números e depois exiba-os em ordem crescente. Está aparecendo ERROR CALCULATE inicio inteiro A, B, C escrever("Digite um número: ") ler A escrever("Digite um numero: ") ler B escrever("Digite um número: ") ler C se (A>B) e (B>C) então escrever("Essa é a ordem crescente dos números citados: ", C, B, A) senao se (B>A) e (A>C) então escrever("Essa é a ordem crescente dos números citados: ", C, A, B) senao se (C>A) e (A>B) então escrever("Essa é a ordem crescente dos números citados: ", B, A, C) senao se (B>C) e (C>A) então escrever("Essa é a ordem crescente dos números citados: ", A, C, B) senao se (A>C) e (C>B) então escrever("Essa é a ordem crescente dos números citados: ", B, C, A) senao se (C>B) e (B>A) então escrever("Essa é a ordem crescente dos números citados: ", A, B, C) fimse fimse fimse fimse fimse fimse fim
  25. Dada uma matriz real A3x3, verificar e mostrar se existem elementos repetidos em A. (fiz o código mas o professor disse que o certo é mostra na tela no máximo 4 valores repetidos e disse que a melhor forma é armazena num vetor. ) ps: primeira postagem. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×