Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''Portugol''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 32 registros

  1. Como faço para limitar um valor de salário para aumentar em porcentagem ? Ex: Preciso informar o nome e o salário. Funcionários que ganham entre 5 e 7mil o aumento vai ser de 14%, e o resultado precisa ser o salario mais a porcentagem. E que condição eu uso, se então ?
  2. Fazer um algoritmo que: • Leia um número indeterminado de linhas contendo cada uma a idade de um indivíduo. • A última linha que não entrará nos cálculos, contém o valor da idade igual a zero. • Calcule e escreva a idade média deste grupo de indivíduos. • Escreva também a maior idade e a menor Conseguir fazer ele, o problema é quando vai escrever a idade menor sempre da 1: algoritmo "Média_de_idades" // Função : Calcular a média de idades de qualquer número de pessoas // Autor : Anatanael Fonseca Barbosa // Data : 13/04/2018 // Seção de Declarações var cont,soma,idade,maior,menor:inteiro media:real inicio cont<-0 soma<-0 idade<-1 menor<-idade maior<-idade enquanto (idade>0) faca escreva("Digite a idade:") leia(idade) escolha idade caso 0 outrocaso se (idade < menor) então menor <- idade senao se idade > maior então maior <- idade fimse fimse fimescolha cont<-cont+1 soma<-soma+idade fimenquanto media<-soma/(cont-1) escreval("A média de idades é:",media) escreval ("MAIOR:",maior) escreval ("MENOR:",menor) fimalgoritmo
  3. Eu comecei a programar a muito pouco tempo, alguém poderia me ajudar numa pergunta? "Some os números de 1 a 100 e imprima o valor" (portugol)
  4. Faça um algoritmo que leia o salário bruto de um cidadão e depois exiba o salário líquido, valor da contribuição a previdência social e valor descontado de imposto de renda. Considere a seguinte situação: desconta-se inicialmente 11% do salário bruto do trabalhador, como contribuição à previdência social. Após esse primeiro desconto, poderá existir outro desconto do salário bruto, referente ao imposto de renda, com base nas seguintes situações. * Salário bruto inferior a R$ 1.500, não há desconto; * Salário bruto de R$ 1.500 até R$ 1.999, desconto de 5%; * Salário bruto de R$ 2.000 até R$ 3.499, desconto de 7%; * Salário bruto igual ou superior a R$ 3.500, desconto de 9,5%. ---- Gente, só está lendo os 5%, me ajudem inicio ---- real salbruto , salliqui , previd , renda , renda2 , renda3 , salliqui2 , salliqui3 escrever "Qual seu salário bruto?: " ler salbruto se salbruto < 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd senao se salbruto >= 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd fimse fimse escrever "\nDesconto da previdência " , salbruto se salbruto < 1500 então escrever "\nNão há desconto de Imposto de Renda" senao se salbruto >= 1500 ou salbruto <= 1999 então renda <- salbruto * 5 / 100 salliqui <- salbruto - renda escrever "\nSeu salário líquido é: " , salliqui senao se salbruto >= 2000 ou salbruto <= 3499 então renda2 <- salbruto * 7 / 100 salliqui2 <- salbruto - renda2 escrever "\nSeu salário líquido é: " , salliqui2 senao se salbruto >= 3500 então renda3 <- salbruto * 9.5 / 100 salliqui3 <- salbruto - renda3 escrever "\nSeu salário líquido é: " , salliqui3 fimse fimse fimse fimse fim
  5. Bem, foi me dado esse algoritmo para fazer mas tenho muitas duvidas de como ficaria Escreva um algoritmo para conversão de moedas onde o usuário deverá informar a quantidade a ser convertida e o nome do país. O algoritmo deverá relacionar o nome do país com um código, e por meio desse código realizar a conversão da quantia solicitada. Como saída o algoritmo deverá fornecer a quantidade na moeda desejada com o símbolo da moeda. A taxa de conversão deverá ser definida no algoritmo (taxa fictícia) e informada na saída juntamente com o resultado da conversão. Considere Código Símbolo País 790 BRL Brasil 996 FUA Costa do Marfim 470 JPY Japão 220 USD Estados Unidos Se puderem me ajudar agradeço.
  6. Alguém poderia transformar esse pseudo código de C para a linguagem Portugol? registro produto codigo: numérico nome: textual preco: numérico fim_registro quantidade_de_produtos = 5 declara produtos: produto[quantidade_de_produtos] para i=0 até quantidade_de_produtos faça leia produtos.codigo leia produtos.nome leia produtos.preco fim_para para i=0 até quantidade_de_produtos faça escreva produtos.codigo escreva produtos.nome fim_para declara codigo_digitado: numérico leia codigo_digitado para i=0 até quantidade_de_produtos faça se produtos.codigo == codigo_digitado então escreva produtos.preco fim_para Codigo em C se facilitar #include <stdio.h> typedef struct { long codigo; char nome[100]; float preco; } Produto; #define QUANTIDADE_DE_PRODUTOS 5 int main(){ Produto produtos[QUANTIDADE_DE_PRODUTOS]; printf("Campos: codigo-do-produto nome preco\n"); for(int i=0; (i < QUANTIDADE_DE_PRODUTOS); i++){ printf("\nInforme os dados do produto(%i): ",i+1); scanf("%ld %s %f",&produtos.codigo,produtos.nome, &produtos.preco); } for(int i=0; (i < QUANTIDADE_DE_PRODUTOS); i++){ printf("\n%ld\t%s R$ %1.2f", produtos.codigo, produtos.nome,produtos.preco); } long codigo_digitado; printf("\nInforme o codigo do produto: "); scanf("%ld", &codigo_digitado); for(int i=1; (i < QUANTIDADE_DE_PRODUTOS); i++){ if (produtos.codigo == codigo_digitado) { printf("\nPreço: R$ %1.2f\n", produtos.preco); } } getchar(); return 0; }
  7. Construa um algoritmo para gerenciar a venda de ingressos das poltronas numeradas de um teatro, que tem 100 lugares. Para cada nova reserva deve ser verificado se o assento se encontra disponível. questão pede para ser feita em matriz.~!
  8. » Criar um algoritmo que leia as informações de 4 produtos distintos (ex Tabela abaixo) e seja capaz de buscar um determinado produto informado pelo usuário e imprima na tela todas as informações sobre esse produto. » A estrutura possui o identificador “Produtos” e conta com os campos: Tipo, Preço e Quantidade em Estoque.
  9. Olá amigos do fórum,boa tarde! Iniciei a faculdade de Ads faz menos de 2 meses e não consigo aprender "Lógica de programação",alguém poderia me dá dicas? Uma ajuda nesse exercício aqui : Um cinema possui capacidade de 30 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário (sendo assim 30 pessoas responderam o questionário), no qual constava sua idade e sua opinião em relação ao filme, segundo as seguintes notas: 5 – ótimo, 4 –bom, 3 – Regular, 2 – Ruim, 1 – Péssimo. Elabore um algoritmo que leia estes dados, calcule e imprima: a quantidade de respostas de cada tipo; a média de idade das pessoas que responderam ruim; a percentagem de respostas péssimo e a maior idade que utilizou esta opção; média de idade das pessoas que responderam ótimo ou bom. Fazer o exercício sem usar vetores, caso o aluno saiba como utilizar vetores.
  10. Bom dia, gostaria que alguém me ajudasse a identificar o erro de um algoritmo para o seguinte exercício: Um cinema possui capacidade de 30 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário (sendo assim 30 pessoas responderam o questionário), no qual constava sua idade e sua opinião em relação ao filme, segundo as seguintes notas: 5 – ótimo, 4 –bom, 3 – Regular, 2 – Ruim, 1 – Péssimo. Elabore um algoritmo que leia estes dados, calcule e imprima: a quantidade de respostas de cada tipo; a média de idade das pessoas que responderam ruim; a percentagem de respostas péssimo e a maior idade que utilizou esta opção; média de idade das pessoas que responderam ótimo ou bom. Fazer o exercício sem usar vetores, caso o aluno saiba como utilizar vetores. //cinema inicio Nota, cont, contNT1, contNT2, contNT3, contNT4, contNT5 inteiro; maioridd, idade, idade1, idade2, idade4, idade5 inteiro; mediabo, mediar real; percentagem real; contNT1=0; contNT2=0; contNT3=0; contNT4=0; contNT5=0; Nota=0; idade1=0; idade2=0; idade4=0; idade5=0; idade=0; mediabo=0; mediar=0; Para cont de 1 até 30 passo 1 faça Escreva ("Digite a sua idade: "); Leia (idade); Escreva ("Digite uma nota, 5 -ótimo, 4 -bom, 3 -regular, 2 -ruim, 1 -péssimo: "); Leia (Nota); se Nota == 1 faça contNT1 = contNT1+1; maioridd=idade; idade>maioridd; maioridd=idade; senaose Nota==2 faça contNT2 = contNT2+1; idade2 = idade2+idade senaose Nota==3 faça contNT3 = contNT3+1; senaose Nota==4 faça contNT4 = contNT4+1; idade4 = idade4+idade senaose Nota==5 faça contNT5 = contNT5+1; idade5 = idade5+idade fimse fimse fimse fimse fimse fimpara mediabo= idade5+idade4/(contNT5+contNT4); mediar= idade2/contNT2; percentagem=(contNT1*100)/30; Escreval ("A quantidade de pessoas que responderam Ótimo foi: ", contNT5); Escreval ("A quantidade de pessoas que responderam Bom foi: ", contNT4); Escreval ("A quantidade de pessoas que responderam Regular foi: ", contNT3); Escreval ("A quantidade de pessoas que responderam Ruim foi: ", contNT2); Escreval ("A quantidade de pessoas que responderam Péssimo foi: ", contNT1); Escreval ("A percentagem de pessoas que responderam Péssimo foi de: ", percentagem); Escreval ("A idade da pessoa mais velha que respondeu Péssimo é: ". maioridd); Escreval ("A média de idade das pessoas que responderam ruin foi: ", mediar); Escreval ("A média de idade das pessoas que responderam bom ou ótimo foi: ", mediabo); fim
  11. Olá preciso que vocês me ajudem pois sou iniciante e não sei se isso é para ser feito em Portugol ou Visualg, mas alguem pode resolver para mim em portugol? Por favor me ajudem. 3. Escreva um algoritmo em PORTUGOL que receba 15 números e imprima quantos números maiores que 30 foram digitados.
  12. Aonde está o erro? Não estou conseguindo fazer. Função : f(x)=2x+4 Desenvolver um programa para calcular a área definida entre o gráfico de uma função e o eixo x dentro de um valor inicial x=a até um valor final x=b sugestão: construir uma função que receba um valor de x e retorne o valor de f(x) para uma função matemática qualquer (adotar). Com isso podemos calcular facilmente para qualquer função (é só trocar)
  13. Não estou conseguindo fazer a questão que meu professor passou: Fazer um programa que receba 3 números e depois exiba-os em ordem crescente. Está aparecendo ERROR CALCULATE inicio inteiro A, B, C escrever("Digite um número: ") ler A escrever("Digite um numero: ") ler B escrever("Digite um número: ") ler C se (A>B) e (B>C) então escrever("Essa é a ordem crescente dos números citados: ", C, B, A) senao se (B>A) e (A>C) então escrever("Essa é a ordem crescente dos números citados: ", C, A, B) senao se (C>A) e (A>B) então escrever("Essa é a ordem crescente dos números citados: ", B, A, C) senao se (B>C) e (C>A) então escrever("Essa é a ordem crescente dos números citados: ", A, C, B) senao se (A>C) e (C>B) então escrever("Essa é a ordem crescente dos números citados: ", B, C, A) senao se (C>B) e (B>A) então escrever("Essa é a ordem crescente dos números citados: ", A, B, C) fimse fimse fimse fimse fimse fimse fim
  14. Dada uma matriz real A3x3, verificar e mostrar se existem elementos repetidos em A. (fiz o código mas o professor disse que o certo é mostra na tela no máximo 4 valores repetidos e disse que a melhor forma é armazena num vetor. ) ps: primeira postagem. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }
  15. galera preciso resolver esse problema, uri 1021: Leia um valor de ponto flutuante com duas casas decimais. Este valor representa um valor monetário. A seguir, calcule o menor número de notas e moedas possíveis no qual o valor pode ser decomposto. As notas consideradas são de 100, 50, 20, 10, 5, 2. As moedas possíveis são de 1, 0.50, 0.25, 0.10, 0.05 e 0.01. A seguir mostre a relação de notas necessárias. Entrada O arquivo de entrada contém um valor de ponto flutuante N (0 ≤ N ≤ 1000000.00). Saída Imprima a quantidade mínima de notas e moedas necessárias para trocar o valor inicial, conforme exemplo fornecido. eu consegui fazer com que calcule o numero de cédulas mas nao consigo fazer com que calcule o numero de moedas. meu algoritmo ta assim : var V: inteiro N100, N50, N20, N10, N5, N2: INTEIRO R100, R50, R20, R10, R5, R2:INTEIRO inicio // Seção de Comandos ESCREVA ("VALOR DO SAQUE: ") LEIA (V) N100<-V DIV 100 R100<-V MOD 100 N50<-r100 DIV 50 R50<-R100 MOD 50 N20<-r50 DIV 20 R20<-R50 MOD 20 N10<-r20 DIV 10 R10<-R20 MOD 10 N5<-r10 DIV 5 R5<-R10 MOD 5 N2<-R5 DIV 2 R2<-R5 MOD 2 ESCREVAL ("CEDULAS DE 100: ",N100) ESCREVAL ("CEDULAS DE 50: ",N50) ESCREVAL ("CEDULAS DE 20: ",N20) ESCREVAL ("CEDULAS DE 10: ",N10) ESCREVAL ("CEDULAS DE 5: ",N5) ESCREVAL ("CEDULAS DE 2: ",N2) fimalgoritmo Alguem pode me ajudar a como posso fazer para colocar o numero de moedas tmb
  16. Enunciado da questão: Crie um algoritmo que receba nome, sexo e idade. Se o sexo for masculino, perguntar se gosta de futebol junto à resposta entre sim ou não. Se for feminino, perguntar se gosta de novela, com a mesma função de resposta. Caso a resposta for negativa de ambas as partes, encerrar o questionário com uma mensagem de encerramento. Meu projeto está funcionando até a parte masculina, quando coloco a feminina, não executa. Essa é até a parte que está funcionando: inicio inteiro idade texto nome, sexo, futebol, novela escrever "Informe seu nome: " ler nome escrever "- Seu nome é: " , nome escrever "\nQual sua idade?: " ler idade escrever "- Você tem: " , idade ," anos" escrever "\nInforme seu sexo (M ou F): " ler sexo se sexo = "M" ou sexo = "m" então escrever "-(Masculino)" escrever "\nVocê gosta de futebol?: " ler futebol se futebol = "s" ou futebol = "sim" então escrever "-(Sim)" senão escrever "-(Não)" fimse fimse fim
  17. Bom Dia Não tenho muito conhecimento em criar "Bat" e gostaria de uma ajuda se possível. Preciso criar uma bat onde eu possa pesquisar pastas onde contém 7 números ex: "7207639" porém o primeiro numero é variável pois o sistema gera automático, ele pode iniciar com "7,6 ,0 ou 5" então eu teria que digitar "*207639" e a bat trazer o valor encontrado de "7207639" e seu tamanho "se possível" e mostrar em qual dos diretórios ela se encontra. \\saowsr0096\Shared\INF\ARCHIVE\ \\saolsr0028\psc\psc\londri\ \\136.238.5.63\outputssao\WORKING\ normalmente quando para aqui ela está com erro" \\136.238.5.63\outputssao\ARCHIVE\ "A extensão aqui é "7207639.tar.gz" Muito Obrigado
  18. Boa noite galera, eu perdi muitas aulas e estou estando pra uma prova(substitutiva) de algoritmos através de videos e estou sofrendo em alguns exercício da lista. Exercícios da lista 1) Faça um algoritmo que crie um procedimento que calcule o fatorial de um número, usando uma função que retorne o valor do fatorial para o bloco que chamou essa função. algoritmo var n, c, fat: inteiro funcao fatorial(x: inteiro): inteiro inicio Retorne fat fimfuncao inicio fat <- 1 escreva("Digite um numero: ") leia(n) para c <- 1 ate n passo 1 faca fat <- fat * c fimpara escreva("O fatorial de ", n, " = ", fat) fimalgoritmo Alguém poderia olhar e ver se já está certo? Caso esteja errado me fale qual o erro fazendo favor! O código está rodando normalmente, mas nunca se sabe né... Procurei vídeos explicando e não achei, só achei um exercício parecido com esse porém achei muito confuso.... Obrigado!
  19. Me ajudem com esses exercícios no Portugol Declare uma matriz 5 x 5. Faça com que o computador preencha com 1 a diagonal principal e com 0 os demais elementos. Escreva ao final a matriz obtida. Leia uma matriz 6 x 6, conte e escreva quantos valores maiores que 10 ela possui.
  20. programa { funcao inicio() { inteiro v[10] para(inteiro i = 0; i < 10; i++){ v[i]=5*(i+1) } escreva("Acabou") } } anunciado: Crie um programa que preencha automaticamente (usando lógica, não apenas atribuindo diretamente) um vetor numérico com 10 posições o cada dado dentro do vetor tem que ser múltiplo de 5 será que fiz certo?
  21. "logico: inclui apenas os valores lógicos falso e verdadeiro e as operações de negação, conjunção e disjunção." Retirado do artigo da UFRN https://www.dimap.ufrn.br/~richard/pubs/dim0320/readings/aula03.pdf O que são valores lógicos falso e verdadeiro? O que são operações de negação, conjunção e disfunção?
  22. Como eu posso compreender as vantagens e desvantagens do Portugol? Procurei na net, mas não me ajudou muito.
  23. Alguém tem referências bibliográficas para como eu posso diferenciar as variáveis lógico, caractere, inteiro e rea? Procurei na internet e não me ajudou. Desde já agradeço pela ajuda.
  24. Alguém me ajuda a resolver essas questões, consegui fazer mas não por completo. 1° Faça um algoritmo que calcule o valor de A, dado por: A = N + N-1/2 + n-2/3...1/n , onde N é um número inteiro positivo? - Ler o valor inteiro de N - Ler o Número de termos que serão calculados da sequência - Calcular e imprimir o valor correto da sequencia 2° Dada uma MAT de 4 x 5 elementos, faça um programa para somar os elementos de cada linha gerando um vetor SOMA, em seguida somar os elementos do vetor SOMA na variável TOTAL que deve ser impressa no final. 3° Crie um programa que entre com valores inteiros para uma matriz m 3 x 3 e imprima a matriz final. 1 2 3 9 8 7 4 5 6 a matriz gira 180° 6 5 4 7 8 9 3 2 1 4 ° - Calcula a Média Aritmética dos elementos hachurados na letra "A" - O maior elemento da linha onde se encontra o menor elementos da área hachurada na letra "B"
  25. Galera preciso Incluir uma FUNÇÃO neste exercício vai cair na prova e professor falou que é igual porém tem que incluir a a função: 24 – Faça um algoritmo em pseudocódigo que calcule a transposta de uma matriz de 2 linhas e 3 colunas através de um procedimento. Matriz transposta, em matemática, é o resultado da troca de linhas por colunas em uma determinada matriz. Uma matriz simétrica é toda a matriz que é igual à sua transposta. Algoritmo Transposta VAR i,j: inteiro M: Matriz [1...2,1...3] de inteiro Procedimento Transposta (X:Matriz [1...2,1...3] de inteiro) Var T: Matriz [1...3,1...2] de inteiro Inicio Para i de 1 até 2 Faça Inicio Para j de 1 até 3 Faça Inicio T[j,i] := X[i,j] Escreva (“O elemento “, j, “,”, i, “é:”, T[j,i] Fim Para Fim Para Fim Procedimento Inicio Para i de 1 até 2 Faça Inicio Para j de 1 até 3 Faça Inicio Escreva “Entre com o valor do elemento da linha “, i, “e da coluna”, j Leia M[i,j] Fim Para Fim Para Transposta[M] Fim Algoritmo COMO FICARIA COM A FUNÇÃO E COM PPROCEDIMENTO?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×