Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''Portugol''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Caixas de som

Encontrado 53 registros

  1. Bom dia, Gostaria da ajuda de vocês, estou tentando criar o jogo dos 8, na qual você tem uma matriz 3x3 e a tabela padrão é de 1 ate 0, e uma tabela aleatoria, e a a função do programa é arrumar a tabela aleatoria para ficar igual a padrão. Só que eu consigo ir mudando as posições apenas para cima e para esquerda, mas quando coloco para direita e para baixo o programa dá erro, não estou conseguindo resolver esse problema, e outro problema é que eu não estou conseguindo limitar o movimento caso eu aperte para esquerda e a matriz acabar eu teria que repetir outro movimento para não ultrapassar a matriz. O meu código é esse. algoritmo "Trabalho Final" // Função : Jogar // Autor : Luiz Felipe rodrigues da Silva // Data : 24/09/2018 var vet :vetor [1..9] de inteiro tab3: vetor[1..3,1..3] de inteiro tab3a: vetor[1..3,1..3] de inteiro aux, i, j, l, c, linha, coluna,tabuleiro, cont, opcao: inteiro inicio //Escolha do tabuleiro repita Escreval("Escolha o modo de jogo:") Escreval("(1) Fácil") Escreval("(2) Normall") Escreval("(3) Difícil") Leia(tabuleiro) ate((tabuleiro = 1) ou (tabuleiro = 2) ou (tabuleiro = 3)) Limpatela escolha (tabuleiro) //Tabuleiro 3X3 caso 1 //Tabela padrão Escreval("Como a tabele deve ficar") Escreval() cont <- 0 para linha de 1 ate 3 faca para coluna de 1 ate 3 faca tab3[linha,coluna]<- cont + 1 cont <- cont + 1 fimpara fimpara tab3[3,3] <- 0 para linha de 1 ate 3 faca para coluna de 1 ate 3 faca escreva(tab3[linha,coluna]) fimpara escreval() fimpara escreval() //Tabela aleatória para i de 1 ate 9 faca vet <- Randi(9) se i > 1 entao j <- 1 enquanto (j < i) faca se vet = vet[j] entao vet <- randi(9) j <- 1 senao j <- j+1 fimse fimenquanto fimse tab3a[1,1] <- vet[1] tab3a[1,2] <- vet[2] tab3a[1,3] <- vet[3] tab3a[2,1] <- vet[4] tab3a[2,2] <- vet[5] tab3a[2,3] <- vet[6] tab3a[3,1] <- vet[7] tab3a[3,2] <- vet[8] tab3a[3,3] <- vet[9] fimpara escreval("-----------------------------------------------------") escreval("Faça o movimento do 0 até igualar a tabela padrão") escreval() para l de 1 ate 3 faca para c de 1 ate 3 faca escreva(tab3a[l,c]) fimpara escreval() fimpara escreval("-----------------------------------------------------") //escolha dos movimentos repita escreval("Faça os movimentos com as teclas 4 para (esquerda),8 para (cima),6 para (direita) ou 2 para (baixo") repita leia (opcao) ate ((opcao = 4) ou (opcao = 6) ou (opcao = 2) ou (opcao = 8)) escolha opcao //Movimento esquerda caso 4 para l de 1 ate 3 faca para c de 1 ate 3 faca se (tab3a[l,c] = 0) entao aux <- tab3a[l,c] tab3a[l,c] <- tab3a[l,c-1] tab3a[l,c-1] <- aux fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 3 faca escreva(tab3a[l,c]) fimpara escreval() fimpara //Movimento para cima caso 8 para l de 1 ate 3 faca para c de 1 ate 3 faca se (tab3a[l,c] = 0) entao aux <- tab3a[l,c] tab3a[l,c] <- tab3a[l-1,c] tab3a[l-1,c] <- aux fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 3 faca escreva(tab3a[l,c]) fimpara escreval() fimpara //Movimento para direita caso 6 para l de 1 ate 3 faca para c de 1 ate 3 faca se (tab3a[l,c] = 0) entao aux <- tab3a[l,c] tab3a[l,c] <- tab3a[l,c+1] tab3a[l,c+1] <- aux fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 3 faca escreva(tab3a[l,c]) fimpara escreval() fimpara //movimento para baixo caso 2 para l de 1 ate 3 faca para c de 1 ate 3 faca se (tab3a[l,c] = 0) entao aux <- tab3a[l,c] tab3a[l,c] <- tab3a[l+1,c] tab3a[l+1,c] <- aux fimse fimpara fimpara para l de 1 ate 3 faca para c de 1 ate 3 faca escreva(tab3a[l,c]) fimpara escreval() fimpara fimescolha ate (tab3[linha,coluna]=tab3a[l,c]) caso 2 escreval("2") caso 3 escreval("3") fimescolha fimalgoritmo
  2. Galera estou precisando criar um programa com laço de repetição mais estou com uma dúvida enorme em desenvolver será que alguém poderia me ajudar por favor) (LAÇO) Solicite para o usuário nome e sexo de pessoas, ao final da entrada desses dados pergunte para o usuário se o mesmo deseja digitar mais pessoas, se sim solicite novamente os dados, se não, encerre o programa e exiba a quantidade de pessoas que foram digitadas, o total de pessoas do sexo masculino, o total do sexo feminino, o total de sexo inválido e a porcentagem de cada um.
  3. Faça um algoritmo que leia dez valores, armazenando num vetor, e diga qual par forneceu a maior média e qual par forneceu a segunda maior média Eu só consegui fazer o básico, não faço a mínima ideia de como conseguir a maior média, muito menos saber qual par gerou isso. var valores: vetor [1..10] de inteiro count: inteiro inicio para count de 1 ate 10 faca leia (valores[count]) fimpara fimalgoritmo
  4. Joãozinho tem em suas mãos um pequeno problema. A professora lhe pediu que ele construísse um programa para verificar, à partir de dois valores inteiros A e B, se B corresponde aos últimos dígitos de A. Entrada A entrada consiste de dois números inteiros positivos (A e B), onde: (1 ≤ A < 9.999.999) e (1 ≤ B < 9.999.999) Saída A saída consiste de uma mensagem indicando se o segundo valor ‘Encaixa’ ou ‘Não Encaixa’ no primeiro valor, conforme exemplos abaixo. Exemplo de Entrada Exemplo de Saída A = 5678690 B = 78690 Encaixa A = 5434554 B = 543 Não Encaixa A = 1243 B = 1243 Encaixa A = 54 B = 654 Não Encaixa A = 9999999 B = 9999999 Encaixa A solução não pode utilizar nenhum tipo de estrutura de repetição. Apenas estruturas de seleção e operações aritméticas queria alguma ideia de como fazer
  5. Alguém poderia me informar se está correto o algoritmo para números triangulares? No enunciado falava que um número triangular é o resultado do produto de três números consecutivos.
  6. Bom dia pessoal! Estou iniciando por conta própria nesse mundo da programação, porém me deparei com um exercício de algoritmo que a meu ver minha lógica está correta. Bom, o exercício é o seguinte: Entrar com o dia e o mês de uma data e informar quantos dias se passaram desde o início do ano. Esqueça a questão dos anos bissextos e considere sempre que um mês possui 30 dias. Minha lógica; algoritmo "semnome" var Mes,TotDias: inteiro inicio Escreval("Informe o mês atual(em numeros):") leia(Mes) TotDias <- (Mes * 30) Escreval("Passaram-se o total de ",TotDias," dias desde o inicio do ano.") fimalgoritmo Ao meu ver minha Lógica está correta, porém não entendi o porque de informar alem do mes o dia......? O dia já não estaria incluido no total de dias corridos até o mes atual? Se alguém puder ajudar agradeço.
  7. Preciso criar um programa que leia 4 números e apresente eles em ordem inversa da grandeza. Alguém consegue me ajudar? Estou usando o Pascalzim
  8. Alguém poderia me ajudar com estes exercícios? 1) Elabore um algoritmo que leia um conjunto de 150 números inteiros e positivos fornecidos pelo usuário. Calcular e apresentar a soma dos números pares, impares e a soma desses dois resultados 2) Uma empresa decide dar um aumento de 30% aos funcionários cujo salário seja inferior a 1500 reais. Elabore um algoritmo que possa efetuar o cálculo do salário reajustado de cada funcionário e o total de funcionários que receberam o reajuste, sabendo que a empresa possui 2000 colaboradores. As respostas devem ser em pseudocódigo e os algoritmos devem ser feitos com a estrutura de repetição Para
  9. Uma empresa decidiu dar um aumento de 10% aos seus funcionários. Escreva um algoritmo em PETEQS que leia um salário e imprima o novo valor deste salário após o aumento dado.
  10. Gostaria que vocês me recomendassem livros sobre programação do básico ao avançado. Se tiver colocado no tópico errado peço desculpa.
  11. Enfim, eu estou criando um jogo no Portugol Studio (Show do Milhão), é um jogo de perguntas e respostas... Porém, meu trabalho tem que ter o modo de 2 jogadores (Multiplayer) E eu não tenho ideia de como fazer esse Loop na mesma pergunta para que os 2 jogadores respondam, e só assim ir pra próxima pergunta Vou deixar parte do código aqui pra entenderem melhor se (jogadores==2) //2 JOGADORES { escreva("Digite nome/apelido do primeiro jogador: ") leia(nome_jogador1) escreva("Digite nome/apelido do segundo jogador: ") leia(nome_jogador2) limpa() escreva("Qual o nível de dificuldade que desejam jogar?\n") escreva("\n") escreva("1 - Fácil\n") escreva("2 - Médio\n") escreva("3 - Difícil\n") escreva("Digite o número da dificuldade aqui: ") leia(dificuldade) limpa() para (inteiro i = 1; i <= sorteios; i++) //Sortear qual jogador irá começar { valor_sorteado = u.sorteia(valor_inicial, valor_final) se (valor_sorteado==1) //Se o valor for 1, logo o jogador número 1 irá começar { escreva("O jogador ", nome_jogador1) escreva(" que irá começar a responder\n\n") } se (valor_sorteado==2) //Se o valor for 2, logo o jogador número 2 irá começar { escreva("O jogador ", nome_jogador2) escreva(" que irá começar a responder\n\n") } } se (dificuldade==1) { escreva("Nível de dificuldade: Fácil\n\n") escreva("Pergunta nº1\n\n") escreva("Qual desses componentes, é um componente de armazenamento?\n") escreva("1 - HD\n") escreva("2 - Processador\n") escreva("3 - Memória Ram\n") escreva("4 - placa-mãe\n") escreva("5 - Fonte\n") escreva("Digite sua resposta aqui: ") leia(resposta1) se (resposta1==1) { escreva("\n") escreva("Você acertou!\n") escreva("----------------------------\n\n") acertos = acertos+1 } senao { escreva("\n") escreva("Você errou, que pena.\n") escreva("----------------------------\n\n") erros = erros+1 } escreva("Pergunta nº2\n\n") escreva("Qual o maior espaço de um disco abaixo?\n") escreva("1 - 500GB\n") escreva("2 - 250GB\n") escreva("3 - 1TB\n") escreva("4 - 40GB\n") escreva("5 - 80GB\n") escreva("Digite sua resposta aqui: ") leia(resposta2) Se puderem me ajudar com isso, irei ficar muito grato. Obs: Como eu posso identificar qual jogador foi sorteado na primeira pergunta? E ordenar para que os 2 jogadores respondam a mesma questão (só assim pra ir pra próxima)!? Obs²: São 5 perguntas no modo fácil, 5 no modo médio e 5 no modo difícil... Cada pergunta com 5 alternativas (Já feito). copa.rar
  12. Olha eu de novo novamente, boa noite, juro q tentei resolver o problema mas não consegui, quando eu escolho os casos de 1 a 4, o "Desenho" aparece e apaga mt rápido, como posso resolver isso? algoritmo "semnome" var M:Vetor[1..4, 1..4] de inteiro R,L,C:Inteiro Procedimento Matriz() inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva(M[L,C]:4) Fimpara Escreval() Fimpara Fimprocedimento Procedimento Diagonal() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L=C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento Procedimento Superior() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L<C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento Procedimento Inferior() Inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Se (L>C) então Escreva(M[L,C]:4) Senao Escreva("":4) Fimse Fimpara Escreval() Fimpara Fimprocedimento inicio Para L <- 1 ate 4 faca Para C <- 1 ate 4 faca Escreva("Digite o valor da posição [",L,",",C,"]") Leia(M[L,C]) Fimpara Fimpara Limpatela Repita Limpatela Escreval("=====================") Escreval(" Menu De Opções ") Escreval("=====================") Escreval("[1]Mostrar a Matriz ") Escreval("[2]Diagonal Principal") Escreval("[3]Triangulo Superior") Escreval("[4]Triangulo Inferior") Escreval("[5]Sair") Escreva("Escolha: ") Leia(R) Escolha R Caso 1 Matriz() Caso 2 Diagonal() Caso 3 Superior() Caso 4 Inferior() Limpatela FimEscolha Ate (R = 5) fimalgoritmo
  13. Boa noite, olha eu aqui dnv... Bom, estava fazendo um algoritmo para reservar poltronas no cinema, ocorreu tudo certinho, maaaas ocorreu algo inusitado, quando eu reservo uma cadeira, a linha --Escreva("Cadeira B",[N]," Reservada") --não aparece na tela, alguem pode me dizer porque acontece isso? conflito de comandos ou sla.... algoritmo "semnome" var Cadeira:Vetor[1..10] de Caractere C, N:Inteiro R :Caractere inicio Para C <- 1 ate 10 faca Cadeira[C] <- "OK" Fimpara Repita Para C <- 1 ate 10 faca Se Cadeira[C]="OK" então Escreva("[B",C,"]") Senao Escreva("[--]") Fimse Fimpara Escreval("") Escreva("Reservar Cadeira: B") Leia(N) Se (Cadeira[N]="OK") então Cadeira[N] <- "X" Escreva("Cadeira B",[N]," Reservada") Senao Escreval("ERROR Cadeira já reservada, Tente novamente") Fimse Escreva("Deseja Reservar outra cadeira?[S/N] ") Leia(R) Limpatela ate(R="N") fimalgoritmo
  14. Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código. Alguém pode me ajudar? ele tem como finalidade, comparar as questões dos alunos, contar a quantidade de acertos e dar as notas. Algoritmo "Gabarito" Var Gab : Vetor[1..5] de Caractere Nome: Vetor[1..3] de Caractere GabA: Vetor[1..5] de Caractere Nota: Vetor[1..3] de Real C : Inteiro Inicio Escreval("-----------------------------") Escreval("Passo 1- Cadastro de gabarito") Escreval("-----------------------------") Para C <- 1 ate 5 Faca Escreva("Questão ",C,": ") Leia(Gab[C]) Fimpara Limpatela Para C <- 1 ate 3 faca Escreval("-----------------------------") Escreval(" Aluno C ") Escreval("-----------------------------") Escreva("Nome: ") Leia(Nome[C]) Para C <- 1 ate 5 faca Escreva("Questao ",C,":") Leia(GabA[C]) Se (GabA[C]= Gab[C]) então Nota[c] <- Nota[c] + 2 Fimse Fimpara Limpatela Fimpara Escreval("============") Escreval("Notas Finais") Escreval("============") Para C <- 1 Ate 3 faca Escreval(Nome[C],Nota[C]) Fimpara Fimalgoritmo
  15. Qual linguagem de programação mais básica? Que programa eu uso para digitar os códigos? Quero aprender a programar, mas não sei por onde começar e nem como. Me falaram para usar o Code:blocks, mas não sei como uso!
  16. Estou tentando resolver um problema que é: Dados os 3 valores escolhidos por Alice, Beto e Clara, cada valor zero ou um, um programa que determina se ha um ganhador, e nesse caso determina quem é o ganhador, tendo como saída somente um caractere, a inicial do nome de quem ganhou. Se nenhum deles ganhar, no caso de todos colocarem 1 ou todos colocarem 0 , que apareça um " * ". Estou aprendendo Logica e estou tentando pegar , mas é bem difícil, estou no começo. Algoritmo Ganhador Var A , B , C : Inteiro inicio
  17. Escreva um procedimento que receba um número inteiro e o imprima na forma extensa. Por exemplo, para 1 a saída desejada é “Um”. A função deve ser capaz de gerar o extenso dos números de 0 até 15, inclusive. Caso um número não compatível seja recebido o procedimento deve mostrar uma mensagem de erro. Crie também um algoritmo que leia um valor inteiro e chame o procedimento criado acima para a impressão do número extenso. Eu fiz assim, alguém pode me ajudar, achei na internet totalmente diferente, então não seio se estar errado, estar dando erro no [ escreval(extenso(n)) ] var n: inteiro procedimento extenso(n: inteiro) var ext: caracter inicio escolha (n) caso 1 ext < "Um" caso 2 ext <- "Dois" caso 3 ext <- Três" caso 4 ext <- "Quatro" caso 5 ext <- "Cinco" caso 6 ext <- "Seis" caso 7 ext <- "Sete" caso 8 ext <- "Oito" caso 9 ext <- "Nove" caso 10 ext <- "Dez" outrocaso ext <- "Erro. Número inválido" fimescolha escreval(ext) fimprocedimento inicio escreva("Informe um número: ") leia(n) escreval(extenso(n)) fimalgoritmo OBS. no visualG (portugol)
  18. Fala galera eu preciso fazer o seguinte exercicio em pseudocódigo: Dado um conjunto de N frases, faça um algoritmo para imprimir cada frase juntamente com o número de vezes que aparece a palavra DE na frase. Gostaria de saber se o que eu fiz está correto? // algoritmo FRASES /* - - - - - - - -- - - - - - - - - - - - -- */ VARIAVEIS string frase[200]; inteiro i,frase,n; INICIO leian frase para(i=0; i<frase; i++) se (frase[i]=='d' e frase[i+1]== 'e' e frase[i+2]== ' ') qtde++ fimse fimpara escrevaln "Encontrados vezes",qtde; fimalgoritmo
  19. Estou tentando montar esse algoritmo, porém, está dando erro quando coloro "Coroa" na escolha do jogador. Se alguém achar outro erro, pode me ajudar a consertar? inicio texto cara , coroa , escolha inteiro moeda escrever "Digite Cara ou Coroa" , "\n" ler escolha moeda <- aleatorio ( ) * 2 se moeda = 0 então escrever "\nCara" fimse se moeda = 1 então escrever "\nCoroa" fimse se escolha = "cara" então escrever "\nVocê ganhou" senao se escolha = "coroa" então escrever "\nA máquina ganhou" fimse fimse fim
  20. Bom dia! Primeiramente gostaria de me apresentar. Meu nome é Everton e recentemente iniciei um curso técnico de análise e desenvolvimento de sistemas... Estamos no segundo mês de curso. Estou gostando bastante. Apesar de parecer muito simples. Estou tendo dificuldades nos comandos SE, SENAO e SENAO SE. Não consegui resolver um exercício que me foi passado... e sinceramente fico bastante frustrado... kkkk. Se alguém conseguir me dar uma dica, ficaria agradecido. A questão é o seguinte. Só pode ser feita com comandos de controle. Questão: Preciso criar um algoritmo que tenha 3 senhas no sistema (Constantes) e um email também. O usuário precisa primeiro inserir o E-mail. Se o e-mail estiver no sistema... ele irá pedir a senha do usuário em seguida se não... O programa finaliza nessa parte, nem chega a pedir os outros dados. (Meu problema é nessa parte). Se a senha do usuário não for nenhuma das 3 do sistema ele informará, que senha é inválida e o programa finaliza. Caso for aparecerá mensagem, "Sistema Ativado". Abaixo o código que fiz... Se alguém conseguir me dar uma luz, ficaria agradecido. Estamos usando o Portugol Studio. Estou tendo problema na parte que pede o E-mail e o usuário insere o mesmo incorreto. Era pro problema finalizar e mesmo assim pede a senha... Programa: { funcao inicio() { const cadeia SENHA1 = "300390" const cadeia SENHA2 = "300490" const cadeia SENHA3 = "300590" const cadeia EMAIL = "teste_everton@hotmail.com" cadeia password cadeia email_usuario escreva ("Informe o seu email: ","\n") leia (email_usuario) se (email_usuario != EMAIL) { escreva ("E-mail inválido!") } se (email_usuario == EMAIL) { escreva ("Informe a sua senha: ") } leia (password) se ((password == SENHA1) ou (password == SENHA2) ou (password == SENHA3)) { escreva ("Sistema ativado!","\n") } senao { escreva ("Senha incorreta!") } } } Muito obrigado galera!
  21. Como faço para limitar um valor de salário para aumentar em porcentagem ? Ex: Preciso informar o nome e o salário. Funcionários que ganham entre 5 e 7mil o aumento vai ser de 14%, e o resultado precisa ser o salario mais a porcentagem. E que condição eu uso, se então ?
  22. Fazer um algoritmo que: • Leia um número indeterminado de linhas contendo cada uma a idade de um indivíduo. • A última linha que não entrará nos cálculos, contém o valor da idade igual a zero. • Calcule e escreva a idade média deste grupo de indivíduos. • Escreva também a maior idade e a menor Conseguir fazer ele, o problema é quando vai escrever a idade menor sempre da 1: algoritmo "Média_de_idades" // Função : Calcular a média de idades de qualquer número de pessoas // Autor : Anatanael Fonseca Barbosa // Data : 13/04/2018 // Seção de Declarações var cont,soma,idade,maior,menor:inteiro media:real inicio cont<-0 soma<-0 idade<-1 menor<-idade maior<-idade enquanto (idade>0) faca escreva("Digite a idade:") leia(idade) escolha idade caso 0 outrocaso se (idade < menor) então menor <- idade senao se idade > maior então maior <- idade fimse fimse fimescolha cont<-cont+1 soma<-soma+idade fimenquanto media<-soma/(cont-1) escreval("A média de idades é:",media) escreval ("MAIOR:",maior) escreval ("MENOR:",menor) fimalgoritmo
  23. Eu comecei a programar a muito pouco tempo, alguém poderia me ajudar numa pergunta? "Some os números de 1 a 100 e imprima o valor" (portugol)
  24. Faça um algoritmo que leia o salário bruto de um cidadão e depois exiba o salário líquido, valor da contribuição a previdência social e valor descontado de imposto de renda. Considere a seguinte situação: desconta-se inicialmente 11% do salário bruto do trabalhador, como contribuição à previdência social. Após esse primeiro desconto, poderá existir outro desconto do salário bruto, referente ao imposto de renda, com base nas seguintes situações. * Salário bruto inferior a R$ 1.500, não há desconto; * Salário bruto de R$ 1.500 até R$ 1.999, desconto de 5%; * Salário bruto de R$ 2.000 até R$ 3.499, desconto de 7%; * Salário bruto igual ou superior a R$ 3.500, desconto de 9,5%. ---- Gente, só está lendo os 5%, me ajudem inicio ---- real salbruto , salliqui , previd , renda , renda2 , renda3 , salliqui2 , salliqui3 escrever "Qual seu salário bruto?: " ler salbruto se salbruto < 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd senao se salbruto >= 1500 então previd <- salbruto * 11 / 100 salbruto <- salbruto - previd fimse fimse escrever "\nDesconto da previdência " , salbruto se salbruto < 1500 então escrever "\nNão há desconto de Imposto de Renda" senao se salbruto >= 1500 ou salbruto <= 1999 então renda <- salbruto * 5 / 100 salliqui <- salbruto - renda escrever "\nSeu salário líquido é: " , salliqui senao se salbruto >= 2000 ou salbruto <= 3499 então renda2 <- salbruto * 7 / 100 salliqui2 <- salbruto - renda2 escrever "\nSeu salário líquido é: " , salliqui2 senao se salbruto >= 3500 então renda3 <- salbruto * 9.5 / 100 salliqui3 <- salbruto - renda3 escrever "\nSeu salário líquido é: " , salliqui3 fimse fimse fimse fimse fim

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×