Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''Portugol''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição, autoração e gravação de áudio e vídeo
    • Programas
  • Sistemas Operacionais
  • Eletrônicos
  • Outros
  • Clube do Hardware

Product Groups

Não há resultados

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Encontrado 91 registros

  1. 4) Coloque VERDADEIRO ou FALSO na avaliação das seguintes expressões: a) 6 <= 7 b) 'Pseudocódigo' < 'PSEUDOCÓDIGO' c) 3 + 5 <= 2 * 4 d) (64) ^ (1/2) > (5)*2 e) 'Pseudocódigo' > 'turbo' 5) Considerando as variáveis declaradas na tabela abaixo e mais a variável booleana TESTE, com valor FALSO, avalie as expressões a seguir, para cada uma das três combinações de valores apresentadas: OBS.: a variável TESTE pode receber o valor de VERDADEIRO e também o valor FALSO, no caso da questão ela é FALSO. combinações variáveis A B NOME PROFISSÂO 01 3 16 ‘MIRIAM’ ‘ADVOGADO’ 02 5 64 ‘PEDRO’ ‘MEDICO’ 03 2,5 9 ‘ANA’ ‘PROFESSOR’ Substitua os valores do quadro nas expressões e informe o resultado no quadro em branco abaixo, referente a cada combinação. a) (A + 1 >= ((B) ^ (1/2)) OU (NOME <> 'ANA')) b) (A + 1 >= ((B) ^ (1/2)) E (PROFISSAO = 'MEDICO')) c) (NOME <> 'ANA') OU (PROFISSAO = 'MEDICO') E (A + 1 >= ((B) ^ (1/2))) d) NÃO (A + 1 >= ((B) ^ (1/2)) E TESTE)
  2. Boa tarde pessoal. Estou com dificuldades em um exercício de algoritmos da faculdade. segue print do exercício abaixo: ps: Acho que esse fluxograma contém uma anomalia, porque não tem como q1 ser falso sem executar c, pelo menos foi o que entendi. sendo assim esse fluxograma não seria estruturado. Me corrijam se eu estiver errada. Poderiam me dar um help? Agradecida!
  3. Gente, estou com a seguinte questão que pede para usar os concecitos de ''div'' e ''mod'', porém não consigo pensar na fórmula e como iria aplicar, por gentileza, alguém conseguiria resolver pra mim em Portugol?, desde já agradeço!! 1. Fazer um algoritmo para ler a idade de um usuário expressa em dias e mostre essa idade expressa em anos, meses e dias.
  4. O professor pediu um algorítmico que calcule função de segundo grau por Bhaskara, porém o meu está dando resultados errados. Alguém pode dar uma olhada? programa { inclua biblioteca Matematica --> mat real a,b,c,x1,x2, delta, b2 funcao inicio() { escreva("Digite o valor de [a]", "\n") leia (a) escreva("Digite o valor de B ", "\n") leia (b) escreva("Digite o valor de [c]", "\n") leia (c) b2 = b*b delta = b2-(4*a*c) se(delta<0 ou (2*a)==0) { escreva("Impossível Calcular", "\n") } senao { x1 = -b + (Matematica.raiz(delta, 2)) / (2*a) x2 = -b - (Matematica.raiz(delta, 2)) / (2*a) escreva("X1 = ", x1, "\n") escreva("X2 = ", x2, "\n") } } }
  5. por algum motivo esta dando erro e não sei onde é se alguém puder me ajudar a encontrar feito no portugol programa { funcao inicio() { real a,b,c,d,x,x1, raiz escreva ("informe o coeficiente a") leia (a) escreva ("informe o coeficiente b") leia (b) escreva ("informe o coeficiente c") leia (c) d=(b^2)-(4*a*c) se (d<0) { escreva ("nao existe raizes reais") } senao se (d=0) { x=-b/(2*a) escreva ("existe 1 raiz real",x) } senao { raiz =mat raiz (d,2=0) x=(-b+raiz)/(2*a) x1=(-b-raiz)/(2*a) escreva ("duas raizes reais :",x",",x1) } } }
  6. Boa noite, gostaria de ajuda no seguinte programa. Fazer com que o usuário cadastre 3 restaurantes e realizasse a venda de 1 único produto (basta adicionar quantidade não sendo necessario cadastro). obs: o programa é em portugol. Minha dúvida é em relação as variaveis; INICIO DO PROGRAMA Pedir nome do restaurante 1 Armazenar nome em uma variavel Pedir nome do restaurante 2 Armazenar nome em uma variavel pedir nome do restaurante 3 armazenar em uma variavel INICIO DAS VENDAS (Essa é a parte que estou em dúvida o mais facíl seria eu dizer o nome do restaurante e o usuario adicionar o valor, porém eu gostaria de saber se tem como o usuario digitar o nome do restaurante e daí então digitar a quantidade vendida como). obs se puder colocar essa parte ( inicio das vendas em c ) eu agradeço.
  7. Utilizando a estrutura “PARA – ATÉ” (“FOR”), escreva um algoritmo que calcule e imprima as tabuadas de 1 a 10 (para os valores de 1 a 10) e ao final de cada tabuada, imprima a soma total dos totais que sejam ímpares: Reescreva o algoritmo do exercício 14 utilizando a estrutura “ENQUANTO” (‘While”) e um CONTADOR, e no lugar da impressão da soma total ao final de cada tabuada, imprima a média aritmética dos totais: Alguem Ajuda!?
  8. programa { inclua biblioteca Arquivos --> a cadeia nomeMedico, espMedico, convMedico, dadosMedico inteiro crm funcao inicio() {inteiro opcao escreva("escolha uma opção \n") escreva(" 1-para cadastrar um medico \n 2-para cadastrar um convenio \n 3-para consultar dados de um medico \n 4-para cadastrar uma especialidade \n") leia(opcao) limpa() se (opcao == 1){ cadastramedico() limpa() } } funcao cadastramedico(){ escreva ("digite o nome do medico\n") leia (nomeMedico) limpa() escreva("digite o CRM de ", nomeMedico, "\n") leia(crm) escreva ("informe a especialidade de ", nomeMedico, "\n") leia (espMedico) escreva("informe qual convenio ",nomeMedico," atende \n") leia (convMedico) escreva ( nomeMedico + espMedico + convMedico ) leia (dadosMedico) inteiro cam = a.abrir_arquivo(dadosMedico, a.MODO_ESCRITA) } } pessoal pfv me ajudem. preciso fazer um programa com portugol studio onde ele faz perguntas ao usuario, tipo "nome, idade, cpf e tal" em seguida guarda e mostra quando o usuario solicita. por enquanto so consigo gerar a pasta, mas ela fica vazia. agradeço a todos que porventura possa ajudar um pobre estudante. ai vai um exemplo. só funciona opção 1
  9. Faça um algoritmo que receba informações de 127 pessoas que serão informadas pelo usuário, que são: idade e o peso. Estas informações devem ser validadas para não aceitar valores inválidos. Após isso, o algoritmo deverá calcular e exibir: a) A media da idade das pessoas que estão com peso entre 50 e 70kg; b) O percentual de pessoas cuja idade está entre 10 e 14 anos e cujo peso está acima de 70kg. Me ajudem, por favor. Não estou conseguindo fazer o codigo para a questão A e nem a B. Também não sei como validar. Desde já obrigado!
  10. Boa noite pessoal,estou fazendo um crud e nao estou conseguindo fazer com que quando um nome ja inserido no bd nao possa ser inserido novamente.Nao estou conseguindo fazer essa validação.Me deem um help OBs:Eestou fazendo em php arquivo -- Veri_usuario.php <!DOCTYPE html> <html> <head> </head> <body> <?php $nome="1"; $consulta = mysqli_query ($con,"select * from cadastrar_cliente where nome = 'nome_cliente' ") or die ("nao deu $consulta"); if (mysqli_num_rows($consulta) === $_POST['nome_cliente']) { echo "$consulta .EXIIISTEE"; } ?> </body> </html> arquivo proce_cliente.php <!DOCTYPE html> <?php include_once ("Conexao.php"); include_once "Veri_usuario.php"; $cpf = filter_input(INPUT_POST, 'cpf_usuario'); $nome = filter_input(INPUT_POST, 'nome_cliente'); $cel = filter_input(INPUT_POST, 'cel_cliente'); /* echo "Nome:$nome <br>"; echo "cpf:$cpf <br>"; /*echo "cel:$cel <br>"; */ $result_usuario = "INSERT INTO cadastrar_cliente(cpf,nome,cel) VALUES ('$cpf','$nome','$cel')"; $resultado_usuario = mysqli_query($con, $result_usuario); unset($cpf,$nome,$cel); if (!empty($_POST)) { // Verifica se a variável $_POST['nome'] existe if (isset($_POST['nome_cliente'])) { // Verifica se o usuário digitou o seu nome if (!empty($_POST['nome_cliente'])) { $nome = $_POST['nome_cliente']; echo 'Seja bem-vindo(a) ' . $nome . '!'; } else { echo "Por favor, preencha o seu nome"; } } else { echo "O campo 'nome_cliente' não existe na variável $_POST"; } } ?> index.php <!DOCTYPE html> <!-- To change this license header, choose License Headers in Project Properties. To change this template file, choose Tools | Templates and open the template in the editor. --> <?php session_start(); if ($_SERVER['REQUEST_METHOD'] == 'POST') { $request = md5(implode($_POST)); if (isset($_SESSION['last_request']) && $_SESSION['last_request'] == $request) { echo 'refresh'; } else { $_SESSION['last_request'] = $request; echo 'post'; } } ?> <html> <head> <title> Cadastro do Cliente</title> </head> <body> <form method="POST" action="proce_cliente.php"> Cpf: <input type="text" name="cpf_usuario" pattern="\d{3}\.\d{3}\.\d{3}-\d{2}" placeholder="___.___.___-__" title="Formato correto: xxx.xxx.xxx-xx"><br><br> Nome: <input type="text" name="nome_cliente" placeholder="Digite seu nome completo"><br><br> Cel: <input type="tel" name="cel_cliente" placeholder="Ex.: (00) 0000-0000"><br><br> <input type="submit" value="Cadastrar"> </form> </body> </html> conexao.php <html> <head> <meta charset="UTF-8"> <title></title> </head> <body> <?php $servidor="localhost"; $usuario="root"; $senha=""; $dbname="cadastro"; $con= mysqli_connect("localhost","root","","cadastro"); ?> </body> </html>
  11. Galera, boa tarde, todo bom? to fazendo EAD de Analise e Desenvolvimento de sistema. E me deparei com esse exercício, logo na 2º semana de aula. ___ Percebemos o quão importante é você estar ciente de como é o funcionamento dos comandos em lógica de programação. Cada comando possui um propósito e com ele podemos perceber qual é o melhor comando para realizar determinada atividade. Neste sentido, analisemos o caso problematizador abaixo: O IBGE (Instituto Brasileiro de Geografia e Estatística) desejou realizar uma estatística nas cidades pertencentes ao estado do Paraná, verificando dados sobre acidentes de trânsito. Neste estudo, precisava-se obter alguns dados, que podemos verificar abaixo: - código da cidade; - número de veículos de passeio; - número de acidentes de trânsito com vítimas. Desejava-se saber ainda: - qual o maior e o menor índice de acidentes de trânsito e a que cidades pertencem; - qual a média de veículos nas cidades juntas; - qual a média de acidentes de trânsito nas cidades com menos de 2000 veículos de passeio. Analisando, assim, o nosso caso problematizador, você, aluno(a), deverá realizar um algoritmo que resolva este problema. ___ Alguem consegue me ajudar a entender a questão, pfv?
  12. Dados dois vetores A = (x1, y1, z1) e B = (x2, y2, z2), faça um algoritmo em Portugol que calcule o produto escalar e o produto vetorial entre os dois vetores. Alguém pode me ajudar?
  13. Considerando n um número inteiro positivo, elabore um algoritmo para calcular o valor de A, onde: A=1+1/2+1/3+1/4+...+1/n (LAÇO-ENQUANTO) funcao inicio() { inteiro n,deno=0, A, num=1 escreva("Qual o valor de n:") leia(n) A=num deno=n-1 A=1+(num/deno) deno=deno+1 enquanto(deno>=n) escreva("A=",A) }
  14. Boas, pessoal estou aprendendo programar em Python, estou bem no começo, eu sei um pouco de inglês. Mas as bibliotecas de Python em inglês tem dificultado um pouco. Gostaria de saber se tem alguma pagina que tenha as bibliotecas de Python traduzidas para o português?
  15. boa noite, estou tentando fazer um programa em pseudo, porém estou bastante perdido. qualquer ajuda será bem-vinda. segue: algoritmo struct reg_alunos inicio literal sair = “s” const alunos = 5 tipo reg_aluno = registro literal: nome[30]; inteiro: serie; real: freq; real: nota[2]; real: media; fim_registro; procedimento mostrar_dados(var reg_livro: aluno[alunos]) int i; para i de 1 ate alunos faca escrever(“nome:”, aluno.nome); escrever(“serie:”, aluno.serie); escrever(“frequencia:”,aluno.freq); escrever(“notas:”,aluno.nota[1],aluno.nota[2]. fim_para fim procedimento menu_escolhas() inteiro opcao = 0; ("controle de alunos\n"); escrever("-----------------/-------------------"); escrever("1 - cadastro"); escrever("2 - consulta"); escrever("3 - maior e menor media"); escrever("4 - maior e menor frequencia"); escrever("5 - alunos acima da media"); escrever("6 - sair"); escrever("escolha uma opcao"); leia opcao; escolha(opcao) repita enquanto (opcao != 6); caso 1: inteiro: i; literal: aluno; escrever(“cadastro de alunos”); registro_aluno(aluno) escrever(“deseja continuar (s/n)”) leia (sair); caso 2: escrever( “consulta aluno”); consulta(aluno, i) escrever(“deseja continuar (s/n)”) leia (sair); caso 3: escrever(“media dos alunos”) real: m,med,maior; inteiro:i; escrever (“a media das turmas:”) para i de 1 ate alunos faca med = media(aluno, real media); escrever (“aluno e medias”, aluno.nome, med) ; fim para ordena_maior(aluno, maior); escrever(“pior e melhor media”,maior[1],maior[alunos]); escrever (deseja sair (s/n)); leia (sair); caso 4: escrever (“maior e menor frequencia)”) int i; procedimento maior_frequencia(aluno); escrever( “pior e melhor frequencia nas aulas:”, freq[1].aluno, freq[alunos].aluno; escrever(deseja sair(s/n)); leia (sair); caso 5: inteiro i; escrever(“medias acima de 7:”); procedimento: passou(aluno) escrever(deseja sair(s/n)); leia (sair); caso 6: escrever(“sair”); procedimento registro_aluno(var reg_aluno: aluno[alunos]) para i de 1 ate alunos faca escrever (“informe o nome do aluno”) leia (aluno.nome); escrever(“informe a serie”) leia (“aluno.serie”) escrever (“informe as notas”) leia (aluno.nota[1], aluno.nota[2]; escrever (“informe a frequencia”) leia (“aluno.frequencia”) fim procedimento consulta(var reg_aluno: aluno[alunos], inteiro: i ) inteiro: i; literal: nome, continua = ‘s’; literal: aluno_pesquisado; repita escrever(“informe o nome do aluno que deseja pesquisar”); leia(aluno_pesquisado); para i de 1 ate alunos faca se (aluno_pesquisado <= aluno.nome ) faca mostrar_dados(); senao escrever(“deseja continuar? (s/n) leia (continua); ate continua = “n”; fim_se fim_para fim funcao real: media(var reg_aluno: aluno[alunos]; real aluno_media) inteiro k,i; para k de 1 ate alunos faca para i de 1 ate alunos faca aluno[k].media = (aluno.nota[1] + aluno.nota[2] )/ 2; fim_para fim_para retorne media[k]; fim procedimento ordena_maior (var reg_aluno: aluno[alunos]; real maior_media)\ real maior; inteiro: i,j,aux,k; para i de 1 ate alunos faca para j de 1 ate alunos faca se maior < maior[j] entao aux = maior; maior = maior[j]; maior[j] = aux; fim_para fim_para para k de 1 ate alunos faca escrever(“medias em ordem da menor para maior”, maior) fim_para fim procedimento ordena_menor(var reg_aluno: aluno[alunos]; real menor_media) real: menor; inteiro : i,j, aux; para i de 1 ate alunos faca para j de 1 ate alunos faca se menor>menor[j] entao aux=menor; menor=menor[j]; menor[j]=aux; fim_para fim_para fim procedimento maior_frequencia(var reg_livro: aluno[alunos]) inteiro: i,j,aux; para i de 1 ate alunos faca para j de 1 ate alunos faca se aluno.freq< aluno.freq[j] entao aux= aluno.freq; aluno.freq = aluno.freq[j]; aluno.freq[j] = aux; fim_para ; fim_para; escrever (“frequencia ordenada do menor para maior”freq.aluno) fim procedimento: passou(var reg_livro: aluno[alunos]) int i; para i de 1 ate alunos faca se (aluno.media > 7) faca escrever(“parabens aos alunos: “, aluno.nome); fim_para fim_se inicio principal int i repita menu escolhas() escrever (“deseja sair:”) leia (sair) ate sair = “n” fim obs: exercicio em anexo.
  16. Opa bom dia, boa tarde e boa noite Tudo bem minha gente eu queria uma ajuda, meu professor pediu pra turma criar um algoritmo no portugol studio que ele fosse capaz de calcular bhaskara porém tinha uma certa particularidade se o resultado de Delta>0 é pra calcular x1 e x2, se delta for Delta<0 é pra dar uma mensagem de erro tipo "Valor não calculavel" e se Delta= 0 é pra calcular o x1 e x2 também então eu fiz esse algoritmo mas estou com um erro nele no qual não aparece os resultados vou mostrar agora programa { inclua biblioteca Matematica --> mat real valorA, valorB, valorC, elevado, raiz, b2, delta, x1, x2 funcao inicio() { escreva("Digite o Valor A: ") leia(valorA) se(valorA!=0){ escreva("Escreva o valor B: ") leia(valorB) escreva("Escreva valor C : ") leia(valorC) b2 = valorB*valorB escreva("Valor de b2", b2) limpa() delta = b2-(4*valorA*valorC) escreva("Valor de Delta: ", delta ) } senao se (delta==0) { x1 = (-valorB + (Matematica.raiz(delta, 2))) / (2*valorA) x2 = (-valorB - (Matematica.raiz(delta, 2))) / (2*valorA) escreva("X1 = ", x1, "\n") escreva("X2 = ", x2, "\n") }senao se (delta>0) { x1 = (-valorB + (Matematica.raiz(delta, 2))) / (2*valorA) x2 = (-valorB - (Matematica.raiz(delta, 2))) / (2*valorA) escreva("X1 = ", x1, "\n") escreva("X2 = ", x2, "\n") } senao se (valorA!=0) { escreva("Não é possivel calcular esse valor") } senao { escreva("Não é possivel calcular") } } }
  17. Pessoal eu fiz uma atividade da disciplina de lógica que envolvia reproduzir o jogo do pim. Cada vez que o número impresso pelo contador fosse multiplo de 4 deveria aparecer Pim! ao invés do número. Eu fiz a resolução mais óbvia para os meus conhecimentos que seria usar o resto da divisão do contador por quatro (%), e esta certo. Mas o professor me desafiou a resolver o problema sem usar o módulo e eu pesquisei muita coisa mas não consegui chegar a nenhuma conclusão. O que eu tentei foi comparar o resultado da divisão do contador por 4 (y = c / 4) e colocar como condicional "se" caso o resultado fosse inteiro. Parece um bom plano mas eu não sei escrever esse código. Sugestões? Segue o que eu tentei fazer: programa { funcao inicio() { real c = 1, y = c / 4 enquanto(c <= 30) { se(y == inteiro(y)) //tentando comparar o resultado de c / 4 para saber se é inteiro ou nao { escreva(" Pim! ") } senao { escreva(" ", c, " ") } c = c + 1 } } }
  18. Tenho um algoritmo aqui e queria que me ajudassem a resolver essa questão(Qual o número de habitantes em cada uma das idades possíveis.). Ou seja, eu tenho que pegar o número dentro do vetor e ver quantas vezes esse número repete depois imprimir isso. Algoritmo: programa { inclua biblioteca Tipos --> tp inclua biblioteca Matematica --> mat funcao inicio() { inteiro idade,idadev[6],menor=999999999,maior=0,minimo=0,maximo=0,soma=0,quant=0,media,menos=0,c=0 cadeia nome,nomev[6] para(inteiro posicao=0;posicao<5;posicao++){ escreva("Qual o nome do " , posicao+1 , "º habitante? ") leia(nome) nomev[posicao] = nome escreva("Qual a idade de " , nome , ", o habitante número " , posicao+1 , "? ") leia(idade) idadev[posicao] = idade se(idade<menor){ menor = idade } se(idade>maior){ maior = idade } soma=soma+idade quant=quant+1 } //QUANTAS PESSOAS TEM A MENOR IDADE DA CIDADE para(inteiro achar2=0;achar2<5;achar2++){ se (idadev[achar2]==menor){ minimo = minimo+1 } } /// //IDADE DO HABITANTE MAIS NOVO escreva("Os habitantes que têm a menor idade(",menor," ano(s)) da cidade são(", minimo ,"): \n") para(inteiro achar=0;achar<5;achar++){ se (idadev[achar]==menor){ escreva(nomev[achar], "\n") } } /// //IDADE DO HABITANTE MAIS VELHO escreva("Os habitantes que têm a maior idade(",maior," ano(s)) da cidade são(", maximo ,"): \n") para(inteiro achar1=0;achar1<5;achar1++){ se (idadev[achar1]==maior){ escreva(nomev[achar1], "\n") } } /// //MÉDIA DE IDADE DOS HABITANTES media=soma/quant escreva("A média de idade dos habitantes da cidade é: " , media , "\n") /// //HABITANTES COM IDADE MENOR QUE A MÉDIA para(inteiro menores=0;menores<5;menores++){ se(idadev[menores]<media){ menos=menos+1 } } escreva("Têm " , menos , " habitantes com idade abaixo da média.\n") /// } }
  19. A questão é que eu tenho que montar um pseudocódigo com essa pergunta: a) Crie uma função que preencha o tabuleiro com o [ X ] em todas as posições. b) Crie uma função que receba os parâmetros da posição e do caracter a ser prenchido: [ E ] , [ ] ou [ S ]. c) Crie uma função que exiba o tabuleiro. d) No corpo principal do algoritmo, deve chamar a função para: - Chamar a função que vai prencher o tabuleiro com [ X ]. - Chamar a função que vai exibir o tabuleiro. - Chamar a função que vai preencher todas as posições que não estejam no tabuleiro acima. Lembre, você deverá chamar a função diversas vezes. Neste ponto otimize o seu algoritmo. - Chamar a função que vai exibir o tabuleiro. A letra a) e c) eu fiz (não sei se ta certa). Letra a): algoritmo preencherTabela procedimento preencher(MatrizA: vetor[1..6,1..6] de caractere) var i, j: inteiro inicio para i de 1 ate 6 passo 1 faca para j de 1 ate 6 passo 1 faca matrizA[i,j]<- "X" fim_para fim_para fim_procedimento letra c): procedimento escrever(matrizA: vetor[1..6,1..6] de caractere) var x,y: inteiro inicio para x de 1 ate 6 passo 1 faca para y de 1 ate 6 passo 1 faca escreval("[",x,"][",y,"] = ", matrizA[x,y]) fim_para fim_para fim_procedimento Se puderem me ajudar na letra B e D, ficarei grato!
  20. Fazendo a leitura de mil números sorteados no PORTUGOL STUDIO, pelo processo de sorteio automático, no qual os números devem estar entre 0 e 100, verifique qual foi: a) O número sorteado mais vezes. b) O número sorteado menos vezes. c) O maior número. d) O menor número. Já realizei a C e a D, mas não consigo saber o que foi sorteado mais vezes, apenas os que se repetiram e quantos números foi repetido. programa { //Sorteia os números do vetor inclua biblioteca Util funcao vazio preenche(inteiro vetor[]){ inteiro numero para(inteiro i = 0; i < 1000; i++){ numero = Util.sorteia(0, 100) vetor[i] = numero } } //Ordena os números do vetor, o maior e o menor funcao ordena(inteiro vetor[]){ para(inteiro i = 0; i< 1000; i++){ inteiro pos_menor=i para(inteiro j = i+1; j < 1000; j++){ se(vetor[j] < vetor[pos_menor]){ pos_menor = j } } inteiro aux = vetor[pos_menor] vetor[pos_menor] = vetor[i] vetor[i] = aux } } //Aqui foi uma tentativa dos repetidos funcao repetidos(inteiro vetor[]){ inteiro num = 0, rep = 0 para(inteiro i = 0; i< 1000; i++){ se(vetor[i] == num){ rep = rep + 1 num = num + 1 escreva(vetor[i]+"\n") } } escreva("repetiu-se "+rep+" números \n") } funcao inicio() { inteiro numeros[1000] preenche(numeros) ordena(numeros) repetidos(numeros) escreva("O menor número é: "+numeros[0]+"\n") escreva("O maior número é: "+numeros[999]) } }
  21. Faça uma função que receba um número N e retorne a soma dos algarismos de N!. Ex: se N = 4, N! = 24. Logo, a soma de seus algarismos é 2 + 4 = 6. Salve no Portugol Studio com o nome “ 25_soma_algarismos.por ”. Pelo o que eu entendi: N = 4 N! = 24 (4*3*2*1), do numero vezes o seu antecessor até o número 1 SOMA ALGARISMOS É 2+4 = 6 Gostaria de entender como separar os algarismos! programa { funcao nNumeros(inteiro numero){ inteiro result = 0, n, soma = 0 n = numero - 1 enquanto(n >= 1){ result = numero * n soma = soma + result n = n -1 } escreva(soma) } funcao inicio() { inteiro numero escreva("Insira um número N: \n") leia(numero) nNumeros(numero) } } adicionado 42 minutos depois Galera já consegui fazer, vou deixar aqui caso alguém também precise: programa { funcao nNumeros(inteiro numero){ inteiro result = 0, n, soma = 0, soma2 = 0, resultSoma = 0 n = numero - 1 enquanto(n >= 1){ result = numero * n soma = soma + result n = n -1 } escreva("N!:"+soma+"\n") faca{ soma2 = soma %10 soma = soma/ 10 resultSoma = resultSoma + soma2 }enquanto(soma > 0) escreva("A soma dos algarismos é: "+resultSoma) } funcao inicio() { inteiro numero escreva("Insira um número N: \n") leia(numero) limpa() escreva("N:"+numero+"\n") nNumeros(numero) } }
  22. como eu faço para criar uma matriz 4x4 e deixar os números da diagonal fixos exemplo 4 3 2 5 1 2 10 3 2 2 5 4 10 1 2 3
  23. estou com problema em comparar a matriz no desafio abaixo ,fiz o seguinte adicionei a matriz com os dados corretos e criei outra matriz que o usuário ira completar seguindo as dicas.No final preciso que compare as 2 matrizes e se o usuário estiver correto,de a mensagem "Parabéns...." se não estiver correto ,apenas continuar a tentar solucionar o desafio. programa { funcao inicio() { cadeia testeUsuario[5][5], testePronto[][] = {{"AMARELO","AZUL","VERMELHA","VERDE","BRANCA"},{"NORUEGUÊS","DINAMARQUÊS","INGLÊS","ALEMÃO","SUECO"},{"ÁGUA","CHÁ","LEITE","CAFÉ","CERVEJA"},{"DUNHIL","BLENDS","PALL MALL","PRINCE","BLUEMASTER"},{"GATOS","CAVALOS","PÁSSAROS","PEIXES","CACHORROS"}}, atributo[] = {"COR ","NACIONALIDADE","BEBIDA ","CIGARRO ","ANIMAL "} inteiro opcao, desistir = 0, cont = 0 logico venceu = falso, fim faca{ escreva ("--------------------------------------------------------------------\n") escreva (" TESTE DE EINSTEIN \n") escreva ("--------------------------------------------------------------------\n") escreva ("\t\t| Casa 1 |\t| Casa 2 |\t| Casa 3 |\t| Casa 4 |\t| Casa 5 |\t\n\n") para (inteiro l=0; l < 5; l++){ escreva (atributo[l],"\t") para (inteiro c=0; c < 5; c++){ escreva ("| ",testeUsuario[l][c]," |\t") } escreva ("\n\n") } escreva ("--------------------------------------------------------------------\n") escreva (" DICAS \n") escreva ("--------------------------------------------------------------------\n") escreva (" 01. O Norueguês vive na primeira casa;\n 02. O Inglês vive na casa Vermelha;\n 03. O Sueco tem Cachorros como animais de estimação;\n 04. O Dinamarquês bebe Chá;\n 05. A casa Verde fica do lado esquerdo da casa Branca;\n 06. O homem que vive na casa Verde bebe Café;\n 07. O homem que fuma Pall Mall cria Pássaros;\n 08. O homem que vive na casa Amarela fuma Dunhill;\n 09. O homem que vive na casa do meio bebe Leite;\n 10. O homem que fuma Blends vive ao lado do que tem Gatos;\n 11. O homem que fuma Blends vive ao lado do que tem Gatos;\n 12. O homem que fuma BlueMaster bebe Cerveja;\n 13. O Alemão fuma Prince;\n 14. O Norueguês vive ao lado da casa Azul;\n 15. O homem que fuma Blends é vizinho do que bebe Água.\n") escreva ("--------------------------------------------------------------------\n") escreva("Escolha uma casa: ") leia(opcao) escolha (opcao){ caso 1: //CASA 1 escreva("\n1) COR \n") escreva("2) NACIONALIDADE \n") escreva("3) BEBIDA \n") escreva("4) CIGARRO \n") escreva("5) ANIMAL \n\n") escreva("Escolha um atributo: ") leia(opcao) escolha (opcao){ caso 1: // COR escreva("\n1) AMARELA \n") escreva("2) AZUL \n") escreva("3) VERMELHA \n") escreva("4) VERDE \n") escreva("5) BRANCA \n\n") escreva("Escolha uma COR para a casa 1: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[0][0] = "AMARELA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[0][0] = "AZUL" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[0][0] = "VERMELHA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[0][0] = "VERDE" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[0][0] = "BRANCA" pare // Fim } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // NACIONALIDADE escreva("\n1) ALEMÃO \n") escreva("2) DINAMARQUÊS \n") escreva("3) INGLÊS \n") escreva("4) NORUEGUÊS \n") escreva("5) SUECO \n\n") escreva("Escolha uma NACIONALIDADE para a casa 1: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[1][0] = "ALEMÃO" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[1][0] = "DINAMARQUÊS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[1][0] = "INGLÊS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[1][0] = "NORUEGUÊS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[1][0] = "SUECO" pare // Fim } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // BEBIDA escreva("\n1) ÁGUA \n") escreva("2) CAFÉ \n") escreva("3) CERVEJA \n") escreva("4) CHÁ \n") escreva("5) LEITE \n\n") escreva("Escolha uma BEBIDA para a casa 1: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[2][0] = "ÁGUA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[2][0] = "CAFÉ" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[2][0] = "CERVEJA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[2][0] = "CHÁ" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[2][2] = "LEITE" pare // Fim } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CIGARRO escreva("\n1) BLENDS \n") escreva("2) BLUEMASTER \n") escreva("3) DUNHIL \n") escreva("4) PALL MALL \n") escreva("5) PRINCE \n\n") escreva("Escolha um CIGARRO para a casa 1: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[3][0] = "BLENDS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[3][0] = "BLUEMASTER" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[3][0] = "DUNHIL" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[3][0] = "PALL MALL" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[3][0] = "PRINCE" pare // Fim } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // ANIMAL escreva("\n1) CACHORROS \n") escreva("2) CAVALOS \n") escreva("3) GATOS \n") escreva("4) PÁSSAROS \n") escreva("5) PEIXES \n\n") escreva("Escolha um ANIMAL para a casa 1: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[4][0] = "CACHORROS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[4][0] = "CAVALOS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[4][0] = "GATOS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[4][0] = "PÁSSAROS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[4][0] = "PEIXES" pare // Fim } } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // CASA 2 escreva("\n1) COR \n") escreva("2) NACIONALIDADE \n") escreva("3) BEBIDA \n") escreva("4) CIGARRO \n") escreva("5) ANIMAL \n\n") escreva("Escolha um atributo: ") leia(opcao) escolha (opcao){ caso 1: // COR escreva("\n1) AMARELA \n") escreva("2) AZUL \n") escreva("3) VERMELHA \n") escreva("4) VERDE \n") escreva("5) BRANCA \n\n") escreva("Escolha uma COR para a casa 2: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[0][1] = "AMARELA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[0][1] = "AZUL" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[0][1] = "VERMELHA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[0][1] = "VERDE" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[0][1] = "BRANCA" pare // Fim } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // NACIONALIDADE escreva("\n1) ALEMÃO \n") escreva("2) DINAMARQUÊS \n") escreva("3) INGLÊS \n") escreva("4) NORUEGUÊS \n") escreva("5) SUECO \n\n") escreva("Escolha uma NACIONALIDADE para a casa 2: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[1][1] = "ALEMÃO" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[1][1] = "DINAMARQUÊS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[1][1] = "INGLÊS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[1][1] = "NORUEGUÊS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[1][1] = "SUECO" pare // Fim } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // BEBIDA escreva("\n1) ÁGUA \n") escreva("2) CAFÉ \n") escreva("3) CERVEJA \n") escreva("4) CHÁ \n") escreva("5) LEITE \n\n") escreva("Escolha uma BEBIDA para a casa 2: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[2][1] = "ÁGUA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[2][1] = "CAFÉ" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[2][1] = "CERVEJA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[2][1] = "CHÁ" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[2][1] = "LEITE" pare // Fim } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CIGARRO escreva("\n1) BLENDS \n") escreva("2) BLUEMASTER \n") escreva("3) DUNHIL \n") escreva("4) PALL MALL \n") escreva("5) PRINCE \n\n") escreva("Escolha um CIGARRO para a casa 2: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[3][1] = "BLENDS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[3][1] = "BLUEMASTER" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[3][1] = "DUNHIL" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[3][1] = "PALL MALL" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[3][1] = "PRINCE" pare // Fim } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // ANIMAL escreva("\n1) CACHORROS \n") escreva("2) CAVALOS \n") escreva("3) GATOS \n") escreva("4) PÁSSAROS \n") escreva("5) PEIXES \n\n") escreva("Escolha um ANIMAL para a casa 2: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[4][1] = "CACHORROS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[4][1] = "CAVALOS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[4][1] = "GATOS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[4][1] = "PÁSSAROS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[4][1] = "PEIXES" pare // Fim } } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // CASA 3 escreva("\n1) COR \n") escreva("2) NACIONALIDADE \n") escreva("3) BEBIDA \n") escreva("4) CIGARRO \n") escreva("5) ANIMAL \n\n") escreva("Escolha um atributo: ") leia(opcao) escolha (opcao){ caso 1: // COR escreva("\n1) AMARELA \n") escreva("2) AZUL \n") escreva("3) VERMELHA \n") escreva("4) VERDE \n") escreva("5) BRANCA \n\n") escreva("Escolha uma COR para a casa 3: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[0][2] = "AMARELA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[0][2] = "AZUL" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[0][2] = "VERMELHA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[0][2] = "VERDE" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[0][2] = "BRANCA" pare // Fim } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // NACIONALIDADE escreva("\n1) ALEMÃO \n") escreva("2) DINAMARQUÊS \n") escreva("3) INGLÊS \n") escreva("4) NORUEGUÊS \n") escreva("5) SUECO \n\n") escreva("Escolha uma NACIONALIDADE para a casa 3: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[1][2] = "ALEMÃO" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[1][2] = "DINAMARQUÊS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[1][2] = "INGLÊS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[1][2] = "NORUEGUÊS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[1][2] = "SUECO" pare // Fim } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // BEBIDA escreva("\n1) ÁGUA \n") escreva("2) CAFÉ \n") escreva("3) CERVEJA \n") escreva("4) CHÁ \n") escreva("5) LEITE \n\n") escreva("Escolha uma BEBIDA para a casa 3: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[2][2] = "ÁGUA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[2][2] = "CAFÉ" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[2][2] = "CERVEJA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[2][2] = "CHÁ" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[2][2] = "LEITE" pare // Fim } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CIGARRO escreva("\n1) BLENDS \n") escreva("2) BLUEMASTER \n") escreva("3) DUNHIL \n") escreva("4) PALL MALL \n") escreva("5) PRINCE \n\n") escreva("Escolha um CIGARRO para a casa 3: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[3][2] = "BLENDS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[3][2] = "BLUEMASTER" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[3][2] = "DUNHIL" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[3][2] = "PALL MALL" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[3][2] = "PRINCE" pare // Fim } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // ANIMAL escreva("\n1) CACHORROS \n") escreva("2) CAVALOS \n") escreva("3) GATOS \n") escreva("4) PÁSSAROS \n") escreva("5) PEIXES \n\n") escreva("Escolha um ANIMAL para a casa 3: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[4][2] = "CACHORROS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[4][2] = "CAVALOS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[4][2] = "GATOS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[4][2] = "PÁSSAROS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[4][2] = "PEIXES" pare // Fim } } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CASA 4 escreva("\n1) COR \n") escreva("2) NACIONALIDADE \n") escreva("3) BEBIDA \n") escreva("4) CIGARRO \n") escreva("5) ANIMAL \n\n") escreva("Escolha um atributo: ") leia(opcao) escolha (opcao){ caso 1: // COR escreva("\n1) AMARELA \n") escreva("2) AZUL \n") escreva("3) VERMELHA \n") escreva("4) VERDE \n") escreva("5) BRANCA \n\n") escreva("Escolha uma COR para a casa 4: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[0][3] = "AMARELA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[0][3] = "AZUL" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[0][3] = "VERMELHA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[0][3] = "VERDE" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[0][3] = "BRANCA" pare // Fim } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // NACIONALIDADE escreva("\n1) ALEMÃO \n") escreva("2) DINAMARQUÊS \n") escreva("3) INGLÊS \n") escreva("4) NORUEGUÊS \n") escreva("5) SUECO \n\n") escreva("Escolha uma NACIONALIDADE para a casa 4: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[1][3] = "ALEMÃO" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[1][3] = "DINAMARQUÊS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[1][3] = "INGLÊS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[1][3] = "NORUEGUÊS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[1][3] = "SUECO" pare // Fim } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // BEBIDA escreva("\n1) ÁGUA \n") escreva("2) CAFÉ \n") escreva("3) CERVEJA \n") escreva("4) CHÁ \n") escreva("5) LEITE \n\n") escreva("Escolha uma BEBIDA para a casa 4: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[2][3] = "ÁGUA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[2][3] = "CAFÉ" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[2][3] = "CERVEJA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[2][3] = "CHÁ" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[2][3] = "LEITE" pare // Fim } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CIGARRO escreva("\n1) BLENDS \n") escreva("2) BLUEMASTER \n") escreva("3) DUNHIL \n") escreva("4) PALL MALL \n") escreva("5) PRINCE \n\n") escreva("Escolha um CIGARRO para a casa 4: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[3][3] = "BLENDS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[3][3] = "BLUEMASTER" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[3][3] = "DUNHIL" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[3][3] = "PALL MALL" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[3][3] = "PRINCE" pare // Fim } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // ANIMAL escreva("\n1) CACHORROS \n") escreva("2) CAVALOS \n") escreva("3) GATOS \n") escreva("4) PÁSSAROS \n") escreva("5) PEIXES \n\n") escreva("Escolha um ANIMAL para a casa 4: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[4][3] = "CACHORROS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[4][3] = "CAVALOS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[4][3] = "GATOS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[4][3] = "PÁSSAROS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[4][3] = "PEIXES" pare // Fim } } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // CASA 5 escreva("\n1) COR \n") escreva("2) NACIONALIDADE \n") escreva("3) BEBIDA \n") escreva("4) CIGARRO \n") escreva("5) ANIMAL \n\n") escreva("Escolha um atributo: ") leia(opcao) escolha (opcao){ caso 1: // COR escreva("\n1) AMARELA \n") escreva("2) AZUL \n") escreva("3) VERMELHA \n") escreva("4) VERDE \n") escreva("5) BRANCA \n\n") escreva("Escolha uma COR para a casa 5: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[0][4] = "AMARELA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[0][4] = "AZUL" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[0][4] = "VERMELHA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[0][4] = "VERDE" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[0][4] = "BRANCA" pare // Fim } pare // Impede que as instruções do caso 2 sejam executadas caso 2: // NACIONALIDADE escreva("\n1) ALEMÃO \n") escreva("2) DINAMARQUÊS \n") escreva("3) INGLÊS \n") escreva("4) NORUEGUÊS \n") escreva("5) SUECO \n\n") escreva("Escolha uma NACIONALIDADE para a casa 5: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[1][4] = "ALEMÃO" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[1][4] = "DINAMARQUÊS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[1][4] = "INGLÊS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[1][4] = "NORUEGUÊS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[1][4] = "SUECO" pare // Fim } pare // Impede que as instruções do caso 3 sejam executadas caso 3: // BEBIDA escreva("\n1) ÁGUA \n") escreva("2) CAFÉ \n") escreva("3) CERVEJA \n") escreva("4) CHÁ \n") escreva("5) LEITE \n\n") escreva("Escolha uma BEBIDA para a casa 5: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[2][4] = "ÁGUA" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[2][4] = "CAFÉ" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[2][4] = "CERVEJA" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[2][4] = "CHÁ" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[2][4] = "LEITE" pare // Fim } pare // Impede que as instruções do caso 4 sejam executadas caso 4: // CIGARRO escreva("\n1) BLENDS \n") escreva("2) BLUEMASTER \n") escreva("3) DUNHIL \n") escreva("4) PALL MALL \n") escreva("5) PRINCE \n\n") escreva("Escolha um CIGARRO para a casa 5: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[3][4] = "BLENDS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[3][4] = "BLUEMASTER" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[3][4] = "DUNHIL" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[3][4] = "PALL MALL" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[3][4] = "PRINCE" pare // Fim } pare // Impede que as instruções do caso 5 sejam executadas caso 5: // ANIMAL escreva("\n1) CACHORROS \n") escreva("2) CAVALOS \n") escreva("3) GATOS \n") escreva("4) PÁSSAROS \n") escreva("5) PEIXES \n\n") escreva("Escolha um ANIMAL para a casa 5: ") leia(opcao) escolha (opcao){ caso 1: testeUsuario[4][4] = "CACHORROS" pare // Impede que as instruções do caso 2 sejam executadas caso 2: testeUsuario[4][4] = "CAVALOS" pare // Impede que as instruções do caso 3 sejam executadas caso 3: testeUsuario[4][4] = "GATOS" pare // Impede que as instruções do caso 4 sejam executadas caso 4: testeUsuario[4][4] = "PÁSSAROS" pare // Impede que as instruções do caso 5 sejam executadas caso 5: testeUsuario[4][4] = "PEIXES" pare // Fim } } pare // Fim } // Fim do primeiro escolha caso escreva ("Você desisti? SIM = 1, NÃO = 0: ") leia(desistir) cont++ //se (cont == 25){ //} }enquanto (cont <= 25 ou desistir != 1) para (inteiro l=0; l < 5; l++){ escreva (atributo[l],"\t") para (inteiro c=0; c < 5; c++){ escreva ("| ",testeUsuario[l][c]," |\t") } escreva ("\n\n") } } }
  24. /*Considere o eixo x, do plano cartesiano. Calcule a distância de um ponto negativo até um ponto positivo. O programa deve esperar dois valores, o primeiro deve ser negativo e o segundo positivo, caso um dos dois não esteja como pedido, deve exibir ?###ERRO: Parâmetros incorretos!!!###?*/ programa { funcao inicio() { inteiro num1, num2, i = 0, distancia = 0 escreva("\nInsira um numero negativo: ") leia(num1) escreva("\nInsira um numero positivo: ") leia(num2) para(i; i>=0; i++){ se((num1<0) e (num2>0)){ i = num1 distancia++ } senao{ escreva("\n?###ERRO: Parâmetros incorretos!!!###?") } } escreva("\nA distância entre os pontos é de "+distancia) } } O cálculo da distância não está dando certo, porém quando faço em versão do façaEnquanto dá certo... Se alguém puder me dar uma luz do que está acontecendo aqui! Obrigada.
  25. programa { funcao inicio() { para(inteiro i = 1; i <= 500; i++) { inteiro num = i%2 se(num%2==0){ escreva("\nNúmero par: "+i) }senao{ escreva("\nNúmero ímpar: "+i) } } } } Preciso montar um algoritmo que mostre quantos números pares e quantos ímpares têm entre 1 e 500, no entanto, não sei como faço pra desenvolver o algoritmo para que haja a soma desses dois tipos de n°. Se alguém puder me ajudar a utilizar o tipo de laço 'para' nesse caso. Obrigada

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes de Computadores - Gabriel Torres

PROMOÇÃO DE QUARENTENA

De R$ 39,90 por apenas R$ 9,90 só até as 23h59min desta sexta-feira 03/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!