Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''Portugol''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição, autoração e gravação de áudio e vídeo
    • Programas
  • Sistemas Operacionais
  • Eletrônicos
  • Outros
  • Clube do Hardware

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Encontrado 91 registros

  1. Bom Dia Não tenho muito conhecimento em criar "Bat" e gostaria de uma ajuda se possível. Preciso criar uma bat onde eu possa pesquisar pastas onde contém 7 números ex: "7207639" porém o primeiro numero é variável pois o sistema gera automático, ele pode iniciar com "7,6 ,0 ou 5" então eu teria que digitar "*207639" e a bat trazer o valor encontrado de "7207639" e seu tamanho "se possível" e mostrar em qual dos diretórios ela se encontra. \\saowsr0096\Shared\INF\ARCHIVE\ \\saolsr0028\psc\psc\londri\ \\136.238.5.63\outputssao\WORKING\ normalmente quando para aqui ela está com erro" \\136.238.5.63\outputssao\ARCHIVE\ "A extensão aqui é "7207639.tar.gz" Muito Obrigado
  2. Boa noite galera, eu perdi muitas aulas e estou estando pra uma prova(substitutiva) de algoritmos através de videos e estou sofrendo em alguns exercício da lista. Exercícios da lista 1) Faça um algoritmo que crie um procedimento que calcule o fatorial de um número, usando uma função que retorne o valor do fatorial para o bloco que chamou essa função. algoritmo var n, c, fat: inteiro funcao fatorial(x: inteiro): inteiro inicio Retorne fat fimfuncao inicio fat <- 1 escreva("Digite um numero: ") leia(n) para c <- 1 ate n passo 1 faca fat <- fat * c fimpara escreva("O fatorial de ", n, " = ", fat) fimalgoritmo Alguém poderia olhar e ver se já está certo? Caso esteja errado me fale qual o erro fazendo favor! O código está rodando normalmente, mas nunca se sabe né... Procurei vídeos explicando e não achei, só achei um exercício parecido com esse porém achei muito confuso.... Obrigado!
  3. Me ajudem com esses exercícios no Portugol Declare uma matriz 5 x 5. Faça com que o computador preencha com 1 a diagonal principal e com 0 os demais elementos. Escreva ao final a matriz obtida. Leia uma matriz 6 x 6, conte e escreva quantos valores maiores que 10 ela possui.
  4. programa { funcao inicio() { inteiro v[10] para(inteiro i = 0; i < 10; i++){ v[i]=5*(i+1) } escreva("Acabou") } } anunciado: Crie um programa que preencha automaticamente (usando lógica, não apenas atribuindo diretamente) um vetor numérico com 10 posições o cada dado dentro do vetor tem que ser múltiplo de 5 será que fiz certo?
  5. Visitante

    Portugol Definição de lógico (Portugol)

    "logico: inclui apenas os valores lógicos falso e verdadeiro e as operações de negação, conjunção e disjunção." Retirado do artigo da UFRN https://www.dimap.ufrn.br/~richard/pubs/dim0320/readings/aula03.pdf O que são valores lógicos falso e verdadeiro? O que são operações de negação, conjunção e disfunção?
  6. Visitante

    Portugol Referência para entender variáveis

    Alguém tem referências bibliográficas para como eu posso diferenciar as variáveis lógico, caractere, inteiro e rea? Procurei na internet e não me ajudou. Desde já agradeço pela ajuda.
  7. Visitante

    Portugol Vantagens e desvantagens do Portugol

    Como eu posso compreender as vantagens e desvantagens do Portugol? Procurei na net, mas não me ajudou muito.
  8. Alguém me ajuda a resolver essas questões, consegui fazer mas não por completo. 1° Faça um algoritmo que calcule o valor de A, dado por: A = N + N-1/2 + n-2/3...1/n , onde N é um número inteiro positivo? - Ler o valor inteiro de N - Ler o Número de termos que serão calculados da sequência - Calcular e imprimir o valor correto da sequencia 2° Dada uma MAT de 4 x 5 elementos, faça um programa para somar os elementos de cada linha gerando um vetor SOMA, em seguida somar os elementos do vetor SOMA na variável TOTAL que deve ser impressa no final. 3° Crie um programa que entre com valores inteiros para uma matriz m 3 x 3 e imprima a matriz final. 1 2 3 9 8 7 4 5 6 a matriz gira 180° 6 5 4 7 8 9 3 2 1 4 ° - Calcula a Média Aritmética dos elementos hachurados na letra "A" - O maior elemento da linha onde se encontra o menor elementos da área hachurada na letra "B"
  9. Galera preciso Incluir uma FUNÇÃO neste exercício vai cair na prova e professor falou que é igual porém tem que incluir a a função: 24 – Faça um algoritmo em pseudocódigo que calcule a transposta de uma matriz de 2 linhas e 3 colunas através de um procedimento. Matriz transposta, em matemática, é o resultado da troca de linhas por colunas em uma determinada matriz. Uma matriz simétrica é toda a matriz que é igual à sua transposta. Algoritmo Transposta VAR i,j: inteiro M: Matriz [1...2,1...3] de inteiro Procedimento Transposta (X:Matriz [1...2,1...3] de inteiro) Var T: Matriz [1...3,1...2] de inteiro Inicio Para i de 1 até 2 Faça Inicio Para j de 1 até 3 Faça Inicio T[j,i] := X[i,j] Escreva (“O elemento “, j, “,”, i, “é:”, T[j,i] Fim Para Fim Para Fim Procedimento Inicio Para i de 1 até 2 Faça Inicio Para j de 1 até 3 Faça Inicio Escreva “Entre com o valor do elemento da linha “, i, “e da coluna”, j Leia M[i,j] Fim Para Fim Para Transposta[M] Fim Algoritmo COMO FICARIA COM A FUNÇÃO E COM PPROCEDIMENTO?
  10. Boa noite galera, estou estudando sobre pseudocodigos, recentemente e me surgiram exercícios nos quais tive problemas; programa calc var n,conta:inteiro inicio n <- 8 conta <- 2 repita conta <- conta + ( n – 1 ) n <- n – 1 até que n = 0 escreva conta fim. var x : inteiro inicio x <- 11 se ( x < > 1 0) se ( ( x > 15 ) OU ( x <= 20 ) ) x <- x + 2 senão x <- x – 4 fim_se fim_se se ( x MOD 4 >= 2 ) x <- x + 5 senão x <- x – 3 fim_se escreva “ x = “, x fim Conseguem me ajudar/explicar qual seria o resultado final de ambos os códigos? Também tenho uma dúvida quanto a algumas suposições: A expressão matemática anexa é utilizada para projetar espelhos. Nesta expressão, n é um índice numérico do tipo real, R e S são números inteiros. Qual deve ser o tipo da variável foco para poder armazenar o resultado da expressão? Creio que o tipo char (caractere) se encaixaria aqui, o que acham? Se um algoritmo lê apenas um nome de uma pessoa e sua idade, qual o procedimento para ler os dados de cinco pessoas? tenho as opções: se/fim-se para/fim_para inicio/fim escolha/fim-escolha caso/fim_caso Qual a estrutura de repetição que executa pelo menos uma vez os comandos que estão dentro dela? tenho as opções: Caso/fim_caso inicio/fim Para/fim_para Repita/ate se/se_fim Podem me ajudar?
  11. Pessoal, minha professora possou o seguinte problema para resolvermos: Pegue 10 números aleatórios que serão inseridos pelo usuário do programa, e dentre eles identifique o MAIOR, o MENOR e a MEDIA deles. até o momento o que eu tenho é isso: programa { inteiro QTD = 0 inteiro i real maior=0.0, menor,num funcao inicio() { leia (QTD) real notas[100],media media = 0.0 para (i=0;i<QTD;i++) { escreva ("Informe a nota ", i ," : ") leia (notas) media=media+notas } media= media/QTD escreva (media) } } O MEU PROBLEMA É O SEGUINTE: com esse código eu não consigo mostrar qual é o maior e o menor numero digitado pelo usuário, e também nem faço ideia de como fazer isso,ja procurei na internet mas sobre portugol não há tanto material em especifico assim,se alguém puder ajudar agradeço,tudo o que preciso é de uma luz doq fazer para mostrar ao usuário qual é o maior e o menor numero.
  12. 4) Faça um algoritmo que gere uma tabela com os números de 1 a 10 e mostre o seu quadrado, cubo, fatorial, número de divisores e uma mensagem dizendo se o número é primo ou não. A cada 20 linhas deve ser escrito o cabeçalho novamente: algoritmo "Tabelade1ate10" var i, r, x, j: inteiro q, c: real funcao fatorial(b:inteiro):inteiro var f, t: inteiro inicio f <- 1 Se (b = 1) então Retorne 1 SeNao Para t <- 1 ate b-1 faca f <- f*t FimPara Retorne f FimSe fimfuncao funcao divisores(b:inteiro):inteiro var div, l: inteiro inicio Para l <- 1 ate b faca Se (b%l=0) então div <- div + 1 FimSe FimPara Retorne div fimfuncao funcao primo(b:inteiro):inteiro var div, l: inteiro inicio Para l <-1 ate b faca Se (b%l=0) então div <- div + 1 FimSe FimPara Se (div = 2) então Retorne "sim" SeNao Retorne "nao" FimSe fimfuncao inicio Escreva("Número Quadrado Cubo Fatorial Divisores Primo") Para i <- 1 ate 10 faca q <- i^2 c <- i^3 r <- fatorial() x <- divisores() z <- primo() Escreva(i, q:7, c:8, r:4, x:6, z:10) FimPara fimalgoritmo Ele finaliza no início da função <fatorial()> e eu não sei por quê... gostaria de entender onde estou errando. obs: desconsiderei a repetição a cada 20 linhas. Achei desnecessário.
  13. programa { funcao inicio() { real valor,sal,mens,pc inteiro ano escreva("-------Empréstimo Bancário--------\n") escreva("Qual o valor da casa? R$") leia(valor) escreva("Qual o salário do comprador? R$") leia(sal) escreva("Em quantos anos deseja pagar? ") leia(ano) mens=valor/ano*12 pc=sal+sal*30/100 se (mens>pc) { escreva("Empréstimo negado...") } senao{ escreva("Mensalidade a pagar: R$",mens) } } } Onde estou errando?
  14. Fiz uma avaliação recentemente e teve uma questão que me deixou muito em duvida e eu não consigo fazer de jeito nenhum, gostaria que alguém me ajudasse a entender como chegar nesse resultado. ps.: imagem da pilha anexada Questão: A seguinte sequência de instruções expressas na forma de uma pseudolinguagem (Português Estruturado) foi executada com base nesse estado da pilha. As instruções PUSH e POP são instruções típicas de estruturas de dados do tipo Pilha. Soma ← 0; POP(x); Soma ← Soma + x; x ← 10; PUSH(x); x ← 12; PUSH(x); POP(x); POP(x); Soma ← Soma + x; Com base nessa sequência de instruções, o valor final da variável Soma será: Escolha uma: a. 5 b. 17 c. 12 d. 10 e. 15 Resposta certa e) 15
  15. Olá pessoal preciso resolver os seguintes exercícios mas estou com dificuldade, queria ajuda se possível. Segue abaixo os exercícios 1 - Escreva um algoritmo que imprima todos os números pares do intervalo fechado de 1 a 100. 3 - Escreva um algoritmo que imprima o quadrado dos números no intervalo fechado de 1 a 20. 4 - Escreva um algoritmo em PORTUGOL que receba dez números do usuário e imprima a metade de cada número. Lembrando que todos devem ser resolvidos em portugol Agradeço desde já.
  16. Leia atentamente os requisitos especificados e analise as opções de solução, expressas em pseudocódigo, e escolha a alternativa que implemente exatamente os requisitos abaixo: Desenvolver um módulo ou programa para validar a entrada de dados para um formulário de informações de clientes, especificamente para o campo sobre estado civil do cliente, considerando: · Os valores válidos para a entrada de dados referente ao estado civil do cliente são: “S” para Solteiro, “C” para Casado, “D” para Divorciado, “V” para Viúvo e “O” para Outros. · O módulo deverá repetir a entrada de dados enquanto um destes valores não for digitado pelo usuário. (A) Var: digitacaoOK, estado_civildigitacaoOK = Verdade REPETIR enquanto digitacaoOK = Falso Obter o campo estado_civil SE(1) estado_civil igual a um dos itens do conjunto {“S”|“C”|“D”|“V”|“O”} ENTÃO digitacaoOK = Verdade FIM SE (1) Fim do Repetir (B) Var: digitacaoOK, estado_civildigitacaoOK = Falso REPETIR enquanto digitacaoOK = Falso Obter o campo estado_civil SE(1) estado_civil igual a um dos itens do conjunto {“S”|“C”|“D”|“V”|“O”} ENTÃO estado_civil = Verdade FIM SE (1) Fim do Repetir (C) Var: digitacaoOK, estado_civildigitacaoOK = Falso REPETIR enquanto digitacaoOK = Falso Obter o campo estado_civil SE(1) estado_civil igual a um dos itens do conjunto {“S”|“C”|“D”|“V”|“O”} ENTÃO digitacaoOK = Verdade FIM SE (1) Fim do Repetir (D) Var: digitacaoOK, estado_civil digitacaoOK = Falso REPETIR enquanto digitacaoOK = Falso Obter o campo estado_civil SE(1) estado_civil igual a um dos itens do conjunto {“S”|“C”|“D”|“V”|“O”} ENTÃO estado_civil = Verdade FIM SE (1) (E) Var: digitacaoOK, estado_civilObter o campo estado_civil SE(1) estado_civil igual a um dos itens do conjunto {“S”|“C”|“D”|“V”|“O”} ENTÃO digitacaoOK = Verdade FIM SE (1)

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes de Computadores - Gabriel Torres

PROMOÇÃO DE QUARENTENA

De R$ 39,90 por apenas R$ 9,90 só até as 23h59min desta sexta-feira 03/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!