Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e ofertas
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Caixas de som

Encontrado 288 registros

  1. Olá amigos. Eu tenho o seguinte algoritmo: algoritmo "SacarDinheiro" // Função : Verificar se o saque é possível na conta bancária // Autor : // Data : 04/12/2018 // Seção de Declarações var SaldoDisponivel: REAL ValorDoSaque: REAL SIM: LOGICO NAAO: LOGICO inicio SaldoDisponivel:= 1000 //Assumimos que há 1000 reais de saldo na conta disponível para o saque ESCREVA ("Informe o valor do Saque: ") LEIA (ValorDoSaque) SE ValorDoSaque <= SaldoDisponivel ENTAO SaldoDisponivel := SaldoDisponivel - ValorDoSaque ESCREVAL ("Sacando R$", ValorDoSaque, ".") ESCREVAL ("Aguarde a contagem das notas") ESCREVAL("Retire as notas") SENAO ESCREVAL ("O valor solicitado é maior que o valor disponível para saque!") FIMSE ESCREVA("Deseja continuar?") LEIA (SIM) SE SIM ENTAO AQUI EU GOSTARIA DE FAZER A REPETIÇÃO DO algoritmo SE MINHA resposta FOR SIM MAS NÃO ENCONTRO A ESTRUTURA CERTA ALGUEM SABE? ESCREVA ("Informe o valor do Saque: ") LEIA (ValorDoSaque) SE ValorDoSaque <= SaldoDisponivel ENTAO SaldoDisponivel := SaldoDisponivel - ValorDoSaque ESCREVAL ("Sacando R$", ValorDoSaque, ".") ESCREVAL ("Aguarde a contagem das notas" ESCREVAL("Retire as notas") SENAO ESCREVAL ("O valor solicitado é maior que o valor disponível para saque!") FIMSE ESCREVAL ("Saldo Disponível: R$", SaldoDisponivel) FIMSE fimalgoritmo
  2. Galera eu preciso da resolução desses algoritmos (Matriz) até amanhã por favor 1) Faça um algoritmo que leia 9 uma matriz 3x3. Posteriormente, percorra esta matriz e imprima somente os números que são pares. 2) Faça um algoritmo que leia uma matriz 2x3 e verifique se a matriz possui algum número repetido. Informe "Possui" ou "Não Possui" ao final do algoritmo. 3) Faça um algoritmo que possua duas matrizes 4x4 de números inteiros. Posteriormente, imprima somente os números que estão nas duas matrizes. 4) Faça um algoritmo que leia uma matriz 3x3 e imprima esta matriz ordenada de forma crescente. POR FAVOR RESPONDAM!!!
  3. Elabore um programa que: i) Leia as três primeiras informações de cada aluno (matrícula, média das provas e média dos trabalhos) ii) Calcula a nota final como sendo a soma da média das provas e da média dos trabalhos iii) Imprima a matrícula do aluno que obteve a maior nota final (assuma que só existe uma maior nota) iv) Imprima a média aritmética das notas finais algoritmo var vet:vetor[1..3,1..3] de inteiro vetx:vetor[1..3] de inteiro i,c,a:inteiro soma:inteiro inicio para i de 1 ate 3 faca para c de 1 ate 3 faca escreval("Digite o valor da primeira matricula ",vet ) leia(vet) fimpara para c de 1 ate 3 faca escreval("Digite o valor da medias do aluno ",vet[c] ) leia(vet[c]) fimpara para a de 1 ate 3 faca escreval("Digite o valor da medias do trabalho do aluno ",vetx[a] ) leia(vetx[a]) fimpara soma <- soma + vet+vet[c]+vetx[a] escreva("A soma total e ",soma ) fimalgoritmo adicionado 1 minuto depois salve galera fiz esse ai mais não gostei muito alguém tem uma ideia melhor de eu arruma essa bagaça kkkk !!!
  4. Saudações galera, sou novo em programação e gostaria de suas valiosa dicas com relação a seguinte questão: Faça um programa que efetue a busca do tipo sequencial por um valor em um vetor de 200 posições, sabendo que o mesmo valor pode ocorrer mais de uma vez no vetor. O programa deve imprimir o número de ocorrências do valor de busca, caso ocorram. Obs. (O programa deve ser desenvolvido por meio da ferramenta Visualg) Comecei fazendo a questão, porém o mesmo não consegue identificar os valores repetidos no vetor. Por gentileza onde estou errando ? Segue o código do programa: algoritmo "busca sequencial " var j,k, vb : inteiro v : vetor[1..20] de inteiro v1: vetor [1..20] de inteiro achou : logico RESP: logico procedimento preenchevetor var j : inteiro inicio para j de 1 ate 20 faca v[j] <- randi(200) escreval(j:10,v[j]:10) fimpara fimprocedimento inicio RESP:= verdadeiro enquanto RESP = verdadeiro faca preenchevetor escreva("Entre com o valor de busca (ESC termina) :") leia(vb) j <- 1 repita se v[j] = vb entao achou <- verdadeiro senao j <- j+1 fimse ate (achou=verdadeiro) ou (j>20) se achou entao escreval("Achei ", vb , " na posição ", j) senao se ( v[j] = vb) entao escreval(" Valor: ", vb , " repetiu na posição ", j) senao escreval("Nao achei.") fimse fimse fimenquanto fimalgoritmo No mais só tenho a agradecer.
  5. Letra mínima tem o mesmo significado que letra muito pequena. Estou filmando com a Apowersoft Free Online Screen Recorder, a tela inteira do meu notebook (1366x768) e quando publico no YouTube, a letra do VisualG fica mínima e quase tudo nos vídeos é ilegível, mesmo com a qualidade 720p.
  6. Considere que você foi contratado por um corretor de seguros para desenvolver um programa de computador que auxilie o corretor no cálculo de seguros de automóveis. Este corretor trabalha com duas companhias de seguro: NextCred Seguros e a LouLou Seguros. O usuário/corretor fornecerá o sexo e a idade do segurado, além do valor do automóvel a ser segurado. Sabe-se que o valor da apólice para as seguradoras NextCred Seguros e LouLou Seguros são de 4,3% e 5,8%, respectivamente. A seguradora NextCred Seguros não faz distinção quanto ao sexo dos segurados. No entanto, segurados com menos de 25 anos têm um acréscimo de 1,5% para cada ano abaixo dos 25, chegando à 10,5% no caso do segurado ter 18 anos. Já os segurados com mais de 50 anos têm desconto de 1% por ano, limitando-se à 15% de desconto. A LouLou Seguros dá desconto de 6% para clientes do sexo feminino e mais 8% de desconto caso o cliente tenha 30 anos de idade ou mais. Todos os acréscimos e descontos para ambas as seguradoras são com base no valor bruto da apólice. Após o cálculo das apólices, o programa deve apresentar ambos os valores, referentes a NextCred Seguros e a LouLou Seguros. O programa deve estar apto a processar vários clientes, encerrando a execução quando um código inválido para o sexo do cliente ou segurado seja digitado. Então, pede-se que seja elaborado um algoritmo em VisualG afim de gerar o produto desejado para o corretor.
  7. Olá galera, preciso de outra ajudinha aqui, acabei de começar o código, mas to com dificuldade para entender a lógica. Eu preciso que a matriz receba a pergunta e a resposta(gabarito. Peço que não mandem o código pronto, me passem uma explicação. Código: Var quest :vetor[1..10,1..5] de caractere a,b,c,d :caractere respostaop :inteiro r,q :inteiro tela :caractere acertos :inteiro cont : inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------------------------") fimprocedimento Inicio escreval("********************************************************") escreval("* *") escreval("* *") escreval("* Questionário Perguntas *") escreval("* Aleatórias *") escreval("* *") escreval("* *") escreval("* *") escreval("* PRESSIONE ENTER PARA COMEÇAR *") escreval("* *") escreval("* BOA SORTE! ;3 *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") escreva("Aperte ENTER para continuar...") leia(tela) limpatela //GABARITO //-----------------questão1-------------------- q() para q de 1 ate 10 faca para r de 1 ate 5 faca quest[1,1] <- "Quem foi Adolf Hitler" fimpara fimpara escreval( quest[1]) separa() escreval( "A)Um Camponês Alemão") escreval( "B)Líder da Alemanha Nazista no período da Segunda Guerra") escreval( "C)Líder do Brasil no período da Segunda Guerra") escreval( "D)Empresário Alemão") escreval() escreva("A alternativa certa é:") leia(resp[1]) se resp[1] = "B" entao acertos <- acertos + 1 fimse q () //--------------------QUESTÃO 2----------------------- quest[2] <- "Quem foi Benito Mussolini?" escreval(quest[2]) separa() escreval( "A)Líder do Partido Nacional Fascista na Itália") escreval( "B)Líder de movimentos comunistas") escreval( "C)Presidente do Brasil") escreval( "D)Camponês") escreval() escreva("A alternativa certa é:") leia(resp[2]) se resp[2] = "A" entao acertos <- acertos + 1 fimse q() Fimalgoritmo
  8. Pessoal, não estou conseguindo executar uma linha (13) de código no Visualg referente à estrutura condicional. * O visuAlg, por sua vez, sempre afirma que falta um "então" algo, que eu já corrigir... Me ajudem, por favor...
  9. Olá, montei o algoritmo para calcular o IMC, quando eu coloco "Peso 59" e "Altura 1.82" o resultado é "IMC 17.81". Deveria aparecer como resultado "Você está abaixo do peso, pede uma pizza aí!", mas o que aparece é "Muito bem, você está no peso ideal!". Eu não estou entendendo onde errei, será que o Visualg tem algum erro? Me ajudem por favor!!! rsrs... O código que fiz foi esse: Algoritmo "imc" Var nome: caracter kg, Altu, IMC: real Inicio Escreval ("Olá, qual seu nome?") Leia (nome) Escreval ("Quanto você pesa ", nome, "?") Leia (kg) Escreval ("Quanto você tem de altura?") Leia (Altu) IMC<- Kg/ (Altu^2) Se (IMC < 17) então Escreval ("Muito abaixo do peso ",nome, ".") Senao Se (IMC >= 17) e (IMC < 18.5) entao Escreval (nome," Você está abaixo do peso, pede uma pizza aí!") Senao Se (IMC >= 18.5) e (IMC < 25) entao Escreval ("Muito bem ", nome, ", você está no peso ideal!") Senao Se (IMC >= 25) e (IMC < 30) entao Escreval ("Hora de pensar em um regime ", nome, ", você está com sobrepeso!") Senao Se (IMC >= 30) e (IMC < 35) entao Escreval ("Obesidade ", nome, ", é isso que você quer pra sua vida?") Senao Se (IMC >= 35) e (IMC < 40) entao Escreval ("Obesidade severa, sinto muito ", nome) Senao Escreval ("Obesidade mórbida", nome, ", aconselho que vá cuidar da sua saúde.") Fimse Fimse Fimse Fimse Fimse Fimse Escreval (nome,", O seu IMC é ", IMC:5:2, ".") Fimalgoritmo
  10. Nao entendi como usar vetores // EXERCICIO NUMERO 7 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "7" var Q: vetor[1..10] de inteiro i,posicao: inteiro inicio para i de 1 ate 10 faca escreval("Digite o", i, "º numero:") leia(Q[i]) posicao <- i escreval("Na posição:", posicao) escreval enquanto (Q[i] < 0) faca escreval("Digite um valor positivo") leia(Q[i]) fimenquanto fimpara para i de 1 ate 10 faca posicao <- i fimpara fimalgoritmo nao sei se o que eu fiz ta certo !
  11. o que eu conseguir foi dar o desconto porém so consigo para 10% os outros eu nao consigo fazer ... preciso de ajuda // EXERCICIO NUMERO 2 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "Desconto para comercio" Var // Seção de Declarações das variáveis descricaoproduto:caractere precounitario,quantidade:real precototal,valordesconto,valorpagar:real valorpagardesconto:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Descrição Do Produto..............: ") leia(descricaoproduto) escreva("Preço Unitario..................R$: ") leia(precounitario) escreva("Quantidade........................: ") leia(quantidade) precototal<-quantidade*precounitario //preço por unidade //OS DESCONTOS //15% menor R$150 se precototal<150 entao valordesconto<-(precototal*15/100) senao valorpagar<-precototal fimse //18% de R$150 a R$499 se precototal>150 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal<499 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal>500 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal<799 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal>800 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal<=1000 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal>1001 entao valordesconto<-(precototal*30/100) senao valorpagar<-precototal-valordesconto fimse escreval("Preço Total do Produto..........R$: ",precototal) escreval("Valor do Desconto...............R$: ",valordesconto) escreval("Valor a Pagar...................R$: ",valorpagar) escreval("********FIM DO ALGORITMO*******") fimalgoritmo
  12. Não consigo achar o menor número usando o repita. algoritmo "TP901.alg" // Função : // Autor : // Data : 07/11/2018 // Seção de Declarações var vln: inteiro vlm: inteiro vls: inteiro vlme: inteiro qtd: inteiro vlmd: real inicio vln <- 0 vlm <- 0 vlme <- 0 vls <- 0 qtd <- 0 vlmd <- 0 escreva ("Digite o primeiro número ou 0 para finalizar: ") leia (vln) vlm <- vln vlme <- vlme se (vln = 0) entao escreva ("Algoritmo finalizado sem calculos...") senao repita qtd <- qtd + 1 vls <- (vls + vln) escreva ("Digite o próximo número ou 0 para finalizar: ") leia (vln) se (vln > vlm) entao vlm <- vln fimse se (vln < vlme) entao vlme <- vln fimse ate (vln = 0) fimse escreval ("Seu algoritmo foi finalizado, veja as conclusões: ") vlmd <- vls/qtd escreval ("O maior valor é: ",vlm,"") escreval ("O menor valor é: ",vlme: 2:2,"") escreval ("A soma dos valores foi de: ",vls) escreval ("Quantidade de números digitados: ",qtd) escreval ("O menor valor digitado foi:" ,vlme,) vlmd <- vls/qtd escreval ("A média foi: ",vlmd) fimalgoritmo
  13. Muito obrigado estou tentando absorver estar explicações sobre "Enquanto" ... Agora entendi como usar ... pode me ajuda neste casso aqui . Faça um algoritmo que leia 5 números inteiros e, para cada um deles, exiba o antecessor, o sucessor, o dobro e o triplo. esta certo ? Algoritmo "leia 5 números inteiros e, para cada um deles, exiba o antecessor, o sucessor, o dobro e o triplo" //Exercicio 1 Var // Seção de Declarações das variáveis anumero:inteiro bnumero:inteiro cnumero:inteiro dnumero:inteiro enumero:inteiro dobro:inteiro triplo:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite o A numero: ") leia(anumero) //1 dobro <- (2*anumero) triplo <- (3*anumero) anumero := anumero-1 escreval("Anterior",anumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o B numero: ") leia(bnumero) //2 dobro <- (2*bnumero) triplo <- (3*bnumero) bnumero := bnumero-1 escreval("Anterior",bnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o C numero: ") leia(cnumero) //3 dobro <- (2*cnumero) triplo <- (3*cnumero) cnumero := cnumero-1 escreval("Anterior",cnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o D numero: ") leia(dnumero) //4 dobro <- (2*dnumero) triplo <- (3*dnumero) dnumero := dnumero-1 escreval("Anterior",dnumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval escreval("Digite o E numero: ") leia(enumero)//5 dobro <- (2*enumero) triplo <- (3*enumero) enumero := enumero-1 escreval("Anterior",enumero) escreval("Dobro",dobro) escreval("Triplo",triplo) escreval Fimalgoritmo Update acho que consegui
  14. Estou tentando mais não consigo alguém pode ma ajudar ?
  15. Galera gostaria por favor da ajuda de vocês aqui da comunidade, estou precisando fazer um fluxograma sobre esse algoritmo mais não sei por onde começar desde já agradeço a colaboração de todos!!! algoritmo "calculo_media" // Função: calcular a média var i:inteiro nota,media,somanota:real inicio // receba quatro notas de provas, calcule e caso: // entre 7 e 10 aluno aprovado // caso entre 5 e 7 aluno em recuperação. // caso entre 0 e 5 aluno reprovado repita i<-i+1 // contagem escreva("Digite a ",i," nota:") leia(nota) escolha nota caso 0 ate 10 somanota<-somanota+nota outrocaso i<-i-1 escreval("NOTA INVÁLIDA!") escreval("DIGITE NOVAMENTE! NOTAS DE 0 A 10!") fimescolha // soma a nota atual com a anterior ate i=4 media<-somanota/i escreval("A média do aluno ") escreval(" foi de: ",media," pontos") escolha media caso 7 ate 10 escreval("APROVADO") caso 5 ate 7 escreval("RECUPERAÇÃO") caso 0 ate 5 escreval("REPROVADO") outrocaso fimescolha fimalgoritmo
  16. Caros, boa noite. Estou desenvolvendo um algorítimo e tenho um problema que não consigo resolver. Pois bem ... Eu criei um vetor para armazenar inteiros e mais dois vetores para armazenar aqueles que são impares e outro para armazenar os que são pares desse primeiro vetor. Mas sempre que inicializo o código fica uns 0 sobre os índices que não estão sendo utilizados, exemplo tem somente 4 pares ai o vetor é de 10 índices e fica aparecendo 6 dígitos 0 sobre o vetor além dos números pares. Segue o código para vocês assimilarem melhor: algoritmo "tira0" var par: vetor [1..10] de inteiro impar: vetor [1..10] de inteiro num: vetor [1..10] de inteiro i: inteiro inicio para i de 1 ate 10 faca Leia (num ) se num %2 = 0 entao par <- num senao se num %2 <> 0 entao impar <- num fimse fimse fimpara para i de 1 ate 10 faca Escreval ("Par:", par ) fimpara Escreval () para i de 1 ate 10 faca Escreval ("Impar:", impar ) fimpara fimalgoritmo Eu acho que teria que mudar o índice do meu vetor para a quantidade de pares e impares, mas não sei como fazer isso. Me ajudem, por favor sou novato !
  17. Criar um algoritmo que lê um vetor de 10 posições e o escreve. Substituir todos os valores nulos desse vetor por 1 e escrevê-lo novamente Não consigo fazer com que leiam e substitua os vetores como se faz?
  18. Olá pessoal, preciso de ajuda em um algoritmo, ele ta quase pronto, porém preciso que o cadastro ocorra de 1 em 1 e em vez de mostrar o preço do produto, mostrar o Código do Produto mais caro/barato. Algoritmo: algoritmo "semnome" Var m: vetor[1..50] de inteiro l:inteiro tela : inteiro c : inteiro valor : real caro : real barato : real sub : inteiro cont : inteiro Inicio repita escreval("1 - Cadastrar Produto") escreval("2 - Visualizar Produto") escreval("3 - Alterar Produto") escreval("4 - Relatórios") escreval("5 - Fechar Sistema") leia(tela) {Cadastrar} se tela = 1 entao limpatela para l de 1 ate 5 faca escreval("Informe o Código do Produto:") leia(m[l]) cont <- cont + 1 escreval("Informe o valor do produto cadastrado:") leia(valor) fimpara fimse limpatela {Visualizar Produto} se tela=2 entao para l de 1 ate 5 faca escreval("O produto cadastrado é:", m[l]) fimpara fimse {Alterar Produto} se tela=3 entao limpatela para l de 1 ate 5 faca escreval(" Os produtos cadastrados são:", m[l]) fimpara para l de 1 ate 5 faca escreval("Informe o código do produto que deseja alterar:") leia(c) se c = (m[l]) entao escreval("Agora informe o novo código do produto") leia (m[l]) fimse fimpara fimse {Sub telas} se tela=4 entao limpatela escreval("1 - Exibe o produto mais caro") escreval("2 - Exibe o produto mais barato") escreval("3 - Exibe a quantidade de produtos cadastrados") escreval("4 - Exibir a média dos produtos cadastrados") leia (sub) {Valor do produto mais caro} se sub=1 entao limpatela para l de 1 ate 10 faca se valor > caro entao caro <- valor fimse fimpara escreval (" O valor do produto mais caro é :" , caro) fimse fimse {Valor do produto mais barato} se sub=2 entao limpatela para l de 1 ate 10 faca se valor < barato entao barato <- valor fimse fimpara escreval (" O valor mais barato é :" , barato) fimse {Quantidade de produtos cadastrados} se sub=3 entao limpatela para l de 1 ate 1 faca escreval(" A quantidade de produtos cadastrados são:", cont) fimpara fimse {Fechar programa} se tela=5 entao fimse ate tela = 5
  19. Boa noite, estou querendo criar um desdobramento aqueles com experiência no assunto poderia me ajudar ou melhorar esse código eu quero inserir 36 números de 1 a 60 depois escolher dos 36 9 e ele fazer o desdobramento de 9 com as 36 números como faria isso e com um contador de máximo que pode chegar de combinação. obrigado desde já Código:
  20. Estou aprendendo a programar , porém não consigo fazer ainda uma programação referente ao iniciado , alguém poder mim ajudada por favor ou dica de como fazer. Escreva um algoritmo que leia 250 valores representando a média final dos alunos de Lógica de Programação e o nome do respectivo aluno, neste trimestre. Ao final o algoritmo deve imprimir o nome do aluno que teve a maior nota e o nome do aluno que teve a menor nota.
  21. Quando tento rodar um algoritmo que contem "escolha" no visualg 3.0 ele simplesmente pula esse escolha e ignora o caso. O que eu faço para corrigir esse erro? No algoritmo abaixo mesmo que eu digite a palavra a que o caso se refere o programa ira pular para o "outrocaso" e escreverá o conteudo presente nele. EX: <algoritmo "semnome" var cont:inteiro modelo,outro:caracter inicio escreva("entre com o modelo do calçado:") leia(modelo) escolha modelo caso "mocassim" escreval("o modelo do calçado é masculino.") caso "rasteirinha" escreval("o modelo do calçado é feminino.") outrocaso escreval("o calçado é infantil.") fimescolha fimalgoritmo>
  22. Galera, boa noite estou com um probleminha , está dando o seguinte erro quando utilizo 0 como finalizador no visualg: algoritmo "semnome" // Função : // Autor : // Data : 09/11/2018 // Seção de Declarações var n, qtn, s, p, qtp, sp: inteiro mde: real inicio n <- 0 qtn <- 0 s <- 0 p <- 0 qtp <- 0 sp <- 0 mde <- 0 // Seção de Comandos escreva ("Por favor digite o primeiro número ou 0 para finalizar:") leia (n) se (n = 0) entao escreval ("Algortmo finalizado sem calculos...") senao repita qtn <- qtn+1 escreva ("Digite o Próximo número ou 0 para finalizar: ") leia (n) se (n = 0) entao escreval ("Algoritmo finalizado, veja: ") s <- s+n se (n > 0) entao qtp <- qtp+1 p <- n sp <- sp+p fimse fimse ate (n = 0) fimse mde <- sp/qtp escreva ("A quantidade de números digitados foi: ") escreva ("A Soma dos números digitados foi: ",s) se (mde < 0 ) entao escreva ("Você não digitou números positivos.") senao escreva ("A média de números positivos digitados foi: ",mde) fimse fimalgoritmo
  23. Bom pessoal, sou iniciante no mundo da programação e estou "aprendendo" pelo VisuAlg. Estou tendo dificuldades na hora da leitura do conteúdo da variável. Já verifiquei várias vezes, alterei o nome porém sem sucesso. Ao meu ver está correto, alguém poderia me auxiliar? Obrigado.
  24. Preciso de ajuda para finalizar o meu programa. //Faça um programa para incluir e montar os dados da tabela de peso especifico dos seguintes materiais. //o programa deve permitir ao usuario escolher o tipo de estrutura para calculo do peso proprio dos elementos estruturais(viga,pilar ou lage-seção retangular), a partir das dimensões informadas pelo teclado. //exemplo: escolha o elemento estrutural,informe as dimensões do elemento estrutural e Calcule e imprima o peso próprio do elemento. algoritmo "semnome" // Função : // Autor : // Data : 01/11/2018 // Seção de Declarações var resp,opcao,viga,pilar,lage:caractere lx_laje,ly_laje, espessura_laje, base_viga, altura_viga, comp_viga, lx_pilar, ly_pilar,comp_pilar,vol_laje, vol_viga, vol_pilar:real concArmad,aco,madeiraMassa,madeiraAngelim:real inicio // Seção de Comandos escreval("MATERIAIS PESO ESPECÍFICO ESTIMADO") escreval( ) escreval("Concreto Armado 2.500 Kgf/m3") escreval("Aço 7.800 Kgf/m3") escreval("Madeira (Massaranduba) 1.000 Kgf/m3") escreval("Madeira (Angelim Vermelho) 1.300 Kgf/m3") escreval( ) escreval("Qual o tipo de estrutura você deseja calcular Viga,Pilar ou Lage?") leia(resp) escolha opcao Viga<-1 escreval(" ") escreva("Digite Base da Viga (m): ") leia(base_viga) escreva("Digite Altura da Viga (m): ") leia(altura_viga) escreva("Digite Comprimento da Viga (m): ") leia(comp_viga) vol_viga<-(base_viga*altura_viga*comp_viga) escreval("O volume de concreto da Viga (m3) = ", vol_viga) pausa caso 2 escreva("Digite Lx da laje (m): ") leia(lx_laje) escreva("Digite Ly da laje (m): ") leia(ly_laje) escreva("Digite Espessura da laje: (m) ") leia(espessura_laje) vol_laje<-(lx_laje*ly_laje*espessura_laje) escreval("O volume de concreto da Laje = ", vol_laje, "m3") escreval(" ") pausa caso 3 escreval(" ") escreva("Digite Lx do Pilar (m): ") leia(lx_pilar) escreva("Digite Ly do Pilar (m): ") leia(ly_pilar) escreva("Digite Comprimento do Pilar (m): ") leia(comp_pilar) vol_pilar<-(lx_pilar*ly_pilar*comp_pilar) escreval("O volume de concreto do Pilar (m3)= ", vol_pilar) escreval(" ") fimcaso fimalgoritmo
  25. Boa tarde pessoal preciso muito da ajuda de vcs para realizar um programa no Visualg. Faça um programa para incluir e montar os dados de um vetor com 100 posições de números inteiros digitados pelo teclado.O programa deverá ter as seguintes funções: 1-Apresentar o maior valor da serie 2-O menor valor da serie 3-A média aritmética dos valores da serie. 4-Ordenar em ordem crescente os valores da serie.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×