Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas e sugestões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 105 registros

  1. Boa tarde, eu fiz um algoritmo utilizando procedimento com vetor e conseguir, mas quando eu fui colocar passagem por parâmetro ele da erro, minha dúvida é: é possível colocar procedimento com vetor e usar parâmetro no Visualg? ou fiz alguma declaração errada? vou copiar uma parte do código e agradeceria qualquer ajuda procedimento troca(var veti, vetj : inteiro) var aux, i, j: inteiro inicio auxi <- veti veti <- vetj vetj <- auxi fimprocedimento esse foi o comando que coloquei pra ele iniciar o procedimento a linha que da erro é essa: troca(veti,vetj)
  2. Alguem pode me ajudar com este algoritmo, algoritmo "semnome" var c1,c2,c3,c4, tempo_maior, tempo_menor:real inicio c1 <- 1 c2 <- 2 c3 <- 3 c4 <- 4 //escreva("Informe o tempo do jogador 1: ") //leia (c1) //escreva("Informe o tempo do jogador 2: ") //leia (c2) //escreva("Informe o tempo do jogador 3: ") //leia (c3) //escreva("Informe o tempo do jogador 4: ") //leia (c4) se (c1 > c4) e (c1 > c3) e (c1 > c2) então tempo_maior <- (c1) escreval("O jogador 1 tem maior tempo:",tempo_maior) senao se(c2 > c4) e (c2 > c3) e c2 > c1) então tempo_maior <- (c2) escreval("O jogador 2 tem maior tempo:",tempo_maior) senao se(c3 > c4) e (c3 > c2) e (c3 > c1) então tempo_maior <- (c3) escreval("O jogador 3 tem maior tempo:",tempo_maior) senao(c4 > c3) e (c4 > c2) e (c4 > c1) então tempo_maior <- (c4) escreval("O jogador 4 tem maior tempo:",tempo_maior) fimse fimse fimse se (c1 < c4) e (c1 < c3) e (c1 < c2) então tempo_menor <- c1 escreva("O jogador 1 tem menor tempo:",tempo_menor) senao (c2 < c4) e (c2 < c3) e (c2 < c1) então tempo_menor <- c2 escreva("O jogador 2 tem menor tempo:",tempo_menor) se (c3 < c4) e (c3 < c2) e (c3 < c1) então tempo_menor <- c3 escreva("O jogador 3 tem menor tempo:",tempo_menor) senao (c4 < c3) e (c4 < c2) e (c4 < c1) então tempo_menor <- c4 escreva("O jogador 4 tem menor tempo:",tempo_menor) fimse fimse fimalgoritmo
  3. Olá galera! Sou novo aqui então se tiver cometendo algum erro por favor me perdoem. Venho através desse tópico pedir a ajuda de você para um erro que está acontecendo na minha programação, sou aluno do 2 ano de Automação Industrial integrado e tenho uma atividade avaliativa para criar um conversor de binário/decimal, mas o problema não é esse e sim o programa não seguir a ordem da programação feita. Eu primeiro fiz uma tela de apresentação e depois uma de login e ai que esta o problema. Quando o usuário termina de se cadastrar o programa encerra e não vai para o principal objetivo que seria a conversão que ele desejaria, ele encerra a programação no fimalgoritmo . Espero que possam me ajudar! Abraços algoritmo "pedro" // Função : converter decima-binario/binario-decimal // Autor : // Data : 16/02/2018 // Seção de Declarações var login,Usuario,Nome,SobreN: caractere Password,Senha,Csenha: real o,V:inteiro decimaleuteodeio01,decimaleuteodeio02,decimaleuteodeio03,decimaleuteodeio04,decimaleuteodeio05,decimaleuteodeio06, decimal: inteiro numero1 : caracter binario,decimalk : inteiro inicio // Seção de Comandos timer 1000 escreval (" 110 10101001 10101001 10101001 WELCOME ") escreval (" 100001 10101001 10101001 10101001 TO ") escreval (" 10000000 10101001 10101001 10101001 CONVERTER ") escreval (" 010000 10101001 10101001 10101001 ") escreval (" 0101 10101001 10101001 10101001 ") escreval escreval (" 00000000 00000000 BEM VINDO ") escreval (" 10110101 10101010 AO ") escreval (" 11010100 10101101 CONVERSOR ") escreval (" 10101001 10110101 ") escreval (" 01010110 10110101 ") escreval (" 11001101 01101100 ") escreval (" 00000000 10101010 10101010 00001101 ") escreval (" 10110101 10101011 01010100 10101110 ") escreval (" 11010100 01101101 10110111 01110100 ") escreval (" 10101001 10111100 10111010 00110101 ") escreval (" 01010110 10110100 10101101 11000010 ") escreval (" ") escreval (" ") escreval (" 00000000 001010101 ") escreval (" 10110101 101101010 ") escreval (" 11010100 110011111 ") escreval (" 10101001 000111110 ") escreval (" 01010110 100011101 ") escreval (" 11001101 100110010 ") escreval timer 2000 //----------------------------------------------------------------------------- Escreva (" ****** BEM VINDO AO CONVERSO BINARIO/DECIMAL IFMA - AUTOMAÇÃO INDUSTRIAL ******") Escreval (" ") Escreval (" ") Escreval (" PRAZER, SOU O ALUNO Pedro Henrique do CURSO DE AUTOMAÇÃO INDUSTRIAL ") ESCREVA (" ") eSCREVA (" ") timer 2000 ESCREVA (" ESPERO QUE GOSTE DO MEU PROGRAMA, ABRAÇOS! ") limpatela timer 0 //----------------------------------------------------------------------------- Escreval("-------------------------------------------------------------------------------------------------") Escreval("Olá visitante seja bem vindo ao nosso programa,crie seu cadastro agora ") Escreval("-------------------------------------------------------------------------------------------------") Escreval(" ") Escreval("Por Favor! Digite seu nome APENAS O PRIMEIRO NOME") Escreva("Nome: ") Leia(Nome) Escreval(" ") Escreval("Por Favor! Digite seu segundo nome") Escreva("Segundo Nome: ") leia(SobreN) Escreval(" ") Escreval("Por Favor! Informe um nome de usuario 'APENAS LETRAS'") Escreva("Usuario ") Leia(Usuario) Escreval(" ") Escreval("Por Favor! Digite uma Senha 'APENAS NUMEROS'") Escreva("Senha: ") Leia(Senha) Limpatela Escreval("--------------------------------------------------------------------------------") Escreval(" Olá ", Nome, " ", SobreN, " SPor Favor! Confirme sua Senha ") Escreval("--------------------------------------------------------------------------------") Escreval(" ") Escreval("Confirme sua senha") Escreva("Senha: ") Leia(Csenha) Se (Senha <> Csenha) então Escreval(" ") Escreval("Senha Incorreta! Por favor digite novamente sua senha") Escreva("Senha: ") leia(Csenha) FimSe //--------------------------------------------------------------------------------------- Limpatela Escreval("--------------------------------------------------------------------------------") Escreval(" Olá ", Nome, " ", SobreN, " SPor Favor! Confirme sua Senha ") Escreval("--------------------------------------------------------------------------------") Escreval(" ") Escreval("Confirme sua senha") Escreva("Senha: ") Leia(Csenha) Enquanto (Senha <> Csenha) Faca Escreval(" ") Escreval("Senha Incorreta! Por favor digite novamente sua senha") Escreva("Senha: ") leia(Csenha) FimEnquanto LimpaTela Escreval("--------------------------------------------------------------------------------") Escreval(" Olá ", Nome, " ", SobreN, " Seu cadastro foi realizado com sucesso! ") Escreval("--------------------------------------------------------------------------------") Escreval(" ") Escreval("Por Favor! Entre na sua conta para continuar") Escreva("Usuario: ") Leia(login) Escreval("Por Favor! Digite sua senha") Escreva("Senha: ") Leia(Password) Escreval(" ") Se (login = Usuario) e (Password = Senha) então Senao Escreval("Usuario ou Senha incorreta! Por Favor tente novamente") Escreval(" ") Escreval("Digite o nome de usuario") Escreva("Usuario: ") Leia(login) Escreval(" ") Escreval("Digite novamente sua senha") Escreva("Senha: ") Leia(Password) Escreval(" ") Fimse Se (Password <> Csenha) ou (login <> Usuario) então Limpatela Escreval("----------------------------------------------------------------------------") Escreval("Você esqueceu de seu Usuario e Senha, por favor escolha umas das opçoês abaixo") Escreval(" ") Escreval("1-Tentar Novamente") Escreval("2-Mudar Usuario e Senha") Escreval(" ") Escreva("Opçâo?: ") Leia(o) Escreval(" ") senao limpatela Escreval("--------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Seu login foi efetuado com sucesso") Escreval("--------------------------------------------------------------------------------") Escreval(" ") Escreval("Espero que esse codigo tenho que ajudo em algo :)") FimSe escolha o Caso 1 limpatela Escreval("------------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Tente Novamente Para continuar entre em sua conta") Escreval("------------------------------------------------------------------------------------") Escreval(" ") Escreval("Digite seu Usuario") Escreval("Usuario: ") Leia(login) Escreval("") Escreval("Digite sua Senha") Escreval("Senha: ") Leia(Password) Enquanto (login <> Usuario) ou (Password <> Senha) faca limpatela Escreval("------------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Você digitou Usuario ou senha incorreto!") Escreval("------------------------------------------------------------------------------------") Escreval(" ") Escreval("Digite seu Usuario") Escreva("Usuario: ") Leia(login) Escreval("") Escreval("Digite sua Senha") Escreva("Senha: ") Leia(Password) FimEnquanto limpatela Escreval("--------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Seu login foi efetuado com sucesso") Escreval("--------------------------------------------------------------------------------") Escreval(" ") Caso 2 limpatela Escreval("Digite um novo Usuario") Escreva("Usuario: ") leia(Usuario) Escreval(" ") Escreval("digite uma Nova senha") Escreval("Senha: ") leia(Senha) Escreval(" ") Escreval("Digite novamente sua senha") Escreva("Senha: ") leia(Csenha) Escreval(" ") Enquanto (Csenha <> Senha) faca limpatela Escreval("--------------------") Escreval("Digite seu Usuario") Escreval("Usuario: ", Usuario) Escreval(" ") Escreval("As senhas não sao iguais, digite novamente") Escreva("Senha: ") leia(Csenha) FimEnquanto limpatela Escreval("------------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Você alterou seu login para continuar entre em sua conta") Escreval("------------------------------------------------------------------------------------") Escreval(" ") Escreval("Digite seu Usuario") Escreval("Usuario: ") Leia(login) Escreval("") Escreval("Digite sua Senha") Escreval("Senha: ") Leia(Password) V <- 1 Enquanto (login <> Usuario) ou (Password <> Senha) faca V <- V +1 limpatela Escreval("------------------------------------------------------------------------------------") Escreval("Olá ", Nome, " ", SobreN, ", Você digitou Usuario ou senha incorreto!") Escreval("------------------------------------------------------------------------------------") Escreval(" ") Escreval("Digite seu Usuario") Escreva("Usuario: ") Leia(login) Escreval("") Escreval("Digite sua Senha") Escreva("Senha: ") Leia(Password) Escreval (" Carregando ...") timer 5000 Escreval (" 3 ") timer 4000 Escreval (" 2 ") timer 3000 Escreval (" 1 " ) timer 2000 limpatela //----------------------------------------------------------------------------------------- timer 0 Escreva("Informe o numero binario: ") Leia(decimaleuteodeio01,decimaleuteodeio02,decimaleuteodeio03,decimaleuteodeio04,decimaleuteodeio05,decimaleuteodeio06) decimal <- (decimaleuteodeio06*1)+(decimaleuteodeio05*2)+(decimaleuteodeio04*4)+(decimaleuteodeio03*8)+(decimaleuteodeio02*16)+(decimaleuteodeio01*32) Escreva("Corresponde ao decimal: ",decimal) Escreval ( " ") Esvreval (" Se temrinou aperte ESC") limpatela //-------------------------------------------------------------------------- escreva("Entre com um número inteiro :") leia(binario) decimalk <- binario enquanto binario > 0 faca se (binario mod 2) = 0 então numero1 <- "0" + numero1 senao numero1 <- "1" + numero1 fimse binario <- binario div 2 fimenquanto fimenquanto escreval("A representação binária de", decimalk, " é ", numero1) fimalgoritmo Local onde está com: Não mostra o erro, mas como havia dito, ele já pula para o final do algoritmo.
  4. Olá a todos, estou tendo dificuldade no meu curso. Fiz os primeiros exercícios numa boa, mas esse estou para enlouquecer e não sei o que falta. Sou novo na área e aqui também. Admiro faz tempo o trabalho do Clube do Hardware. Por favor me ajudem. Esse é o algoritmo algoritmo "estadocivil" var ec: inteiro inicio ec <- 0 Escreva ("Digite o estado civil (1 - solteiro, 2 - casado, 3 - outro) ") Leia (ec) faca caso caso ec = 1 Escreva ("solteiro") caso ec = 2 Escreva ("casado") caso ec = 3 Escreva ("outro") outrocaso Escreva ("Valor inválido") fimalgoritmo Ele não entende FIM CASO (ou eu não sei como coloca).
  5. Oi pessoal, fiz meu primeiro jogo, jogo da forca. Amei o resultado. Poderiam avaliar meu algoritmo :)? Algoritmo "Jogo da Forca" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Jogo da Forca // Autor(a) : Vinícius Viana Werneck // Data atual : 30/01/2018 funcao Caract(palavra: caractere; posicao: inteiro): caractere var R : caractere inicio R <- copia(palavra, posicao,1) Retorne R fimfuncao procedimento sortear(var palavraAleatoria:caractere) var palavraDisponivel: vetor[0..15] de caractere ind: inteiro inicio palavraDisponivel[0] <- "reflexao" palavraDisponivel[1] <- "interrupcao" palavraDisponivel[2] <- "necessarios" palavraDisponivel[3] <- "ambulantes" palavraDisponivel[4] <- "humanidade" palavraDisponivel[5] <- "juventude" palavraDisponivel[6] <- "shopping" palavraDisponivel[7] <- "supermercado" palavraDisponivel[8] <- "proporcionar" palavraDisponivel[9] <- "sensatez" palavraDisponivel[10] <- "incidente" palavraDisponivel[11] <- "administracao" palavraDisponivel[12] <- "paralelepipedo" palavraDisponivel[13] <- "abacaxizeiro" palavraDisponivel[14] <- "autocentrado" palavraDisponivel[15] <- "acidente" ind <- Randi(15) palavraAleatoria <- palavraDisponivel[6] fimprocedimento procedimento desenhaForca() inicio EscrevaL("---+") EscrevaL(" |") EscrevaL(" |") fimprocedimento procedimento desenhaBoneco(n_parteBoneco: inteiro) var contador: inteiro inicio Se (n_partesBoneco = 1) então EscrevaL(" o ") Fimse Se (n_partesBoneco = 2) então EscrevaL(" o ") EscrevaL(" / ") Fimse Se (n_partesBoneco = 3) então EscrevaL(" o ") EscrevaL(" /| ") Fimse Se (n_partesBoneco = 4) então EscrevaL(" o ") EscrevaL(" /|\ ") Fimse Se (n_partesBoneco = 5) então EscrevaL(" o ") EscrevaL(" /|\ ") EscrevaL(" | ") Fimse Se (n_partesBoneco = 6) então EscrevaL(" o ") EscrevaL(" /|\ ") EscrevaL(" | ") EscrevaL(" / ") Fimse Se (n_partesBoneco = 7) então EscrevaL(" o ") EscrevaL(" /|\ ") EscrevaL(" | ") EscrevaL(" / \ ") Fimse Para contador de n_partesBoneco ate 6 faca EscrevaL() Fimpara fimprocedimento procedimento Pedir(var Letra: caractere) inicio EscrevaL() EscrevaL("Chute uma letra: ") EscrevaL() Leia(Letra) fimprocedimento funcao ehRealmenteLetra(Letra: caractere): logico var Resultado: logico inicio Se (maiusc(Letra) >= "A") e (maiusc(Letra) <= "Z") então Resultado <- verdadeiro Senao Resultado <- falso Fimse Retorne Resultado fimfuncao funcao jafoiDita(Letra:caractere):logico var Resultado: logico contador: inteiro Inicio Resultado <- falso Para contador de 1 ate compr(LetrasJaDitas) faca Se (Caract(Letra,contador) = Caract(LetrasJaDitas,contador)) então Resultado <- verdadeiro Fimse Fimpara Se (Resultado = falso) então LetrasJaDitas <- LetrasJaDitas + Letra Fimse Retorne Resultado fimfuncao funcao acertou(Letra:caractere):logico var contador: inteiro Resultado : logico inicio contador <- 1 Resultado <- falso Para contador de 1 ate compr(palavraAleatoria) faca Se (Letra = Caract(palavraAleatoria,contador)) então ParteDescoberta[contador] <- Letra Resultado <- verdadeiro Fimse Fimpara Retorne Resultado fimfuncao procedimento EscreverVetor() var cont: inteiro inicio Escreva(" ") Para cont de 1 ate TamMaiorPalavra faca Escreva(parteDescoberta[cont], " ") Fimpara fimprocedimento procedimento Desenhae_Escreve(quadro,letra: caractere) inicio EscrevaL("+-------+") EscrevaL("|",quadro:7,"|") EscrevaL("+-------+") EscrevaL() fimprocedimento funcao revelouTudo():logico var i: inteiro letrasDescobertas: inteiro JogoFinalizou : logico inicio i<-1 letrasDescobertas <- 0 Para i de 1 ate compr(palavraAleatoria) faca Se (parteDescoberta[i] = copia(palavraAleatoria,i,1)) então letrasDescobertas <- letrasDescobertas + 1 Fimse FimPara Se (letrasDescobertas = compr(palavraAleatoria)) então JogoFinalizou <- verdadeiro Fimse Retorne JogoFinalizou fimfuncao const TamMaiorPalavra = 46 Var // Seção de Declarações das variáveis palavraAleatoria: caractere quadro: caractere n_partesBoneco: inteiro ParteDescoberta: vetor[1..TamMaiorPalavra] de caractere contador: inteiro Letra: caractere LetrasJaDitas: caractere Boneco_esta_Completo: logico Inicio // Seção de Comandos, procedimento, funções, operadores, etc... sortear(palavraAleatoria) //Ok DesenhaForca() DesenhaBoneco(n_partesBoneco) //Atribui valores a parteDescoberta e escreve: Escreva(" ") Para contador de 1 ate compr(palavraAleatoria) faca ParteDescoberta[contador] <- "__" Escreva(ParteDescoberta[contador]) Escreva(" ") FimPara EscrevaL() //----------- n_partesBoneco <- 0 Boneco_esta_Completo <- falso Repita Pedir(Letra) Se ehRealmenteLetra(Letra) então Se jafoiDita(Letra) então LimpaTela DesenhaForca() DesenhaBoneco(n_partesBoneco) Desenhae_Escreve(quadro,letra) EscreverVetor() Senao LimpaTela DesenhaForca() Se acertou(Letra) então //Vai atribuir letra às posições correspondente na função acertou() Senao n_partesBoneco <- n_partesBoneco + 1 Se (n_partesBoneco = 7) então Boneco_esta_Completo <- verdadeiro Fimse quadro <- quadro + Letra Fimse DesenhaBoneco(n_partesBoneco) Desenhae_Escreve(quadro,letra) EscreverVetor() Fimse Senao LimpaTela DesenhaForca() DesenhaBoneco(n_partesBoneco) Desenhae_Escreve(quadro,letra) EscreverVetor() Fimse Ate revelouTudo() ou (Boneco_esta_Completo) Fimalgoritmo
  6. Boa noite galera, gostaria de tirar uma duvida a respeito daquele " melhorAluno <- nome" , depois do comando "Se (nota > maiornota) então maiornota <- nota ( ESSA LINHA EU ENTENDI) melhorAluno <- nome (ESSA LINHA QUE NÃO ENTENDI, pois a variável "melhorAluno" poderia receber qualquer um dos nomes digitados...ou seja, qual a logica que faz "linkar" que a variavel "nome" é do aluno que tirou maior nota?)
  7. Oi pessoal. Estou com curiosidade em saber se o Espaço vazio ("") possui código ANSI, pois quero comparar palavras para ver quem vem primeiro . Abraços.
  8. Galera sou iniciante em programação e estava testando esse algoritmo, que diz que tem erro de sintaxe na 4 linha: algoritmo ''Soma dos numeros'' var N1, N2, S:Inteiro inicio Escreva (''Informe um numero:'') Leia (N1) Escreva (''Informe outro numero:'') Leia (N2) S<- N1+N2 Escreva (S) fimalgoritmo
  9. Olá pessoal, meu professor me passou esta tarefa e não estou conseguindo resolver, se alguém me ajudar agradeço. Escreva um algoritmo em pseudocódigo que armazene as letras vogais em um vetor chamado vogal, as consoantes em um vetor chamado consoante. Em seguida crie duas funções do tipo lógico (as quais vão percorrer os vetores e comparar com a letra digitada, retornando V ou F) para saber se a letra é vogal ou consoante. Ao final deverá ser impresso: vogal, consoante ou não é uma letra (dependendo da letra digitada pelo usuário). Eu fiz um pouco mas não estou sabendo como armazenar as vogais e as consoantes nos seu devido vetor. Estou travado no algoritmo Algoritmo "VOGAL_CONSOANTE" Var vogal:vetor [1..5] de caracter consoante:vetor [1..21] de caracter i:inteiro funcao letra(x:inteiro):logico var l:caractere inicio escolha l se fimescolha se fimse fimfuncao Inicio Fimalgoritmo
  10. Olá pessoal ... funciona assim, a primeira tela é para cadastrar o gabarito. Vai ter um contador j que vai de 1 a 5 que vai lendo as notas e armazenando as notas em um vetor de 5 posições (gab[x]). Vai limpar a tela. A segunda tela é a tela de cadastrar o nome e a nota dos alunos. São 3 alunos. A resposta da resposta de cada aluno é armazenada é armazenada temporariamente em outro vetor de 5 posições(resp[x]). Se o valor das posição respectiva do vetor gabarito e resp[x] forem iguais, o aluno ganha dois pontos, que são armazenados em nota[x]. Na terceira tela, mostra o resultado, com a nota de cada aluno e a média da turma. algoritmo "Aula 14 - Corrigindo provas" var nome: vetor[1..3] de caractere Gab, Resp: vetor[1..5] de caractere Nota: vetor[1..3] de real NotasTurma, MediaTurma: real i, j: inteiro funcao CalcularPontos(gabarito, resposta: real):real var N: real Inicio Se (maiusc(gabarito) = maiusc(resposta)) então N:= 2 Fimse Retorne N fimfuncao inicio //--------------------------------------------// //Tela 1: //Cadastro de Gabarito: EscrevaL(" Passo 1 - Cadastro de Gabarito ") EscrevaL("----------------------------------") Para j de 1 ate 5 faca EscrevaL("Questão ", j, ":") Leia(Gab[j]) Fimpara LimpaTela //--------------------------------------------// //Tela 2: //Cadastro de Nome: Para i de 1 ate 3 faca EscrevaL("--------------------") EscrevaL(" Aluno ", i) EscrevaL("--------------------") Escreva("Nome: ") Leia(nome[i]) //Cadastro da Notas e cálculo da nota //de cada aluno: Para j de 1 ate 5 faca EscrevaL("RESPOSTAS DADAS") Escreva("Questão ", j, ":") Leia(Resp[j]) nota[i]:= nota[i] + CalcularPontos(Gab[j], Resp[j]) FimPara //-----------------------------------------// NotasTurma:= NotasTurma + Nota[i] LimpaTela Fimpara MediaTurma:= NotasTurma/3 LimpaTela //--------------------------------------------// //Tela 3: //Resultado com notas finais e média da turma: EscrevaL("Notas Finais") EscrevaL("------------------------") Para i de 1 ate 3 faca EscrevaL("Nome: ", nome[i]:10, Nota[i]:3:1) FimPara EscrevaL("------------------------") EscrevaL("Média da turma: ", MediaTurma) //--------------------------------------------// fimalgoritmo Alguém poderia avaliar?
  11. Exercício: -Precisamos criar uma entrada e os cálculos para uma nota fiscal, sendo: entradas=até 100 produtos, ate 100 valores total do produto, ate 100 descontos, ate 100 quantidades calculados= valor total da linha, valor total da nota, valor total de desconto valor liquido saida= nota fiscal montada
  12. var n: inteiro Inicio //Inicializando Soma S0MA <- 0 //Aplicando o comoando de repetição para n de 0 a 90 faca escreva ("Digite o numero:") leia (F1=f2) //Acumulado o numero lido Funcao: = F1 + F2; //calculando a media media <-soma /3 //Escrevendo a media calculada escreva ( "A media é:"",MEDIA) fimalgoritmo
  13. Boa noite, Estou com uma questão pra elaborar um algoritmo que calcule o total de números primos entre 1 e 1000 utilizando a estrutura de repetição para. E depois de um dia batendo cabeça, o máximo que eu consegui foi a seguinte solução: o programa apresenta o resultado correto, porém durante a execução do algoritmo ele para de responder cerca de 5 segundos. Var Cont1, N, divisores, Cont2, primo: inteiro Inicio para Cont1 de 1 ate 1000 faca N <- Cont1 divisores <- 0 para Cont2 de 1 ate N faca se (N % Cont2 = 0) então divisores <- divisores + 1 fimse fimpara se (divisores = 2) então primo <- primo + 1 fimse fimpara escreval("Total de números primos: ", primo) Fimalgoritmo Alguém tem uma forma melhor de fazer, ou de ajustar/otimizar? Qualquer dica adicional quanto a elaborar um código é muito bem vinda também.
  14. Boa tarde pessoal, Estou tentando fazer um algoritmo so que ele está dando um erro que informa que o até não tem o repita atrelado. Algoritmo "semnome" // Uma empresa de vendas tem três corretores. A empresa paga ao corretor uma //comissão calculada de acordo com o valor de suas vendas. Se o valor da venda // de um //corretor for maior que R$ 50.000.00 a comissão será de 12% do valor vendido. Se o //valor da venda do corretor estiver entre R$ 30.000.00 e R$ 50.000.00 (incluindo //extremos) a comissão será de 9.5%. Em qualquer outro caso, a comissão será de 7%. //Escreva um algoritmo que gere um relatório contendo nome, valor da venda e //comissão de cada um dos corretores. O relatório deve mostrar também o total de //vendas da empresa. Var sair : caracter total : real i, j : inteiro nome: vetor[1..100] de caracter vvenda: vetor[1..100] de real comissao: vetor[1..100] de real Inicio escreval("########################################") escreval("### ###") escreval("### Cadastro de Venda Corretores ###") escreval("### ###") escreval("########################################") escreval("") sair <- "s" repita para i de 1 ate 100 faca para j de 1 ate 100 faca escreva("Digite o nome do vendedor: ") leia(nome[i]) escreva("Digite o valor da venda: ") leia(vvenda[j]) escreval("Deseja cadastrar outro corretor? Digite s para SIM e n para NÃO") ate sair <> "n" fimpara fimpara se ( vvenda[j] > 50000 ) então comissao[j] <- vvenda[j] * 0.12 senao se ( vvenda[j] >= 30000 ) e ( vvenda[j] <= 50000 ) então comissao[j] <- vvenda[j] * 0.095 senao comissao[j] <- vvenda[j] * 0.07 fimse fimse total <- vvenda[j] + total fimenquanto para i de 1 ate 100 faca para j de 1 ate 100 faca escreval("O vendedor: ", nome[i], " vendeu R$ ", vvenda[j], " sua comissao foi de R$ ", comissao[j]) fimpara fimpara escreval("A empresa vendeu um total de R$ ", total) Fimalgoritmo O que estou fazendo de errado ?
  15. Estava tentando resolver o seguinte problema: Faça um algoritmo que leia um nº inteiro e mostre uma mensagem indicando se este número é par ou ímpar, e se é positivo ou negativo. Fiz o algoritmo, mas quando coloco um número ímpar e negativo não aparece nada escrito, sendo que em todas as outras condições dá certo. var num :inteiro inicio escreva ("Digite um número: ") leia (num) se (num%2 = 0) e (num > 0) então escreval (num, " é par e positivo") senao se (num%2 = 0) e (num < 0) então escreval (num, " é par e negativo") senao se (num%2 = 1) e (num > 0) então escreval (num, " é ímpar e positivo") senao se (num%2 = 1) e (num < 0) então escreval (num, " é ímpar e negativo") fimse fimse fimse fimse Queria que descobrissem onde eu tô errando
  16. Faça um algoritmo que leia 4 variáveis A,B,C e D. A seguir, se B for maior do que C e se D for maior do que A e a soma de C com D for maior que a soma de A e B e se C e D, ambos, forem positivos e se a variável A for par escrever a mensagem “valores aceitos”, senão escrever “valores não aceitos”.
  17. Ola Pessoal, Boa noite, sou novo aqui no fórum, mas vi que sempre que possível podemos tirar algumas duvidas.. Comecei a aprender programação sozinho e estou usando como auxilio o VISUALG Para desenvolver meus algoritmos, Tenho material de apoio e sempre tento resolver sozinho ( a maioria das vezes sofro mas consigo) Minha intenção é simplesmente entender qual meu erro logico no seguinte problema. Desenvolvi este algoritmo que calcula o adicional noturno de um funcionário com base em algumas informações fornecidas, o problema é que quando o programa pede ao usuário para digitar o salario, se este digitar usando um ponto (.) ex (1.800) o programa retorna o resultado do adicional noturno com um zero antes como um numero decimal, Ex( 0.315) No entanto se o usuário digita o salario sem o ponto, o programa retorna o resultado correto sem o Zero Como deveria editar algoritmo para que o resultado seja sempre coerente, independente do que o usuário digite? Var // Seção de Declarações das variáveis valorhora: real adicionalporhora: real horascontratuais: inteiro salario: real jornada: inteiro diastrabalhados: inteiro folgas: inteiro adicionalnoturnototal: real nome: caracter jornadadeadicional: inteiro qtdhorasadicionais: real horasadicionaismes: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreval("Oi, Para iniciar digite seu nome") leia ( nome) escreval("") escreval (nome," Digite seu salario") leia (salario) escreval("") escreval(nome," Digite suas folgas no mes") leia (folgas) escreval("") escreval(nome," Digite sua jornada total na noite de trabalho") leia (jornada) escreval("") escreval("O adicional noturno eh valido das 22:00 ate as 5:00 portanto ") escreval ("digite quantas horas de Adicional notunro você se encaixa") leia(jornadadeadicional) escreval("") diastrabalhados <- 30 - folgas horascontratuais <- diastrabalhados*jornada valorhora <- salario/horascontratuais adicionalporhora <- valorhora*0.2 horasadicionaismes <- diastrabalhados*jornadadeadicional adicionalnoturnototal <- horasadicionaismes*adicionalporhora Escreval ("Ola ",nome," voce trabalha ",horascontratuais," horas por mes,com um salario base de ",salario) escreval("") escreval ("Portanto sua hora de trabalho vale ",valorhora," R$ Logo, seu adicional noturno sera no valor de ",adicionalnoturnototal," R$ mensais") escreval("") Fimalgoritmo
  18. como posso fazer um código para testar se um e-mail é valido no visualg usando função as regras são as seguintes: Um e-mail é válido quando possui apenas algarismos alfanuméricos, “_”, “-“ e “.”, 1 “@” e ao menos 1 ponto após o “@”. Quando não possuir arroba, iniciar com um caractere diferente de letra ou ”_”, não possuir ao menos 1 ponto após o “@” ou possuir caracteres especiais além dos válidos. por favor me ajudem
  19. Faça um algoritmo que leia 100 números entre 1 e 9, e escreva o número que foi digitado mais vezes. Sugestão: utilize um vetor de contadores
  20. 1. Monte um algoritmo para contabilizar os acertos de um determinado jogo, levando em conta a explicação a seguir: a.) Alimente uma matriz de ordem 10 com números aleatórios entre 1 e 100 b.) Alimente um vetor de 10 posições com números aleatórios entre 1 e 100 c.) Contabilize a pontuação de acertos Ao final, exiba a matriz, o vetor e quantos acertos foram realizados.
  21. Bom eu tenho que fazer um trabalho pra faculdade, e eu só me prendi nisso(o algoritmo que venho pedir ajuda) por questão de insistência. Não preciso fazer ele, posso fazer outra forma, mas eu acredito que vá funcionar. O problema que tenho, é que na hora de calcular, o desconto acaba saindo diferente da porcentagem que peço. Queria que, caso possam, me mostrem o que fiz errado. Tenho que entregar ele hoje. To preso a dias vendo forma de arrumar e não consigo. Então, se alguém me ajudar a tempo, uso ele. Se não ajudarem ou for "tarde demais", fica o aprendizado apenas. Indo direto ao ponto, eu quero aplicar um valor de 5 porcento em valores totais acima de 200 e 10 porcento acima de 1000. Mas na hora de aplicar o resultado, ele tá multiplicando a porcentagem junto. Desde já, agradeço. Segue o algoritmo (ta bem porco, porque alterei tanto, que acabei não cuidando a estetica: algoritmo "semnome" // Função : // Autor : // Data : 25/11/2017 // Seção de Declarações var valor1, valor2: inteiro resultado1, media, desconto, valor_desc, total: real inicio escreva ("informe um valor: ") leia (valor1) escreva ("informe o segundo valor: ") leia (valor2) resultado1 <- (valor1)*2 + (valor2)*2 //Total com relação ao valor da manutenção, vezes as horas trabalhadas escreval ("O total foi de: ", resultado1) media <- (resultado1) SE(media>=200) então desconto <- media*5/100 total<-(media-desconto) escreval ("seu desconto foi de: ", desconto, "%", " e total a pagar foi de ", media-desconto) SENAO SE (media>=1000) então desconto <- media*10/100 escreval ("seu desconto foi de: ", desconto, " e o total a pagar foi de", media-desconto) SENAO Se(media < 200)então escreval ("o total a pagar sem desconto, foi de:", resultado1) FIMSE FIMSE FIMSE fimalgoritmo
  22. Bom dia! Segue Exercício, porém o que esta de errado na minha estrutura pois minha matriz não fica simétrica. Me ajudem!!!! Faça um algoritmo para ler uma matriz A de ordem 5x5 de números inteiros e verificar se a matriz é ou não simétrica. Dizemos que uma matriz é simétrica quando todo elemento aij é igual ao elemento aji, para todo i, j ≤ 5 var simetrica: logico I: inteiro J: inteiro N: inteiro matrizA : vetor [1..5,1..5] de real inicio //Secão de comandos simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca leia(matrizA[I,J]) fimpara fimpara escreval("MATRIZ A") simetrica <- verdadeiro para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(matrizA[I,J]," ") fimpara escreval(" ") fimpara simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca se ( matrizA[I,J] <> matrizA[J,I] ) então simetrica <- falso fimse fimpara se ( simetrica = verdadeiro ) então escreval ("A matriz é simétrica!") senao escreval("A matriz não é simétrica!") fimse fimpara fimalgoritmo
  23. Algoritmo "bnct" // Um banco concederá um crédito especial aos seus clientes, //variável com saldo médio no último ano. Faça um algoritmo que leia //o saldo médio de um cliente e calcule o valor do crédito de acordo com a //tabela abaixo. Mostre uma mensagem informando o saldo médio e o valor de //crédito (a porcentagem aplicada sobre o saldo médio). Var // Seção de Declarações das variáveis sma:inteiro; zporct,vtporct,trtporct,qrtporcent:real; Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Qual o saldo médio anual do cliente?") leia(sma) se (sma <= 200) então zporct <- sma * 0.00 escreval("Crédito total oferecido para o saldo de R$",sma," é ",zporct) senao se (sma => 201 e sma=<400) então vtporct <- sma * 0.20 escreval("Crédito total oferecido para o saldo de R$",sma," é ",vtporct) senao se (sma => 401 e sma=<600) então trtporct <- sma * 0.30 escreval("Crédito total oferecido para o saldo de R$",sma," é ",trtporct) senao se (sma => 601) então qrtporcent <- sma * 0.40 escreval("Crédito total oferecido para o saldo de R$",sma," é ",qrtporcent) senao fimse fimse fimse fimse Fimalgoritmo Quando eu coloco valor acima de 201 da o erro.
  24. Boa tarde galera. Estou com dificuldade em 2 situações no código abaixo. 1-Gostaria que o valor da hora trabalhada já aparecesse automaticamente e não que fosse preciso digitar o valor. 2-Aplicar um desconto no valor final do serviço. Algoritmo "centro automotivo" Var a,b,opcao,op:inteiro c,d, soma: inteiro desconto: inteiro //--------------------------------------------------------------------- procedimento menu_principal Inicio //menu principal limpatela escreval ("CENTRO AUTOMOTIVO") escreval("Informe a opção de reparo") escreval ("1 - Motor") escreval ("2 - Suspensão") escreval ("3 - Freio") escreval ("4 - sair") escreva("=> ") Fimprocedimento //--------------------------------------------------------------------- //funcao da opcao 1 procedimento menu_motor inicio limpatela escreval ("Opcao informada: MOTOR") escreval ("1- Alto consumo de óleo lubrificante") escreval ("2- Excesso de fumaça sendo expelida pelo escapamento") escreval ("3- Baixa potência") escreval ("4- Voltar") escreval ("Selecione o problema relatado pelo cliente") escreva("=> ") fimprocedimento //---------------------------------------------------------------------- //funcao da opcao 2 procedimento menu_suspensao inicio limpatela escreval ("Opcao Suspensão") escreval ("1- Ruidos e batidas nas rodas") escreval ("2- Vibrações e direção puxando") escreval ("3- Desgaste irregular dos pneus") escreval ("4- Voltar") escreval ("Selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- // funcao opcao 3 procedimento menu_freio inicio limpatela escreval ("Opcao Freio") escreval ("1- Carro ou pedal vibrando ao pisar no pedal do freio") escreval ("2- O carro puxa para algum lado quando freia") escreval ("3- Chiado ou ronco quando pisa no freio") escreval ("4- Voltar") escreval ("Selecione uma opção") escreva("=> ") fimprocedimento //--------------------------------------------------------------------- //--------------------------------------------------------------------- procedimento alto_consumo //Motor inicio escreval("Problema informado: Alto consumo") escreval("Custo por Hora/Atividade R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento excesso_de_fumaca // Motor inicio escreval("Problema informado: Excesso de fumaça") escreval("Custo por Hora/Atividade R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento baixa_potencia //Motor inicio escreval("Problema informado: Baixa potência do motor") escreval("Custo por Hora/Atividade: R$ 100,00") escreval("Informe o valor da hora:") leia (c) escreval("Quantidade de horas utilizadas no serviço:") leia (d) escreval("Valor total dos serviços R$",c*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento ruidos_e_batidas_nas_rodas //Suspensão inicio escreval("Problema informado: Ruidos e batidas nas rodas") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Vibracoes_e_direcao_puxando //Suspensão inicio escreval("Problema informado: Vibrações e Direção puxando") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento desgaste_irregular_dos_peneus //Suspensão inicio escreval("Problema informado: Pneus desgastando de forma irregular") escreval("Custo por Hora/Atividade: R$ 200,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_ou_pedal_vibra_ao_pisar //Freio inicio escreval("Problema informado: Carro ou pedal vibrando ao pisar no freio") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento carro_puxa_para_algum_lado //Freio inicio escreval("Problema informado: Veículo com tendencia de saída para os lados") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- procedimento Chiado_ou_ronco_quando_pisa //Freio inicio escreval("Problema informado: Chiado ou ronco ao acionar pedal do freio") escreval("Custo por Hora/Atividade: R$ 300,00") escreval("Informe o valor da hora:") leia (b) escreval("Quantidade de horas utilizadas no serviço: ") leia (d) escreval("Valor total dos serviços R$",b*d) escreval("Tecle Enter") leia(a) fimprocedimento //--------------------------------------------------------------------- Inicio repita menu_principal leia(Opcao) limpatela escolha opcao caso 1 repita menu_motor leia(op) escolha op caso 1 alto_consumo caso 2 excesso_de_fumaca caso 3 baixa_potencia caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 2 repita menu_suspensao leia(op) escolha op caso 1 Ruidos_e_batidas_nas_rodas caso 2 Vibracoes_e_direcao_puxando caso 3 desgaste_irregular_dos_peneus caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 3 repita menu_freio leia(op) escolha op caso 1 carro_ou_pedal_vibra_ao_pisar caso 2 carro_puxa_para_algum_lado caso 3 Chiado_ou_ronco_quando_pisa caso 4 escreval("voltando . . . Tecle Enter") leia(a) fimescolha ate op=4 caso 4 escreval("você pediu para sair, saindo . . . !") fimescolha ate opcao=4 Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×