Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 199 registros

  1. exercício: Elaborar programa que lê uma disciplina e respectiva nota (de 0 a 10, com uma casa decimal), e informa se o aluno passou na disciplina, repetindo o ciclo até que a nota lida seja zero. O aluno passa quando tira 7 ou mais. código: Algoritmo "q5" Var // Seção de Declarações das variáveis opcao,quant,abaixo5:inteiro nota,soma,media:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita escreval("1-Digitar Nota") escreval("2-Resultados") leia(opcao) limpatela escolha(opcao) caso 1 ((quant) <- ((quant) + 1)) escreval("Digite sua nota") leia(nota) limpatela (soma <- (soma+nota)) se (nota < 5) então (abaixo5 <- (abaixo5+1)) fimse se(nota > 10) ou (nota < 0) então escreval("ERRO") caso 2 ((media) <- (soma/quant)) escreval("Media: ", media) escreval("Quantidade de notas: ", quant) escreval("Notas abaixo de 5: ", abaixo5) outrocaso escreval("ERRO") fimalgoritmo fimescolha ate (nota>10) Fimalgoritmo por algum motivo tá dando erro e já tentei ajustar de várias formas, ainda estou aprendendo, podem me ajudar?? adicionado 32 minutos depois já consegui não encontrei como apagar o tópico (não sei se dá)
  2. Criar um algoritmo que calcula o maior e o menor número digitado pelo usuário, parar se o número digitado for zero (0) usar a função repita-ate. Anexei a imagem do código que fiz mas não está 100% vcs poderiam me ajudar a fazê-lo funcionar corretamente.
  3. Boa noite pessoa, dentro do meu codigo eu tenho uma matriz. Do jogo da velha. do vetor tab eu tenho numeros de 1 ate 9 e do vetor rep tambem de 1 ate 9 , mas somente o tab recebe o X ou O. então eu quero colocar uma condição, que o usuario leia a jogada. Verifique o numero que ele leu na matriz rep e veja se a matriz tab na mesma posição tem X ou O. Ate ai eu fiz. Mas que quero que a cada novo leia, ele veja a matriz inteira novamente. O que ele esta fazendo: coloquei X e O na primeira e segunda posição da matriz TAB. quando digito novamente 1 ele da como ocupada, quando digito 2 ele tambem da como ocupada. Mas quando digito novamente 1 ele n zera a matriz e continua a contagem normalmente ate o final: para m de 1 ate 3 faca para n de 1 ate 3 faca // aqui nesse primeiro eu encontro onde é a jogada se numpcarac(jogada1) = rep[m,n] então //aqui faz a comparação das duas matrizes se tab[m,n] <> rep[m,n] então repita escreval(" posição ja preenchida!") escreva(jogador1," escolha a sua jogada novamente:") leia (jogada1) ate (rep[m,n] <> numpcarac(jogada1)) m<-1 n<-1 fimse fimse fimpara fimpara O que posso fazer para ele zerar a contagem, e verificar desde o começo esse codigo novamente sempre a cada leia? adicionado 32 minutos depois Conseguiiiiiiiiiiiiiiiiiiiii!! Afff 1:30 tentando. Coloquei um repita logico e a matriz dentro, se FALSO repita, se VERDADEIRO não repita. Alguem sabe se tem outro jeito(deve ter) de resolver? só por curiosidade
  4. Meu professor de programação me mandou fazer um algoritmo no VisualG, porém estou com dificuldade quando os valores empatam, se alguem puder me ajudar, eu agradeço. Segue o Algoritmo com comentários para facilitar Código:
  5. Bom dia amigos, eu desenvolvi ontem esse algoritmo que faz a verificação se uma palavra é um Palíndromo ou não, no VisualG e gostaria de saber se alguém tem alguma ideia de como eu poderia melhorar essa lógica. O VisualG não tem muitos métodos para manipulação de strings, então fica difícil o negócio! Algoritmo "Verificador de palíndromos" // Disciplina : [Algoritmos e Lógica de Programação] // Descrição : Este programa verifica se uma palavra, quando tem suas //letras invertidas, acaba se tornando a mesma palavra. Ex: Arara. // Autor(a) : GKuze // Data atual : 12/06/2018 Var PalavraEscolhida: caractere //string vetPalavraInvertida : vetor [1..50] de caractere //armazena os caracteres da palavra escolhida em ordem contrária vetPalavraEscolhida : vetor [1..50] de caractere // caracteres da palavra escolhida indiceInverso: inteiro contador: inteiro n: inteiro palindrome: logico Inicio contador <- 50; palindrome <- verdadeiro //"palindrome" por padrão escreva("Digite a palavra para verificar se ela é palindrome: ") leia(palavraEscolhida) contador <- compr(palavraEscolhida) para n de 1 ate contador faca indiceInverso <- (compr(palavraEscolhida) - n) + 1 vetPalavraInvertida[indiceInverso] <- copia(palavraEscolhida, indiceInverso, 1) vetPalavraEscolhida[n] <- copia(palavraEscolhida, n, 1) se (vetPalavraEscolhida[n] <> vetPalavraInvertida[indiceInverso]) então //caso alguma letra da palavra invertida seja diferente da letra na //mesma posição, da palavra escolhida, //a variavel palindrome vira falso palindrome <- falso fimse fimpara se palindrome = verdadeiro então escreva("A palavra é palíndromo!") senao escreva("A palavra não é palíndromo...") fimse Fimalgoritmo
  6. Olá! Tenho o seguinte exercício para implementar um algoritmo em VisualG: Solicite ao usuário quantos números ele deseja informar, crie um vetor com estes números. Após isto armazenar os pares em um vetor e ímpares em outro, e apresente os pares e ímpares. Minha dúvida está na declaração da variável do vetor. É possível declarar um vetor inicialmente sem um intervalo definido? Se não for possível, como proceder nesse caso?
  7. Estou fazendo um pseudocódigo no Visualg e queria saber como eu peço para ele aceitar somente valores para variavel entre 0 e 10, podendo ser valores com vírgula também, e se o usuário digitar fora deste intervalo, escrever um aviso pedindo numeros dentro do intervalo.
  8. Olá, pensei em disponibilizar esse algoritmo em VisualG, pois quando tinha algumas dúvidas sobre ele, infelizmente, não encontrei muita coisa. Vamos ao problema: Elabore um programa no Visualg que calcule o troco a ser fornecido em uma compra, ao ser informado o valor da compra e o valor pago. Além disso, o algoritmo deve fornecer menor número de cédulas de 2,5,10,20,50 e 100 reais, de moedas de 1 real, e de moedas de 1,5,10,25 e 50 centavos a ser dado de troco. Vamos ao código: algoritmo "TROCO" var //Valor da compra e Valor pago V1, V2 : real // X é o troco e a variável M é utilizada para fazer a troca de Real para inteiro X, M : real //Y é o valor inteiro do troco utilizado para as cédulas Y : inteiro //Z é o valor inteiro das moedas (multiplicado por 100) Z : inteiro //N são as cédulas N50, N20, N10, N5, N2, N1: inteiro //M são as moedas M50, M25, M10, M5, M1 : inteiro Inicio Escreval ("Valor da compra:") leia (V1) Escreval ("Valor Pago:") leia (V2) //Aqui vamos obter o troco X<- V2-V1 //Aqui vamos obter apenas a parte inteira do troco. Exemplo : X= 13,45 , logo o Y= 13 Y<- int(X) //Aqui vamos pegar a parte "quebrada" do troco, ou seja, as moedas. É o inverso da função anterior. M<- X-Y //Aqui vamos transformar o número "quebrado" em número inteiro, ou seja, transforma-lo de Real para Inteiro. M<- M*100 //Aqui o Z (troco quebrado) recebe a parte inteira de M Z<- int(M) Escreval ("Troco=",X) Se (V1 > V2) então N50<- (Y div 50) Y<- (Y mod 50) N20<- (Y div 20) Y<- (Y mod 20) N10<- (Y div 10) Y<- (Y mod 10) N5<- (Y div 5) Y<- (Y mod 5) N2<- (Y div 2) Y<- (Y mod 2) N1<- (Y div 1) Y<- (Y mod 1) fimse Se n50>0 então Escreval (n50,"_", "Nota(s) de 50") fimse Se n20>0 então Escreval (n20,"_", "Nota(s) de 20") fimse Se n10>0 então Escreval (n10,"_", "Nota(s) de 10") fimse Se n5>0 então Escreval (n5,"_", "Nota(s) de 5") fimse Se n2>0 então Escreval (n2,"_", "Nota(s) de 2") fimse Se n1>0 então Escreval (n1,"_", "Nota(s) de 1") fimse Se (V2 > V1) então M50 <- (Z div 50) Z <- (Z mod 50) M25 <- (Z div 25) Z <- (Z mod 25) M10 <- (Z div 10) Z <- (Z mod 10) M5 <- (Z div 5) Z <- (Z mod 5) M1 <- (Z div 1) Z <- (Z mod 1) fimse Se M50>0 então Escreval (M50,"_", "Moeda(s) de 50 centavos") fimse Se M25>0 então Escreval (M25,"_", "Moeda(s) de 25 centavos") fimse Se M10>0 então Escreval (M10,"_", "Moeda(s) de 10 centavos") fimse Se M5>0 então Escreval (M5,"_", "Moeda(s) de 5 centavos") fimse Se M1>0 então Escreval (M1,"_", "Moeda(s) de 1 centavos") fimse fimalgoritmo Bons estudos !!
  9. o Estoque Cadastro de item no estoque Descrição / Quantidade / Preço de custo / Preço de venda Cadastro de combo promocional Descrição / Quantidade / Preço de custo / Preço de venda Retirar item do estoque Retira quantidade do item selecionado Relatório de itens no estoque. Todos os itens Bom dia, guys. Como viram estou com esse projeto para fazer, um estoque de ponto de venda, porém estou com dúvida em como iniciarei isso. Tenho ideias, só preciso de um START no cérebro e como estou sem internet boa para ver vídeos sobre, vim recorrer aqui. Sei que necessitarei de procedimento para criar os menus e vetor para cadastramento de itens. Só que, como? Se puder me dar uma luz agradeço de coração! adicionado 33 minutos depois algoritmo "ESTOQUE" // Função : // Autor : // Data : 17/10/2009 // Seção de Declarações var OPC,OPC_CAD:INTEIRO PROCEDIMENTO item_cadastro //Procedimento que dará inicio ao cadastro de item inicio repita ESCREVAL("------CADASTRO DE ITEM---------") ESCREVAL(" 1-Unidade ") ESCREVAL(" 2-Combo ") ESCREVAL(" 5-Voltar ") ESCREVAL("-------------------------------") leia (opc_cad) escolha (opc_cad) ate (opc_cad = 5) caso 5 limpatela menu_estoque fimprocedimento PROCEDIMENTO menu_estoque //Procedimento relacionado ao menu princnipal INICIO repita ESCREVAL("--------- ESTOQUE - PDV--------") ESCREVAL(" 1-Cadastro de Item ") ESCREVAL(" 3-Retirar Item ") ESCREVAL(" 4-DEVOLVER ") ESCREVAL(" 5-Sair ") ESCREVAL("-------------------------------") leia (opc) escolha (opc) ate (opc=5) caso 1 limpatela item_cadastro fimprocedimento INICIO menu_estoque fimalgoritmo FIZ ISSO ATÉ AGORA.
  10. Olá galera!! Tenho o seguinte problema,espero que me consigam ajudar!! Quero saber como fazer programação de uma calculadora no visualg,porém com algumas restrições! Vou tentar explicar da forma mais detalhada. A calculadora terá que ter três operações,multiplicação (*),divisão (/), e a raiz(R).só que essas operacoes so podem ser efectuados com soma e subtração (ou seja a programação só pode ser feita com soma e subtração)para poder calcular as 3 operações. Inicialmente quando a tela abrir,terá que abrir com uma moldura e dentro da moldura terá um quadro para escolher uma das 3 opções (operações). Depois de escolher a operação que deseja ,ira abrir uma tela secundaria a dizer o tipo de operação e a pedir os numeros que deseja introduzir. É um trabalho bem complexo,por favor se poderem ajudar serei muito grato.
  11. Por favor! Alguém pode me ajudar a criar esse algoritmo no Visualg? Criar um algoritmo que leia o tempo de aposentadoria para homem sendo que 100% com 65 anos, 80% com 60 anos, 60% com 55 anos ou salário integral por tempo de serviço de 30 anos para as referencias acima.
  12. Saudações terráqueos! Preciso fazer com que esse laço de repetição seja interrompido caso o usuário deixe o campo "nome" em branco. Mas quero que o programa continue a execução dos comandos que vem depois do laço (Não postei os comandos para não alongar demais o post). Desse jeito que fiz, sempre dá erro. Quando coloco um comando para encerrar a execução do programa (fimalgoritmo) dentro do "Se" no lugar do "fimpara', funciona normalmente. inicio repet <- 0 Para repet de 0 ate 12 passo 1 faca Escreva ("Nome: ") Leia (nome) se nome = "" então fimpara fimse fimpara fimalgoritmo Alguém pode me ajudar?
  13. galera perdi o dia inteiro tentando achar o erro aqui. Eu estou fazendo um algoritmo que leia 5 numeros e veja qual deles se repete, e imprima qual numero é , quantas vezes ele se repete e em quais indices. Ja fiz TUDO. mas ele tem um pequeno bug . Na primeira parte para comparar eu fiz com que se o numero fosse igual, o vetor x recebia 0, se fosse diferente o vetor x recebia o numero lido. Mais tarde eu fazia outra comparação e escrevia o vetor que repetia. Da tudo certo. Só que na segunda vez ele não grava o 0. exemplo: eu coloco 1 1 2 2 5.. beleza... era pra ele gravar 1 0 2 0 5 assim eu saberia que o numero 1 e 2 se repetiram. Mas ele ta gravando 1 0 2 2 5. o codigo: Var // Seção de Declarações das variáveis Vx,Vy: vetor[1..5] de inteiro i,j,k,l,numero,repetido: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escrevaL("Digite 5 numeros") escreval("") para i de 1 ate 5 faca escreval("Digite o ",i,"° numero:") leia (numero) para j de 1 ate 5 faca se (numero= vx[j]) e (numero<>0) então vx[i]<-0 vy[i]<-numero numero<-0 fimse se (numero<>vx[i]) e (numero<>0) então vx[i]<-numero vy[i]<-numero numero<-0 fimse fimpara fimpara escreval("") escreval("") para l de 1 ate 5 faca repetido<-0 para k de 1 ate 5 faca se vx[l] = vy[k] então repetido<-repetido+1 fimse fimpara se repetido>1 então escreval ("O numero ",vy[l]," apareceu ",repetido," vezes nas posições: ") para k de 1 ate 5 faca se vx[l] = vy[k] então escreva ("{",k," }") fimse fimpara escreval("") fimse fimpara Podem ver que se colocar por exemplo: 1 1 2 5 4 ele vai dar certo. Agora se colocar um segundo numero repetido ele ja não da certo.
  14. Bem, tenho um erro na linha 10 de meu programa e não consigo encontrar qual é o problema, na minha percepção está tudo certo. Segue o algoritmo: algoritmo "repeticao" var soma:real numeros,i:vetor[1..20] de inteiro valoresn:inteiro x:inteiro inicio x<-0 escreval ("DIGITE OS 20 NÚMEROS:") leia(numeros) para x de 1 ate 20 faca soma<-i+x escreval ("OS 20 VALORES SOMADOS DÃO ",soma) fimpara se i<0 então leia(valorn) escreval ("OS NÚMEROS NEGATIVOS INSERIDOS SÃO: ",valorn) fimse fimalgoritmo
  15. Escreva uma função que receba dois números inteiros x e y. Essa função deve verificar se x é divisível por y. No caso positivo, a função deve retornar 1, caso contrário zero. Escreva também um algoritmo para testar tal função exibindo uma mensagem de acordo com o resultado. NÃO SEI NEM COMO COMEÇAR, DE 20 SÓ NÃO CONSEGUI 3, ESSE QUE NÃO SEI COMO, E MAIS DOIS MAIS OU MENOS, SE ALGUÉM PODER ME AJUDAREM E EXPLICAR! AGRADEÇO. OBS. no visualG (portugol)
  16. OBS. no visualG (portugol) Crie um algoritmo que leia os limites inferior e superior de um intervalo e imprimir todos os números pares no intervalo aberto e seu somatório (UTILIZE O PARA). Suponha que os dados digitados são para um intervalo DECRECENTE exemplo Limite inferior: 5 Saída: 12 10 8 6 Limite superior: 14 Soma: 36 O QUE FIZ ATE AGORA. var su, in, i, soma: inteiro inicio // Seção de Comandos escreval("Digite o valor inferior ") leia(in) escreval("Digite o valor superior ") leia(su) soma <- 0 se (i mod 2 = 0) então in <- in + 1 senao in <- in + 2 fimse para i de in ate su passo 2 faca soma <- soma + 1 escreva ("", i) fimpara fimalgoritmo Não sei o que está errado, porq não soma, e como coloco na ordem decrescente!
  17. Preciso de ajuda com esse exercício Ler um número (informado pelo usuário) de pares de valores. Cada par representa a idade de um aluno e a sua respectiva nota. Calcular e escrever: - A idade do aluno que obteve a maior nota. - A nota do aluno mais velho.algoritmo var numero,x,mais_velho : inteiro nota,maior_nota,idade:real inicio escreva("Informe um numero:") leia(numero) para x de 1 ate numero passo 1 faca escreva("Informe a idade do aluno:") leia(idade) escreva("Informe a nota do aluno:") leia (nota) escreval("----------------") se (nota > maior_nota) então maior_nota<-nota idade<-maior_nota fimse se (idade > mais_velho) então nota<-mais_velho fimse fimpara escreval("O aluno que obteve a maior nota tem:" ,idade,"anos") escreva("O aluno mais velho obteve a nota:" ,nota,) fimalgoritmo Eu não tenho certeza se interpretei corretamente a questão mas fiz dessa forme e não funcionou, a idade aparece sempre a ultima que eu informei ao invés de aparecer a do aluno que obteve a maior nota e o "escreva ("O aluno mais velho que obteve a nota:" ,nota,)" nem aparece na tela.
  18. Uma loja de Calçados deseja fazer uma estimativa para saber quais calçados vendem mais entre femininos e masculinos. Considerando 50 vendas, leia o valor do calçado vendido e se é feminino (F) ou masculino (M). Após as vendas mostre qual o gênero de calçado mais vendido e o valor total de vendas dos calçados masculinos e femininos. var f,m,genero,mais_vend:caracter total_fem,total_masc, x,valor:inteiro inicio escreval("Veja qual o gênero do calçado mais vendido e o valor total das vendas de ambos") acm<-0 para x de 1 ate 5 passo 1 faca escreva("Informe o valor do calçado:") leia(valor) escreval("Informe o gênero do calçado:") escreval("Digite F para feminino") escreval("Digite M para masculino") escreva("->") leia(genero) se (f > m) então mais_vend<- f fimse se(m > f ) então mais_vend<- m fimse fimpara escreva("O genero mais vendido é:" ,mais_vend) fimalgoritmo Estou tendo dificuldade em conseguir mostrar qual o gênero mais vendido, fiz dessa forma mas não funcionou. O valor total das vendas de cada gênero também não sei como colocar, se alguém pode me mostrar o caminho, o que estou errado eu agradeço.
  19. O menor valor sempre apresenta 0 independente do numero que eu informe, preciso de ajuda pra descobrir o que tem errado var valor_venda, maior_venda ,menor_venda:real x:inteiro inicio escreval("Veja qual a maior venda e a menor venda do dia") para x de 1 ate 5 faca escreva("Informe o valor da venda:") leia(valor_venda) escreval("---------------") se (valor_venda > maior_venda )então maior_venda <- valor_venda fimse se (valor_venda < menor_venda) então menor_venda<- valor_venda fimse fimpara escreval("O valor da maior venda é:",maior_venda) escreva("O valor da menor venda é:",menor_venda) fimalgoritmo
  20. Tem esse problema que já fiz de tudo mas não consigo nem entender o que estou fazendo. Começo e no meio fico toda atrapalhada. Sou mega iniciante e super frustrada. o tal problema é o seguinte: Foi realizada uma pesquisa entre os habitantes de uma cidade. Através dessa pesquisa foram coletados os dados de salário, idade, sexo, e número de filhos de cada habitante. Faça um algoritmo que calcule e mostre: a) A média de salário das mulheres. b) A maior e a menor idade da população. c) A média do número de filhos de cada habitante. d) O maior salário da população. e) O percentual de pessoas com salário maior que R$ 954,00. Obs.: O programa encerra quando o salário digitado for igual a zero. meu algoritmo todo errado é o seguinte: Var idade,sexo,mulheres,somaFilho,quantFilho,habitante,menoridade,maioridade:inteiro TotalSalario,percentualSalario,totalFilho,maiorSalario,salario,salarioMulher,mediaSalMulher:real inicio salario:= 1 enquanto (salario <> 0) faca escreval("Digite o seu salario") leia (salario) se(salario <> 0) então escreval("Digite seu sexo:") escreval("1 - Masculino") escreval("2 - Feminino") leia(sexo) escreval("Digite a sua idade") leia(idade) escreval("qual o numero de filhos:") leia(quantFilho) se(salario > maiorSalario) então maiorSalario <- salario fimse se(salario > 954) então salarioMaior 954<= salarioMaior 954 + 1 enquanto(salario > 0) faca totalSalario<-totalSalario + salario totalFilho<- quantFilho + quantFilho habitante <- habitante + 1 fimenquanto repita escreval("Sua idade") leia(idade) se(idade>= 18) então escreval("maioridade") senao("menoridade") fimse escreval("Sua idade") leia(idade) se(idade>= 18) então escreval("maioridade") senao("menoridade") ate(idade=0) fimse fimse ate(sexo = 1) ou (sexo = 2) mediaSalMulher := totalSalMulher/habitante escreval("Digite Nº Filhos") leia(filhos) totalFilhos := totalFilhos + filhos mediaFilhos := totalFilhos/habitante fimse fimse escreval("____________________________________________________") fimenquanto mediaSalMulher := salarioMulher / mulheres mediaFilho := somaFilho / habitante percentualSalMaior954 := (salarioMaior954 * 100) / habitante escreval("RELATORIO") escreval("a) Media Salario das mulheres: ", meidaSalMulher) escreval("b) Maior idade da poulcao:", maioridade) escreval("Menor idade da populacao:", menoridade) escreval("c) A média do numero de filhos de cada habitante:", mediaFilho) escreval("d) O maior salario da população:", maiorSalario) escreval("e) O percentual de pessoas com salario maior que R$ 954,00:", percentualSalario) fimalgoritmo
  21. Ler o código e a altura de cada aluno de uma turma de 10 alunos. Escrever o código e a altura do aluno mais alto.
  22. Algoritmo "estações do ano" // Disciplina : // Professor : // Descrição : // Autor(a) : iTwxx // Data atual : - - - Var // Seção de Declarações das variáveis DD: inteiro MM: inteiro AAAA: inteiro parada: caracter Inicio // Seção de Comandos, procedimento, funções, operadores, etc... Escreval ("Informe o dia(DD)") Leia (DD) limpatela Escreval ("Informe o mês(MM)") Leia(MM) limpatela Escreval ("Informe o ano(AAAA)") Leia (AAAA) limpatela Se (DD>=21) e (MM=9) ou (DD>=01) e (DD<=31) e (MM=10) e (MM=11) ou (DD<=20) e (MM=12)então escreval ("Primavera") senao fimse Se (DD>=21) e (MM=12) ou (DD>=01) e (DD<=31) e (MM=01) e (MM=02) ou (DD<=20) e (MM=03)então escreval ("Verao") senao fimse Se (DD>=21) e (MM=03) ou (DD>=01) e (DD<=31) e (MM=04) e (MM=05) ou (DD<=20) e (MM=06)então escreval ("Outono") senao fimse Se (DD>=21) e (MM=06) ou (DD>=01) e (DD<=31) e (MM=07) e (MM=08) ou (DD<=20) e (MM=09)então escreval ("Inverno") senao escreval ("Data inválida") fimse Fimalgoritmo O algoritmo tem o objetivo de receber as datas e informar a qual estação do ano a data tal pertence, porém, nada disso acontece...aparece apenas a mensagem de erro, mesmo estando com as datas corretas. O que pode ser?
  23. Boa noite pessoal, sou novo aqui, to tentando criar um código, mas não ta dando certo. Não to conseguindo pegar o menor e maior valores dos vetores Questão 3) - Construa um algoritmo que leia (usando estrutura de repetição) um conjunto de dados de alunos contendo Nota e Faltas de 10 alunos, calcule e escreva: - a maior nota da turma; - a menor nota da turma; - e a média das notas dos aprovados (considera-se aprovado quem obteve nota >= 6 e faltas <= 25); - o percentual de reprovados por faltas e o percentual de reprovados por nota. algoritmo "semnome" // Função : // Autor : // Data : 23/05/2018 // Seção de Declarações var vet : vetor [1..10] de inteiro vet1 :vetor [1..10] de real cont, menor : inteiro inicio para cont de 1 ate 10 faca escreval (" digite a nota") leia (vet1[cont]) escreval (" digite as faltas") leia (vet[cont]) fimpara para cont de 1 ate 10 faca se (menor > (vet1[cont]) então menor <- (vet1[cont]) fimpara para cont de 1 ate 10 faca se (menor > (vet1[cont]) então menor <- menor fimpara fimalgoritmo
  24. Eu queria usar um vetor como uma variável em uma função, mas as estrutura que eu tentei davam erro. Qual é a estrutura correta? Funcao Verificador(Vet:vetor[1..5] de caractere):inteiro var R,A:inteiro inicio Para A<-1 ate 5 Se (Res[A] = Gab[A]) então R<-R+1 Fimpara retorne R FimFuncao PS:faltou eu digitar o FimSe, faca
  25. Galera, alguém pode rodar esse programa no Visualg 3.0 e me ajudar a resolver esse erro do qual não estou entendendo? É um trabalho de faculdade, disciplina Algoritmos II. PS: ainda não terminei o programa. Algoritmo "APS" //resgistro do campo aluno tipo aluno = registro identificador:inteiro nome:caractere idade:caractere sexo:caractere fimregistro //variaveis globais var pessoa: vetor[1..5] de aluno i:inteiro valordigitado:inteiro opcao:inteiro aux_pes:inteiro resp:inteiro //FUNÇÃO PESQUISA SEQUENCIAL SIMPLES funcao func_pes(x:inteiro):inteiro var resposta,j:inteiro inicio para j de 1 ate 5 faca se(pessoa[j].identificador = x) então resposta <- 1 senao resposta <- 0 fimse retorne resposta fimfuncao //INICIO DO PROGRAMA inicio repita escreval("UNICARIOCA - BANCO DE DADOS") escreval escreval("[1] - ADICIONAR") escreval("[2] - PESQUISAR") escreval("[3] - ORDENAR") escreval("[4] - EXIBIR") escreval("[0] - SAIR") escreval escreva("Opção: ") leia(valordigitado) escolha valordigitado //ADICIONAR USUARIO caso 1 repita i<-i+1 Escreval("UNICARIOCA - BANCO DE DADOS") escreval("ADICIONAR USUARIO") escreval escreva("Digite seu identificador: ") leia(pessoa.identificador) escreva("Digite aqui seu nome: ") leia(pessoa.nome) escreva("Digite aqui sua idade: ") leia(pessoa.idade) escreva("Digite aqui seu sexo: ") leia(pessoa.sexo) escreval escreval("PARABÉNS,USUARIO CADASTRADO!") escreval escreval("[1] - Para continuar adicionando") escreval("[2] - Para voltar ao menu usuario") leia(opcao) limpatela ate opcao = 2 limpatela caso 2 repita escreval("Digite aqui o identificador que deseja pesquisar: ") leia(resp) aux_pes <- func_pes(resp) se aux_pes = 1 então escreva("Usuario já existe") senao escreva("Usario não existe") fimse escreval escreval("[1] - Para continuar pesquisando") escreval("[2] - Para voltar ao menu usuario") leia(opcao) limpatela ate opcao = 2 fimescolha ate valordigitado = 0 fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×