Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
    • Mac OS
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 158 registros

  1. Olá, boa tarde! Estou com uma pequena dúvida, é possível acrescentar 2 "valores" em uma constante só? Por exemplo: op:= ("A") e ("B") Eu não estou achando um jeito de fazer isso, e não sei se é possível. Obrigado desde já.
  2. Algoritmo que receba a UF e escreva se este estado pertence a região SUL, SUDESTE, NORTE, NORDESTE ou CENTRO-OESTE. Pessoal preciso de uma ajuda com exercicio, segue o que eu já fiz, mas acredito que esteja errado e nao estou conseguindo desenvolver o algoritmo pra rodar da maneira que pede o exercicios. Quem puder ajudar ficarei muito grato! Var // Seção de Declarações das variáveis sigla:caractere Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva (" Para sul, sudeste,norte, nordeste ou centro-oeste como estados- Informe a sigla: ") leia (sigla) escolha sigla caso "sul" escreval ("pertence a região sul") caso "sudeste" escreval ("pertence a região sudeste") caso "norte" escreval ("pertence a região norte") caso "nordeste" escreval ("pertence a região nordeste") caso "centro-oeste" escreval ("pertence a região centro-oeste") caso "oe" escreval ("outros estados") outrocaso escreval ("sigla inválida") fimescolha fimalgoritmo
  3. Boa Tarde pessoal se possível alguém me dar uma ajuda eu tenho que criar um algoritmo que de o quadrado de um numero depois o cudo , os divisores e o primo pois não consegui fazer com que diga a quantidade de divisores só consegui mostrar os divisores como posso fazer pra mostrar somente a quantidade? Algoritmo "Atividade 3" Var rep, qd, cb, resto, i, aux : inteiro cabecalho : caractere Inicio cabecalho <- "Numero Quadrado Cubo Divisores Primos" escreval (cabecalho) para rep de 01 ate 20 faca escreva(rep, "") qd <- rep * rep escreva (qd, "") cb <- (rep * rep) * rep escreva (cb, "") para resto de 1 ate rep faca se (rep mod resto = 0) então escreva(resto) fimse fimpara aux <- 0 para i de 2 ate rep -1 faca se rep mod i = 0 então aux <- aux +1 fimse fimpara se aux = 0 então escreva ("sim") senao aux = escreva ("nao") fimse escreval("") fimpara Fimalgoritmo
  4. Olá, recentemente aprendi procedimentos, até que não é difícil, mas tenho as minhas dúvidas. Eu gostaria de saber qual a diferença do primeiro algoritmo do segundo. Eu não percebo para que serve os parâmetros visto que sem eles funciona na mesma, como podem ver em negrito. É que o algoritmo 2 é bem mais simples que o primeiro, pois imaginemos que estou a usar variáveis de tipo inteiro e caractere, teria que criar 2 procedimentos? ou teria que mudar essa variavel do tipo caractere para inteiro? 1 algoritmo "FazSomaProcedimento" var X, Y: Inteiro Procedimento Soma(A, B: Inteiro) inicio EscrevaL("Recebi o valor ",A) Escreval("Recebi o valor ",B) Escreval("A soma entre os dois e ", A + B ) FimProcedimento inicio X <- 5 Y <- 3 Soma(X, Y) fimalgoritmo ____________________________________ 2 algoritmo "FazSomaProcedimento" var X, Y: Inteiro Procedimento Soma() inicio EscrevaL("Recebi o valor ",X) Escreval("Recebi o valor ",Y) Escreval("A soma entre os dois e ", X + Y ) FimProcedimento inicio X <- 5 Y <- 3 Soma() fimalgoritmo
  5. então, preciso fazer um algoritmo que calcule o resultado de 1 ate n, por exemplo: 1 x n = n 2 x n = 2n 3 x n = 3 ... n x n = n2 porém nao sei como iniciar, pois sou novo na programação poderiam me ajudar .?
  6. "Faça um algorítmo que leia um conjunto de números e imprima sua soma e sua média. O valor -1 deve ser utilizado para encerrar o programa." Alguem poderia me ajudar? Preciso fazer esse alg com a estrutura enquanto, mas ao final, o "-1" é contado como número e acaba entrando na média e na soma.
  7. Estava explorando mais as ferramentas do VisuAlg e descobri que ele tem uma opção de "listas" em sua área de Ferramentes>Opções>Listas. Gostaria de saber pra qual finalidade existe essa opção e como funciona. Segue imagem para ilustrar...
  8. Uma escola deseja saber algumas informações estatísticas referente a uma sala de aula com 20 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas: - Nome do aluno - Data de nascimento (DD/MM/AAAA) - Sexo (F/M/O) - Signo - Altura Apresentar no final as seguintes informações: a) Percentual de alunos do sexo F média de idade dos alunos c) nome e peso da pessoa mais pesada do sexo M d) quantidade de pessoas do signo de aries abaixo de 1,80m de altura e) nome e altura da pessoa mais baixa f) média aritmética de peso de todos os alunos entrevistados g) percentual de pessoas que nasceram em ano BISSEXTO h) quantidade de pessoas que nasceram em dias PRIMO J) quantidade de alunos por signo Alguém me ajuda a explicar sobre parte que esta grifado Segue a imagem abaixo da onde eu parei código var NA,DDMMAAAA,S,Sig:CARACTERE inicio Escreval("Digite o nome aluno") leia(NA) Escreval("Digite data de nascimento") leia(DDMMAAAA) Repita Escreval("Digite o seu sexo") leia(S) SE (S<>"F") e (S<>"M") e (S<>"O") então Escreval("sexo invalido") fimse ATE (S="F") ou (S="M") ou (S="0") Repita Escreval("Digite o seu signo") leia(Sig) SE (Sig<>"aries") e (Sig<>"touro") e (Sig<>"Gemeos") e (Sig<>"Cancer") e (Sig<>"Leao") e (Sig<>"Virgem") e (Sig<>"Libra") e (Sig<>"Escorpiao") e (Sig<>"Sagitario") e (Sig<>"Capricornio") e (Sig<>"Aquario") e (Sig<>"Peixes") então Escreval("signo invalido") fimse ATE (Sig="aries") ou (Sig="touro") ou (Sig="Gemeos") ou (Sig="Cancer") ou (Sig="Leao") ou (Sig="Virgem") ou (Sig="Libra") ou (Sig="Escorpiao") ou (Sig="Sagitario") ou (Sig="Capricornio") ou (Sig="Aquario") ou (Sig="Peixes") Escreval("Digite a sua altura") leia(alt) Escreval("Digite o seu peso") leia(p) fimalgoritmo
  9. Alguém me ajuda, estou fazendo validação da data de nascimento usando switch case, considerando ano bissexto também, mas está dando esse erro que esperava uma expressão do tipo inteiro... Não estou conseguindo ver onde tem erro... Por favor, se alguém puder me ajuda, agradeço.
  10. Tenho o seguinte exercício: Construa um algoritmo que leia os valores de 10 números inteiros e diferentes entre si. (Usando o laço de repetição para, nao podendo usar o enquanto) algoritmo "semnome" var i1,i2:inteiro //i1 e i2: contadores para laços de repetições n:vetor[1..10] de inteiro //n: vetor para receber os números inicio para i1 de 1 ate 10 faca escreva("Informe o valor do",i1,"º número:") leia (n[i1]) para i2 de 1 ate i1 faca se (i1>i2) e (n[i1]=n[i2]) então escreval ("Número já informado, informe outro número:") leia (n[i1]) i2<-0 fimse fimpara fimpara fimalgoritmo O problema é que eu queria que a variável i2 reiniciasse assim que recebesse um novo valor para (n[i1]). O que acontece é que esse "i2<-0" é completamente ignorado e a variável contadora continua seu laço de repetição da onde ela tinha parado anteriormente como se eu nao tinha dado o comando para ela atribuir o valor 0.
  11. 4) Solicitando 15 valores inteiros entre 10 e 200, apresente a quantidade de números pares informados. 5) Solicite 10 números inteiros entre -100 e 100, e apresente a quantidade de números ímpares, e a média aritmética dos números pares. 6) Construa um algoritmo que solicite 10 números e apresente a média aritmética dos mesmos. 7) Considerando que a nota bimestral de um aluno seja calculada através da média ponderada de 4 avaliações, solicite os dados (notas e respectivos pesos) e apresente a média. 8) Solicite 10 valores inteiros ao usuário e apresente a média harmônica deste conjunto. 9) Construa um programa que gere N números aleatórios entre 64 e 1239 e os apresente ao usuário. O valor de N deverá ser indagado ao usuário. Dica: Utilize o comando RANDI. 10) Solicite dois valores inteiros (A,B) onde B deve ser obrigatoriamente maior que o valor de A. Posteriormente, apresente o produto entre as duas variáveis, sem no entanto utilizar o operador de multiplicação (*). 11) Solicite um número inteiro e positivo, e posteriormente apresente se o mesmo é ou não um número PRIMO. 12) Solicite um valor inteiro maior ou igual a zero, e posteriormente apresente o seu FATORIAL. 13) A sequência de Fibonacci é uma sequência de números inteiros, começando por 0 e 1, na qual cada termo subsequente corresponde a soma dos dois anteriores. Os números de Fibonacci, são, portanto, os números que compõem a seguinte sequência: 0, 1, 1, 2, 3, 4, 8, 13, 21, 34, 55, 89, 144, 233, ... Desta forma, desenvolva um algoritmo que apresente os N-primeiros termos da sequência de Fibonacci. O usuário deverá fornecer o valor de N. 14) Construa um algoritmo que solicite o divisor e o dividendo de uma expressão e posteriormente apresente o quociente inteiro desta operação sem no entanto utilizar o operador de divisão (/). O divisor obrigatoriamente deverá ser MENOR que o dividendo. 15) Solicite dois números inteiros onde o segundo deverá ser no mínimo 20 unidades maior que o primeiro e no máximo 50 unidades, e posteriormente apresente todos os números primos deste intervalo. 16) Desenvolva um jogo Jokempô (Pedra, papel e tesoura) ao qual possibilite o usuário jogar contra o computador. 17) Uma universidade deseja saber algumas informações estatísticas referente a uma sala de aula com 40 alunos. Para isso, fora elaborado um questionário contendo as seguintes perguntas: - Nome do aluno - Data de nascimento (DD/MM/AAAA) - Sexo (F/M/O) - Signo - Altura - Peso Desta forma, deseja-se apresentar no final as seguintes informações: a) Percentual de alunos do sexo Feminino média de idade dos alunos c) nome e peso da pessoa mais pesada do sexo masculino d) quantidade de pessoas do signo de GEMEOS abaixo de 1,75m de altura e) nome e altura da pessoa mais baixa f) média aritmética de peso de todos os alunos entrevistados g) percentual de pessoas que nasceram em ano BISSEXTO h) quantidade de pessoas que nasceram em dias PRIMO J) quantidade de alunos por signo
  12. Ola Pessoas, eu queria saber como quebrar linhas no visualg tipo: Linha1 <texto> Linha2<texto> Linha3<texto> Linha4<texto>
  13. algoritmo "calculadora" // Função : calcular // Autor : Paulo Antonio // Data : 11/04/2018 // Seção de Declarações var: n1, n2, x, resultado, temp1, temp2, op3, op4: real menu, operacao, unidade, temperatura, sair, km, m, cm, mm: caractere inicio escreval ("para calculadora simples digite 1") escreval ("para calculo de unidade de medida digite 2") leia (menu) //calculadora simples escolha menu caso "1" Escreval ("Escolha a operação desejada: + (SOMA) , - (SUBTRAÇÃO), / (DIVISÃO)") escreval ("* MULTIPLICAÇÃO, % PORCENTAGEM") leia (operacao) escolha (operacao) caso "+" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 + n2) Escreval("O resultado é:", x) caso "-" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 - n2) Escreval("O resultado é:", x) caso "*" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 * n2) Escreval("O resultado é:", x) caso "/" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) se (n2 = 0) então escreval(" Erro - impossível dividir por zero. Refaça a operação clicando enter") senao x <- (n1 / n2) Escreval("O resultado é:", x) fimse caso "%" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <-(n1*n2/100) escreval ("O resultado é:", x) outrocaso escreval(">ERRROOO< Repita a operação!") fimescolha escreval ("Deseja fazer outra operação? se sim clique enter, se não digite sair") leia (sair) //calculadora de unidades de unidades caso "2" escreval ("escolha uma unidade") escreval("T pra Temperatura") escreval ("D pra distancia") leia (menu) escolha menu caso"T" escreval("DE:") escreval("1 Graus Celsius(°C)") escreval("2 Graus Kelvin(°K)") leia(temp1) escreval("PARA:") escreval("1 Graus Celsius(°C)") escreval("2 Graus kelvin(°K)") leia (temp2) escolha temperatura caso(temp1="1") e (temp2="2") então escreval("Temperatura em Graus Celsius:") leia(temp1) x<- temp1+273.15 escreval escreval("Temperatura em Graus kelvin:", x ) caso (temp1="2") e (temp2="1") então escreva("Temperatura em Graus kelvin:") leia(temp1) x <- temp1-273.15 escreval escreval("Temperatura em Graus Celsius:", x ) caso (temp1="2") e (temp2="2") então escreva("Temperatura em Graus kelvin") leia(temp1) escreval("Temperatura em Graus kelvin", x) outrocaso escreval(" >repita a operação!<") caso"D" escreval("DE:") escreval("1 Quilômetro(km)") escreval("2 Metro(m)") escreval("3 Centímetro(cm)") escreval("4 Milímetro(mm)") leia(op3) escreval("PARA:") escreval escreval("1 Quilômetro(km)") escreval("2 Metro(m)") escreval("3 Centímetro(cm)") escreval("4 Milímetro(mm)") leia(op4) escolha unidade caso (op3="1") e (op4="1") então escreval("Distância em Quilômetros(km): ") leia(km) escreval("Distância em Quilômetros: ", km, " km") caso(op3="1") e (op4="2") então escreval("Distância em Quilômetros(km): ") leia(km) m <- km * 1000 escreval("Distância em Metros: ", m,"m") caso(op3="1") e (op4="3") então escreval("Distância em Quilômetros(km): ") leia(km) cm <- km * 100000 escreval("Distância em Centímetros: ", cm, "cm") caso(op3="1") e (op4="4") então escreval("Distância em Quilômetros(km): ") leia(km) mm <- km * 1000000 escreval("Distância em Milímetros: ", mm, " mm") caso(op3="2") e (op4="1") então escreval("Distância em Metros(m): ") leia(m) km <- m / 1000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="2") e (op4="2") então escreval("Distância em Metros(m): ") leia(m) escreval("Distância em Metros: ", m, " m") caso(op3="2") e (op4="3") então escreval("Distância em Metros(m): ") leia(m) cm <- m * 100 escreval("Distância em Centímetros: ", cm, " cm") caso(op3="2") e (op4="4") então escreval("Distância em Metros(m): ") leia(m) mm <- m * 1000 escreval("Distância em Milímetros: ", mm, " mm") caso(op3="3") e (op4="1") então escreval("Distância em Centímetros(cm): ") leia(cm) km <- cm / 100000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="3") e (op4="2") então escreval("Distância em Centímetros(cm): ") leia(cm) m <- cm / 100 escreval("Distância em Metros: ", m, " m") caso(op3="3") e (op4="3") então escreval("Distância em Centímetros(cm): ") leia(cm) escreval("Distância em Centíetros: ", cm, " cm") caso(op3="3") e (op4="4") então escreval("Distância em Centímetros(cm): ") leia(cm) mm <- cm * 10 escreval("Distância em Milímetros: ", mm, " mm") caso (op3="4") e (op4="1") então escreval("Distância em Milímetros(mm): ") leia(mm) km <- mm / 1000000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="4") e (op4= "2") então escreval("Distância em Milímetros(mm): ") leia(mm) m <- mm / 1000 escreval("Distância em Metros: ", m, " m") caso(op3="4") e (op4="3") então escreval("Distância em Milímetros(mm): ") leia(mm) cm <- mm / 10 escreval("Distância em Centímetros: ", cm, " cm") caso (op3="4") e (op4="4") então escreva("Distância em Milímetros(mm): ") leia(mm) escreval("Distância em Milímetros: ", mm, " mm") escreval(">refaça a operação<") fimse fimescolha fimescolha fimescolha fimalgoritmo
  14. Estava escrevendo um código no VisualG quando me deparei com um exercício que não consegui resolver o problema, não sei se estava muito cansado ou algo do tipo, mas acabei desistindo dele e recorri aqui para pedir ajuda de vocês, precisa ser feito em portugol, pois a professora ainda não ta aceitando linguagem C. Segue o link do enunciado e o código (deixei até aonde está funcionando kkkk), se alguém conseguir me ajudar a elabora o que devo fazer ou me explicar o passo a passo do raciocínio, eu ficaria bem grato. Enunciado: O processo de avaliação de uma determinada disciplina obedece aos seguintes critérios: *durante o ano são dadas 4 notas; *a nota final é obtida pela média aritmética das 3 maiores notas dadas durante o curso; *é considerado aprovado o aluno que obtiver a nota final superior ou igual a 70 pontos e que tiver comparecido a um mínimo de 40 aulas O algoritmo deve: *cadastrar um conjunto de dados obtendo o número da matrícula, o nome do aluno, as 4 notas e a frequência(número de aulas frequentadas) Calcular: *a nota final de cada aluno; *a maior e menor nota da turma; *a nota média da turma; *ao total de alunos reprovados; *a percentagem de alunos reprovados por frequência Listar os dados: *gerar um relatório contento todos os dados dos alunos cadastrados *o que foi calculado no item anterior Código: algoritmo "ex 17" var aluno, curso, per:caracter mat, freq: real nota1, nota2, nota3, nota4: real medtotal: real inicio Enquanto mat=0 ou mat=-1 Escreval("Nome do Aluno: ") leia(aluno) Escreval("Matricula do Aluno: ") leia(mat) Escreval("O Nome do Curso: ") leia(curso) Escreval("Informe o seu Periodo: ") leia(per) Escreval("Informe a frequencia: ") leia(freq) Escreval("Sua primeira Nota: ") leia(nota1) Escreval("Sua segunda Nota: ") leia(nota2) Escreval("Sua terceira nota: ") leia(nota3) Escreval("Sua quarta nota: ") media_total<-((nota1*4)+(nota2*3)+(nota3*2)+(nota4*1)/4) Escreval("Aluno: ",aluno) Escreval("Matrícula: ",mat) Escreval("Curso: ",curso) Escreval("Período: ",per) Escreval("Média Total: ",medtotal) fimalgoritmo
  15. Olá, galera! Bom, estou com um projeto em mãos de desenvolver um programa que simule vendas de ingressos para uma balada! Está praticamente finalizado, porém; Não estou conseguindo por o valor final de todas as vendas realizadas. E quando eu erro a senha de login/senha para entrar no programa, ele fica num loop do "repita/ate". Alguém sabe como resolver? Aliás, se souberem forma melhor de programar isso, me ajuda. Mas quero usar o código que eu digitei, acrescentar coisas ou remover está de pé também. OBRIGADO DESDE JÁ! Segue o código algoritmo "semnome" var user,senha: caracter vf: logico idade,cartao,qtd_cartao,qtd_dinheiro, sair: inteiro opcao: inteiro inicio escreval ("Digite o nome de usuario: ") leia(user) escreval ("Digite a Senha: ") leia (senha) se (user = "admin") e (senha = "admin") então vf:=verdadeiro limpatela escreval ("Olá Admin, Acesso liberado.") escreval ("Inicie as suas vendas!") senao vf:=falso escreval ("Acesso negado!") fimse repita se vf = verdadeiro então escreval ("Qual é a idade do comprador?") leia (idade) se (idade <18) então escreval ("O comprador não tem idade o suficiente.") senao limpatela escreval ("Qual é o modo de compra?") escreval ("Cartão - Digite 1") escreval ("Dinheiro - Digite 2") leia (cartao) escolha (cartao) caso 1 escreval("Sua compra será processada no cartão.") escreval("Quantos ingressos você irá comprar?") leia (qtd_cartao) escreval("O valor total da compra é: ", qtd_cartao*20+qtd_cartao*5) caso 2 escreval("Sua compra será processada no dinheiro.") escreval("Quantos ingressos você irá comprar?") leia (qtd_dinheiro) escreval("O valor total da compra é: ", qtd_dinheiro*20-qtd_dinheiro*5) fimescolha fimse fimse escreval("1- Iniciar nova sessão") escreval("2- Fechar o programa!") leia(opcao) limpatela ate (opcao = 2) se (opcao = 2) então escreval ("Totalaxazxz: ", qtd_dinheiro*20-qtd_dinheiro*5 + qtd_cartao*20+qtd_cartao*5) fimse Fimalgoritmo
  16. Lá vem eu encher o saco de novo kk, mas esse programa não quer funcionar nem ferrando, da um help aqui. Um país A tem 50 milhões de habitantes e cresce a uma taxa de 2% ao ano e outro país B tem 100 milhões de habitantes e cresce a uma taxa de 1,2% ao ano. Escreva um programa que:  Calcule e escreva o tempo para que o país A ultrapasse o país B em número de habitantes.  Escreva o número de habitantes de cada pais quando esta hipótese ocorrer. Eu tentei fazer ele de um monte de forma, mas ele não funcionou em nenhuma delas. Ele simplesmente faz as conta uma vez e a var:AUX fica subindo o valor dela sem parar. var paisA, paisB, total, aux:real porcA, porcB:real totalA, totalB:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... aux <- 0 totalA <- 50000000 totalB <- 100000000 paisa<-0 paisb<-1 enquanto (paisA < paisB) faca porcA<- totalA * 0.06 porcB<- totalB * 0.012 paisA <- totalA + porcA paisb <- totalB + porcB aux <- aux + 1 total <- aux escreva (paisa) escreva (aux) fimenquanto escreva (paisa) escreva (aux) Fimalgoritmo
  17. Estou com um código impecável e o visualG diz ter erro de não ter encontrado a palavra reservada "então" do condicional SE. A ideia é completar um exercício na qual preciso de 80 entradas de dados e comparar quantos destes estão entre 150 e 10. C Ó D I G O: Algoritmo ">=10 e <=150" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 05/04/2018 Var // Seção de Declarações das variáveis x,q:inteiro numeros:vetor[1..80] de inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para x de 1 ate 80 faca escreval("escreva o º",x," número") leia(numeros[x]) se (numero[x]>=10) e (numeros[x]<=150) então q<-q+1 fimse fimpara escreval(q,"estão entre 150 e 10") Fimalgoritmo A linha com erro seria a linha 15 " se (numeros[x]>=10) e (numeros{x}<=150) então" o visualg acusa de não encontrar o "então " sendo que ele esta na linha Não é a primeira vez que isso acontece outra vez aconteceu o mesmo e eu coloquei a palavra reservada em maiúsculo e foi mas desta vez não esta indo de jeito nenhum já tentei varias coisas mas não vai eu já estou enloquecendo com esse bug pois eu confiro o manual do visualg e da linguagem portugol e a sintaxe esta correta.Me ajudem a entender definitivamente a natureza disso pois eu to quase desistindo do visualg já.
  18. Galera meu professor me deu esse exercício mais por motivos que não entendo ele nao quer rodar. Escreva um programa que:  Leia dois números inteiros  Armazene o menor valor em uma variável a e o maior em uma variável b  Escreva todos os inteiros do intervalo [a, b] Programação: Var // Seção de Declarações das variáveis number1, number2:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Digite o primeiro numero: ") leia(number1) escreva("Digite o segundo numero: ") leia(Number2) se (number1 < number2) então PARA de number1 ate number2 FAÇA escreva (number1) number1+1 fimpara senao para number2 ate number1 faca escreva (number2) number2+1 fimpara fimse
  19. A serie de Fibonacci e formada por uma sequencia de números onde os dois primeiros são iguais a 1 e os seguintes obtidos pela somados dois anteriores.Por exemplo,uma serie com 6 termos 1,1,2,3,5,8... Escrever um algoritmo para solicitar quantos termos a serem gerados e em seguida mostrar a serie.Não permitir número de termos a serem gerados e em seguida mostrar a serie.Não permitir número de termos menor que 2 deixando digitar novamente em caso de erro.
  20. Escrever um algoritmo para calcular e mostrar a soma dos 10 primeiros números inteiros a partir de um número inteiro N fornecido pelo teclado.
  21. Escreva um algoritmo para ter um número inteiro positivo N no intervalo [1000,9999] pelo teclado e mostrar seus divisores.se o número estiver fora do intervalo permitir que o usuário entre outro que esteja no intervalo ou digite um zero para encerrar o algoritmo.
  22. Galera eu estou criando um algoritmo que teste se o número é maior que 10. Ai pensei comigo que até agora os algoritmos que crie no Visualg executam 1 vez.Ai pensei em formas de criar um algoritmo de repetição para repetir o programa e cheguei a um código. Na teoria esta perfeito mas o Visualg esta bugado dizendo haver erro de sintaxe nas linhas 17 e 18 mas eu já revisei e não encontrei. Preciso que me ajudem a corrigir este erro, desde já agradeço C Ó D I G O : Algoritmo "Número>10?" Var num:inteiro x:caractere Inicio repita escreval("digite um número:") leia(num) se num >10 então escreval("o valor é maior que 10") escreval("repetir programa? não/sim") leia(x) fimse se x<> "não","sim" então escreval("!!Respostas invalida!!.Repetir programa? sim/não") leia(x) fimse ate x="nao",x="não",x="Não",x="Nao",x="NAO",x="NÃO" Fimalgoritmo
  23. Enunciado: 9- Dados um capital, uma taxa de juros (em porcentagem) mensal e um período em meses, informe o montante ao final de cada mês. O programa deve funcionar como a seguir: Juros: 10% Capital: 100.00 Período: 3 1o mês R$ 110,00 2o mês R$ 121,00 3o mês R$ 133,10 Minha Resposta: algoritmo "Exercício 9 - Para" // Função : Este programa pede para o usuário informar a taxa de juros, o capital, o período e ao final é exibido o montante ao final de cada mês. // Autor : // Data : 01/04/2018 // Seção de Declarações var m, p, i :real x, n :inteiro inicio escreva("Informe a taxa de juros(%): ") leia(i) escreva("Informe o capital: ") leia(p) escreva("Informe o período: ") leia(n) escreval() i := (i / 100) para x de 1 ate n faca n := (n + 1) m := (p * (1 + i) ^ n) escreval(x, "° Mês: R$", m) fimpara fimalgoritmo
  24. algoritmo "Exercício 9 - Para" // Função : Este programa pede para o usuário informar a taxa de juros, o capital, o período e ao final é exibido o montante ao final de cada mês. // Autor : // Data : 01/04/2018 // Seção de Declarações var m, p, i, n :real x :inteiro inicio escreva("Informe a taxa de juros: ") leia(i) escreva("Informe o capital: ") leia(p) escreva("Informe o período: ") leia(n) i := (i / 100) para x de 1 ate n faca n := (n + 1) m := (p * (1 + i) ^ n) escreval(x, "° Mês: R$", m) fimpara fimalgoritmo Porém ao ser executado da erro de sintaxe na linha "para x de 1 ate n faca". Como posso resolver?
  25. Comecei esse ano o curso de Ciências da Computação, minha professora de lógica de programação é muito louca e não da conta de tirar dúvidas de quase 60 alunos em 2 horários de aulas só, então ela passou uma lista enorme de exercícios e eu estou nos 2 últimos, sendo que tem algumas coisas que ela ainda não explicou muito bem, ainda tem muitas dúvidas minhas no ar.(tem que ser feito no VisualG). Segue o link dos exercícios com enunciado: (não consigo ir mais longe que isso, ja tentei armar as variáveis, pra mostrar certinho o que se pede e nada acontece.) 1º //16. Num armazém existem inúmeras caixas de produtos diferentes. Cada caixa //tem uma etiqueta que contém o seu nome, o número de identificação, seu peso, //sua quantidade e o seu valor. Fazer um algoritmo que faça o cadastro de //todos os produtos do armazém(4 produtos) e faça a listagem, quando for //solicitado, destes produtos cadastrados identificando caixa mais pesada e //caixa mais pesada e caixa mais cara. ------------------------------------------------------------------------------- algoritmo "Exercício 16" var N1, N2, N3, N4: caracter NumId, NumId2, NumId3, NumId4: real Peso, Peso2, Peso3, Peso4: real Quant, Quant2, Quant3, Quant4: real Valor, Valor2, Valor3, Valor4: real inicio Escreval ("Informe os nomes dos produtos: ") Leia(N1, N2, N3, N4) Escreval("Informe o código de identificação: ") Leia(NumId, NumId2, NumId3, NumId4) Escreval ("Informe o peso do produto:(em kilos) ") Leia(Peso, Peso2, Peso3, Peso4) Escreval ("Informe a quantidade em estoque: ") Leia(Quant, Quant2, Quant3, Quant4) Escreval ("Informe o preço do produto:(em reais) ") Leia(Valor, Valor2, Valor3, Valor4) Escreval ("Nomes: ", N1, N2, N3, N4) Escreval ("Identificador: ", NumId, NumId2, NumId3, NumId4) Escreval ("Peso: ", Peso, Peso2, Peso3, Peso4) Escreval ("Quantidade em estoque: ", Quant, Quant2, Quant3, Quant4) Escreval ("Valor: ", Valor, Valor2, Valor3, Valor4) [REMOVIDO PELA MODERAÇÃO - Para um "exercício diferente, favor criar uma nova postagem]

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×