Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
  • Eletrônicos
  • Outros
  • Clube do Hardware

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Caixas de som

Encontrado 300 registros

  1. Algoritmo "semnome" var time:caractere inicio escreval("Digite um time") leia (time) escolha (time) caso "vasco" escreval("e um time carioca") fimescolha fimalgoritmo Ola sou iniciante e venho pedir ajuda, quando executo este código, e coloco a variável vasco no terminal do algorítimo ele finaliza sem exibir a mensagem "e um time carioca", mas quando eu coloco VASCO tudo em maiúsculo ele funciona e exibe a mensagem, o que seria?
  2. O sistema de numeração romana (ou números romanos) desenvolveu-se na Roma Antiga e utilizou-se em todo o seu Império. Neste sistema as cifras escrevem-se com determinadas letras, que representam os números. As letras são sempre maiúsculas, já que no alfabeto romano não existem as minúsculas, as letras são I, V, X, L, C, D e M. Sua tarefa é desenvolver um programa que converta números indo-arábicos para o formato romano e vice-versa. As regras para a formação dos números romanos são apresentadas a seguir. Cada letra corresponde a um determinado valor: I = 1 V = 5 X = 10 L = 50 C = 100 D = 500 M = 1000. Agrupando as letras acima, podemos representar os números de acordo com um conjunto de regras: Com exceção de V, L e D, os outros numerais podem se repetir no máximo três vezes: III = 3 XXX = 30 CCC = 300 MMM = 3000 Quando escritos à direita de numerais maiores, I, X e C somam-se aos valores dos primeiros: VIII = 5 + 1 + 1 + 1 = 8 LXII = 50 + 10 + 1 + 1 = 62 CLVIII = 158 MCXX = 1000 + 100 + 10 + 10 = 1120 Mas se os numerais I, X e C estiverem à esquerda dos maiores, seus valores são subtraídos como, por exemplo, em: IV = 5 - 1 = 4 IX = 10 - 1 = 9 XC = 100 - 10 = 90 Melhorei a lógica do código que antes eu teria que fazer 1 por um porém na hora de executar no visualg aparece a seguinte mensagem depois que coloco o número <Erro>, voltou -1, os parâmetros Devem ser inteiro e não Real Não sei onde está o erro me ajudem ai se puderem, e falta fazer o código de conversão de romano para indo-arábico a regra é a mesma? Var // Seção de Declarações das variáveis i: inteiro romano:caractere arabico, opcao: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval("Digite 1 para conversão de um número indo-arábico") escreval("para o formato romano") escreval("Digite 2 para conversão de um número romano para indo-arábico") leia(opcao) se(opcao = 1) entao escreval("Digite um número indo-arábico para ser convertido") leia(arabico) se(arabico = 1) entao escreval("I") fimse se(arabico = 2) entao escreval("II") fimse se(arabico = 3) entao escreval("III") fimse se(arabico = 4) entao escreval("IV") fimse se(arabico = 5) entao escreval("V") fimse se(arabico = 6) entao escreval("VI") fimse se (arabico = 7) entao escreval("VII") fimse se (arabico = 8) entao escreval("VIII") fimse se (arabico = 9) entao escreval("IX") fimse se (arabico = 10) entao escreval("X") fimse se (arabico = 11) entao escreval("XI") fimse se(arabico = 12) entao escreval("XII") fimse se(arabico = 13) entao escreval("XIII") fimse se(arabico = 14) entao escreval("XIV") fimse se (arabico = 15) entao escreval("XV") fimse se (arabico = 16) entao escreval("XVI") fimse se (arabico = 17) entao escreval("XVII") fimse se (arabico = 18) entao escreval("XVIII") fimse se (arabico = 19) entao escreval("XIX") fimse se (arabico = 20) entao escreval("XX") fimse se (arabico = 21) entao escreval("XXI") fimse se (arabico = 22) entao escreval ("XXII") fimse se (arabico = 23) entao escreval ("XXIII") fimse se (arabico = 24) entao escreval ("XXIV") fimse se (arabico = 25) entao escreval ("XXV") fimse se (arabico = 26) entao escreval ("XXVI") fimse se (arabico = 27) entao escreval ("XXVII") fimse se (arabico = 28) entao escreval ("XXVIII") fimse se (arabico = 29) entao escreval ("XXIX") fimse se (arabico = 30) entao escreval ("XXX") fimse se (arabico = 31) entao escreval ("XXXI") fimse se (arabico = 32) entao escreval ("XXXII") fimse se (arabico = 33) entao escreval ("XXXIII") fimse se (arabico = 34) entao escreval ("XXXIV") fimse se (arabico = 35) entao escreval ("XXXV") fimse se (arabico = 36) entao escreval ("XXXVI") fimse se (arabico = 37) entao escreval ("XXXVII") fimse se (arabico = 38) entao escreval ("XXXVIII") fimse se(arabico = 39) entao escreval ("XXXIX") fimse se (arabico = 40) entao escreval ("XL") fimse se (arabico = 41) entao escreval ("XLI") fimse se (arabico = 42) entao escreval ("XLII") fimse se (arabico = 43) entao escreval ("XLIII") fimse se (arabico = 44) entao escreval ("XLIV") fimse se (arabico = 45) entao escreval ("XLV") fimse se (arabico = 46) entao escreval ("XLVI") fimse se (arabico = 47) entao escreval ("XLVII") fimse se (arabico = 48) entao escreval ("XLVIII") fimse se (arabico = 49) entao escreval ("XLIX") fimse se (arabico = 50) entao escreval ("L") fimse se (arabico = 51) entao escreval ("LI") fimse se (arabico = 52) entao escreval ("LII") fimse se (arabico = 53) entao escreval ("LIII") fimse se (arabico = 54) entao escreval ("LIV") fimse se (arabico = 55) entao escreval ("LV") fimse se (arabico = 56) entao escreval ("LVI") fimse se (arabico = 57) entao escreval ("LVII") fimse se (arabico = 58) entao escreval ("LVIII") fimse se (arabico = 59) entao escreval ("LIX") fimse se (arabico = 60) entao escreval ("LX") fimse se (arabico = 61) entao escreval ("LXI") fimse se (arabico = 62) entao escreval ("LXII") fimse se (arabico = 63) entao escreval("LXIII") fimse se (arabico = 64) entao escreval("LXIV") fimse se (arabico = 65) entao escreval("LXV") fimse se (arabico = 66) entao escreval("LXVI") fimse se (arabico = 67) entao escreval("LXVII") fimse se (arabico = 68) entao escreval("LXVIII") fimse se (arabico = 69) entao escreval("LXIX") fimse se (arabico = 70) entao escreval("LXX") fimse se (arabico = 71) entao escreval("LXXI") fimse se (arabico = 72) entao escreval("LXXII") fimse se (arabico = 73) entao escreval("LXXIII") fimse se (arabico = 74) entao escreval("LXXIV") fimse se (arabico = 75) entao escreval("LXXV") fimse se (arabico = 76) entao escreval("LXXVI") fimse se (arabico = 77) entao escreval("LXXVII") fimse se (arabico = 78) entao escreval("LXXVIII") fimse se (arabico = 79) entao escreval("LXXIX") fimse se (arabico = 80) entao escreval("LXXX") fimse se (arabico = 81) entao escreval("LXXXI") fimse se (arabico = 82) entao escreval("LXXXII") fimse se (arabico = 83) entao escreval("LXXXIII") fimse se (arabico = 84) entao escreval("LXXXIV") fimse se (arabico = 85) entao escreval("LXXXV") fimse se (arabico = 86) entao escreval("LXXXVI") fimse se (arabico = 87) entao escreval("LXXXVII") fimse se (arabico = 88) entao escreval("LXXXVIII") fimse se (arabico = 89) entao escreval("LXXXIX") fimse se (arabico = 90) entao escreval("XC") fimse se (arabico = 91) entao escreval("XCI") fimse se (arabico = 92) entao escreval("XCII") fimse se (arabico = 93) entao escreval("XCIII") fimse se (arabico = 94) entao escreval("XCIV") fimse se (arabico = 95) entao escreval("XCV") fimse se (arabico = 96) entao escreval("XCVI") fimse se (arabico = 97) entao escreval("XCVII") fimse se (arabico = 98) entao escreval("XCVIII") fimse se (arabico = 99) entao escreval("XCIX") fimse se (arabico = 100) entao escreval("C") fimse
  3. Pessoal sou iniciante e preciso de ajuda nestes exercícios. Help me please!!!!1 Os exercicios devem ser feitos no visualg. Capitulo 12 e 15 Exercícios Exercício 1 Escrever um algoritmo que lê um número desconhecido de valores, um de cada vez, e conta quantos deles estão em cada um dos intervalos [0,25], (25,50], (50,75], (75,100]. Exercício 2 Escrever um algoritmo que leia informações sobre um grupo de 250 pessoas e calcule alguns dados estatísticos. Para cada pessoas do grupo deve ler o nome da pessoa, a altura, o peso e o sexo (“F” para feminino e “M” para o masculino). Calular e escrever: A quantidade total de homens e mulheres e o percentual de cada. A média de peso das pessoas (somatório dos pesos de todas as pessoas pela quantidade de pessoas) O nome da pessoa mais alta. Exercício 3 Escrever um algoritmo que gera e escreve os 4 primeiros números perfeitos. Um número perfeito é aquele que é igual à soma dos seus divisores. Ex: 6 = 1+2+3, 28 = 1+2+4+7+14. Exercício 4 Escrever um algoritmo que lê um número não determinado de valores para m, todos inteiros e positivos, um de cada vez. Se m for par, verificar quantos divisores possui e escrever esta informação. Se m for ímpar e menor do que 12 calcular e escrever o fatorial de m. Se m for ímpar e maior ou igual a 12 calcular e escrever a soma dos inteiros de 1 até numero lido. Exercício 5 Faça um algoritmo que gere uma tabela com os números de 1 a 10 e mostre o seu quadrado, cubo, fatorial, número de divisores e uma mensagem dizendo se o número é primo ou não. A cada 20 linhas deve ser escrito o cabeçalho novamente: "Número Quadrado Cubo Fatorial Divisores Primo" 1 1 1 1 1 Sim 2 4 8 2 2 Sim Desafio Escrever um algoritmo que lê um conjunto não determinado de pares de valores a, b, todos inteiros e positivos, e para cada par lido, obtém o M.D.C. e o M.M.C. de a,b, escrevendo-os juntamente com os valores lidos.
  4. var numero, i, cont :inteiro inicio escreval("digite um numero: ") leia(numero) se numero = 1 entao escreval("o numero ",numero," NAO e primo!") senao escreval("os divisores do numero ",numero," sao: ") se numero <= 10 entao // se o numero for ate 10 divide pelos antecessores: para i de 1 ate numero faca se numero mod i = 0 entao escreva(" ",i) cont <- cont+1 fimse i <- i+1 fimpara senao // sefor maior que 10 divide pelos antecessores de 1 a 10: para i de 1 ate 10 faca se numero mod i = 0 entao escreva(" ",i) // só deve achar um divisor: o numero 1 cont <- cont+1 // cont vai ter valor 1 fimse i <- i+1 fimpara cont <- cont+1 // aumentar para poder exibir a mensagem escreva(numero) // para exibir o próprio numero depois do 1 fimse escreval() // pula um linha se cont = 2 entao escreval("o numero", numero," e primo!") senao escreval("o numero", numero," NAO e primo!") fimse fimse fimalgoritmo Crie esse algoritmo porém quero mostrar, todos os números primos e mostrar o primo anterior a ele como deveria ser feito?
  5. Var // Seção de Declarações das variáveis respostas,gabarito: VETOR[1..3]caractere i,acertos, erros: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... para i de 1 ate 3 faca Escreval("Digite a resposta") leia(respostas[i]) fimpara para i de 1 ate 3 faca Escreval("Digite o gabarito") leia(gabarito[i]) fimpara acertos<-0 para i de 1 ate 3 faca se(respostas[i] = gabarito[i]) entao acertos<-acertos+1 fimse erros<-3-acertos fimpara escreval("O número de acertos foi:",acertos) escreval("O número de erros foi:", erros) Fimalgoritmo Estou fazendo um algoritmo para ler as respostas e comparar com o gabarito porém está dando erro e não sei onde está o erro, o erro que está dando é variável RESPOSTAS não foi encontrada alguém sabe o porque disso? adicionado 13 minutos depois Atualizei o código Var // Seção de Declarações das variáveis respostas,gabarito: vetor[1..3]caractere i,acertos, erros: inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... //Escreval("Digite a resposta") //Escreval("Digite o gabarito") para i de 1 ate 3 faca Escreval("Digite a resposta") se(respostas[i]<>a) e (respostas[i]<>b) e (respostas[i]<>c) e (respostas[i]<>d) Escreval("Por favor digite respostas válidas de a,b,c e d") leia(respostas[i]) fimpara para i de 1 ate 3 faca Escreval("Digite o gabarito") se(gabarito[i]<>a) e (gabarito[i]<>b) e (gabarito[i]<>c) e (gabarito[i]<>d) Escreval("Por favor digite um gabarito válido de a,b,c e d") leia(gabarito[i]) fimpara acertos<-0 para i de 1 ate 3 faca se(respostas[i] = gabarito[i]) entao acertos<-acertos+1 fimse erros<-3-acertos fimpara escreval("O número de acertos foi:",acertos) escreval("O número de erros foi:", erros) Fimalgoritmo O código irá ver as respostas verificar se a resposta é a,b,c,d caso não seja irá pedir para informar esse valores e o gabarito também, porém continua não compilando com o mesmo erro, o código está errado onde, acho que ele está correto
  6. Olá, estou iniciando em algorítimos e me deparei com a seguinte questão: O gerente de uma loja decidiu vender os produtos em três pagamentos, com uma entrada e mais duas parcelas, que devem ser iguais e inteiras. Por exemplo, para um produto que custa R$360,00, tanto a entrada como as duas parcelas serão de R$ 120,00; se o produto custar R$ 902,50 a entrada deve ser de R$ 302,50 mais duas parcelas de R$ 300,00. Faça um programa onde informaremos o valor do produto e teremos calculada a entrada e as duas parcelas, com as regras estabelecidas pelo gerente. Fiz o seguinte algorítimo: Algoritmo "parcelamento_entrada_mais_duas" Var valor, entrada, resto: inteiro parcela, n_parcelas: inteiro Inicio escreva("Digite o valor do produto: ") leia(valor) n_parcelas <- 3 resto <- valor mod n_parcelas parcela <- valor \ n_parcelas entrada <- parcela + resto escreval("A entrada será de R$",entrada:2:2) escreval("O valor da parcela será: ",parcela:2:2) Fimalgoritmo quando eu coloco as variáveis: valor, entrada e resto como real, tenho a seguinte resposta: <ERRO>, VOLTOU -1, os parâmetros devem ser inteiros e não real. Alguém sabe me explicar o motivo? O erro está no meu algorítimo? Obrigado pela ajuda
  7. Boa tarde, estou fazendo curso de redes e meu professor pediu que fizéssemos um trabalho em casa porém no visualg não consigo de jeito nenhum usar o copia tentei varias vezes e não esta pegando diz que esperava uma variável inteiro ou real mas mesmo colocando na variável o mesmo não pega... vocês saberiam me explicar segue as duas perguntas: 3) Altere o código anterior para que seu nome seja impresso com as primeiras letras de cada nome/sobrenome em maiúsculas, sem alterar o conteúdo original da cadeia de caracteres. (Utilize as funções: Copia() e Maiusc() em conjunto). 5) Ainda utilizando o código anterior, altere-o para que seja impresso na saída padrão o seu primeiro sobrenome. (utilize a função Copia()).
  8. Boa tarde. sou iniciante na área de programação e estou estudando algorítmicos. durante os estudos, eu me deparei com uma situação da qual eu não consigo compreender exatamente o que ocorre na vídeo aula que eu estou acompanhando, nas operações matemáticas no meio do código, quando há a presença números quebrados no meio de código (em divisão por exemplo), o resultado é alcançado, mas comigo não acontece, o mesmo código, não vai, exemplo: só funciona se eu alocar uma variável, que deve ser preenchida via 'leia' no meio do código, para aí sim a execução fazer a operação correta, exemplo: Ou seja, eu não consigo incluir operação matemática com números quebrados no código, só pelo preenchimento da variável. Caso eu deseje colocar uma conta fixa que envolva um valor quebrado, não consigo. Se alguém puder me falar o que eu estou fazendo de errado, agradeço.
  9. Gostaria das respostas desse exercício eu fiz, porém gostaria de corrigi-los pra ver se obtive um bom rendimento 1. Coloque VERDADEIRO ou FALSO na avaliação das seguintes expressões: a) 6 <= 7 b) (64) ^ (1/2) > (5)*2 c) 'Pseudocódigo' < 'PSEUDOCÓDIGO' d) 'Pseudocódigo' > 'turbo' e) 3 + 5 <= 2 * 4 2. Faça um algoritmo para calcular a área de uma circunferência, considerando a fórmula ÁREA = π * RAIO2. Utilize as variáveis AREA e RAIO, a constante π (pi = 3,14159) e os operadores aritméticos de multiplicação. 3. Faça um algoritmo que leia uma temperatura em Fahrenheit e a apresente convertida em graus Celsius. A fórmula de conversão é C = (F – 32) * ( 5 / 9), na qual F é a temperatura em Fahrenheit e C é a temperatura em Celsius. 4. Faça um algoritmo que leia os valores de COMPRIMENTO, LARGURA e ALTURA e apresente o valor do volume de uma caixa retangular. Utilize para o cálculo a fórmula VOLUME = COMPRIMENTO * LARGURA * ALTURA. 5. Faça um algoritmo que leia dois valores inteiros (A e B e apresente o resultado da soma do quadrado de cada valor lido. 6. Leia um código de cinco algarismos e gere o digito verificador (DigitoV) módulo 7 para o mesmo. Supondo que os cinco algarismos do código são ABCDE, uma forma de calcular o dígito desejado, com módulo 7 é: DigitoV = resto da divisão de S por 7, onde S = 6*A + 5*B + 4*C + 3*D + 2*E 7. Faça um algoritmo que leia um número N e imprima “F1”, “F2” ou “F3”, conforme a condição: • “F1”, se N <= 10 • “F2”, se N > 10 e N <= 100 • “F3”, se n > 100 A revendedora de carros Liechester Ltda. paga aos seus funcionários vendedores dois salários mínimos fixos, mais uma comissão fixa de R$ 50,00 por carro vendido e mais 5% do valor das vendas. Faça um algoritmo que determine o salário total de um vendedor.
  10. Boa tarde, peguei esse código aqui mesmo no forum e fiz algumas modificações e minha duvida é quando ele gera aleatorio os 80 números dos 100 desses 80 ele fizesse outro processo aleatorio tambem so que 25 numeros impares e 25 numeros pares escolhido do 80 como faz isso alguem poderia me ajudar obrigado. algoritmo "Algoritmo exercicio de numeracao3" var vetor_100 :vetor [1..100] de inteiro //vetor armazena 100posiçoes vetor_80_1 :vetor [1..80] de inteiro //vetor armazena 80 posições p :inteiro //auxiliar para posicionar o vetor i,j :inteiro //auxiliar para percorrer o vetor OK :logico //flag para verificar se a etapa foi realizada com sucesso aguardar:caracter //variável criada apenas para aguardar um ENTER na interação com o usuário Inicio MudaCor("Preto","Frente") --> caracter Azul MudaCor("Branco","Fundos") --> fundo branco //gera os 100 números do vetor inicial escreval("GERANDO OS 100 NÚMEROS INICIAIS...") para p de 1 ate 100 faca vetor_100[p]:=p fimpara escreval("Tecle Enter") leia(aguardar) escreval("NÚMEROS GERADOS COM SUCESSO!") //exibe os 100 números gerados escreval() escreval("Aqui estão os 100 números iniciais") p:=1 para i de 1 ate 10 faca //cada linha para j de 1 ate 10 faca //cada coluna escreva(vetor_100[p]:2," - ") p:=p+1 fimpara escreval//para pular para a linha de baixo fimpara //Sorteia os primeiro 80 números do vetor de 100 posições escreval("Vamos Escolher Aleatoriamente Os Primeiros 80 Números Dos 100") para i de 1 ate 80 faca repita // repite se precisar ok := verdadeiro p:=randi(100)+1 // gera um número aleatorio se vetor_100[p]=0 ENTÃO//numero foi deletado ok := falso fimse para j de 1 ate 80 faca//verifica os numeros se ok = verdadeiro ENTÃO //se o número não houver sido deletado se vetor_80_1[j] = vetor_100[p] ENTÃO//se no vetor já haver o numero gerado ok := falso interrompa fimse fimse fimpara se ok = verdadeiro ENTÃO vetor_80_1[i] := vetor_100[p] fimse ate ok fimpara escreval("Os Primeiros 80 Números Foram Gerados Com Sucesso") //escrevando os primeiros números gerados aleatórios escreval("Aqui Estão Os primeiros 80 Números Gerados Aleatórios") p:=1 para i de 1 ate 16 faca para j de 1 ate 5 faca escreva(vetor_80_1[p]," - ") p := p+1 fimpara escreval//para pular para a linha de baixo fimpara fimalgoritmo
  11. Faz tempo que não brincava com Visual G, eu usava pra ensinar pessoas que estavam querendo entrar na area de TI. Um assunto sempre bom a abordar são as funções, elas podem ainda ser confusos pra muitas pessoas que estão iniciando. ao ouvir o termo "Procedimento ou Procedure" , "Função ou Function", podemos ter uma percepção do que pode ser na questão de interpretar cada palavra. Fiz Aqui um algoritmo usando a função, eu posso chama-la a qualquer momento em meu script. Vou deixar o Script pra vocês interpretarem, qualquer duvida, só me citar que eu respondo qualquer duvida do código pra ajudar mesmo o entendimento Algoritmo "calculadora" //função de Adição Matematica funcao soma(a,b:real):real inicio retorne (a+b) fimfuncao //função de Subtração Matematica funcao sub(a,b:real):real inicio retorne (a-b) fimfuncao //função de Multiplicação Matematica funcao mult (a,b:real):real inicio retorne (a*b) fimfuncao //função de Divisão Matematica funcao divs (a,b:real):real inicio retorne (a/b) fimfuncao Var escolhe_num: inteiro numeroa:real numerob:real GuardaResultado: real Inicio repita MudaCor("Preto","Fundos") MudaCor("Amarelo","Frente") escreval("Calculadora") escreval() escreval("1- Adição") escreval("2- Subtração") escreval("3- Multiplicação") escreval("4- Divisão") escreval("5- Limpar a Tela") escreval("6- Sair da Calculadora") leia(escolhe_num) //adição se escolhe_num = 1 entao limpatela escreval("Digite o primeiro Numero:") leia(numeroa) escreval() escreval("Digite o segundo Numero:") leia(numerob) GuardaResultado <- soma(numeroa,numerob) escreval("O Resultado da Soma é:",GuardaResultado) fimse //subtração se escolhe_num = 2 entao limpatela escreval("Digite o primeiro Numero:") leia(numeroa) escreval() escreval("Digite o segundo Numero:") leia(numerob) GuardaResultado <- sub(numeroa,numerob) escreval("O Resultado da subtração é:",GuardaResultado) fimse //multiplicação se escolhe_num = 3 entao limpatela escreval("Digite o primeiro Numero:") leia(numeroa) escreval() escreval("Digite o segundo Numero:") leia(numerob) GuardaResultado <- mult(numeroa,numerob) escreval("O Resultado da multiplicação é:",GuardaResultado) fimse //Divisão se escolhe_num = 4 entao limpatela escreval("Digite o primeiro Numero:") leia(numeroa) escreval() escreval("Digite o segundo Numero:") leia(numerob) GuardaResultado <- divs(numeroa,numerob) escreval("O Resultado da divisão é:",GuardaResultado) fimse //limpatela se escolhe_num = 5 entao limpatela fimse //sair do programa se escolhe_num = 6 entao escreval("Saindo da Calculadora, Obrigado por Utilizar!") fimse //Digitou outro numero fora de (1..6) se escolhe_num > 6 entao escreval("voce digitou um numero não correspondente as opções acima") fimse ate escolhe_num = 6 Fimalgoritmo
  12. Pessoal estou precisando de ajuda, comecei meu curso na faculdade e não estou conseguindo fazer um exercício de vetores que é pedir para o usuário digitar 3 times de futebol e fazer mostrar as possíveis combinações de partidas entre eles. Porém os resultados não podem se repetir. Segue o Código abaixo: obs: Estou com dificuldades com vetores e laços de repetições utilizados juntos, alguém poderia me indicar um material ? algoritmo "TabelaDePartidas" var i,j: inteiro nome: vetor[1..4] de Caractere inicio Para i de 1 ate 3 faca Escreva("Nome do ",i,"° Time: ") leia(nome[i]) FimPara LimpaTela EscrevaL("=================================") EscrevaL("T A B E L A D E P A R T I D A S") EscrevaL("=================================") Para i <- 1 ate 3 faca para j <- i ate 3 faca escreval(nome[i]," [] X [] ",nome[j]) FimPara FimPara fimalgoritmo
  13. Olá amigos. Eu tenho o seguinte algoritmo: algoritmo "SacarDinheiro" // Função : Verificar se o saque é possível na conta bancária // Autor : // Data : 04/12/2018 // Seção de Declarações var SaldoDisponivel: REAL ValorDoSaque: REAL SIM: LOGICO NAAO: LOGICO inicio SaldoDisponivel:= 1000 //Assumimos que há 1000 reais de saldo na conta disponível para o saque ESCREVA ("Informe o valor do Saque: ") LEIA (ValorDoSaque) SE ValorDoSaque <= SaldoDisponivel ENTAO SaldoDisponivel := SaldoDisponivel - ValorDoSaque ESCREVAL ("Sacando R$", ValorDoSaque, ".") ESCREVAL ("Aguarde a contagem das notas") ESCREVAL("Retire as notas") SENAO ESCREVAL ("O valor solicitado é maior que o valor disponível para saque!") FIMSE ESCREVA("Deseja continuar?") LEIA (SIM) SE SIM ENTAO AQUI EU GOSTARIA DE FAZER A REPETIÇÃO DO algoritmo SE MINHA resposta FOR SIM MAS NÃO ENCONTRO A ESTRUTURA CERTA ALGUEM SABE? ESCREVA ("Informe o valor do Saque: ") LEIA (ValorDoSaque) SE ValorDoSaque <= SaldoDisponivel ENTAO SaldoDisponivel := SaldoDisponivel - ValorDoSaque ESCREVAL ("Sacando R$", ValorDoSaque, ".") ESCREVAL ("Aguarde a contagem das notas" ESCREVAL("Retire as notas") SENAO ESCREVAL ("O valor solicitado é maior que o valor disponível para saque!") FIMSE ESCREVAL ("Saldo Disponível: R$", SaldoDisponivel) FIMSE fimalgoritmo
  14. Galera eu preciso da resolução desses algoritmos (Matriz) até amanhã por favor 1) Faça um algoritmo que leia 9 uma matriz 3x3. Posteriormente, percorra esta matriz e imprima somente os números que são pares. 2) Faça um algoritmo que leia uma matriz 2x3 e verifique se a matriz possui algum número repetido. Informe "Possui" ou "Não Possui" ao final do algoritmo. 3) Faça um algoritmo que possua duas matrizes 4x4 de números inteiros. Posteriormente, imprima somente os números que estão nas duas matrizes. 4) Faça um algoritmo que leia uma matriz 3x3 e imprima esta matriz ordenada de forma crescente. POR FAVOR RESPONDAM!!!
  15. Elabore um programa que: i) Leia as três primeiras informações de cada aluno (matrícula, média das provas e média dos trabalhos) ii) Calcula a nota final como sendo a soma da média das provas e da média dos trabalhos iii) Imprima a matrícula do aluno que obteve a maior nota final (assuma que só existe uma maior nota) iv) Imprima a média aritmética das notas finais algoritmo var vet:vetor[1..3,1..3] de inteiro vetx:vetor[1..3] de inteiro i,c,a:inteiro soma:inteiro inicio para i de 1 ate 3 faca para c de 1 ate 3 faca escreval("Digite o valor da primeira matricula ",vet ) leia(vet) fimpara para c de 1 ate 3 faca escreval("Digite o valor da medias do aluno ",vet[c] ) leia(vet[c]) fimpara para a de 1 ate 3 faca escreval("Digite o valor da medias do trabalho do aluno ",vetx[a] ) leia(vetx[a]) fimpara soma <- soma + vet+vet[c]+vetx[a] escreva("A soma total e ",soma ) fimalgoritmo adicionado 1 minuto depois salve galera fiz esse ai mais não gostei muito alguém tem uma ideia melhor de eu arruma essa bagaça kkkk !!!
  16. Saudações galera, sou novo em programação e gostaria de suas valiosa dicas com relação a seguinte questão: Faça um programa que efetue a busca do tipo sequencial por um valor em um vetor de 200 posições, sabendo que o mesmo valor pode ocorrer mais de uma vez no vetor. O programa deve imprimir o número de ocorrências do valor de busca, caso ocorram. Obs. (O programa deve ser desenvolvido por meio da ferramenta Visualg) Comecei fazendo a questão, porém o mesmo não consegue identificar os valores repetidos no vetor. Por gentileza onde estou errando ? Segue o código do programa: algoritmo "busca sequencial " var j,k, vb : inteiro v : vetor[1..20] de inteiro v1: vetor [1..20] de inteiro achou : logico RESP: logico procedimento preenchevetor var j : inteiro inicio para j de 1 ate 20 faca v[j] <- randi(200) escreval(j:10,v[j]:10) fimpara fimprocedimento inicio RESP:= verdadeiro enquanto RESP = verdadeiro faca preenchevetor escreva("Entre com o valor de busca (ESC termina) :") leia(vb) j <- 1 repita se v[j] = vb entao achou <- verdadeiro senao j <- j+1 fimse ate (achou=verdadeiro) ou (j>20) se achou entao escreval("Achei ", vb , " na posição ", j) senao se ( v[j] = vb) entao escreval(" Valor: ", vb , " repetiu na posição ", j) senao escreval("Nao achei.") fimse fimse fimenquanto fimalgoritmo No mais só tenho a agradecer.
  17. Letra mínima tem o mesmo significado que letra muito pequena. Estou filmando com a Apowersoft Free Online Screen Recorder, a tela inteira do meu notebook (1366x768) e quando publico no YouTube, a letra do VisualG fica mínima e quase tudo nos vídeos é ilegível, mesmo com a qualidade 720p.
  18. Considere que você foi contratado por um corretor de seguros para desenvolver um programa de computador que auxilie o corretor no cálculo de seguros de automóveis. Este corretor trabalha com duas companhias de seguro: NextCred Seguros e a LouLou Seguros. O usuário/corretor fornecerá o sexo e a idade do segurado, além do valor do automóvel a ser segurado. Sabe-se que o valor da apólice para as seguradoras NextCred Seguros e LouLou Seguros são de 4,3% e 5,8%, respectivamente. A seguradora NextCred Seguros não faz distinção quanto ao sexo dos segurados. No entanto, segurados com menos de 25 anos têm um acréscimo de 1,5% para cada ano abaixo dos 25, chegando à 10,5% no caso do segurado ter 18 anos. Já os segurados com mais de 50 anos têm desconto de 1% por ano, limitando-se à 15% de desconto. A LouLou Seguros dá desconto de 6% para clientes do sexo feminino e mais 8% de desconto caso o cliente tenha 30 anos de idade ou mais. Todos os acréscimos e descontos para ambas as seguradoras são com base no valor bruto da apólice. Após o cálculo das apólices, o programa deve apresentar ambos os valores, referentes a NextCred Seguros e a LouLou Seguros. O programa deve estar apto a processar vários clientes, encerrando a execução quando um código inválido para o sexo do cliente ou segurado seja digitado. Então, pede-se que seja elaborado um algoritmo em VisualG afim de gerar o produto desejado para o corretor.
  19. Olá galera, preciso de outra ajudinha aqui, acabei de começar o código, mas to com dificuldade para entender a lógica. Eu preciso que a matriz receba a pergunta e a resposta(gabarito. Peço que não mandem o código pronto, me passem uma explicação. Código: Var quest :vetor[1..10,1..5] de caractere a,b,c,d :caractere respostaop :inteiro r,q :inteiro tela :caractere acertos :inteiro cont : inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------------------------") fimprocedimento Inicio escreval("********************************************************") escreval("* *") escreval("* *") escreval("* Questionário Perguntas *") escreval("* Aleatórias *") escreval("* *") escreval("* *") escreval("* *") escreval("* PRESSIONE ENTER PARA COMEÇAR *") escreval("* *") escreval("* BOA SORTE! ;3 *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") escreva("Aperte ENTER para continuar...") leia(tela) limpatela //GABARITO //-----------------questão1-------------------- q() para q de 1 ate 10 faca para r de 1 ate 5 faca quest[1,1] <- "Quem foi Adolf Hitler" fimpara fimpara escreval( quest[1]) separa() escreval( "A)Um Camponês Alemão") escreval( "B)Líder da Alemanha Nazista no período da Segunda Guerra") escreval( "C)Líder do Brasil no período da Segunda Guerra") escreval( "D)Empresário Alemão") escreval() escreva("A alternativa certa é:") leia(resp[1]) se resp[1] = "B" entao acertos <- acertos + 1 fimse q () //--------------------QUESTÃO 2----------------------- quest[2] <- "Quem foi Benito Mussolini?" escreval(quest[2]) separa() escreval( "A)Líder do Partido Nacional Fascista na Itália") escreval( "B)Líder de movimentos comunistas") escreval( "C)Presidente do Brasil") escreval( "D)Camponês") escreval() escreva("A alternativa certa é:") leia(resp[2]) se resp[2] = "A" entao acertos <- acertos + 1 fimse q() Fimalgoritmo
  20. Pessoal, não estou conseguindo executar uma linha (13) de código no Visualg referente à estrutura condicional. * O visuAlg, por sua vez, sempre afirma que falta um "então" algo, que eu já corrigir... Me ajudem, por favor...
  21. Olá, montei o algoritmo para calcular o IMC, quando eu coloco "Peso 59" e "Altura 1.82" o resultado é "IMC 17.81". Deveria aparecer como resultado "Você está abaixo do peso, pede uma pizza aí!", mas o que aparece é "Muito bem, você está no peso ideal!". Eu não estou entendendo onde errei, será que o Visualg tem algum erro? Me ajudem por favor!!! rsrs... O código que fiz foi esse: Algoritmo "imc" Var nome: caracter kg, Altu, IMC: real Inicio Escreval ("Olá, qual seu nome?") Leia (nome) Escreval ("Quanto você pesa ", nome, "?") Leia (kg) Escreval ("Quanto você tem de altura?") Leia (Altu) IMC<- Kg/ (Altu^2) Se (IMC < 17) então Escreval ("Muito abaixo do peso ",nome, ".") Senao Se (IMC >= 17) e (IMC < 18.5) entao Escreval (nome," Você está abaixo do peso, pede uma pizza aí!") Senao Se (IMC >= 18.5) e (IMC < 25) entao Escreval ("Muito bem ", nome, ", você está no peso ideal!") Senao Se (IMC >= 25) e (IMC < 30) entao Escreval ("Hora de pensar em um regime ", nome, ", você está com sobrepeso!") Senao Se (IMC >= 30) e (IMC < 35) entao Escreval ("Obesidade ", nome, ", é isso que você quer pra sua vida?") Senao Se (IMC >= 35) e (IMC < 40) entao Escreval ("Obesidade severa, sinto muito ", nome) Senao Escreval ("Obesidade mórbida", nome, ", aconselho que vá cuidar da sua saúde.") Fimse Fimse Fimse Fimse Fimse Fimse Escreval (nome,", O seu IMC é ", IMC:5:2, ".") Fimalgoritmo
  22. Nao entendi como usar vetores // EXERCICIO NUMERO 7 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "7" var Q: vetor[1..10] de inteiro i,posicao: inteiro inicio para i de 1 ate 10 faca escreval("Digite o", i, "º numero:") leia(Q[i]) posicao <- i escreval("Na posição:", posicao) escreval enquanto (Q[i] < 0) faca escreval("Digite um valor positivo") leia(Q[i]) fimenquanto fimpara para i de 1 ate 10 faca posicao <- i fimpara fimalgoritmo nao sei se o que eu fiz ta certo !
  23. o que eu conseguir foi dar o desconto porém so consigo para 10% os outros eu nao consigo fazer ... preciso de ajuda // EXERCICIO NUMERO 2 // Disciplina : [Linguagem e Lógica de Programação] // Professor : Lourivaldo Pereira // Aulo : Rafael Santos Castilho Algoritmo "Desconto para comercio" Var // Seção de Declarações das variáveis descricaoproduto:caractere precounitario,quantidade:real precototal,valordesconto,valorpagar:real valorpagardesconto:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreva("Descrição Do Produto..............: ") leia(descricaoproduto) escreva("Preço Unitario..................R$: ") leia(precounitario) escreva("Quantidade........................: ") leia(quantidade) precototal<-quantidade*precounitario //preço por unidade //OS DESCONTOS //15% menor R$150 se precototal<150 entao valordesconto<-(precototal*15/100) senao valorpagar<-precototal fimse //18% de R$150 a R$499 se precototal>150 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal<499 entao valordesconto<-(precototal*18/100) senao valorpagar<-precototal fimse se precototal>500 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal<799 entao valordesconto<-(precototal*23/100) senao valorpagar<-precototal fimse se precototal>800 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal<=1000 entao valordesconto<-(precototal*27/100) senao valorpagar<-precototal fimse se precototal>1001 entao valordesconto<-(precototal*30/100) senao valorpagar<-precototal-valordesconto fimse escreval("Preço Total do Produto..........R$: ",precototal) escreval("Valor do Desconto...............R$: ",valordesconto) escreval("Valor a Pagar...................R$: ",valorpagar) escreval("********FIM DO ALGORITMO*******") fimalgoritmo
  24. Não consigo achar o menor número usando o repita. algoritmo "TP901.alg" // Função : // Autor : // Data : 07/11/2018 // Seção de Declarações var vln: inteiro vlm: inteiro vls: inteiro vlme: inteiro qtd: inteiro vlmd: real inicio vln <- 0 vlm <- 0 vlme <- 0 vls <- 0 qtd <- 0 vlmd <- 0 escreva ("Digite o primeiro número ou 0 para finalizar: ") leia (vln) vlm <- vln vlme <- vlme se (vln = 0) entao escreva ("Algoritmo finalizado sem calculos...") senao repita qtd <- qtd + 1 vls <- (vls + vln) escreva ("Digite o próximo número ou 0 para finalizar: ") leia (vln) se (vln > vlm) entao vlm <- vln fimse se (vln < vlme) entao vlme <- vln fimse ate (vln = 0) fimse escreval ("Seu algoritmo foi finalizado, veja as conclusões: ") vlmd <- vls/qtd escreval ("O maior valor é: ",vlm,"") escreval ("O menor valor é: ",vlme: 2:2,"") escreval ("A soma dos valores foi de: ",vls) escreval ("Quantidade de números digitados: ",qtd) escreval ("O menor valor digitado foi:" ,vlme,) vlmd <- vls/qtd escreval ("A média foi: ",vlmd) fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!