Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Blog

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Categorias

  • Cursos

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrado 224 registros

  1. Alguém poderia me ajudar para que essas sequencias funcionem? Para mim parece certo, mas quando coloco para executar da errado.
  2. Sempre quando se escreve a palavra Mensagem ela fica azul e sublinhada. Para que ela serve? Não achei sobre ela nem na documentação do VisualG nem em lugar nenhum.
  3. Estou fazendo um algoritmo de perguntas para um trabalho de biologia no qual tenho que fazer um jogo, Ele ficou assim, preciso colocar para o texto em baixo do leia(Nota1) Ficar 1 minuto depois limpar o chat do DDOS e ir para as perguntas tem como? Preciso deixar o texto 1m pois o objetivo do jogo é que você consiga guardar os dados na sua memória para responder os questionários então a pessoa tem q ter uma boa atenção para conseguir absorver esse texto em 1 minuto e depois responder as perguntas, qualquer duvida deixa no chat algoritmo "semnome" // Função : // Autor : // Data : 28/07/2018 // Seção de Declarações var nota1,nota2,nota,media:caractere inicio escreval("Seja Bem Vindo, O Objetivo desse jogo é testar seu conhecimento sobre enzimas") escreval("|----------------------------------------------------------------------------------------------------------------") escreval("|Participantes: Kayky, Ana Julia, Ana Luiza, Lorena, Manoel ") escreval("|") escreval("|Serão 5 perguntas e no final te daremos a nota, Boa Sorte!") escreval("|") escreval("| * *") escreval("| u") escreval("|-----------------------------------------------------------------------------------------------------------------") escreval("aparecera um texto e você tera 1 minuto para ler e depois") escreval("tera que responder algumas perguntas sobre Enzimas, você esta pronto? ") escreval("") escreval("Responda com Sim ou Não") leia(nota1) escreval("As enzimas são moléculas catalisadoras, presentes no organismo do ser humano") escreval("formadas por proteínas. A principal função delas é favorecer o acontecimento de") escreval("algumas reações biológicas, cada enzima é responsável por apenas um") escreval("tipo de reação química, que são essenciais para a vida.") escreval("o que São Enzimas ?") leia(nota2) escreval("Qual a principal função das Enzimas?") leia(nota3) fimalgoritmo
  4. Seria possível colocar, por exemplo, dois comandos repita...ate no mesmo algoritmo? Se sim como?
  5. Código: algoritmo "semnome" // Função : // Autor : // Data : 25/07/2018 // Seção de Declarações var v1, v2, v1_2, v2_2, c, d, resultadoC, resultadoD, v1C, v2C, v1D, v2D :inteiro inicio escreva(" - Informe o primeiro valor: ") leia(v1) escreva(" - Informe o segundo valor : ") leia(v2) c <- 2 d <- 3 resultadoC <- 1 resultadoD <- 1 v1C <- v1 v2C <- v2 v1D <- v1 v2D <- v2 v1_2 <- v1 v2_2 <- v2 se (v1 = 0) ou (v2 = 0) então escreval() escreval(" * MMC [", v1C, ",", v2C," ]: = 0") escreval(" * MDC [", v1D, ",", v2D," ]: = 0") senao se (v1 < 0) ou (v2 < 0) então escreval() escreval(" * Este número é negativo.") senao enquanto (v1 + v2 <> 2) faca se (v1 mod c = 0) então resultadoC <- (resultadoC * c) v1 <- (v1 \ c) fimse se (v2 mod c = 0) então resultadoC <- (resultadoC * c) v2 <- (v2 \ c) fimse se (v1 mod d = 0) então resultadoC <- (resultadoC * d) v1 <- (v1 \ d) fimse se (v2 mod d = 0) então resultadoC <- (resultadoC * d) v2 <- (v2 \ d) fimse se (v1 mod v1 = 0) então resultadoC <- (resultadoC * v1) v1 <- (v1 \ v1) fimse se (v2 mod v2 = 0) então resultadoC <- (resultadoC * v2) v2 <- (v2 \ v2) fimse fimenquanto enquanto (v1_2 + v2_2 <> 2) faca se (v1_2 mod c = 0) e (v2_2 mod c = 0) então resultadoD <- (resultadoD * c) v1_2 <- (v1_2 \ c) v2_2 <- (v2_2 \ c) senao v1_2 <- (v1_2 \ c) v2_2 <- (v2_2 \ c) fimse se (v1_2 mod d = 0) e (v2_2 mod d = 0) então resultadoD <- (resultadoD * d) v1_2 <- (v1_2 \ d) v2_2 <- (v2_2 \ d) senao v1_2 <- (v1_2 \ d) v2_2 <- (v2_2 \ d) fimse se (v1_2 mod v1_2 = 0) e (v2_2 mod v1_2 = 0) ou (v2_2 mod v2_2 = 0) e (v1_2 mod v2_2 = 0) então resultadoD <- (resultadoD * v1_2) v1_2 <- (v1_2 \ v1_2) v2_2 <- (v2_2 \ v2_2) senao se (v1_2 mod v1_2 = 0) então v1_2 <- (v1_2 \ v1_2) fimse se (v2_2 mod v2_2 = 0) então v2_2 <- (v2_2 \ v2_2) fimse fimse fimenquanto escreval() escreval(" * MMC [", v1C, ",", v2C, " ]:", resultadoC) escreval(" * MDC [", v1D, ",", v2D, " ]:", resultadoD) fimse fimse fimalgoritmo O programa calcula o MMC e o MDC de dois números informados pelo usuário. Ele calcula e tudo, mas não exibe pois da o erro: Divisão por zero. Os valores das variáveis de resultado estão corretos, porém na parte de exibir na tela os resultados aparece:
  6. . Preciso de uma fórmula que gere os 4 primeiros números perfeitos de um número perfeito informado pelo usuário. . Um número perfeito é aquele que é igual à soma dos seus divisores. Ex: 6 = 1+2+3, 28 = 1+2+4+7+14. . Já consegui fazer um algoritmo para verificar se o número é perfeito. Veja: algoritmo "semnome" var n, x, soma :inteiro inicio escreva(" - Informe um número: ") leia(n) para x de 1 ate (n - 1) faca se (n % x = 0) então soma <- (soma + x) fimse fimpara se (soma = n) então escreval() escreval(" * Este número é perfeito.") senao escreval() escreval(" * Este número é imperfeito.") fimse fimalgoritmo . O problema é que preciso exibir os 4 primeiros números perfeitos caso o número informado for perfeito. Alguém saberia como fazer isso? Desde já agradeço.
  7. Gostaria de saber se é possível salvar a saída de um algoritmo em um arquivo (.txt)? EXEMPLO: - ALGORITMO algoritmo "semnome" var x :inteiro inicio escreva("Digite um valor: ") leia(x) escreval(x) fimalgoritmo - SAÍDA Digite um valor: 1 1 Teria como salvar a saída em um arquivo (.txt)?
  8. Preciso de um algoritmo que escreva o vetor em ordem crescente e caso possível impedir que sejam gerados vetores iguais. Segue o código: algoritmo "semnome" // Função : // Autor : // Data : 11/07/2018 // Seção de Declarações var n :vetor [1..6] de inteiro x :inteiro inicio para x de 1 ate 10 faca n[1] := randi(60) n[2] := randi(60) n[3] := randi(60) n[4] := randi(60) n[5] := randi(60) n[6] := randi(60) enquanto (n[1] = 0) ou (n[2] = 0) ou (n[3] = 0) ou (n[4] = 0) ou (n[5] = 0) ou (n[6] = 0) ou (n[1] = n[2]) ou (n[1] = n[3]) ou (n[1] = n[4]) ou (n[1] = n[5]) ou (n[1] = n[6]) ou (n[2] = n[1]) ou (n[2] = n[3]) ou (n[2] = n[4]) ou (n[2] = n[5]) ou (n[2] = n[6]) ou (n[3] = n[1]) ou (n[3] = n[2]) ou (n[3] = n[4]) ou (n[3] = n[5]) ou (n[3] = n[6]) ou (n[4] = n[1]) ou (n[4] = n[2]) ou (n[4] = n[3]) ou (n[4] = n[5]) ou (n[4] = n[6]) ou (n[5] = n[1]) ou (n[5] = n[2]) ou (n[5] = n[3]) ou (n[5] = n[4]) ou (n[5] = n[6]) ou (n[6] = n[1]) ou (n[6] = n[2]) ou (n[6] = n[3]) ou (n[6] = n[4]) ou (n[6] = n[5]) faca n[1] := randi(60) n[2] := randi(60) n[3] := randi(60) n[4] := randi(60) n[5] := randi(60) n[6] := randi(60) fimenquanto escreval(x, ".", n[1], " - ", n[2], " - ", n[3], " - ", n[4], " - ",n[5], " - ", n[6]) escreval("") fimpara fimalgoritmo O QUE JÁ CONSEGUI FAZER: - Impedir que o número gerado seja 0. - Impedir que os números no mesmo vetor se repitam. O QUE GOSTARIA DE FAZER: - Escrever o vetor gerado em ordem crescente. - Caso possível: Impedir que sejam gerados vetores iguais. Exemplificando: - Vetor Gerado: n[1] = 34 n[2] = 23 n[3] = 2 n[4] = 54 n[5] = 53 n[6] = 25 Saída: 1. 34 - 23 - 2 - 54 - 53 - 25 Como gostaria: 1. 2 - 23 - 25 - 34 - 53 - 54 E caso possível fazer com que os vetores gerados não se repitam. Se puderem ajudar agradeço.
  9. Este é o desafio. Meu problema é com o comando Repita do Visualg, pois quando tento executar o código aparece as seguintes notificações: o código segue abaixo algoritmo "QUADRADO MÁGICO" // Função :criador de quadrado mágico de ordem 7 // Autor : Ayron Gabryew Dias da Costa Matos // Data : 10/07/2018 // Seção de Declarações procedimento MOSTRARPAINEL() inicio EscrevaL(" =============================") EscrevaL("| CRIADOR DE QUADRADO MÁGICO |") EscrevaL("| [ 1 ] inverta a matriz |") EscrevaL("| [ 2 ] rotac. a matriz |") EscrevaL("| [ 3 ] sair |") EscrevaL(" =============================") fimprocedimento procedimento INVERSOR() inicio LimpaTela Para i := 1 ate 4 faca Para j := 1 ate 7 faca c <-8-i Se (i=j) então aux <- m[i,j] m[i,j] <- m[c,c] m[c,c] <- aux FimSe Se (j=c) então aux <- m[i,j] m[i,j] <- m[j,i] m[j,i] <- aux FimSe FimPara FimPara Para i := 1 ate 7 faca Para j := 1 ate 7 faca Escreva(m[i,j]:4) FimPara EscrevaL() FimPara fimprocedimento procedimento ROTACIONADOR() inicio LimpaTela Para j := 1 ate 6 faca c <- j+1 m[1,c] <- m[1,j] FimPara Para i := 7 ate 2 passo -1 faca c <- i-1 m[c,1] <- m[i,1] FimPara Para j:= 7 ate 2 passo -1 faca c <- j-1 m[7,c] <- m[7,j] FimPara Para i := 3 ate 6 faca c <- i+1 m[c,7] <- m[i,7] FimPara m[3,7] <- 14 Para i := 1 ate 7 faca Para j:= 1 ate 7 faca Escreva(m[i,j]:4) FimPara EscrevaL() FimPara fimprocedimento var m: vetor[1..7, 1..7] de inteiro i,j,c,aux,somador, opcao,resp: inteiro inicio Para i := 1 ate 7 faca Para j := 1 ate 7 faca somador <- somador + 1 m[i,j] <- somador FimPara FimPara LimpaTela Repita MOSTRARPAINEL() Escolha opcao CASO 1 INVERSOR() CASO 2 ROTACIONADOR() CASO 3 Escreva("Programa finalizado com sucesso!") Outrocaso Escreva("opcao inválida") ATE opcao=3 fimalgoritmo
  10. algoritmo "semnome" // Função : // Autor : // Data : 02/07/2018 // Seção de Declarações var polt: vetor [1..48] de real polts: vetor [1..48] de inteiro canc, menu, pol: inteiro i, j, m, cont, Tot, Totg: inteiro resp, respc: literal inicio Totg <- 870 para i de 1 ate 48 faca polt[i] <- i fimpara menu <- 0 enquanto menu <> 5 faca limpatela escreval() escreval(" ******* Bem vindo a Lios Ayrline ******* ") escreval(" **************************************** ") escreval() escreval(" ESCOLHA UMA OPÇÃO PARA INICIAR ") escreval("****[1] - Mostrar o mapa de poltronas*******") escreval("****[2] - Comprar passagens*****************") escreval("****[3] - Trocar passagens******************") escreval("****[4] - Cancelar passagem*****************") escreval("****[5] - Finalizar*************************") escreval(" **************************************** ") escreval() escreva ("DIGITE UMA OPÇÃO PARA CONTINUAR -> ") leia(menu) limpatela // MENU 1 -> MOSTRAR A TELA se menu = 1 então cont <- 1 // MOLDANDO A TELA DE MOSTRAR MAPAS DE POLTRONAS escreval("**** Opção: Mostrar o mapa de poltronas *******") escreval("**** -> Poltronas <- *******") para j de 1 ate 12 faca escreval ("**** ", polt[cont]:3, " ", polt[cont+1]:3, polt[cont+2]:3," ", polt[cont+3]:3," *******") cont <- cont+4 fimpara // MOLD TERMINADO E INICIANDO TELAS DE OBS E OPÇÕES escreval() escreval("**** -> OBS:Com numeros estão vazias <-*******") escreval("**** -> OBS:Com zero estão vendidas <-*******") //TELA DE OPÇÕES escreval() escreval("Para escolher a sua poltrona aperte [2] ") escreval("Para voltar ao menu inicial aperte [6] ") escreva("Digite a sua opção - > ") leia(menu) // MENU 2 LIMPA A PLANILHA E ENTRA NA OPÇÃO 2 LOGO ABAIXO se menu = 2 então fimse fimse Limpatela Escreval ( ) // MENU 2 -> COMPRAR PASSAGEM// se menu = 2 então cont <- 1 escreval("**** Opção: Comprar passagem *******") escreval("**** -> Poltronas <- *******") para j de 1 ate 12 faca escreval ("**** ", polt[cont]:3, " ", polt[cont+1]:3, polt[cont+2]:3," ", polt[cont+3]:3," *******") cont <- cont+4 fimpara // DEPOIS DE APRESENTADO O MAPA DE POLTRONAS, TA NA HORA DE ESCOLHER A DESEJADA // escreval( ) escreva ("Qual poltrona você deseja escolher -> ") leia (i) // CASO A POLTRONA ESTEJA DIFERENTE DE 0 (OCUPADA), APARECE A MENSAGEM E A CONFIRMAÇÃO DE RESERVA se polt[i] <> 0 então escreval (" -> Poltrona livre. Deseja Adquirir? " ) escreval() escreval( "Para Sim -> aperte [s] | Para Não -> aperte [n]") escreva( "Digite a opção desejada -> ") leia(resp) se resp = "s" então polt[i] <- 0 polts[i] <- i escreval ("Poltrona", i , " selocionada com sucesso") escreval ("--------------------------------------") // APRESENTA NOVAMENTE O MENU PERGUNTANDO SE DESEJA FINALIZAR TUDO OU SO DESEJA RETORNAR AO MENU PRINCIPAL escreval ("Para finalizar a sua compra digite [5}") escreval ("Para ir ao menu principal e realizar qualquer outra operação aperte [6]") escreval ( ) escreva ("Digite sua opção -> ") leia(menu) fimse // SE A POLTRONA TIVER O '0'(OCUPADA), APARECE A MENSAFEM E DA A OPÇÃO DE VOLTAR PRO MENU PRA REFAZERA A OPERAÇÃO) senao se polt[i] = 0 então escreval ("Desculpe! A poltrona ja esta ocupada. Volte ao menu apertando a tela [6]") leia (menu) fimse fimse fimse // MENU 3 -> TROCANDO PASSAGEM se menu = 3 então cont <- 1 escreval("**** Opção: Trocar passagem *******") escreval("**** -> Poltronas <- *******") para j de 1 ate 12 faca escreval ("**** ", polt[cont]:3, " ", polt[cont+1]:3, polt[cont+2]:3," ", polt[cont+3]:3," *******") cont <- cont+4 fimpara //se polt[i] <> 0 então escreval(" Qual a poltrona que você deseja trocar? ") escreva (" Digite o número da sua poltrona -> ") leia(i) polt[i] <- i polts[i] <- 0 escreval() escreval (" POLTRONAS COM O NÚMERO 0 JÁ ESTÃO OCUPADAS") escreva (" Qual poltrona você deseja? -> ") leia(i) se polt[i] = 0 então escreval ("***** Desculpe! Poltrona já ocupada *****") timer(4000) timer(0) limpatela() senao se polt[i] <> 0 então polt[i] <- 0 polts[i] <- i fimse escreval() escreval(" ***** Troca realizada com sucesso! ***** ") escreval() escreval() timer(1500) timer(0) limpatela() escreval("Para fazer uma nova compra ou retornar ao menu principal digite [6]") escreval("Para finalizar a sua compra digite [5]") escreva ("Digite a opção desejada -> ") leia (menu) escreval fimse fimse //MENU 4 -> cancelar passagem se menu = 4 então cont <- 1 escreval("**** Opção: Cancelar passagem *******") escreval("**** -> Poltronas <- *******") para j de 1 ate 12 faca escreval ("**** ", polt[cont]:3, " ", polt[cont+1]:3, polt[cont+2]:3," ", polt[cont+3]:3," *******") cont <- cont+4 fimpara escreval() escreval ("Qual a poltrona que você deseja cancelar? ") escreva ("Digite o numéro da poltrona -> ") leia(i) se (i <> 0) então polt[i] <- i polts [i] <- 0 escreval ("Passagem cancelada com sucesso!") escreva (" Retorne ao menu principal digitando [6] -> ") leia (menu) fimse fimse //menu 5 vai finalizar e contar quanto foi gasto se menu = 5 então escreval() escreval ("Deseja finalizar sua compra?") escreval ("Para Sim -> aperte [s] | Para Não -> aperte [n]") escreva ("Digite a sua opção -> ") leia(respc) se (respc = "s") então escreva() para i de 1 ate 48 faca se (polts[i] <> 0 ) então Tot <- Tot + 1 timer(1000) timer(0) limpatela() fimse fimpara senao se (respc= "n") então menu <- 6 timer(1500) timer(0) limpatela() fimse fimse fimse fimenquanto // dando o total pago) escreval("---") escreval("Total de passagem: ", Tot) escreval("Valor total das passagens foi:" , " R$ ", Tot * Totg:4:2) escreval("----") escreval("Desejamos a você uma otima viagem!") Eu preciso que nesse código, ao reservar uma cadeira o mapa apareça "--" invés de 0. E preciso que ao trocar essa cadeira por outra, volte a numeração da cadeira na ordem correta e o "--" vá para a outra. O que acontece agora é que aparece um zero quando reservo, "0", e quando troco o zero realmente vai pra outra poltrona, mas a que estava antes não fia na numeração correta. Na que estava antes fica o número 1
  11. 5- Escrever um algoritmo que lê o nome de um funcionário, o número de horas trabalhadas, o valor que recebe por hora e o número de filhos. Com estas informações, calcular o salário deste funcionário, sabendo que para cada filho, o funcionário recebe 3% a mais, calculado sobre o salário bruto. algoritmo "Exercício 5" // Função : Calcular o salário de um funcionário que recebe 3% a mais por filho calculado sobre o salário bruto. // Autor : // Data : 08/07/2018 // Seção de Declarações var nome :caractere horas, filhos :inteiro valor, salario_bruto, salario :real inicio escreva("Digite seu nome: ") leia(nome) escreval("") escreva("Digite o número de horas trabalhadas: ") leia(horas) escreval("") escreva("Digite o valor que recebe por hora: ") leia(valor) escreval("") escreva("Digite quantos filhos você tem: ") leia(filhos) escreval("") salario_bruto <- (valor * horas) salario <- ((3 * filhos / 100) + salario_bruto) escreva("Sálario do ", nome, ": R$", salario) fimalgoritmo 6- Escrever um algoritmo que lê o nome de um vendedor, o seu salário fixo, o total de vendas por ele efetuadas e o percentual que ganha sobre o total de vendas. Calcular o salário total do vendedor. Escrever o número do vendedor e seu salário total. algoritmo "Exercício 6" // Função : Calcular o salário de um vendedor. // Autor : // Data : 08/07/2018 // Seção de Declarações var nome :caractere total_vendas :inteiro salario_fixo, percentual, salario :real inicio escreva("Digite seu nome: ") leia(nome) escreval("") escreva("Digite seu salário fixo: ") leia(salario_fixo) escreval("") escreva("Digite o total de vendas efetuadas: ") leia(total_vendas) escreval("") escreva("Digite o percentual sobre o total de vendas: ") leia(percentual) escreval("") salario <- ((percentual * total_vendas / 100) + salario_fixo) escreval("Salário do vendedor ", nome, ": R$", salario) fimalgoritmo Desde já agradeço.
  12. Bom dia, estou com uma dificuldade em um algoritmo para um jogo da forca em VisuALG, o algoritmo foi solicitado para um trabalho e um dos requisitos é que ele tenha uma função, como vocês podem ver foi colocado uma função, porém a professora disse que aquela função não retorna nenhum valor, e por isso ela se encaixa como procedimento, pesquisei, tentei e não conseguir encaixar uma função nesse algoritmo, queria acrescentar também a cada final de rodada a opção de jogar ou não novamente. desde já agradeço a ajuda. Abaixo segue o Algorítimo - obs o VisuALG utilizado foi o 2.0 algoritmo "Jogo da forca" var op,frutas,ne,na:inteiro //op: opção, ne: numero erro, na:numero de acertos l1,l2,l3,l4,l5,l6,l7,ld1,ld2,ld3,ld4,ld5,ld6,ld7,dig,verifica:caracter //linhas(l1,l2,l3...) serão usadas para o aleatorio, já as ld (ld1, ld2, ld3) serão usadas para verificar o acerto V,D:Caracter funcao Derrota () :caracter inicio Escreval("============================================================") escreval("============================================================") escreval escreval(" --------- FIM DE JOGO! ------- ") ESCREVAL ESCREVAL(" --------- GAME OVER =( ------- ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao funcao vitoria () : caracter inicio limpatela Escreval("============================================================") escreval("============================================================") escreval escreval(" PARABÊNS voce VENCEU! ") ESCREVAL Escreval("============================================================") escreval("============================================================") fimfuncao inicio aleatorio on // ativa o modo aleatorio fonte, palavra on é opcional aleatorio 1,7 // seleciona o ranger do aleatorio, é preciso definir para o comando ter as opção para escolha leia (frutas) // todo leia vai ser lançado um numero aleatorio nesse caso de 1 a 3 aleatorio off // desativa o modo aleatorio, assim ele escolher uma das opções das palavras. limpatela // limpa tela repita // (repita 1) repitir o comando ate achar o comando interrompa escreval("---SEJA BEM VINDO---") escreval escreval(" ---JOGO DA FORCA--- ") escreval("Autores: Charles Ramos, Pedro Duca, Richard Vepo") escreval escreval escreval("Digite 1 para jogar e 0 para sair") leia(op) escolha op // verificar qual opção foi selecionada caso 0 //sair escreva("você escolheu a opção 0 para sair") escreval escreval fimalgoritmo // encerrar o algoritmo caso 1 interrompa // para o loop de escolher opção outrocaso // caso digite algo diferente de 0 ou 1 ele vai limpar a tela limpatela // limpa a tela, e vai voltar para o loop de opção. fimescolha fimrepita// fim repita 1 escolha frutas // palava que vai ser escolhida automaticamente pelo aleatorio no inicio do código em aleatorio on caso 1 l1 <- "d" l2 <- "a" l3 <- "m" l4 <- "a" l5 <- "s" l6 <- "c" l7 <- "o" caso 2 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "x" l7 <- "i" caso 3 l1 <- "a" l2 <- "b" l3 <- "a" l4 <- "c" l5 <- "a" l6 <- "t" l7 <- "e" caso 4 l1 <- "a" l2 <- "c" l3 <- "e" l4 <- "r" l5 <- "o" l6 <- "l" l7 <- "a" caso 5 l1 <- "l" l2 <- "a" l3 <- "r" l4 <- "a" l5 <- "n" l6 <- "j" l7 <- "a" caso 6 l1 <- "p" l2 <- "e" l3 <- "s" l4 <- "s" l5 <- "e" l6 <- "g" l7 <- "o" caso 7 l1 <- "g" l2 <- "u" l3 <- "a" l4 <- "r" l5 <- "a" l6 <- "n" l7 <- "a" fimescolha ld1 <- "_" // LINHAS USADAS PARA ESCREVER ld2 <- "_" ld3 <- "_" ld4 <- "_" ld5 <- "_" ld6 <- "_" ld7 <- "_" // inicio do jogo repita //repita2 se (ne > 7) então // Se número de erros for maior que 6 que é o tamanho das palavras logo, jogador perde, ou seja, jogador possui 6 chances apenas. D<- Derrota FIMALGORITMO fimse se (ld1 <> "_") e (ld2 <> "_") e (ld3 <> "_") e (ld4 <> "_") e (ld5 <> "_") e (ld6 <> "_") e (ld7 <> "_") então // Se as linhas forem diferentes de _ significa que existe letra no local, V<- Vitoria FIMALGORITMO fimse limpatela Escreval("============================================================") escreval("============================================================") escreval("") escreval(" /-----|") escreval(" / |") se (ne > 0 ) então escreval(" / (x.x)") senao escreval(" /") fimse se (ne > 1 ) então escreval(" | __||__ ") senao escreval(" | ") fimse se (ne > 2 ) então escreval(" | /| |\\") senao escreval(" | ") fimse se (ne > 3) então escreval(" | / |_____| \\") senao escreval(" | ") fimse se (ne > 4) então escreval(" | || ||") senao escreval(" | ") fimse se (ne > 5) então escreval(" | _|| _||") senao escreval(" | ") fimse se (ne > 6) então escreval(" | |__||__|") escreval("===== ULTIMA CHANCE! ") senao escreval(" | ") escreval("===== ") fimse escreval("") escreval("Acertos: ",na) escreval("Erros: ",ne) escreval("") escreva("Palavra com 7 letras: ",ld1," ",ld2," ",ld3," ",ld4," ",ld5," ",ld6," ",ld7) Escreval("") escreval("Dica da palavra: FRUTA ") escreval escreva("digite uma letra: ") leia(dig) verifica <- "0" se (l1 = dig) e (ld1 = "_") então ld1 <- dig na <- na + 1 verifica <- "1" fimse se (l2 = dig) e (ld2 = "_") então ld2 <- dig na <- na + 1 verifica <- "1" fimse se (l3 = dig) e (ld3 = "_") então ld3 <- dig na <- na + 1 verifica <- "1" fimse se (l4 = dig) e (ld4 = "_") então ld4 <- dig na <- na + 1 verifica <- "1" fimse se (l5 = dig) e (ld5 = "_") então ld5 <- dig na <- na + 1 verifica <- "1" fimse se (l6 = dig) e (ld6 = "_") então ld6 <- dig na <- na + 1 verifica <- "1" fimse se (l7 = dig) e (ld7 = "_") então ld7 <- dig na <- na + 1 verifica <- "1" fimse se (verifica = "0") então ne <- ne + 1 fimse escreval("==============================================================") escreval("==============================================================") fimrepita fimalgoritmo
  13. Galera, to precisando de uma ajuda em um exercício de Visualg. Seguem o anunciado e o código que eu fiz. Obrigado. Crie um vetor de 4 posições e o "alimente" com dados numéricos. Depois utilize o comando "para" para verificar os dados do vetor e mostrar, no fim, o maior e o menor número armazenado nele. var i,maior,menor:inteiro numero:vetor[1..5] de inteiro inicio para i de 1 ate 5 faca escreva("Digite o numero: ") leia(numero) fimpara se numero >= 1 então maior <- numero numero <= 1 então menor <- numero fimse se numero > maior então maior <- numero fimse se numero < menor então menor <- numero fimse escreval() escreva("O maior numero é ",maior," e o menor é",menor) fimalgoritmo
  14. Galera, estou precisando de uma ajuda com o código que estou desenvolvendo # Preciso que o código abaixo que quando alguém digite um número diferente de 16, que ele escreva a seguinte resposta: Não temos esta poltrona. E preciso que logo depois que escreva isso: escolha uma opção valida. E reapresente o mapa com as opções. # Preciso de um menu que faça a troca de passagens também. Observação: ele tem que trocar a passagem escolhida por uma não escolhida da preferência do cliente # Preciso que em cada opção ele repita o mapa, sem as opções. var polt : vetor [1..16] de real menu : inteiro i, j, cont : inteiro inicio para i de 1 ate 16 faca polt <- i fimpara menu <- 0 enquanto menu <> 3 faca escreval ("Escolha:") escreval (" 1 - Mapa de Poltronas") escreval (" 2 - Venda de Passagens") escreval (" 3 - Sair") leia (menu) limpatela se menu = 1 então cont <- 1 para j de 1 ate 4 faca escreval (polt[cont]:3, " ", polt[cont+1]:3, " ", polt[cont+2]:3, " ", polt[cont+3]:3) cont <- cont+4 fimpara senao se menu = 2 então escreva ("Qual a poltrona? ") leia (i) se polt = 0 então escreval ("Desculpe. Poltrona indisponivel. Verifique as disponiveis abaixo:") cont <- 1 para j de 1 ate 4 faca escreval (polt[cont]:3, " ", polt[cont+1]:3, " ", polt[cont+2]:3, " ", polt[cont+3]:3) cont <- cont+4 fimpara senao polt <- 0 escreval ("Poltrona ", i, " vendida") fimse senao escreval ("Escolha uma opcao valida!!! ") fimse fimse fimenquanto fimalgoritmo
  15. Galera, preciso que me ajudem a desenvolver um código que ja testei o dia todo. O código seria em matriz, no visualg. Preciso de uma matriz com 15 números. Seria 5x3 Precisa conter os números de 1 a 15 Preciso que sejam inseridos os comandos: 1 -> Mostrar assentos 2 -> Comprar assento (tem que aparecer um menu pedindo pra ele confirmar compra, quando confirmar, o assento em questão deve aparecer isto ----) A pessoa não pode comprar o mesmo assento e ao tentar, deve aparecer: ERRO! A poltrona já foi reservada 3-> Trocar assento (Quando ela trocar, deve desaparecer o --- da poltrona antiga e aparecer o --- na poltrona nova. Não podendo trocar por uma poltrona ja ocupada) 4-> Cancelar assento (Ao cancelar o assento, deve sair o --- das poltronas) 5 -> Sair (A pessoa so pode sair quando digitar 5 ou quando se criar um menu perguntando: Algo mais? Se a resposta for não, saia. Preciso que no final desse algoritmo ele me de o valor de assentos que a pessoa comprou. Cada passagem custa R$875,00
  16. Boa noite, galera. Preciso fazer um algoritmo que retorne o menor elemento de uma matriz, mas não sei como comparar o último elemento da linha de cima com o primeiro elemento da linha de baixo.
  17. Uma loja deseja fazer a avaliação com base na opinião de seus clientes. Para isto, ela irá disponibilizar um computador que irá perguntar a cada cliente a sua idade e a nota que ele avalia a loja. Você deverá elaborar o programa de computador que fará a leitura da opinião dos 100 primeiros clientes e deverá informar os dados solicitados abaixo: NOTAS INFORMAÇÕES A. Ótimo B. Bom C. Regular D. Ruim E. Péssimo 1. A quantidade de respostas que respondeu A (Ótimo); 2. A média de idade das pessoas que responderam D (Ruim); 3. A percentagem de respostas E (Péssimo) e a menor idade de quem informou esta resposta; 4. A maior idade de quem respondeu A (Ótimo) e a maior idade de quem respondeu D (Ruim);
  18. Preciso de uma força com esses exercícios não consegui compreender bem a matéria
  19. Sei que é um código simples mas sou iniciante e não to conseguindo fazer só conseguir chegar fazendo multiplicação mas a questão diz que não pode, apenas com adição e subtração não consegui chegar ao resultado Construa um código que leia 2 valores (n1 e n2). Em seguida imprima o resultado da divisão inteira de n1 por n2, bem como o resto dessa divisão. Detalhe: Não é permitido utilizar os operadores “div”, “/”, “mod”, “\” ou “%, *”. n1, n2, c, i, r, resto, multi, aux:inteiro inicio escreva("Digite o dividendo: ") leia(n1) escreva("Digite o divisor: ") leia(n2) aux <- n1 para i de 1 ate n1 faca se (n1 >= n2) então n1 <- n1-n2 r <- n2 c <- c+1 fimse fimpara multi <- c*n2 resto <- aux-multi escreval("Resultado:", c) escreva("Resto:", resto)
  20. Me ajuda ai galera pf Preciso de um algoritmo que a partir de uma palavra digitada pelo usuario ele imprima a quantidade de vogais e a quantidade de letras consoantes, Utilizando as funções copia e compr 2- Um algoritmo que solicite uma mensagem ao usuario em seguida calcule e imprima a quantidade de letras a, e, i,o, e u da mensagem
  21. Var nome, digito, erro: caracter ind: inteiro Funcao testaNome(nome: caracter):caracter var nom, sobrenom, msg: caracter x, controle, comprnom, comprsobrenom: inteiro Inicio controle := 1 para x de 1 ate compr(nome) faca se (copia(nome,x,1) = " ") então controle := 2 fimse se (controle = 1) e (copia(nome,x,1) <> " ") então nom := nom + copia(nome,x,1) fimse se (controle = 2) e (copia(nome,x,1) <> " ") então sobrenom := sobrenom + copia(nome,x,1) fimse fimpara comprsobrenom := compr(sobrenom) comprnom := compr(nom) se (comprnom > comprsobrenom) então msg := "Nome maior que sobrenome" senao se (comprsobrenom > comprnom) então msg := "Sobrenome maior que nome" senao msg := "Nome e sobrenome de mesmo tamanho" fimse fimse fimse retorne msg Fimfuncao Inicio Escreva ("Digite o nome: ") Leia(nome) erro := "n" para ind de 1 ate compr(nome) passo 1 faca digito := copia(nome,ind,1) se nao((digito >= "a") e (digito <= "z") ou (digito = " ")) então erro := "s" interrompa fimse fimpara se (erro = "s") então Escreval ("O e-mail só pode conter número ou espaço.") fimse se (erro = "n") então para ind de 1 ate compr(nome) passo 1 faca se (copia(nome,ind,1) = " ") e (copia(nome,ind+1,1) = " ") então erro := "s" interrompa fimse fimpara se (erro = "s") então Escreval ("Só deve haver um espaço entre nome e sobrenome.") fimse fimse se (erro = "n") então escreva (testaNome(nome)) fimse Fimalgoritmo
  22. exercício: Elaborar programa que lê uma disciplina e respectiva nota (de 0 a 10, com uma casa decimal), e informa se o aluno passou na disciplina, repetindo o ciclo até que a nota lida seja zero. O aluno passa quando tira 7 ou mais. código: Algoritmo "q5" Var // Seção de Declarações das variáveis opcao,quant,abaixo5:inteiro nota,soma,media:real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita escreval("1-Digitar Nota") escreval("2-Resultados") leia(opcao) limpatela escolha(opcao) caso 1 ((quant) <- ((quant) + 1)) escreval("Digite sua nota") leia(nota) limpatela (soma <- (soma+nota)) se (nota < 5) então (abaixo5 <- (abaixo5+1)) fimse se(nota > 10) ou (nota < 0) então escreval("ERRO") caso 2 ((media) <- (soma/quant)) escreval("Media: ", media) escreval("Quantidade de notas: ", quant) escreval("Notas abaixo de 5: ", abaixo5) outrocaso escreval("ERRO") fimalgoritmo fimescolha ate (nota>10) Fimalgoritmo por algum motivo tá dando erro e já tentei ajustar de várias formas, ainda estou aprendendo, podem me ajudar?? adicionado 32 minutos depois já consegui não encontrei como apagar o tópico (não sei se dá)
  23. Criar um algoritmo que calcula o maior e o menor número digitado pelo usuário, parar se o número digitado for zero (0) usar a função repita-ate. Anexei a imagem do código que fiz mas não está 100% vcs poderiam me ajudar a fazê-lo funcionar corretamente.
  24. Boa noite pessoa, dentro do meu codigo eu tenho uma matriz. Do jogo da velha. do vetor tab eu tenho numeros de 1 ate 9 e do vetor rep tambem de 1 ate 9 , mas somente o tab recebe o X ou O. então eu quero colocar uma condição, que o usuario leia a jogada. Verifique o numero que ele leu na matriz rep e veja se a matriz tab na mesma posição tem X ou O. Ate ai eu fiz. Mas que quero que a cada novo leia, ele veja a matriz inteira novamente. O que ele esta fazendo: coloquei X e O na primeira e segunda posição da matriz TAB. quando digito novamente 1 ele da como ocupada, quando digito 2 ele tambem da como ocupada. Mas quando digito novamente 1 ele n zera a matriz e continua a contagem normalmente ate o final: para m de 1 ate 3 faca para n de 1 ate 3 faca // aqui nesse primeiro eu encontro onde é a jogada se numpcarac(jogada1) = rep[m,n] então //aqui faz a comparação das duas matrizes se tab[m,n] <> rep[m,n] então repita escreval(" posição ja preenchida!") escreva(jogador1," escolha a sua jogada novamente:") leia (jogada1) ate (rep[m,n] <> numpcarac(jogada1)) m<-1 n<-1 fimse fimse fimpara fimpara O que posso fazer para ele zerar a contagem, e verificar desde o começo esse codigo novamente sempre a cada leia? adicionado 32 minutos depois Conseguiiiiiiiiiiiiiiiiiiiii!! Afff 1:30 tentando. Coloquei um repita logico e a matriz dentro, se FALSO repita, se VERDADEIRO não repita. Alguem sabe se tem outro jeito(deve ter) de resolver? só por curiosidade
  25. Meu professor de programação me mandou fazer um algoritmo no VisualG, porém estou com dificuldade quando os valores empatam, se alguem puder me ajudar, eu agradeço. Segue o Algoritmo com comentários para facilitar Código:

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×