Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição de áudio e vídeo
    • Programas
  • Sistemas Operacionais
    • Recomendação de sistemas operacionais
    • Windows
    • GNU/Linux, BSD, Unix-like e software livre
  • Eletrônicos
    • Equipamentos de som, home theaters e gravadores de mesa
    • Televisores e projetores
    • Câmeras e filmadoras
    • Players portáteis
    • Consoles (videogames)
    • GPS
    • Telefonia fixa
    • Eletrônica
    • Retrocomputação
  • Outros
    • Recomendações de serviços e lojas
    • Preços e promoções
    • Notícias
    • Bolsa de empregos, certificações e mercado de trabalho
    • "Causos"
    • Encontros de usuários
    • Feira do Rolo
  • Clube do Hardware
    • Comentários, elogios, críticas, sugestões e questões sobre o Clube do Hardware
    • Comentários de artigos
    • Fórum para testes de funcionalidades

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Caixas de som

Encontrado 260 registros

  1. Boa tarde, estou querendo converter todo esse código escrito em Visualg para o C++. Alguém experiente poderia me ajudar? quero deixar da forma que está . Meu motivo para migrar para o C++ é para apenas estudos e também para aprendizado da linguagem, porém acho que só da para fazer no C++. Eu quero salvar toda operação quando o programa terminar a execução em modo texto, depois que salvar os números gerado em modo texto ter uma opção para abrir novamente o arquivo txt e ter a opção de fazer o analise de acertos novamente e salvar em txt de novo. Não sei como fazer isso nem ideia salvar texto, abrir texto, fazer analise dos acertos. Código:
  2. Estou precisando de ajuda de como resolver isso: (a) (1.25 ponto) Quantos pontos o time conseguiu no campeonato, sabendo que uma vitória vale três pontos e um empate um ponto. Uma derrota não conta nenhum ponto. (b) (1.25 ponto) O saldo de gols do time. Isto é calcule a diferença entre os gols feitos e os gols sofridos. (c) (1.25 ponto) Em quantos jogos o time não fez nenhum gol. (d) (1.25 ponto) A média de gols que o time fez por jogo. Os resultados dos jogos devem ser fornecidos no formato indicado abaixo. O primeiro valor inteiro é número de gols que o time fez e o segundo quantos ele sofreu. Jogo 1? 3 1 Jogo 2? 1 3 Jogo 3? 2 2 Jogo 4? 1 1 Jogo 5? 0 2 Jogo 6? 2 1 Jogo 7? 0 0 Jogo 8? 2 0 Jogo 9? 2 0 Jogo 10? 1 0 Jogo 11? 0 3 Jogo 12? 3 0 Para os dados mostrados no exemplo acima os resultados impressos pelo algoritmo devem ser. Pontos: 21 Saldo de gols: 4 Jogos sem fazer gols: 3 Media de gols por jogo: 1.417 Var pontos: inteiro golfeito: inteiro golsofrido: inteiro empate: inteiro saldogols: inteiro mediagol: real i: inteiro vitoria, impate: inteiro Inicio vitoria <- 3 impate <- 1 pontos <- 0 golfeito <- 0 golsofrido <- 0 mediagol <- 0 para i <- 1 até 12 faça se golfeito > golsofrido = vitoria senao impate escreva("Jogo 1: ") leia (golfeito) leia (golsofrido) pontos <- vitoria fimse fimpara escreva("Jogo 2: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 3: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 4: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 5: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 6: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 7: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 8: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 9: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 10: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 11: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreva("Jogo 12: ") leia (golfeito) leia (golsofrido) pontos <- pontos + golfeito escreval("mediagol: ", golfeito*12/2) escreval("pontos : ", vitoria+impate) escreval("Saldo : ", pontos+golsofrido) Fimalgoritmo
  3. 1. Faça o somatório de todos os números inteiros ímpares compreendidos entre 5 e 30. No final do algoritmo, mostre o valor do somatório. (*****PORTUGUES ESTRUTURADO******)
  4. Como faço para calcular quantas vezes uma letra repetiu na matriz? Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : João dos ceus // Data atual : 03/09/2018 Var // Seção de Declarações das variáveis dados: vetor[1..5,1..5] de caracter i,j: inteiro letras: vetor[1..6] de caracter k: inteiro contador:inteiro opcao,opcao2:inteiro Inicio // Seção de Comandos, procedimento, funções, operadores, etc... repita Escreval("------ Menu principal ------") Escreval("Selecione uma das opções") Escreval("1. Inserir sopa de letras") Escreval("2. Sair") leia(opcao) escolha opcao caso 1 escreval("Introduza as letras para a sopa de letras:") para i de 1 ate 5 faca para j de 1 ate 5 faca leia (dados[i,j]) fimpara fimpara escreval ("") escreval("A sopa de letras é:") para i de 1 ate 5 faca para j de 1 ate 5 faca escreva (dados[i,j]) fimpara escreval ("") fimpara escreval ("") escreval(" As letras introduzidas são:") para i de 1 ate 6 faca leia (letras) fimpara para i de 1 ate 5 faca para j de 1 ate 5 faca para k de 1 ate 6 faca se letras[k]=dados[i,j] entao contador<-contador+1 escreval("") escreval ("-> Letra:") escreval (dados[i,j]) escreval ("->> Coordenada:") escreva (i,j) escreval("") escreval ("->>> Numero de vezes que a letra foi repetida:") escreva (contador=dados[k]) contador<-contador+1 fimse fimpara fimpara fimpara caso 2 fimalgoritmo fimescolha Fimalgoritmo
  5. Preciso de ajuda nos seguintes exercícios: 1- Escrever um algoritmo que leia 5 pares de valores A e B, todos inteiros e positivos, um par de cada vez e com a<b e escreva inteiros os pares de A até B, incluindo o A e o B se forem pares. 2- Escreva um programa que leia 5 conjuntos e dois valores, o primeiro representando o número de um aluno e o segundo representando a altura em cm. Encontre o aluno mais alto e o mais baixo. Mostre o número do aluno mais alto e o do mais baixo, junto com suas alturas. 3- Escreva um programa que mostre a média aritmética dos números entre 13 e 73
  6. Ola Pessoas, eu queria saber como quebrar linhas no visualg tipo: Linha1 <texto> Linha2<texto> Linha3<texto> Linha4<texto>
  7. Como eu faço para ver o maior e menor numero ? pois eu só consigo ver entre 2 Números. algoritmo "MaioreMenor" @devair1010 var N,Contador, S, Maior, Menor: inteiro inicio Contador <- 1 Maior <- N Menor <- N S <- N Enquanto (Contador <= 3) faca Escreva("Digite o ", Contador , "°. valor: ") Leia(N) Se (N > Maior) entao Maior <- N Senao Se (N > Menor)entao Menor <- N Fimse Fimse Contador <- Contador + 1 S <- S + N FimEnquanto Escreval("A soma de todos os valores foi: ", S) Escreval("O maior valor digitado foi: ", Maior) Escreval("O menor valor digitado foi: ", Menor) fimalgoritmo
  8. Pedro Algoritmo: Totobola O algoritmo utiliza uma matriz de 13x3 para registar os resultados da jornada de futebol, na configuração 1X2, em que 1 ganhou a equipa da casa, X empataram e 2 ganhou a equipa visitante. Desenvolva para uma casa de apostas a recolha das apostas de vários utilizadores e o cálculo dos resultados acertados. Sabendo que os prémios são atribuídos de acordo com a tabela seguinte, o algoritmo deve apresentar o número de premiados em 1º, 2º ou 3º lugar. 1º prémio 13 2º prémio 12 3º prémio 11
  9. Como eu faço para aparecer o Nome do meu 1° aluno quando eu colocar ele tanto como a melhor nota quanto a pior ? Se eu colocar na 2° ou na 3° nota como o pior ou o melhor o nome aparece mas no 1° não... algoritmo "Melhoraluno" var N, Contador: inteiro N1, maiorNota, menorNota: Real Aluno, MelhorAluno, piorAluno: caracter inicio Escreval("---------------") Escreval(" Maradona louco ") Escreval("---------------") Escreva("Quantos alunos tem a turma: ") Leia(N) Contador <- 1 Enquanto (Contador <= N) Faca Escreval("---------------") Escreval("Aluno ", Contador) Escreva("Nome do Aluno: ") Leia(Aluno) Escreva("Nota de ", Aluno, ": ") Leia(N1) se (contador = 1) entao maiorNota := N1 menorNota := N1 Senao Se (contador = 1) entao MelhorAluno:= Aluno piorAluno:= Aluno Fimse Se (N1 > maiorNota)entao maiorNota <- N1 MelhorAluno <- Aluno Senao Se (N1 < menorNota)entao menorNota <- N1 piorAluno <- Aluno Fimse Fimse Fimse Contador <- Contador + 1 FimEnquanto Escreval("--------------------") Escreval("O melhor aproveitamento foi de ", MelhorAluno, " com a nota de ", maiorNota:3:1) Escreva("O pior aproveitamento foi de ", piorAluno, " com a nota de ", menorNota:3:1) fimalgoritmo
  10. Pessoal sou aluno de Engenharia 1º semestre. Como é a primeira vez que topo com algoritmos, cheguei no seguinte: algoritmo "Pintura " var A,B,C,Paredes,Teto,Latas: Inteiro Inicio escreval ("Considerando que: A= comprimento, B= largura, C= altura, dado em metros") escreval ("Qual o comprimento?") Leia (A) escreval ("Qual a Largura?") Leia (B) escreval ("Qual a altura?") Leia (C) Paredes=:2*((A*C)+(B*C)) Teto=:(A*B) Latas=:(Paredes*Teto)/3 Escreva (" O número de latas que serão nescessarias é ",Latas) fimalgoritmo Porém está dando erro em Paredes=:2*((A*C)+(B*C)).
  11. Será que alguém pode me ajudar? Faça um programa que leia as medidas de uma sala retangular (largura da parede maior, largura da parede menor e altura da parede), calcule e escreva a soma das áreas das paredes internas e também do teto. Considerando a área calculada, calcule quantas latas de tintas serão necessárias para pintar a sala em questão, sabendo que uma lata de tinta é suficiente para pintar 3m2. Obs.: - Despreze a existência de portas e janelas. - Não se esqueça que a quantidade de latas de tinta deve ser um valor inteiro. A outros na lista anexadas, será que alguém consegue? (20170925162717)Lista02.pdf Outro exercício! (USAR ESCOLHA) Faça um programa que receba dois números, calcule e imprima o resultado das operações listadas a seguir, de acordo com a escolha do usuário: Escolha Operação 1 Média entre os números digitados 2 Diferença do maior pelo menor 4 Divisão do primeiro pelo segundo Se a opção digitada for inválida, mostre uma mensagem de erro e termine a execução. Lembre-se que, na operação 3, o segundo número deve ser diferente de zero. Outro exercício! Dados 3 valores L1, L2, L3, verifique se podem ser valores de lados de um triângulo (cada lado deve ser menor do que a soma dos outros dois) e, se for, determine a sua área. Caso não formem um triângulo, imprima uma mensagem informando isso. Para o cálculo da área do triângulo, considere as seguintes fórmulas: sp = (L1 + L2 + L3)/2. Área= √sp ∗ (sp−L1)∗(sp−L2)∗(sp−L3) Novamente outro O perfil de uma pessoa pode ser determinado a partir da sua data de nascimento, conforme exemplificado a seguir. Dada uma data de nascimento, informe em qual perfil a pessoa se encaixa. O ultimo exercício Faça um programa que leia 3 números e imprima-os de forma crescente (os valores devem também ser trocados nas variáveis).
  12. algoritmo "semnome" var N, Cont: inteiro inicio Cont <- 1 Repita Escreval(" ") Escreval("===================") Escreval("| Menu |") Escreval("===================") Escreval("| [1] De 1 a 10 | ") Escreval("| [2] De 10 a 1 | ") Escreval("| [3] Sair | ") Escreval("===================") Leia(N) Repita Se (N <= 1)entao Escreva(Cont, "..") Cont <- Cont + 1 Senao Se (N = 2)entao Escreva(Cont, "..") Cont <- Cont - 1 Senao Se (N = 3)entao Escreva("Saindo..") Fimse Fimse Fimse Ate(Cont = 10) Ate(N = 3) Como eu faço para o N°1 ( contar de 1 ate 10 e não ate 09) E como eu faço para o N° 2 ( contar de 10 ate 1 sem ficar no loop ) ?
  13. Como faço para a minha contagem começar com o numero que eu inserir tanto no Inicio quanto no Fim ? @devair1010 algoritmo "ContagemInteligente" var I, F: inteiro inicio I <- 0 F <- 0 Escreval("Contagem Inteligente") Escreval("--------------------") Escreva("Inicio: ") Leia(I) Escreva("Fim: ") Leia(F) Escreval("--------------------") Escreval(" Contando ") Escreval("--------------------") Se (I < F) entao Enquanto (I < F) faca I <- I + 1 Escreva (I) FimEnquanto SeNao Se (I > F) entao Enquanto (I > F) faca I <- I - 1 Escreva (I) FimEnquanto FimSe FimSe
  14. Boa noite pessoal! Fiz o algoritmo do seguinte exercício: 10. Construa um algoritmo para calcular a distância entre dois pontos do plano cartesiano. Cada ponto é um par ordenado (x,y). Parece ser fácil porém não tenho certeza se esta correto meu código, alguém pode dar uma olhada e dizer o que acha? Obrigado pela ajuda! algoritmo "semnome" //10.Construa um algoritmo para calcular a distância entre dois pontos do plano //cartesiano. Cada ponto é um par ordenado (x,y). var PtoAb, x1,x2,y1,y2:real inicio Escreval("============================================") Escreval(" COORDENADAS CARTESIANAS ") Escreval("============================================") Escreval("Digite as coordendas do ponto A") Escreval("============================================") Escreval("Digite x1") Leia(x1) Escreval("Digite x2") Leia(x2) Escreval("============================================") Escreval("Digite as coordendas do ponto B") Escreval("============================================") Escreval("Digite y1") Leia(y1) Escreval("Digite y2") Leia(y2) PtoAb <- raizQ((x1-x2)^2)+((y1-y2)^2) Escreval("===========================================") Escreval(" A distancia entre o ponto A e B é igual a: ",PtoAb) fimalgoritmo
  15. algoritmo "semnome" // Função : // Autor : // Data : 25/09/2018 // Seção de Declarações var matriz: vetor [1..2,1..2] de real //contadores x,y: inteiro inicio // Seção de Comandos //Contador das Linhas para x de 1 ate 2 faca //contador das colunas para y de 1 ate 2 faca escreva("Digite o valor da Linha ",x, " Coluna ", y,":") leia(matriz[x,y]) fimpara escreval ("xxxxxxxxxxxxxxxxxx") fimpara //Mostrar valores da matriz escreval ("valores da matriz") escreval ("| ", matriz[1,1]," ",matriz[1,2],"|") escreval ("| ", matriz[2,1]," ",matriz[2,2],"|") //calcula o valor da determinante determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1]) escreval("O valor da determinante é:",determinante) fimalgoritmo Está dando erro na hora de achar a determinante, mas não consegui identificar. determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])
  16. Preciso resolver esse exercício, mas estou com dúvida se estou fazendo da forma correta. algoritmo "tabuada para faca" // Função : // Autor : // Data : 25/09/2018 // Seção de Declarações var n,cont,prod:inteiro inicio // Seção de Comandos escreva("digite o valor de n") leia(n) escreval("tabuada de ",n) para cont de 2 ate 9 passo 1 faca prod<-cont*n escreval(n,"X",cont,"=",prod) cont<-cont+1 fimpara fimalgoritmo
  17. Crie um algoritmo que leia um vetor de 10 posições e exiba seu resultado em tela. Em seguida mostre a posição e exiba o menor e o maior elemento. Eu fiz até na parte onde exibe o menor e o maior número, porém não to conseguindo achar uma forma de achar a posição do menor e maior. Segue o código até agora feito e a foto de como deve ficar: var valores: vetor [1..10] de inteiro maior, menor, contador: inteiro inicio para contador de 1 ate 10 faca escreva("Informe o",contador,"º Elemento: ") leia (valores[contador]) menor <- valores[1] se (valores[contador]>maior) entao maior <- valores[contador] fimse se (valores[contador]<menor) entao menor <- valores[contador] fimse fimpara escreval("O menor elemento é:",menor," na posição: ?") escreval("O maior elemento é:",maior," na posicão: ?") fimalgoritmo
  18. Exercício: Desenvolva um algoritmo que peça ao usuário valores entre 100 e 200, caso o usuário digite um valor fora deste limite, o sistema deve fechar e exibir a mensagem ("valor fora do alcance"). var valor: inteiro inicio escreval ("digite um valor entre 100 e 200: ") leia(valor) enquanto valor < > 100 e 200 faca leia(valor) fimenquanto escreval("valor fora do alcance: " Estou tendo problema pra resolver a partir do comando Enquanto, que eu tento de várias formas chegar a solução, mas não encontro.
  19. Eu estou fazendo um curso gratis na internet e nao tenho ninguem para tirar minhas duvidas, por isso estou contando com você leitor para me ajudar a corrigir e chegar na resposta certa das questões que estou fazendo Questão: Elabore um programa que receba 5 números e imprima somente os positivos. Eu consegui fazer isso abaixo e pelo que parece, depois de eu apertar f9, surgiu algum resultado, mas nao sei se esta correto a forma que eu fiz. Por isso me diga se eu fiz certo ou nao var valor, x :inteiro inicio escreval ("digite um valor positivo") leia(valor) para x de 0 ate 5 faca escreva (valor + x) fimpara Eu gostaria de saber tambem como seria caso ao invés de ele falar, ''imprima somente os positivos'' ele falasse ''imprima os negativos". Eu teria que mudar somente o sinal (+) para (-)? Enfim, obrigado pela atenção e paciencia
  20. Boa noite pessoa, dentro do meu codigo eu tenho uma matriz. Do jogo da velha. do vetor tab eu tenho numeros de 1 ate 9 e do vetor rep tambem de 1 ate 9 , mas somente o tab recebe o X ou O. então eu quero colocar uma condição, que o usuario leia a jogada. Verifique o numero que ele leu na matriz rep e veja se a matriz tab na mesma posição tem X ou O. Ate ai eu fiz. Mas que quero que a cada novo leia, ele veja a matriz inteira novamente. O que ele esta fazendo: coloquei X e O na primeira e segunda posição da matriz TAB. quando digito novamente 1 ele da como ocupada, quando digito 2 ele tambem da como ocupada. Mas quando digito novamente 1 ele n zera a matriz e continua a contagem normalmente ate o final: para m de 1 ate 3 faca para n de 1 ate 3 faca // aqui nesse primeiro eu encontro onde é a jogada se numpcarac(jogada1) = rep[m,n] então //aqui faz a comparação das duas matrizes se tab[m,n] <> rep[m,n] então repita escreval(" posição ja preenchida!") escreva(jogador1," escolha a sua jogada novamente:") leia (jogada1) ate (rep[m,n] <> numpcarac(jogada1)) m<-1 n<-1 fimse fimse fimpara fimpara O que posso fazer para ele zerar a contagem, e verificar desde o começo esse codigo novamente sempre a cada leia? adicionado 32 minutos depois Conseguiiiiiiiiiiiiiiiiiiiii!! Afff 1:30 tentando. Coloquei um repita logico e a matriz dentro, se FALSO repita, se VERDADEIRO não repita. Alguem sabe se tem outro jeito(deve ter) de resolver? só por curiosidade
  21. por favor me ajudem! sou iniciante no visualg e consigo fazer isso: faça um programa usando uma estrutura de repetição onde será digitado os dados de uma turma de 10 alunos da escola, como nome, nota 1 e nota 2. No final mostre o nome, as notas e a media do melhor aluno. mostre tambem a media da turma. EU SO FIZ ISSO: algoritmo "semnome" var nome: vetor [1..10] de caracter n1,n2: vetor [1..10] de real i,t:inteiro media:vetor [1..10] de real maior: real inicio para i de 1 ate 10 faca escreva ("digite o nome", i, "° aluno:") leia (nome) escreva ("digite a nota1:") leia (n1) escreva ("digite a nota2:") leia (n2) escreval ("__________________________________") escreval ("__________________________________") fimpara para i de 1 ate 10 faca media <- (n1 + n2) /2 fimpara para i de 1 ate 10 faca se (media > maior) entao maior <- media t <- fimse fimpara escreval("melhor aluno: ",maior) fimalgoritmo
  22. 1- Criar um programa que imprima na tela os números de 0 a 10 em ordem crescente.
  23. Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs... O trabalho é este: Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo: Tabela IRPF Tabela INSS Salário até R$1500,00 será 0% de imposto; Salário até R$3000,00 será 15% de imposto; Salário acima de R$3000,00 será 27,5% de imposto. Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor) Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido. Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo: Salário Bruto Salário Líquido R$ 5000,00 R$ 3225,00 R$ 3500,00 R$ 2152,50 Retorno de resultado R$ 1800,00 R$ 1332,00 R$ 1400,00 R$ 1246,00 Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor): var salarioB, irpf, inss: real inicio //IRRF: //Até 1.500 | - //De 1.500 até 3.000 | 15,0 //Acima de 3.000 | 27,5 //INSS: //Fixo | 11,0 | Limite de desconto 400 escreva("Digite o salário:") leia (salarioB) se (salarioB<1500.00)ou(salarioB=1500.00) entao inss<- salarioB*11/100 escreval("Seu SalarioB Liquido é", salarioB - inss) senao se (salarioB>1500.01)e(salarioB<=3000.00) entao irpf<- salarioB*15/100 inss<- salarioB*11/100 escreval ("IRPF a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) senao se (salarioB>3000.00)ou(salarioB= 3000.00) entao irpf<- salarioB*27.5/100 inss<- salarioB*11/100 escreval ("IRPJ a ser descontado é", irpf) escreval ("INSS a ser descontado é", inss) escreval("O salário Líquido é", salarioB - irpf - inss) fimse fimse fimse fimalgoritmo
  24. Galera preciso fazer um algorítimo que receba dois números, e faça a divisão do maior número pelo menor, e diga se esse resultado é par ou ímpar, tentei de todas as formas e nao consigo fazer funcionar de jeito nenhum. O VisualG diz que minha variável "divisao" tem que ser do tipo real, mas quando mudo para real ele me diz que é pra ser inteiro. SOCORRO.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×