Ir ao conteúdo
  • Cadastre-se

Pesquisar na Comunidade

Mostrando resultados para as tags ''VisualG''.



Mais opções de pesquisa

  • Pesquisar por Tags

    Digite tags separadas por vírgulas
  • Pesquisar por Autor

Tipo de Conteúdo


Categorias

  • Armazenamento
  • Áudio
  • Energia
  • Entrada
  • Feiras e Eventos
  • Gabinetes
  • Memória
  • Museu
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Rádio CdH
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Armazenamento
  • Áudio
  • Câmeras
  • Computadores
  • Consoles
  • Eletrônicos
  • Energia
  • Entrada
  • Gabinetes
  • Impressão
  • Jogos
  • Memória
  • Placas-mãe
  • Portáteis
  • Processadores
  • Programas
  • Redes
  • Refrigeração
  • Smartphones
  • Tablets
  • Vídeo
  • Outros

Categorias

  • Livros disponíveis
  • Livros esgotados

Fóruns

  • Mensagens do Clube do Hardware
    • Regras gerais
    • Boletins do Clube do Hardware
    • Notícias da administração
  • Hardware
    • Recomendações de computadores
    • Placas de vídeo
    • Placas-mãe e chipsets
    • Processadores
    • Problemas de gargalo e desempenho
    • Memórias
    • Armazenamento
    • Refrigeração e superaquecimento
    • Fontes e energia
    • Gabinetes e casemods
    • Placas de som e áudio on-board
    • Periféricos
    • Mac
    • Overclock
    • Hardware - outros
  • Computação móvel
    • Notebooks
    • Tablets
    • Smartphones e apps
  • Redes e Internet
    • Redes e Internet
    • Hospedagem de sites e registro de domínios
  • Segurança da informação
    • Remoção de malware
    • Dúvidas sobre invasões e infecções
    • Programas de proteção
  • Programação e desenvolvimento
    • Java
    • C/C#/C++
    • Pascal/Delphi
    • .NET
    • Bancos de dados
    • Programação web
    • Programação - iniciantes
    • Programação de microcontroladores
    • Programação - outros
  • Software
    • Jogos
    • Pacotes de escritório
    • Computação distribuída (Folding@Home, Bitcoin etc.)
    • Virtualização
    • Design, animação e tratamento de imagens
    • Edição, autoração e gravação de áudio e vídeo
    • Programas
  • Sistemas Operacionais
  • Eletrônicos
  • Outros
  • Clube do Hardware

Categorias

  • Hardware
  • Redes
  • Eletrônica
  • Sistemas operacionais

Encontrar resultados em...

Encontrar resultados que...


Data de criação

  • Iniciar

    FIM


Última atualização

  • Iniciar

    FIM


Filtrar pelo número de...

Data de registro

  • Iniciar

    FIM


Grupo


Encontrado 408 registros

  1. algoritmo "Calculadora de Bhaskara" var a,b,c,x1,x2,delta :real inicio Escreval ("Calculadora de Bhaskara") Escreva("digite valor de a: ") Leia(a) Escreva("digite valor de b: ") Leia(b) Escreva("digite valor de c: ") Leia(c) delta <-b*b-4*a*c Escreval("Delta igual a ",delta) se delta > 0 entao senao escreva ("o valor de delta é negativo") fimalgoritmo fimse x1<-(-b+(raizQ(delta)))/(2*a) x2<-(-b-(raizQ(delta)))/(2*a) Escreval ("x1 igual a ",x1) Escreval ("x2 igual a ",x2) fimalgoritmo
  2. Exercicio 4 Faça uma subrotina que receba uma matriz M(10,10), o número de uma linha L, o numero de uma coluna C e retorne a matriz N(9,9), resultante da remoção da linha L e da coluna C. Boa tarde galerinha! Estava reforçando a minha lógica emm uma bateria de questoes e me deparei com esta...Estou com problemas de interpretação do enunciado, pois pelo que entendi ele pede pra fazer uma função com três parametros: um deles é uma matriz. Como nunca vi nada parecido peço a ajuda de vcs como montar esse código! Obrigado!
  3. pessoal instalei o Visual G e ele fica dando espaço automatico como tiro isso? fica espaços entre as letras
  4. algoritmo "Biblioteca" // Função : // Autor : // Data : 05/02/2020 // Seção de Declarações var titulo:vetor[0..2] de caractere autor:vetor[0..2] de caractere editora:vetor[0..2]de caractere isbn:vetor[0..2] de caractere sair:real login, senha, login1, senha1, respost, empres, reserva: caractere repet, repet1, opcao, ano, reserv: inteiro inicio // Seção de Comandos escreval("biblioteca:") escreval escreval("Login: usuario") escreval("Senha: senhausuario") escreval enquanto repet < 3 faca escreval("-----------------------") escreva("|Digite o login: ") leia(login) escreval("-----------------------") escreva("Digite a senha: ") leia(senha) escreval("-----------------------") escreval se (login = "usuario") e (senha = "senhausuario") entao repet <- 5 senao repet <- repet + 1 escreval("-------> Login ou senha incorretos <-------") escreval fimse fimenquanto se (repet = 5) entao limpatela repita escreva("Entre com o ID da opção: ") escreval("| ID | Opção |") escreval("|====|=========================|") escreval("| #1 | Cadastrar livro |") escreval("| #2 | Buscar livro |") escreval("| #3 | Emprestimo/devolução |") escreval("| #4 | Reserva |") escreval("| #5 | Exibir acervo |") escreval("| #6 | Cadastrar Leitor |") escreval("| #7 | Trocar usuarior |") escreval("| #8 | Sair |") escreval(" ¯¯¯¯ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯ ") leia(opcao) escreval escolha opcao para i de 0 ate 2 faca caso 1 se (titulo"") entao escreva("Digite o título do livro: ") leia (titulo) escreva("Digite o Autor: ") leia(autor) escreva("Digite o nome da Editora: ") leia(editorai) escreva("Digite o ano de lançamento: ") leia(ano) escreva("Digite o ISBN: ") leia(isbn) escreval limpatela caso 2 escreva("Digite o título completo do livro: ") leia(tit) se (tit = titulo) entao escreval("Título: ", titulo) escreval("Autor: ", autor) escreval("Editora: ", editora) escreval("Ano:", ano) escreval("ISBN: ", isbn) escreva senao escreva("Livro não encontrado") fimse escreval caso 3 escreva("Deseja realizar um empréstimo [E] ou devolução [D]? ") leia(respost) escreval se (respost = "E") entao escreva("Digite o título do livro: ") leia(respost) se (respost = titulo) entao empres <- titulo escreval("Você acaba de pegar empréstimo de um livro cujo nome é:", empres) escreval fimse senao escreva("Digite o título do livro: ") leia(respost) se (respost = titulo) entao escreval("Devolução efetuada com sucesso!") escreval fimse fimse caso 4 escreva("Digite o título do livro: ") leia(reserva) se (reserva = titulo) entao reserv <- 1 escreval("Reserva efetuada com sucesso!") escreval senao escreval("Livro não encontrado!") escreval fimse caso 5 limpatela escreval("Confira agora, o menu de opções!") escreval escreval("| ID | Opção |") escreval("|====|=========================|") escreval("| #1 | Cadastrar livro |") escreval("| #2 | Buscar livro |") escreval("| #3 | Emprestimo/devolução |") escreval("| #4 | Reserva |") escreval("| #5 | Exibir acervo |") escreval("| #6 | Cadastrar Leitor |") escreval("| #7 | Trocar usuarior |") escreval("| #8 | Sair |") escreval(" ¯¯¯¯ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯ ") se (reserv = 1) entao escreval("Título: ", titulo, " [Reservado]") escreval("Autor: ", autor) escreval("Editora: ", editora) escreval("Ano:", ano) escreval("ISBN: ", isbn) escreva senao escreval("Título: ", titulo) escreval("Autor: ", autor) escreval("Editora: ", editora) escreval("Ano:", ano) escreval("ISBN: ", isbn) escreva fimse caso 6 escreva("Digite o novo login: ") leia(login) escreva("Digite a nova senha: ") leia(senha) escreval caso 7 enquanto repet1 < 3 faca escreva("Digite o login: ") leia(login1) escreva("Digite a senha: ") leia(senha1) escreval se (login1 = login) e (senha1 = senha) entao repet1 <- 5 limpatela escreval("Novo login efetuado") escreval("Confira agora, o menu de opções!") escreval escreval("| ID | Opção |") escreval("|====|=========================|") escreval("| #1 | Cadastrar livro |") escreval("| #2 | Buscar livro |") escreval("| #3 | Emprestimo/devolução |") escreval("| #4 | Reserva |") escreval("| #5 | Exibir acervo |") escreval("| #6 | Cadastrar Leitor |") escreval("| #7 | Trocar usuarior |") escreval("| #8 | Sair |") escreval(" ¯¯¯¯ ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯ ") senao repet1 <- repet1 + 1 escreval("-------> Login ou senha incorretos <-------") escreval fimse fimenquanto fimescolha ate opcao = 8 escreval("Gerenciamento de Biblioteca Encerrado") fimse fimalgoritmo adicionado 7 minutos depois gente minha duvida é, quero armazenar os livros e exibir eles quando pedirem pra buscar ele
  5. Boa tarde, estou fazendo alguns exercícios para estudo e acabei me deparando com um que pede para criar um programa para gerenciar uma biblioteca, tentei fazer algo mais faz muito tempo que não utilizava o VisuAlg para estudo de algoritmos, quem puder dar alguma dica de ajuda: parei ficando no modo excluir. algoritmo "Biblioteca" // Função : // Autor : var //Criação das variaveis cpf,nome,exclusao,endereco,livro, autor, editora, ano: vetor [1..20] de caracter telefone:vetor [1..20] de inteiro x,y,z: inteiro opcao: inteiro //criacao do menu de opções procedimento MenuP var //não irei utilizar nenhuma var local neste procedimento. inicio Limpatela Escreval (" ******************") Escreval (" * MENU PRINCIPAL *") Escreval (" ******************") Escreval ("") escreval ("#1 - Cadastrar livro") escreval ("#2 - Buscar livro ") escreval ("#3 - Listar livro") escreval ("#4 - Excluir livro") escreval ("#5 - Emprestar livro") escreval ("#6 - Devolver livro") escreval ("#7 - Cadastrar Leitor") escreval ("#8 - Buscar leitor") escreval ("#9 - Excluir leitor") escreval ("#10 - Sair") Escreval ("") Escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao caso 1 cadastrolivro caso 2 buscarlivro caso 3 listarlivro caso 4 excluirlivro caso 5 emprestarlivro caso 6 devolverlivro caso 7 cadastroleitor caso 8 buscarleitor caso 9 excluirleitor caso 10 sair outrocaso MenuP fimescolha fimprocedimento // Fim procedimento menu principal //inicio do menu Cadastro. procedimento cadastrolivro var //não necessita utilizar nenhuma var local. inicio limpatela Escreval ("") Escreval (" *****************") escreval (" * Cadastro Nº",x, " *") Escreval (" *****************") escreval ("") escreva ("Nome do livro: ") leia (livro[x]) escreva ("Nome do autor: ") leia (autor[x]) escreva ("Editora: ") leia (editora[x]) escreva ("Entre com o ano do livro: ") leia (ano[x]) x <- x + 1 MenuP fimprocedimento // Fim procedimento Cadastro // inicio do procedimento Listar procedimento listarlivro var i: inteiro c: caracter inicio limpatela Escreval (" ****************") Escreval (" * LISTAR *") Escreval (" ****************") para i de 1 ate x faca escreval ("Nome do livro : ", livro) escreval ("Nome do autor : ", autor) escreval ("Nome da editora : ", editora) escreval ("Ano de puplicacao : ", ano) escreval ("") fimpara escreval ("Pressione *|ENTER|* para continuar") leia (C) MenuP// chama o MENU PRINCIPAL fimprocedimento // Fim procedimento Listar // Busca os registros procedimento buscarlivro var i, a : inteiro busca, c : caracter inicio limpatela Escreval (" ****************") Escreval (" * BUSCAR *") Escreval (" ****************") escreva ("Entre com o nome do livro: ") leia (busca) a <- 0 para i de 1 ate (x-1) faca se livro = busca então a <- i fimse fimpara //inicio de impressão do livro. se a> 0 então Escreval (" ***********************************") Escreval ("Nome do livro : ", livro[a]) Escreval ("Nome do autor : ", autor[a]) Escreval ("Nome da editora : ", editora[a]) Escreval ("Ano de publicação : ", ano[a]) Escreval (" ***********************************") Escreval ("") senao escreval ("O livro ", busca, " não foi encontrado em nosso banco de dados") fimse escreval ("Pressione *|ENTER|* para continuar") leia (c) MenuP fimprocedimento // Fim procedimento Buscar // inicio do procedimento de excluir procedimento excluirlivro var i, a : inteiro busca, c : caracter inicio limpatela Escreval (" ****************") Escreval (" * EXCLUIR*******") Escreval (" ****************") escreva ("Entre com o nome do livro a ser excluído: ") leia (busca) a <- 0 para i de 1 ate (x-1) faca se livro = busca então a <- i x<-i fimse fimpara escreval (" Exclusão realizada com sucesso") escreval ("Pressione *|ENTER|* para continuar") leia (c) MenuP fimprocedimento // inicio do procedimento de cadastro de leitor procedimento cadastroleitor var //não precisa de nenhuma variavel local inicio limpatela Escreval ("") Escreval (" *****************") escreval (" * Cadastro Nº",y, " *") Escreval (" *****************") escreval ("") escreva ("Nome do aluno: ") leia (nome[y]) escreva ("CPF do aluno: ") leia (CPF[y]) escreva ("Endereço: ") leia (endereco[y]) escreva ("Telefone ") leia (telefone[y]) y <- y + 1 MenuP fimprocedimento // fim do procedimento de cadastro do leitor // Busca os registros de alunos procedimento buscarleitor var i, a : inteiro busca, c : caracter inicio limpatela Escreval (" ****************") Escreval (" * BUSCAR LEITOR*") Escreval (" ****************") escreva ("Entre com o nome do leitor: ") leia (busca) a <- 0 para i de 1 ate (x-1) faca se nome = busca então a <- i fimse fimpara //inicio de impressão do livro. se a> 0 então Escreval (" ***********************************") Escreval ("Nome do Aluno : ", nome[a]) Escreval ("CPF do Aluno : ", cpf[a]) Escreval ("Endereço do Aluno : ", endereco[a]) Escreval ("Telefone do Aluno : ", telefone[a]) Escreval (" ***********************************") Escreval ("") senao escreval ("O Aluno ", busca, " não foi encontrado em nosso banco de dados") fimse escreval ("Pressione *|ENTER|* para continuar") leia (c) MenuP fimprocedimento procedimento excluirleitor var i, a : inteiro busca, c : caracter inicio limpatela Escreval (" ****************") Escreval (" * EXCLUIR*******") Escreval (" ****************") escreva ("Entre com o nome do leitor: ") leia (busca) a <- 0 para i de 1 ate (x-1) faca se nome = busca então a <- i fimse fimpara //inicio de impressão do livro. se a> 0 então escreval (" Exclusão realizada com sucesso") escreval ("Pressione *|ENTER|* para continuar") leia (c) MenuP fimprocedimento //inicio do procedimento SAIR procedimento sair inicio limpatela fimprocedimento //fim do procedimento SAIR inicio //********* //atribuir valor para X e Y x<- 1 y<- 1 z<- 1 //********* //MENU PRINCIPAL MenuP fimalgoritmo
  6. Olá, estou cursando Análise e Desenvolvimento de Sistemas, estou indo para o segundo semestre, embora a classe esteja indo para o terceiro. Por esse motivo, estou me atualizando em lógica básica. Eu estou tentando criar um prótotipo de formulário.Quando executo o programa, o Visualg não reconhece o ENTAO na linha 32 ( " se (x =/= 1) entao "). Esse é o programa: ( Sei que poderia deixar esse programa mais prático utilizando repetições e até o SENAO, porém estou indo aos poucos, para aprender cada comando e suas utilizações corretas) Algoritmo "semnome" Var nome : caractere idade: inteiro cpf: inteiro x : inteiro Inicio escreval("Digite seu nome completo: ") leia(nome) escreval("Digite a sua idade: ") leia(idade) escreval("Digite o número do seu CPF: ") leia(cpf) escreval("Confirmação dos Dados Informados: ") escreval("") escreval("O seu nome é " ,nome, " ,? Se sim, digite 1:") leia(x) se (x =/= 1) entao escreval("Digite novamente seu nome: ") leia(nome) escreva("O seu nome " ,nome, " ? Se sim, digite 1:") leia(x) se (x = 1) entao escreval("Sua idade é ",idade, " ? Se sim, digite 1:") leia(x) se (x =/= 1) entao escreval ("Digite novamente sua idade: ") leia(idade) escreval("Sua idade é ",idade," anos ? Se sim, digite 1: ") leia(x) se (x = 1) entao escreval("O seu CPF é " , cpf , " ? Se sim, digite 1: ") leia(x) se (x =/= 1) entao escreval("Digite novamente seu CPF: ") leia(cpf) escreval("Seu CPF é: " , cpf , " ? Se sim, digite 1: ") se (x = 1)entao escreval ("Nome: ", nome) escreval ("Idade: ", idade, " anos" ) escreval ("CPF: ", cpf) escreva ("Dados inseridos !") Fimalgoritmo
  7. E aí galera, estou fazendo um curso de algoritmo e resolvi fazer um projeto simples pra por em prática só que ele da erro e eu nao consigo localizar o que há de errado, ficarei grato com dicas e possíveis soluções algoritmo "Calculo IMC" // Função : Testes // Autor : Julcemar Bauer // Data : 10/01/2020 // Seção de Declarações var imc, altur, peso: real nome, sim: caractere inicio Escreval ("Ola. Qual seu nome?") Leia (nome) Escreval ("Bem vindo, ", nome, " iremos realizar o calculo de seu IMC") Escreval ("para isso precisaremos de algumas informações, Ok?") Sim <- sim, ok, yes, ta bom, aham, s, ta Leia (sim) Se(sim = sim)entao Escreval ("Otimo!, ", nome, " Qual seu peso?") Escreval ("(digite apenas numeros)") Leia (peso) Escreval ("Quase lá,", nome, ". Qual sua altura, por gentileza?") Leia (altur) Escreval ("Aguarde um momento, estamos efetuando os calculos.........") imc <- (peso/(altur*2)) SeNao Escreval ("Ok, tchau") fimse Se(imc>=40)entao Escreval ("Seu IMC é de: ", imc, "!! Cuidado, este valor indica") Escreval ("Obesidade Morbida Grau III e pode indicar risco a saude") Senao Se(imc>=35)e(imc<39)entao Escreval ("Seu IMC é de: ", imc, ". Indica obesidade Severa III") Senao Se(imc>=30)e(imc<35) Escreval ("Seu IMC é de: ", imc, ". Indica obesidade.") Senao Se(imc>=25)e(imc<30) Escreval ("Seu IMC é de: ", imc, ". Indica sobrepeso.") Senao Se(imc>=18.5)e(imc<25) Escreval ("Seu IMC é de: ", imc, ". Indica que seu peso esta normal.") Senao Se(imc<18.5) Escreval ("Seu IMC é de: ", imc, ". Indica que voce esta com sobrepeso.") Senao fimalgoritmo fimse fimse fimse fimse fimse fimse fimalgoritmo
  8. Alguém poderia me ajudar nesse algoritmo? O algoritmo deve receber um valor que representa um troco e retorna a forma de dar esse troco utilizando o menor número possível de notas e moedas (Moedas e notas atuais em reais). Atualmente existem notas de cem reais, cinquenta reais, vinte reais, dez reais, cinco reais e dois reais. Além disso existem as moedas de um real, cinquenta centavos, vinte e cinco centavos, dez centavos, cinco centavos e um centavo.
  9. Alguém poderia me dizer o que está errado? Algoritmo "semnome" Var num: inteiro Inicio escreval ("Verifique se um numero é perfeito !") repita escreval ("Informe o numero : ") leia (num) se (num < 6) e (num <> 0) então escreval ("Este numero não é perfeito !") senao fimse ate num = 0 fimrepita Fimalgoritmo
  10. Meu programa até que funciona normalmente. Mas quanto insiro a massa de 2kg e Altura de 2m aparece como se estivesse dentro o IMC ideal. Alguém sabe o por quê e como corrigir? algoritmo "CalculoIMC" var M, A, IMC: real inicio Escreva("Massa(Kg): ") Leia(M) Escreva("Altura(m): ") Leia(A) IMC <- M/(A^2) EscrevaL("Seu IMC é de ", IMC:5:2) Se (IMC >= 18.5) e (IMC < 25) entao Escreva(" Parabéns, você está no seu peso ideal") Senao Escreva("Você não está na faixa de peso ideal") FimSe fimalgoritmo
  11. Fui executar essa estrutura var m1: vetor[1..2, 1..2] de real m2: vetor[1..2, 1..2] de real resultados: vetor [1..2] de real opcao, opmenu, l, c, menu, n: inteiro inicio menu <- 1 enquanto menu = 1 faca escreval("(1) Somar matrizes") escreval("(2) Subtrair primeira matriz da segunda") escreval("(3) Adicionar uma constante as duas matrizes") escreval ("(4) Mostrar matrizes") escreva("Escolha uma das opções acima: ") leia(opcao) escolha opcao caso 1 para l de 1 ate 2 faca para c de 1 ate 2 faca resultados [l, c] <- m1[l, c] + m2[l, c] fimpara fimpara escreval("Resultado soma") para l de 1 ate 2 faca para c de 1 ate 2 faca escreva(resultados[l, c]) fimpara escreval("") fimpara escreva("Você deseja voltar ao menu? Use 1 - Sim ou 2 - Não") leia(opmenu) se opmenu = 2 entao menu <- 0 fimse caso 2 para l de 1 ate 2 faca para c de 1 ate 2 faca resultados [l, c] <- m2[l, c] - m1[l, c] fimpara fimpara escreval("Resultado subtração") para l de 1 ate 2 faca para c de 1 ate 2 faca escreva(resultados[l, c]) fimpara escreval("") fimpara escreva("Você deseja voltar ao menu? Use 1 - Sim ou 2 - Não") leia(opmenu) se opmenu = 2 entao menu <- 0 fimse caso 3 para l de 1 ate 2 faca para c de 1 ate 2 faca escreva("Digite um valor para posição [", l, ",", c, "] da matriz 1: ") leia(n) m1[l, c] <- n fimpara fimpara para l de 1 ate 2 faca para c de 1 ate 2 faca escreva("Digite um valor para posição [", l, ",", c, "] da matriz 2: ") leia(n) m2[l, c] <- n fimpara fimpara escreval ("Matrizes preenchidas com sucesso!") escreva("Você deseja voltar ao menu? Use 1 - Sim ou 2 - Não") leia(opmenu) se opmenu = 2 entao menu <- 0 fimse caso 4 escreval("Matriz 1") para l de 1 ate 2 faca para c de 1 ate 2 faca escreva(m1[l, c]) fimpara escreval("") fimpara escreval("Matriz 2") para l de 1 ate 2 faca para c de 1 ate 2 faca escreva(m2[l, c]) fimpara escreval("") fimpara escreva("Você deseja voltar ao menu? Use 1 - Sim ou 2 - Não") leia(opmenu) se opmenu = 2 entao menu <- 0 fimse outrocaso escreval("Opção invalida!") fimescolha fimenquanto fimalgoritmo e ela ao meu ver esta terminada, sendo que da erro ao por as opções 1, 2, 3. não consigo identificar o erro.!
  12. Boa tarde pessoal. Preciso fazer um exercício, mas não estou conseguindo. É necessário aplicar o comando ENQUANTO nesse exercício, mas não sei onde colocá-lo. Segue o exercício sem o comando ENQUANTO aplicado: 1) Escreva um algoritmo que ao final da exibição na tela da escolha do cliente pergunte se ele gostaria de realizar outro pedido. Se o cliente quiser fazer um novo pedido, deverá pressionar a tecla “s” (sem aspas e em minúsculo). Var // Seção de Declarações das variáveis opcao, quantidade: inteiro valor: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... escreval (" Lanchonete Central ") escreval (" ------------------ ") escreval (" ***Opções de lanches*** ") escreval (" [1] - Torrada Simples -> R$ 4,00") escreval (" [2] - Torrada Completa -> R$ 5,00") escreval (" [3] - Cachorro Quente Simples -> R$ 5,00") escreval (" [4] - Cachorro Quente Completo -> R$ 6,00") escreval (" [5] - Cheeseburger Completo -> R$ 8,00") escreval ("Digite a opção escolhida") leia (opcao) escreval ("Qual a quantidade desejada?") leia (quantidade) escolha opcao caso 1 valor:=quantidade*4 escreval ("O lanche escolhido foi ",quantidade," Torrada Simples(s) e custará R$ ", valor,",00") caso 2 valor:=quantidade*5 escreval ("O lanche escolhido foi ",quantidade," Torrada Completa(s) e custará R$ ", valor,",00") caso 3 valor:=quantidade*5 escreval ("O lanche escolhido foi ",quantidade," Cachorro Quente Simples(s) e custará R$ ", valor,",00") caso 4 valor:=quantidade*6 escreval ("O lanche escolhido foi ",quantidade," Cachorro Quente Completo(s) e custará R$ ", valor,",00") caso 5 valor:=quantidade*8 escreval ("O lanche escolhido foi ",quantidade," Cheeseburger Completo(s) e custará R$ ", valor,",00") fimescolha Fimalgoritmo
  13. Tem algum jeito de colocar um vetor dinamico no visualg?
  14. Bom dia, Estou com problema na hora de excluir um contato nessa agenda em pseudocode. Ele não não exclui contato a contato. Alguém poderia dar uma força? Algoritmo "Projeto Cadastro" Var nome, endereco, email, tel: vetor [1..100] de caracter x: inteiro opcao: inteiro Procedimento Menu Var Inicio escreval ("========================") escreval ("== PROJETO - CADASTRO ==") escreval ("========================") escreval ("") escreval ("========================") escreval ("==== [1] Cadastrar =====") escreval ("==== [2] Listar =====") escreval ("==== [3] Editar =====") escreval ("==== [4] Excluir =====") escreval ("==== [5] Sair =====") escreval ("========================") escreval ("") escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao caso 1 cadastronome caso 2 listarnomes caso 3 editarnome caso 4 excluircadastro caso 5 sair outrocaso escreval ("Opção Inválida.") Menu fimescolha Fimprocedimento procedimento cadastronome Inicio limpatela escreval ("") escreval ("=================") escreval ("==",x,"o. Contato ==") escreval ("=================") escreval ("") escreva ("Nome: ") leia (nome[x]) escreva ("Telefone: ") leia (tel[x]) escreva ("Endereço: ") leia (endereco[x]) escreva ("E-mail: ") leia (email[x]) escreval("") x <- x + 1 limpatela escreval("Contato cadastrado com sucesso!") escreval("") escreval ("== [1] Cadastrar novo contato ==") escreval ("== [2] Voltar Menu Principal ==") escreval ("") escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao caso 1 cadastronome caso 2 limpatela Menu outrocaso escreval ("Opção Inválida.") Menu Fimprocedimento Procedimento listarnomes Var i, cadastro: inteiro Inicio limpatela escreval ("========================") escreval ("== LISTA DE CADASTROS ==") escreval ("========================") para i de 1 ate (x-1) faca escreval (i,"o Cadastro") escreval ("Nome: ", nome[i]) escreval ("Telefone: ", tel[i]) escreval ("Endereço: ", endereco[i]) escreval ("E-mail: ", email[i]) escreval ("") fimpara escreval ("== [1] Listar novamente ==") escreval ("== [2] Voltar Menu Principal ==") escreval ("") escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao caso 1 listarnomes caso 2 limpatela Menu outrocaso escreval ("Opção Inválida.") Menu Fimprocedimento Procedimento editarnome Var cadastro, i, dado: inteiro Inicio limpatela escreval ("") escreval ("======================") escreval ("== ALTERAR CADASTRO ==") escreval ("======================") escreval ("") para i de 1 ate (x-1) faca escreval (i,"o Cadastro") escreval ("Nome: ", nome[i]) escreval ("Telefone: ", tel[i]) escreval ("Endereço: ", endereco[i]) escreval ("E-mail: ", email[i]) escreval ("") fimpara escreval ("") escreval ("Entre com o nº do cadastro a ser alterado") leia (cadastro) para i de 1 ate (x-1) faca se i = cadastro entao escreval ("Nº de cadastro: ", i) escreval ("[1] - Nome: ", nome[i]) escreval ("[2] - Telefone: ", tel[i]) escreval ("[3] - Endereço: ", endereco[i]) escreval ("[4] - E-mail: ", email[i]) escreval ("[5] - Não alterar.") escreval ("Escolha o dado que deseja alterar: ") leia (dado) escolha (dado) caso 1 escreval ("Digite o novo nome: ") leia (nome[i]) caso 2 escreval ("Digite o novo telefone: ") leia (tel[i]) caso 3 escreval ("Digite o novo endereço: ") leia (endereco[i]) caso 4 escreval ("Digite o novo e-mail: ") leia (email[i]) caso 5 escreval ("O cadastro não foi alterado.") outrocaso Menu fimescolha fimse fimpara escreval ("O Cadastro foi alterado com sucesso.") escreval ("") escreval ("== [1] Alterar outro contato ==") escreval ("== [2] Voltar Menu Principal ==") escreval ("") escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao limpatela caso 1 editarnome caso 2 limpatela Menu outrocaso escreval ("Opção Inválida.") Menu Fimprocedimento Procedimento excluircadastro Var cadastro,i: inteiro Inicio limpatela escreval ("======================") escreval ("== EXCLUIR CADASTRO ==") escreval ("======================") escreval ("") escreval ("== LISTA DE CADASTROS ==") escreval ("") para i de 1 ate (x-1) faca escreval (i,"o Cadastro") escreval ("Nome: ", nome[i]) escreval ("Telefone: ", tel[i]) escreval ("Endereço: ", endereco[i]) escreval ("E-mail: ", email[i]) escreval ("") fimpara escreval ("==========================================") escreva ("Entre com o nº do cadastro a ser excluído: ") leia (cadastro) para i de 1 ate (x-1) faca se i = cadastro entao x <- i fimse fimpara escreval ("O Cadastro foi excluido com sucesso.") escreval ("") escreval ("== [1] Excluir outro contato ==") escreval ("== [2] Voltar Menu Principal ==") escreval ("") escreva ("Entre com a sua opção: ") leia (opcao) escolha opcao limpatela caso 1 excluircadastro caso 2 limpatela Menu outrocaso escreval ("Opção Inválida.") Menu Fimprocedimento Procedimento sair Inicio limpatela Fimprocedimento Inicio x <- 1 Menu Fimalgoritmo
  15. Eu quero criar uma calculadora usando funções, esse é o primeiro calculo, mas nao esta sempre dando erro algoritmo "calculadora" var n1,n2,total,soma: inteiro sinais,calc: caractere //-------------------------------------------y--------------------// funcao reposta (x,y: inteiro): inteiro var divisao, subtracao: real inicio soma <- x+y divisao <- x/y multiplicacao <- x*y subtracao <- x-y retorne resposta fimfuncao inicio //----------------------fimfuncao-----------------------// escreval (" Calculadora") //espaço// escreval ("") escreval ("") escreval ("") //fimespaço// escreval ("Digite + para fazer a soma de dois numeros") escreval ("Digite 2 para fazer a divisao de dois numeros") escreval ("Digite 3 para fazer a multiplicacao de dois numeros ") escreval ("Digite 4 para fazer a subtracao de dois numeros") //------------// leia (sinais) total <- reposta (x,y) escolha (sinais) caso "1" leia (n1) leia (n2) escreval (total) fimescolha fimalgoritmo
  16. Olá estou com problemas com a seguinte questão: 2 - Ler 3 números reais em vetor e depois exibir os números localizados nas posições impares. algoritmo "Localizar números" // Função : localizar números nas posições impares // Autor : MendigoBR // Data : 30/11/2019 // Seção de Declarações var vet :vetor[1..3] de inteiro cont1, cont2 : inteiro inicio para cont1 de 1 ate 3 faca escreva("Digite um número: ") leia(vet[cont1]) fimpara para cont2 de 1 ate 3 faca se (vet[cont2]% 2=1) entao escreva(vet[cont2]) fimse fimpara fimalgoritmo no caso teria de mostrar os números da posição 1 e 3(impares), independente se seus valores são pares ou impares (pelo o que eu entendi do enunciado). Esse foi meu código.
  17. Olá estou a aprender programação, e estudando em um dos cursos gratuitos que faço acabei trancado em um exercício: 9- Dados um capital, uma taxa de juros (em porcentagem) mensal e um período em meses, informe o montante ao final de cada mês. O programa deve funcionar como a seguir: Juros: 10% Capital: 100.00 Período: 3 1o mês R$ 110,00 2o mês R$ 121,00 3o mês R$ 133,10 tentei resolvê-lo mas sem sucesso. eis meu código de tentativa (tentei outras diversas vezes mas esse foi o mais próximo que consegui chegar): algoritmo "comando para" // Função : calcular taxa de juros // Autor : MendigoBR // Data : 29/11/2019 // Seção de Declarações var c, j, m : real p, cont : inteiro inicio escreva("Capital: ") leia(c) escreva("Juros: ") leia(j) escreva("Período: ") leia(p) j <- j/100 m <- 0 para cont de 1 ate p faca m := j*c+c escreval(cont,"º mês: ",m) fimpara fimalgoritmo Por favor me ajudem,obrigado.
  18. Quero pegar essa base e modificar para fazer a questão que ta no titulo pois nao consigo fazer do 0 Algoritmo "semnome" // // // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 29/11/2019 Var simetrica: logico I: inteiro J: inteiro N: inteiro matrizA : vetor [1..5,1..5] de real Inicio simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca leia(matrizA[I,J]) fimpara fimpara escreval("MATRIZ 1") simetrica <- verdadeiro para i de 1 ate 5 faca para j de 1 ate 5 faca escreva(matrizA[I,J]," ") fimpara escreval(" ") fimpara simetrica <- verdadeiro para I de 1 ate 5 faca para J de 1 ate 5 faca se ( matrizA[I,J] <> matrizA[J,I] ) ENTÃO simetrica <- falso fimse fimpara se ( simetrica = verdadeiro ) ENTÃO escreval ("A matriz é simétrica!") senao escreval("A matriz não é simétrica!") fimse fimpara fimalgoritmo
  19. Neste código, coloco 5 valores aleatórios e o programa retorna na ordem crescente... Já entendi como é um Bubble Sort, mas me compliquei com a lógica disto... vejam. escreva("Entre com o valor da posição", i , " ") leia(valores[i]) fimpara para i de 1 ate 4 faca para j de i + 1 ate 5 faca se(valores[i] > valores[j]) então x <- valores[i] valores[i] <- valores[j] valores[j] <- x fimse fimpara fimpara para i de 1 ate 5 faca escreval("Valor da Posição", i, " = ", valores[i]) fimpara fimalgoritmo para i de 1 ate 5 faca Essa estrutura de repetição está muito confusa pra mim, não consigo entender como isto consegue organizar os números na ordem correta... Alguém pode explicar? Grato.
  20. Alguém me pode dizer como fazer este exercício em Visualg da imagem inserida? Estou a ter algumas dificuldades...
  21. Estou fazendo esse código, porém quando vou executar, informa que na linha 7 era esperado o então, todavia, ele está lá ! Algoritmo "semnome" var idade: real inicio escreva ("Qual a idade: ") leia(idade) se idade_eleitor < 16 então imprime "NÃO É ELEITOR" se idade_eleitor >= 16 e idade_eleitor < 18 então imprime "FACULTATIVO" se idade_eleitor >= 18 e idade_eleitor <70 então imprime "OBRIGATÓRIO" se não "FACULTATIVO" fimse fimse fimse Fimalgoritimo
  22. Olá galera, meu algorítimo no visuALG tá errado, eu queria saber como colocar " enquanto "tal variável" for igual a "tal palavra" faca " meu algorítimo está assim: <enquanto esc <> ("sim") ou esc <> ("não") faca> o que está errado?
  23. Crie um algoritmo para simular um sorteio de 3 números em uma cartela de 30 números. Para tanto, monte a cartela usando uma matriz 6x5. Use repetições para alimentar a matriz sem a intervenção do usuário, com números inteiros, sequenciais de 1 a 30. Após a montagem da matriz, imprima a mesma. Leia um vetor de 3 números inteiros informados pelo usuário. Garanta que os números lidos pelo usuário não sejam menores ou iguais a zero e também não se repitam dentro do vetor. Após a leitura do vetor, faça uma busca dos números lidos no vetor na matriz (cartela) montada, imprimindo quais números do vetor foram encontrados na cartela. **Nessa atividade estou com dificuldade para que na alimentação dos números na sequência sem a intervenção do usuário. Var numero: vetor [1..6,1..5] de inteiro l,c: inteiro Inicio para l de 1 ate 6 faca para c de 1 ate 5 faca numero[l,c]<- numero[l,c]+1 leia(numero[l,c]) fimpara fimpara Fimalgoritmo Se puderem me ajudar, Agradeço!!
  24. Então pessoal, comecei a estudar recentemente lógica de programação e fui para VisualG, por ser Portugal e etc. No entanto tenho o exercício abaixo: Deve-se criar um algoritmo que receba a quantidade de livros que deseja comprar e pautado na quantidade exibir ao usuário qual o melhor critério à se utilizar. O melhor critério se dará pelo MENOR VALOR à Pagar de acordo com as informações abaixo: Critério A: Custo Fixo de 7,50 e Desconto de 0,25 Critério B: Custo Fixo de 2,50 e Desconto de 0,50 Critério Custo Fixo de 1,50 e Desconto de 0,65 O Valor à Pagar se dará pela expressão Custo Fixo + (Quantidade * Desconto). Percebam que esta variável terá seu valor alterado de acordo com a Quantidade de Livros comprados. Minha dúvida é: eu preciso usar o se/senão, escolha/caso. Estou muito confusa quanto a isso, e gostaria de exemplos também.
  25. algoritmo "geração DE RIQUEZA" // Função : Calcular a distribuição do salário de acordo com o proposto no livreo Geração de Riqueza do Master Coach Paulo Vieira // Autor : Vanessa Venites // Data : 08/11/2019 // Seção de Declarações var pagarse, doar, investir,poupar,abundar, pagarcontas : real salario, total: real // Seção de Comandos inicio ESCREVAL ("INFORME SEU SALARIO LÍQUIDO:R$") LEIA (salario) pagarse <- salario * 0.05 doar <- salario * 0.10 investir <- salario * 0.10 poupar <- salario * 0.10 abundar <- salario * 0.05 pagarcontas <- salario * 0.60 ESCREVAL ("SUA DISTRIBUIÇÃO DOS RENDIMENTOS SERÁ:") ESCREVAL ("PAGAR-SE:R$", pagarse) ESCREVAL ("DOAR:R$", doar) ESCREVAL ("INVESTIR:R$", investir) ESCREVAL ("POUPAR:R$", poupar) ESCREVAL ("ABUNDAR:R$", abundar) ESCREVAL ("PAGAR CONTAS:R$", pagarcontas) TOTAL <- (pagarse + doar + investir + poupar + abundar + pagarcontas)) ESCREVAL ("VALOR TOTAL:R$", total) fimalgoritmo Pessoal, Preciso de ajuda para converter esse código que fiz em visual G para Linguagem C

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

ebook grátis "Aprenda a ler resistores e capacitores", de Gabriel Torres

GRÁTIS! BAIXE AGORA MESMO!